]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin-Makefile.patch
- updated to 2.0.42
[packages/munin.git] / munin-Makefile.patch
index 5fd99671429723e1a7a49b5df3d9fa52ad2a50d9..9c09ede5716fe673193d4ac2e4eede4a6f295577 100644 (file)
@@ -1,7 +1,7 @@
-diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
---- munin-2.0.25.orig/Makefile 2014-11-24 21:46:24.000000000 +0000
-+++ munin-2.0.25/Makefile      2015-09-08 10:02:24.392593251 +0000
-@@ -81,6 +81,7 @@ install-master-prime: $(INFILES_MASTER)
+diff -urNpa munin-2.0.42.orig/Makefile munin-2.0.42/Makefile
+--- munin-2.0.42.orig/Makefile 2018-09-21 02:11:11.000000000 +0000
++++ munin-2.0.42/Makefile      2018-10-11 14:59:08.887033000 +0000
+@@ -106,6 +106,7 @@ install-master-prime: $(INFILES_MASTER)
        mkdir -p $(CONFDIR)/munin-conf.d
        mkdir -p $(LIBDIR)
        mkdir -p $(BINDIR)
@@ -9,7 +9,7 @@ diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
        mkdir -p $(PERLLIB)
        mkdir -p $(PERLLIB)/Munin/Master
        mkdir -p $(HTMLDIR)
-@@ -112,8 +113,8 @@ install-master-prime: $(INFILES_MASTER)
+@@ -137,8 +138,8 @@ install-master-prime: $(INFILES_MASTER)
        test -f $(HTMLDIR)/.htaccess || $(INSTALL) -m 0644 build/master/www/munin-htaccess $(HTMLDIR)/.htaccess
        test -f "$(CONFDIR)/munin.conf"  || $(INSTALL) -m 0644 build/master/munin.conf $(CONFDIR)/
  
@@ -20,9 +20,9 @@ diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
        $(INSTALL) -m 0755 build/master/_bin/munin-update $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-html $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
-diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
---- munin-2.0.25.orig/Makefile.config  2014-11-24 21:46:24.000000000 +0000
-+++ munin-2.0.25/Makefile.config       2015-09-08 10:02:24.393593251 +0000
+diff -urNpa munin-2.0.42.orig/Makefile.config munin-2.0.42/Makefile.config
+--- munin-2.0.42.orig/Makefile.config  2018-09-21 02:11:11.000000000 +0000
++++ munin-2.0.42/Makefile.config       2018-10-11 14:59:55.327033000 +0000
 @@ -17,10 +17,10 @@
  #
  # the base of the Munin installation.
@@ -81,12 +81,12 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  BASH       := /bin/bash
  
  # Server only - Where to install the perl libraries
--PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-+PERLSITELIB := $(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
- PERLLIB    = $(DESTDIR)$(PERLSITELIB)
+-PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
++PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
  
  # Client only - Install plugins for this architecture
-@@ -106,7 +106,7 @@ OSTYPE     := $(shell uname | LANG=C tr
+ # the LANG=C makes tr work as expected, not regarding any locale it
+@@ -105,7 +105,7 @@ OSTYPE     := $(shell uname | LANG=C tr
  
  # How to figure out the hostname. (Only used in default configuration
  # files)
@@ -95,7 +95,7 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  
  # What is the safest way to create a tempfile.
  # Default is to figure it out by testing various methods.
-@@ -129,9 +129,9 @@ CGIUSER := nobody
+@@ -128,9 +128,9 @@ CGIUSER := nobody
  # Which command to use to check if the USER and GROUP to run Munin as, exists.
  # These will work on most modern OSes:
  #
@@ -108,7 +108,7 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  
  # For OSX, comment out the previous two lines and comment in these
  #
-@@ -153,9 +153,9 @@ CHECKGROUP := $(shell $(GETENT) group $(
+@@ -152,9 +152,9 @@ CHECKGROUP := $(shell $(GETENT) group $(
  #CHECKUSER  := $(shell id $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
  #CHECKGROUP := $(shell grep ^$(GROUP): /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))