]> TLD Linux GIT Repositories - packages/virt-manager.git/blobdiff - virt-manager.spec
- merged update to 2.0.0 from PLD
[packages/virt-manager.git] / virt-manager.spec
index d75ca3646b478b3de238b29423d35718e50e1dc1..7716b1759fb387f8c111047d50cbf8f3dd3b4c23 100644 (file)
@@ -1,45 +1,37 @@
 Summary:       Virtual Machine Manager
 Summary(pl.UTF-8):     Zarządca maszyn wirtualnych
 Name:          virt-manager
-Version:       1.5.1
-Release:       5
+Version:       2.0.0
+Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         Applications/Emulators
-Source0:       https://virt-manager.org/download/sources/virt-manager/%{name}-%{version}.tar.gz
-# Source0-md5: 32a929fd91fca9767730abaefb94661d
+Source0:       https://releases.pagure.org/virt-manager/%{name}-%{version}.tar.gz
+# Source0-md5: 5326c493de70453497b39d5a688e530f
 URL:           http://virt-manager.org/
-BuildRequires: gettext-devel >= 0.14.1
+BuildRequires: gettext-tools >= 0.14.1
 BuildRequires: glib2-devel
-BuildRequires: gtk-update-icon-cache
 BuildRequires: intltool >= 0.35.0
 BuildRequires: perl-tools-pod
-BuildRequires: python-devel >= 1:2.7
+BuildRequires: python3-devel
 BuildRequires: rpmbuild(macros) >= 1.592
+Requires(post,postun): glib2
+Requires(post,postun): gtk-update-icon-cache
 Requires:      dconf
 Requires:      adwaita-icon-theme
 Requires:      gnome-icon-theme
-Requires(post,postun): glib2
-Requires(post,postun): gtk-update-icon-cache
 Requires:      gtk+3 >= 3.14
 Requires:      gtk3-vnc >= 0.4.3
 Requires:      hicolor-icon-theme
 Requires:      libosinfo >= 0.2.10
-Requires:      libvirt-glib
-Requires:      python-chardet
-Requires:      python-dbus >= 0.84.0
-Requires:      python-idna
-Requires:      python-ipaddr
-Requires:      python-libvirt >= 0.9.6
-Requires:      python-pycairo
-Requires:      python-pygobject3 >= 3.14
-Requires:      python-requests
-Requires:      python-virtinst = %{epoch}:%{version}-%{release}
+Requires:      libvirt-glib >= 0.0.9
+Requires:      python3-libvirt >= 0.9.6
+Requires:      python3-pygobject3 >= 3.14
+Requires:      python3-virtinst = %{epoch}:%{version}-%{release}
 Requires:      spice-gtk
 Requires:      vte >= 0.34
 Suggests:      gnome-keyring >= 0.4.9
-Suggests:      python-gnome-desktop-keyring >= 2.15.4
-Suggests:      python-libguestfs >= 1.12.0
+Suggests:      python3-libguestfs >= 1.12.0
 ExclusiveArch: %{ix86} %{x8664} ia64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -59,25 +51,26 @@ statystyki wykorzystania zasobów istniejących maszyn wirtualnych na
 maszynach lokalnych i zdalnych. Wykorzystuje libvirt jako API do
 zarządzania.
 
-%package -n python-virtinst
+%package -n python3-virtinst
 Summary:       Python modules and utilities for installing virtual machines
 Summary(pl.UTF-8):     Moduły Pythona i narzędzia do instalowania maszyn wirtualnych
 Group:         Libraries/Python
-Requires:      python-libvirt >= 0.9.6
-Requires:      python-libxml2 >= 1:2.7.8
-Requires:      python-modules
-Requires:      python-urlgrabber
-Suggests:      python-selinux
+Requires:      python3-libvirt >= 0.9.6
+Requires:      python3-libxml2 >= 1:2.7.8
+Requires:      python3-modules
+Requires:      python3-requests
+Suggests:      python3-selinux
 Suggests:      virt-viewer >= 0.0.1
+Obsoletes:     python-virtinst < 2.0.0
 
-%description -n python-virtinst
+%description -n python3-virtinst
 virtinst is a module that helps build and install libvirt based
 virtual machines. Currently supports KVM, QEmu and Xen virtual
 machines. Package includes several command line utilities, including
 virt-install (build and install new VMs) and virt-clone (clone an
 existing virtual machine).
 
-%description -n python-virtinst -l pl.UTF-8
+%description -n python3-virtinst -l pl.UTF-8
 virtinst to moduł pomagający przy tworzeniu i instalowaniu maszyn
 wirtualnych opartych na libvirt. Obecnie obsługiwane są maszyny KVM,
 QEmu i Xen. Pakiet zawiera kilka działających z linii poleceń
@@ -88,29 +81,16 @@ virt-clone (klonujący istniejącą maszynę wirtualną).
 %setup -q
 
 %build
-%{__python} setup.py configure \
+%{__python3} setup.py \
+        configure \
        --prefix=%{_prefix}
 
-%{__python} setup.py build
+%py3_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
-
-%py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
-%py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
-# requires patching(?)
-#%%py_postclean %{_datadir}/%{name}
-
-# Replace '#!/usr/bin/env python2' with '#!/usr/bin/python2'
-# The format is ideal for upstream, but not a distro. See:
-# https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython
-for f in $(find $RPM_BUILD_ROOT -type f -executable -print); do
-    sed -i "1 s|^#!/usr/bin/env python2|#!%{__python}|" $f || :
-done
+%py3_install
 
 %find_lang %{name}
 
@@ -142,7 +122,7 @@ fi
 %{_iconsdir}/hicolor/*/apps/virt-manager.png
 %{_mandir}/man1/virt-manager.1*
 
-%files -n python-virtinst -f %{name}.lang
+%files -n python3-virtinst -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/virt-clone
 %attr(755,root,root) %{_bindir}/virt-convert
@@ -156,6 +136,10 @@ fi
 %{_datadir}/%{name}/virtconv/*.py*
 %dir %{_datadir}/%{name}/virtinst
 %{_datadir}/%{name}/virtinst/*.py*
+%dir %{_datadir}/%{name}/virtinst/devices
+%{_datadir}/%{name}/virtinst/devices/*.py*
+%dir %{_datadir}/%{name}/virtinst/domain
+%{_datadir}/%{name}/virtinst/domain/*.py*
 %attr(755,root,root) %{_datadir}/%{name}/virt-clone
 %attr(755,root,root) %{_datadir}/%{name}/virt-convert
 %attr(755,root,root) %{_datadir}/%{name}/virt-install