]> TLD Linux GIT Repositories - packages/apache.git/blobdiff - apache.spec
- build all mpms as module, prefork is default
[packages/apache.git] / apache.spec
index a6b31768213acc268a8ad6df5e7f6a961450ef65..626b70c06e2368d8a11e47468c957208c1e47b80 100644 (file)
@@ -17,7 +17,6 @@
 %bcond_without ssl             # build without SSL support
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
-%bcond_without event           # event MPM
 %bcond_with    itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
@@ -1773,7 +1772,7 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch12 -p1
+#%%patch12 -p1
 %patch14 -p1
 %patch15 -p1
 %patch18 -p1
@@ -1818,12 +1817,10 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
-install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
-../%configure \
+%configure \
        --enable-layout=TLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
+       --enable-exception-hook \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1878,13 +1875,9 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --enable-speling \
        --enable-rewrite \
        --enable-so \
-       --with-program-name=httpd.${mpm} \
-       --with-mpm=${mpm} \
-%ifarch %{ix86}
-%ifnarch i386 i486
-       $( [ "${mpm}" = "leader" ] && echo "--enable-nonportable-atomics=yes" ) \
-%endif
-%endif
+       --with-program-name=httpd \
+       --with-mpm=prefork \
+       --enable-mpms-shared=all \
        --with-suexec-bin=%{_sbindir}/suexec \
        --with-suexec-caller=http \
        --with-suexec-docroot=%{_datadir} \
@@ -1897,18 +1890,7 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --with-pcre
 
 %{__make}
-./httpd.${mpm} -l | grep -v "${mpm}" > modules-inside
-cd ..
-
-done
-
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
-               echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
-               echo "Build failed."
-               exit 1
-       fi
-done
+./httpd -l > modules-inside
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1919,18 +1901,13 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 # prefork is default one
-%{__make} -C buildmpm-prefork install \
+%{__make}  install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# install other mpm-s
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
-done
-
-ln -s httpd.prefork $RPM_BUILD_ROOT%{_sbindir}/httpd
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run
 ln -s %{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/logs
+mv $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf.orig
 ln -s conf.d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd