]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- build all mpms as module, prefork is default
authorBartosz Świątek <shadzik@tld-linux.org>
Wed, 22 Feb 2012 00:36:46 +0000 (01:36 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Wed, 22 Feb 2012 00:36:46 +0000 (01:36 +0100)
apache.spec

index 8f232f86214f490137f9f0e5daaa0c2afa9704a7..626b70c06e2368d8a11e47468c957208c1e47b80 100644 (file)
@@ -17,7 +17,6 @@
 %bcond_without ssl             # build without SSL support
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
-%bcond_without event           # event MPM
 %bcond_with    itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
@@ -1878,9 +1877,7 @@ CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
        --enable-so \
        --with-program-name=httpd \
        --with-mpm=prefork \
-       --with-mpm=worker \
-       --with-mpm=event \
-       --enable-mpms-shared \
+       --enable-mpms-shared=all \
        --with-suexec-bin=%{_sbindir}/suexec \
        --with-suexec-caller=http \
        --with-suexec-docroot=%{_datadir} \
@@ -1904,13 +1901,13 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 # prefork is default one
-%{__make} -C buildmpm-prefork install \
+%{__make}  install \
        DESTDIR=$RPM_BUILD_ROOT
 
-ln -s httpd.prefork $RPM_BUILD_ROOT%{_sbindir}/httpd
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run
 ln -s %{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/logs
+mv $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf.orig
 ln -s conf.d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd