]> TLD Linux GIT Repositories - packages/ansible.git/blob - ansible.spec
- updated to 9.4.0
[packages/ansible.git] / ansible.spec
1 Summary:        Curated set of Ansible collections included in addition to ansible-core
2 Name:           ansible
3 Version:        9.1.0
4 Release:        1
5 License:        GPL v3+
6 Group:          Development/Libraries
7 Source0:        https://files.pythonhosted.org/packages/source/a/ansible/%{name}-%{version}.tar.gz
8 # Source0-md5:  dcc0b77c8d808668232f190934a95acb
9 Patch0:         setup.patch
10 URL:            https://ansible.com
11 BuildRequires:  python3-PyYAML
12 BuildRequires:  python3-modules
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 Requires:       %{name}-core >= 2.6.11
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Ansible is a radically simple model-driven configuration management,
21 multi-node deployment, and remote task execution system. Ansible works
22 over SSH and does not require any software or daemons to be installed
23 on remote nodes. Extension modules can be written in any language and
24 are transferred to managed machines automatically.
25
26 %prep
27 %setup -q
28 %patch0 -p1
29
30 grep -rlZ -0 '#!/usr/bin/env bash' ansible_collections | xargs -0 sed -i -e 's,#!/usr/bin/env bash,#!/bin/bash,g'
31
32 %build
33 %py3_build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %py3_install
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %attr(755,root,root) %{_bindir}/ansible-community
45 %{py3_sitescriptdir}/ansible_collections
46 %{py3_sitescriptdir}/ansible-%{version}-*.egg-info