]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- build MPMs as loadable modules
authorBartosz Świątek <shadzik@tld-linux.org>
Tue, 21 Feb 2012 23:58:52 +0000 (00:58 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Tue, 21 Feb 2012 23:58:52 +0000 (00:58 +0100)
apache.spec

index 66cf677a3529fde0325e91b233966322b71b97f0..8f232f86214f490137f9f0e5daaa0c2afa9704a7 100644 (file)
@@ -1818,12 +1818,10 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
-install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
-../%configure \
+%configure \
        --enable-layout=TLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" ] && echo "--enable-exception-hook" ) \
+       --enable-exception-hook \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1878,13 +1876,11 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --enable-speling \
        --enable-rewrite \
        --enable-so \
-       --with-program-name=httpd.${mpm} \
-       --with-mpm=${mpm} \
-%ifarch %{ix86}
-%ifnarch i386 i486
-       $( [ "${mpm}" = "leader" ] && echo "--enable-nonportable-atomics=yes" ) \
-%endif
-%endif
+       --with-program-name=httpd \
+       --with-mpm=prefork \
+       --with-mpm=worker \
+       --with-mpm=event \
+       --enable-mpms-shared \
        --with-suexec-bin=%{_sbindir}/suexec \
        --with-suexec-caller=http \
        --with-suexec-docroot=%{_datadir} \
@@ -1897,18 +1893,7 @@ install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
        --with-pcre
 
 %{__make}
-./httpd.${mpm} -l | grep -v "${mpm}" > modules-inside
-cd ..
-
-done
-
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
-               echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
-               echo "Build failed."
-               exit 1
-       fi
-done
+./httpd -l > modules-inside
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1922,11 +1907,6 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
 %{__make} -C buildmpm-prefork install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# install other mpm-s
-for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
-       install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
-done
-
 ln -s httpd.prefork $RPM_BUILD_ROOT%{_sbindir}/httpd
 ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run