]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- add upgrading info and trigger
authorBartosz Świątek <shadzik@tld-linux.org>
Fri, 24 Feb 2012 16:30:53 +0000 (17:30 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Fri, 24 Feb 2012 16:30:53 +0000 (17:30 +0100)
apache.spec

index 4b253b76cadb325a38133f3773738aa34189f7f6..23e530bf2fe22128cf34e1a8d5dd23b522fa0278 100644 (file)
@@ -2481,6 +2481,33 @@ Please report bugs to <http://bugs.pld-linux.org/>.
 
 EOF
 
+%triggerpostun base -- %{name} < 2.4.0
+if [ -f /etc/sysconfig/httpd ]; then
+       MPM=$(grep HTTPD_MPM /etc/sysconfig/httpd |sed 's,HTTPD_MPM=,,;s,",,g')
+       echo "LoadModule mpm_${MPM}_module                modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
+       cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
+       mv /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf
+fi
+%banner -e %{name} << EOF
+WARNING!!!
+Since apache-2.4 mod_authn_alias has been obsoleted.
+If you use access control (Deny,Allow) install mod_access_compat by doing:
+poldek -ivh %{name}-mod_access_compat
+
+If you use "User" statement install mod_unixd by doing:
+poldek -ivh %{name}-mod_unixd
+
+In apache-2.4 mod_authn_default and mod_authz_default have been obsoleted by
+mod_authn_core and authz_core. If you used these modules install the new ones by invoking:
+poldek -ivh %{name}-mod_authn_core
+and/or
+poldek -ivh %{name}-mod_authz_core
+
+For more information on how to upgrade from Apache 2.2 visit:
+http://httpd.apache.org/docs/2.4/upgrading.html
+EOF
+
+
 %triggerpostun mod_ssl -- %{name}-mod_ssl < 1:2.2.0-3.1
 cp -f /etc/httpd/conf.d/40_mod_ssl.conf{,.rpmsave}
 sed -i -e '