]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- 2.4 access control syntax httpd-2_4
authorBartosz Świątek <shadzik@tld-linux.org>
Sun, 26 Feb 2012 20:53:09 +0000 (21:53 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Sun, 26 Feb 2012 20:53:09 +0000 (21:53 +0100)
- clear 2.4 TODO

apache-common.conf
apache-example.net.conf
apache-manual.conf
apache-mod_authz_host.conf
apache-mod_autoindex.conf
apache-mod_info.conf
apache-mod_proxy.conf
apache-mod_status.conf
apache-mod_userdir.conf
apache-multilang-errordoc.conf
apache.spec

index 05686e9666a584d6725887cd3a9bf8424e295489..8643668fb619b8f4be48370700fdfde7c44569d0 100644 (file)
@@ -16,8 +16,7 @@ DocumentRoot "/home/services/httpd/html"
        Options FollowSymLinks
        AllowOverride None
        <IfModule mod_authz_host.c>
-               Order deny,allow
-               Deny from all
+               Require all denied
        </IfModule>
 </Directory>
 
@@ -50,8 +49,7 @@ DocumentRoot "/home/services/httpd/html"
        # Controls who can get stuff from this server.
        #
        <IfModule mod_authz_host.c>
-               Order allow,deny
-               Allow from all
+               Require all granted
        </IfModule>
 
 </Directory>
index 2d65d7f18789bf5a8951053d23546eeab835603c..90a938bf014bcd68d56e62ef7199733e61e8863c 100644 (file)
@@ -18,7 +18,6 @@
 #  AllowOverride None
 #  Options None
 #  <IfModule mod_authz_host.c>
-#    Order allow,deny
-#    Allow from all
+#      Require all granted
 #  </IfModule>
 #</Directory>
index a94735d99b762218d8aea97c8b6515b889c1459d..77edb70db0a83efa3935a00837a09c285baf2fa7 100644 (file)
@@ -12,8 +12,7 @@ AliasMatch ^/manual(?:/(?:de|en|es|fr|ja|ko|pt-br|ru))?(/.*)?$ "/home/services/h
 <Directory "/home/services/httpd/manual">
        Options Indexes
        AllowOverride None
-       Order allow,deny
-       Allow from all
+       Require all granted
 
        <Files *.html>
                SetHandler type-map
index cf9c2599c7387fc9df9703ea44b328756fd856bb..679203500d45df15ac23fa2637568478cb369bc1 100644 (file)
@@ -1,4 +1,3 @@
-
 LoadModule authz_host_module modules/mod_authz_host.so
 
 # The following lines prevent .htaccess and .htpasswd files from being
@@ -6,7 +5,6 @@ LoadModule authz_host_module modules/mod_authz_host.so
 #
 <IfModule authz_host_module>
        <FilesMatch "^\.ht">
-               Order allow,deny
-               Deny from all
+               Require all denied
        </FilesMatch>
 </IfModule>
index a8fb2ed58b38de783a5a8fcdca339daa054257e3..e23c0a10b8fcb2e89a47faee13ca0e98e74291bf 100644 (file)
@@ -1,4 +1,3 @@
-
 LoadModule autoindex_module    modules/mod_autoindex.so
 
 #
@@ -26,8 +25,7 @@ Alias /icons/ "/home/services/httpd/icons/"
        Options Indexes MultiViews
        AllowOverride None
        <IfModule mod_authz_host.c>
-               Order allow,deny
-               Allow from all
+               Require all granted
        </IfModule>
 </Directory>
 
index 6ede0b073e1f4df081b211976235e5fe67370492..0b8bc14a003849def55357be1a0646c859915311 100644 (file)
@@ -14,9 +14,7 @@ LoadModule info_module                modules/mod_info.so
 #
 <Location /server-info>
        SetHandler server-info
-       Order deny,allow
-       Deny from all
-       Allow from 127.0.0.1
+       Require local
 </Location>
 
 </IfModule>
index 8b21e9c6daf7caebd555e4871b94701aaa63a565..31c7afc2cbc3212889067b0b8fb914e77a371eed 100644 (file)
@@ -20,9 +20,8 @@ ProxyRequests On
 # http://victim:25/ and sending raw data.
 #
 <Proxy *>
-       Order deny,allow
-       Deny from all
-#      Allow from .your-domain.com
+       Require all denied
+#      Require host .your-domain.com
 </Proxy>
 
 #
index 62e9b2a26e6198258f5bd2a740bdc827c9e1bcfd..9851db41cd615a71eae7a4dee51f198dbe203fe9 100644 (file)
@@ -15,9 +15,7 @@ LoadModule status_module              modules/mod_status.so
 
 <Location /server-status>
        SetHandler server-status
-       Order deny,allow
-       Deny from all
-       Allow from 127.0.0.1
+       Require local
 </Location>
 
 #
index 967522711c88a542077262a9b35d943f438b0919..8e8ce28ed3baa37c32a864648a0033fcb4b98f74 100644 (file)
@@ -21,12 +21,10 @@ UserDir public_html
        AllowOverride FileInfo AuthConfig Limit Indexes
        Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
        <Limit GET POST OPTIONS>
-               Order allow,deny
-               Allow from all
+               Require all granted
        </Limit>
        <LimitExcept GET POST OPTIONS>
-               Order deny,allow
-               Deny from all
+               Require all denied
        </LimitExcept>
        #<IfModule mod_php.c>
        #       php_admin_value open_basedir "/home/users:/usr/share/pear:/usr/share/php:/tmp"
index f865b6f5984ae468f3652914f8dc621389411941..0cc6af5427ba5e1b7acd61b2b857d714d148c0cc 100644 (file)
@@ -26,8 +26,7 @@ Alias /error/ "/home/services/httpd/error/"
        Options IncludesNoExec
        AddOutputFilter Includes html
        AddHandler type-map var
-       Order allow,deny
-       Allow from all
+       Require all granted
        LanguagePriority en cs de es fr it ja ko nl pl pt-br ro sv tr
        ForceLanguagePriority Prefer Fallback
 </Directory>
index 04e62f66018782391646e17b090c21dd6ea92db7..4203cf260d7ead02b681da2684757e34e18811dd 100644 (file)
 # - mod_auth_digest and mod_auth_basic R: apache(authn) ?
 # - FYI: http://wiki.apache.org/httpd/InternalDummyConnection
 
-
-# 2.4 TODO
-#
-# add new access control syntax to configs by default (mod_access_compat provides old syntax)
-
-
 # Conditional build:
 %bcond_without ssl             # build without SSL support
 %bcond_without ldap            # build without LDAP support