]> TLD Linux GIT Repositories - packages/apache.git/commitdiff
- PLD merge
authorMarcin Krol <hawk@tld-linux.org>
Tue, 9 Jul 2013 17:05:01 +0000 (17:05 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Tue, 9 Jul 2013 17:05:01 +0000 (17:05 +0000)
apache-example.net.conf
apache-httpd.conf
apache-layout.patch
apache.spec

index 90a938bf014bcd68d56e62ef7199733e61e8863c..c08629d732576ee0fabe33f64db380451638641c 100644 (file)
@@ -18,6 +18,6 @@
 #  AllowOverride None
 #  Options None
 #  <IfModule mod_authz_host.c>
-#      Require all granted
+#    Require all granted
 #  </IfModule>
 #</Directory>
index 60453a0fb867b220074a78776c82b7371aaa2e3a..28199f7fd7a4861baf92015000102ffe5fb0f1a6 100644 (file)
@@ -7,9 +7,10 @@
 # <URL:http://httpd.apache.org/docs/2.2/mod/directives.html>
 # for a discussion of each configuration directive.
 
+ServerRoot "/etc/httpd"
+
 LoadModule unixd_module   modules/mod_unixd.so
 
-ServerRoot "/etc/httpd"
 
 # User/Group: The name (or #number) of the user/group to run httpd as.
 # It is usually good practice to create a dedicated user and group for
index b2ebbfc396d212bac7b3d247c534b21e636243e1..f211aff5f02e701992f30cac8c2dd1d898c66476 100644 (file)
@@ -1,6 +1,6 @@
 --- httpd-2.4.3/config.layout.orig     2012-04-17 16:01:41.000000000 +0200
-+++ httpd-2.4.3/config.layout  2012-08-22 11:06:19.883386343 +0200
-@@ -370,3 +370,28 @@
++++ httpd-2.4.3/config.layout  2012-08-23 13:01:27.879147377 +0200
+@@ -370,3 +370,29 @@
      logfiledir:      ${localstatedir}/log/httpd
      proxycachedir:   ${localstatedir}/cache/httpd
  </Layout>
@@ -29,3 +29,4 @@
 +    proxycachedir: /var/cache/httpd
 +    installbuilddir: ${libexecdir}/build
 +</Layout>
++
index 5458b3659f8eee1977d93d22a037f94a57ee75e2..06064245b2dd7035f790675c126f1389fa24663c 100644 (file)
@@ -21,7 +21,7 @@
 # this is internal macro, don't change to %%apache_modules_api
 %define                _apache_modules_api 20120211
 
-%define                openssl_ver     0.9.8i
+%define                openssl_ver     1.0.1e
 %define                apr_ver         1:1.4.6
 
 %include       /usr/lib/rpm/macros.perl
@@ -35,7 +35,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.4.4
-Release:       4
+Release:       5
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -206,6 +206,8 @@ Obsoletes:  apache-mod_optional_fn_import
 Obsoletes:     apache-mod_optional_fn_import
 Obsoletes:     apache-mod_optional_hook_import
 Conflicts:     apache < 2.2.0
+# mod_wsgi >= 3.4 is required for apache 2.4
+Conflicts:     apache-mod_wsgi < 3.4
 Conflicts:     logrotate < 3.7-4
 # for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
@@ -838,8 +840,6 @@ Group:              Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.4/mod/mod_authz_host.html
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-mod_authz_core = %{version}-%{release}
-# provides compatibility directives for 2.2-style access control
-Requires:      apache(mod_access_compat) = %{version}-%{release}
 Provides:      apache(mod_authz_host) = %{version}-%{release}
 # for apache < 2.2.0
 Provides:      apache(mod_access) = %{version}-%{release}
@@ -2617,7 +2617,7 @@ if [ "$MODULES_API" != "%_apache_modules_api" ]; then
        exit 1
 fi
 
-# fix libdir (at least in PLD layout; no need to care about other ones)
+# fix libdir (at least in TLD layout; no need to care about other ones)
 sed -i -e 's,/lib$,/%{_lib},' config.layout
 
 %build
@@ -2931,7 +2931,7 @@ if [ ! -L /etc/httpd/httpd.conf ]; then
 fi
 if [ -f /etc/sysconfig/httpd ]; then
         MPM=$(grep ^HTTPD_MPM /etc/sysconfig/httpd |sed 's,HTTPD_MPM=,,;s,",,g')
-        if [ -n $MPM ]; then
+        if [ -n "$MPM" ]; then
                 echo "LoadModule mpm_${MPM}_module                modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
                 cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
                 mv /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf