]> TLD Linux GIT Repositories - packages/coreutils.git/commitdiff
- merged 9.1 from PLD
authorMarcin Krol <hawk@tld-linux.org>
Sat, 28 May 2022 13:21:24 +0000 (15:21 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 28 May 2022 13:21:24 +0000 (15:21 +0200)
coreutils-fmt-wchars.patch
coreutils-info.patch
coreutils-uname-cpuinfo.patch
coreutils.spec

index 64748ea0ad5e51d1d78f27f7cf9bb7bc0b9dd0a2..e82dde10be6df065855969cbf15af929e17ea2c1 100644 (file)
 +          word_limit->width += xwcwidth (c);
 +          c = xgetwc (f);
          }
--      while (c != EOF && !isspace (c));
+-      while (c != EOF && !c_isspace (c));
 -      in_column += word_limit->length = wptr - word_limit->text;
 +      while (c != WEOF && !isspace (c));
 +      word_limit->length = wptr - word_limit->text;
index dc3373a8f63ed863ae8367cfa2485631f4476e02..dc83a42f905e0475e1b3648aae5e49323f4332f5 100644 (file)
@@ -1,5 +1,5 @@
---- coreutils-9.0/doc/coreutils.texi.orig      2021-09-24 13:31:05.000000000 +0200
-+++ coreutils-9.0/doc/coreutils.texi   2021-10-07 17:55:04.486617755 +0200
+--- coreutils-9.1/doc/coreutils.texi.orig      2022-04-15 19:30:07.000000000 +0200
++++ coreutils-9.1/doc/coreutils.texi   2022-04-17 14:06:21.550894970 +0200
 @@ -22,123 +22,112 @@
  @syncodeindex pg cp
  @syncodeindex vr cp
  @section @command{csplit}: Split a file into context-determined pieces
  
  @pindex csplit
-@@ -3736,17 +3718,17 @@ These commands generate just a few numbe
+@@ -3737,17 +3719,17 @@ These commands generate just a few numbe
  contents of files.
  
  @menu
  @section @command{wc}: Print newline, word, and byte counts
  
  @pindex wc
-@@ -3872,7 +3854,7 @@ find . -name '*.[ch]' -print0 |
+@@ -3873,7 +3855,7 @@ find . -name '*.[ch]' -print0 |
  @exitstatus
  
  
  @section @command{sum}: Print checksum and block counts
  
  @pindex sum
-@@ -3921,7 +3903,7 @@ next section) is preferable in new appli
+@@ -3922,7 +3904,7 @@ next section) is preferable in new appli
  @exitstatus
  
  
  @section @command{cksum}: Print and verify file checksums
  
  @pindex cksum
-@@ -3953,7 +3935,7 @@ for each file along with the number of b
+@@ -3954,7 +3936,7 @@ for each file along with the number of b
  and the file name unless no arguments were given.
  
  The same usage and options as the @command{b2sum}
  In addition @command{cksum} supports the following options.
  
  @table @samp
-@@ -3996,11 +3978,11 @@ This format has the checksum at the star
+@@ -3997,11 +3979,11 @@ This format has the checksum at the star
  more amenable to further processing by other utilities,
  especially in combination with the @option{--zero} option.
  Note this does not identify the digest algorithm used for the checksum.
  @section @command{b2sum}: Print or check BLAKE2 digests
  
  @pindex b2sum
-@@ -4012,7 +3994,7 @@ Note this does not identify the digest a
+@@ -4013,7 +3995,7 @@ Note this does not identify the digest a
  
  @command{b2sum} computes a 512-bit checksum for each specified
  @var{file}.  The same usage and options as the @command{md5sum}
  In addition @command{b2sum} supports the following options.
  
  @table @samp
-@@ -4027,7 +4009,7 @@ This option is ignored when @option{--ch
+@@ -4028,7 +4010,7 @@ This option is ignored when @option{--ch
  as the length is automatically determined when checking.
  @end table
  
  @section @command{md5sum}: Print or check MD5 digests
  
  @pindex md5sum
-@@ -4050,7 +4032,7 @@ fingerprint is considered infeasible at
+@@ -4051,7 +4033,7 @@ fingerprint is considered infeasible at
  to modify certain files, including digital certificates, so that they
  appear valid when signed with an \hash\ digest.  For more secure hashes,
  consider using SHA-2, or the newer @command{b2sum} command.
  @end macro
  @weakHash{MD5}
  
-@@ -4208,7 +4190,7 @@ Also file name escaping is not used.
+@@ -4209,7 +4191,7 @@ Also file name escaping is not used.
  @exitstatus
  
  
  @section @command{sha1sum}: Print or check SHA-1 digests
  
  @pindex sha1sum
-@@ -4220,7 +4202,7 @@ Also file name escaping is not used.
+@@ -4221,7 +4203,7 @@ Also file name escaping is not used.
  
  @command{sha1sum} computes a 160-bit checksum for each specified
  @var{file}.  The usage and options of this command are precisely the
  
  @weakHash{SHA-1}
  
-@@ -4256,7 +4238,7 @@ various lengths (respectively 224, 256,
+@@ -4257,7 +4239,7 @@ various lengths (respectively 224, 256,
  collectively known as the SHA-2 hashes.  The usage and options of
  these commands are precisely the same as for @command{md5sum}
  and @command{sha1sum}.
  
  
  @node Operating on sorted files
-@@ -4268,16 +4250,16 @@ and @command{sha1sum}.
+@@ -4269,16 +4251,16 @@ and @command{sha1sum}.
  These commands work with (or produce) sorted files.
  
  @menu
  @section @command{sort}: Sort text files
  
  @pindex sort
-@@ -4573,7 +4555,7 @@ appear earlier in the output instead of
+@@ -4574,7 +4556,7 @@ appear earlier in the output instead of
  Sort by hashing the input keys and then sorting the hash values.
  Choose the hash function at random, ensuring that it is free of
  collisions so that differing keys have differing hash values.  This is
  except that keys with the same value sort together.
  
  If multiple random sort fields are specified, the same random hash
-@@ -4771,7 +4753,7 @@ Set the number of sorts run in parallel
+@@ -4772,7 +4754,7 @@ Set the number of sorts run in parallel
  @var{n} is set to the number of available processors, but limited
  to 8, as there are diminishing performance gains after that.
  Note also that using @var{n} threads increases the memory usage by
  
  @item -u
  @itemx --unique
-@@ -4789,7 +4771,7 @@ The commands @code{sort -u} and @code{so
+@@ -4790,7 +4772,7 @@ The commands @code{sort -u} and @code{so
  this equivalence does not extend to arbitrary @command{sort} options.
  For example, @code{sort -n -u} inspects only the value of the initial
  numeric string when checking for uniqueness, whereas @code{sort -n |
  
  @optZeroTerminated
  @macro newlineFieldSeparator
-@@ -5002,7 +4984,7 @@ ls */* | sort -t / -k 1,1R -k 2,2
+@@ -5003,7 +4985,7 @@ ls */* | sort -t / -k 1,1R -k 2,2
  @end itemize
  
  
  @section @command{shuf}: Shuffling text
  
  @pindex shuf
-@@ -5158,7 +5140,7 @@ shuf -r -n 100 -e Head Tail
+@@ -5159,7 +5141,7 @@ shuf -r -n 100 -e Head Tail
  @exitstatus
  
  
  @section @command{uniq}: Uniquify files
  
  @pindex uniq
-@@ -5180,7 +5162,7 @@ lines that are not repeated, or all repe
+@@ -5181,7 +5163,7 @@ lines that are not repeated, or all repe
  The input need not be sorted, but repeated input lines are detected
  only if they are adjacent.  If you want to discard non-adjacent
  duplicate lines, perhaps you want to use @code{sort -u}.
  
  @vindex LC_COLLATE
  Comparisons honor the rules specified by the @env{LC_COLLATE}
-@@ -5345,7 +5327,7 @@ compared.
+@@ -5346,7 +5328,7 @@ compared.
  @exitstatus
  
  
  @section @command{comm}: Compare two sorted files line by line
  
  @pindex comm
-@@ -5460,7 +5442,7 @@ $ comm -12 file1 file2 | wc -l    # numb
+@@ -5461,7 +5443,7 @@ $ comm -12 file1 file2 | wc -l    # numb
  
  @end table
  
  @section @command{ptx}: Produce permuted indexes
  
  @pindex ptx
-@@ -5950,7 +5932,7 @@ allowed with System V @command{ptx}.
+@@ -5951,7 +5933,7 @@ allowed with System V @command{ptx}.
  @end itemize
  
  
  @section @command{tsort}: Topological sort
  
  @pindex tsort
-@@ -6112,13 +6094,13 @@ in different ways.
+@@ -6113,13 +6095,13 @@ in different ways.
  @chapter Operating on fields
  
  @menu
  @section @command{cut}: Print selected parts of lines
  
  @pindex cut
-@@ -6243,7 +6225,7 @@ many fields and want to print all but a
+@@ -6244,7 +6226,7 @@ many fields and want to print all but a
  @exitstatus
  
  
  @section @command{paste}: Merge lines of files
  
  @pindex paste
-@@ -6341,7 +6323,7 @@ $ paste -d '%_' num2 let3 num2
+@@ -6342,7 +6324,7 @@ $ paste -d '%_' num2 let3 num2
  @exitstatus
  
  
  @section @command{join}: Join lines on a common field
  
  @pindex join
-@@ -6873,13 +6855,13 @@ entire lines as the key.
+@@ -6874,13 +6856,13 @@ entire lines as the key.
  These commands operate on individual characters.
  
  @menu
  @section @command{tr}: Translate, squeeze, and/or delete characters
  
  @pindex tr
-@@ -7291,7 +7273,7 @@ square brackets from interpretation by a
+@@ -7303,7 +7285,7 @@ tr -d -- -axM
  @end itemize
  
  
  @section @command{expand}: Convert tabs to spaces
  
  @pindex expand
-@@ -7360,7 +7342,7 @@ characters) on each line to spaces.
+@@ -7372,7 +7354,7 @@ characters) on each line to spaces.
  @exitstatus
  
  
  @section @command{unexpand}: Convert spaces to tabs
  
  @pindex unexpand
-@@ -7423,14 +7405,14 @@ This chapter describes the @command{ls}
+@@ -7435,14 +7417,14 @@ This chapter describes the @command{ls}
  and @command{vdir}, which list information about files.
  
  @menu
  @section @command{ls}: List directory contents
  
  @pindex ls
-@@ -8325,7 +8307,7 @@ be one of the following:
+@@ -8337,7 +8319,7 @@ be one of the following:
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{ls} to list timestamps like @samp{2020-03-30 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -8526,7 +8508,7 @@ This is the default unless the output is
+@@ -8538,7 +8520,7 @@ This is the default unless the output is
  @end table
  
  
  @section @command{dir}: Briefly list directory contents
  
  @pindex dir
-@@ -8536,10 +8518,10 @@ This is the default unless the output is
+@@ -8548,10 +8530,10 @@ This is the default unless the output is
  -b}; that is, by default files are listed in columns, sorted vertically,
  and special characters are represented by backslash escape sequences.
  
  @section @command{vdir}: Verbosely list directory contents
  
  @pindex vdir
-@@ -8549,9 +8531,9 @@ and special characters are represented b
+@@ -8561,9 +8543,9 @@ and special characters are represented b
  -b}; that is, by default files are listed in long format and special
  characters are represented by backslash escape sequences.
  
  @section @command{dircolors}: Color setup for @command{ls}
  
  @pindex dircolors
-@@ -8638,16 +8620,16 @@ This chapter describes the commands for
+@@ -8656,16 +8638,16 @@ This chapter describes the commands for
  copying, moving (renaming), and deleting (removing).
  
  @menu
  @section @command{cp}: Copy files and directories
  
  @pindex cp
-@@ -9142,7 +9124,7 @@ option, and overrides the @option{--pres
+@@ -9160,7 +9142,7 @@ option, and overrides the @option{--pres
  @exitstatus
  
  
  @section @command{dd}: Convert and copy a file
  
  @pindex dd
-@@ -9683,7 +9665,7 @@ environment variable is set.
+@@ -9740,7 +9722,7 @@ environment variable is set.
  @exitstatus
  
  
  @section @command{install}: Copy files and set attributes
  
  @pindex install
-@@ -9865,7 +9847,7 @@ This option is mutually exclusive with t
+@@ -9922,7 +9904,7 @@ This option is mutually exclusive with t
  @exitstatus
  
  
  @section @command{mv}: Move (rename) files
  
  @pindex mv
-@@ -10011,7 +9993,7 @@ to the system default type for destinati
+@@ -10068,7 +10050,7 @@ to the system default type for destinati
  @exitstatus
  
  
  @section @command{rm}: Remove files or directories
  
  @pindex rm
-@@ -10177,7 +10159,7 @@ predates the development of the @code{ge
+@@ -10234,7 +10216,7 @@ predates the development of the @code{ge
  @exitstatus
  
  
  @section @command{shred}: Remove files more securely
  
  @pindex shred
-@@ -10187,7 +10169,7 @@ predates the development of the @code{ge
+@@ -10244,7 +10226,7 @@ predates the development of the @code{ge
  @command{shred} overwrites devices or files, to help prevent even
  extensive forensics from recovering the data.
  
  and metadata are not actually destroyed.  Only the file's directory
  entry is removed, and the file's storage is reclaimed only when no
  process has the file open and no other directory entry links to the
-@@ -10474,18 +10456,18 @@ Besides directories, other special file
+@@ -10531,18 +10513,18 @@ Besides directories, other special file
  (FIFOs), symbolic links, sockets, and so-called @dfn{special files}.
  
  @menu
  @section @command{link}: Make a hard link via the link syscall
  
  @pindex link
-@@ -10498,7 +10480,7 @@ It is a minimalist interface to the syst
+@@ -10555,7 +10537,7 @@ It is a minimalist interface to the syst
  @code{link} function.  @xref{Hard Links, , , libc,
  The GNU C Library Reference Manual}.
  It avoids the bells and whistles of the more commonly-used
  Synopsis:
  
  @example
-@@ -10524,7 +10506,7 @@ to specify which behavior is desired.
+@@ -10581,7 +10563,7 @@ to specify which behavior is desired.
  @exitstatus
  
  
  @section @command{ln}: Make links between files
  
  @pindex ln
-@@ -10711,7 +10693,7 @@ ln -srv /a/file /tmp
+@@ -10768,7 +10750,7 @@ ln -srv /a/file /tmp
  Relative symbolic links are generated based on their canonicalized
  containing directory, and canonicalized targets.  I.e., all symbolic
  links in these file names will be resolved.
  over relative file name generation, as demonstrated in the following example:
  
  @example
-@@ -10788,7 +10770,7 @@ ln -s ../adir/afile yetanotherfile
+@@ -10845,7 +10827,7 @@ ln -s ../adir/afile yetanotherfile
  @end example
  
  
  @section @command{mkdir}: Make directories
  
  @pindex mkdir
-@@ -10866,7 +10848,7 @@ Print a message for each created directo
+@@ -10923,7 +10905,7 @@ Print a message for each created directo
  @exitstatus
  
  
  @section @command{mkfifo}: Make FIFOs (named pipes)
  
  @pindex mkfifo
-@@ -10907,7 +10889,7 @@ permission bits.  @xref{File permissions
+@@ -10964,7 +10946,7 @@ permission bits.  @xref{File permissions
  @exitstatus
  
  
  @section @command{mknod}: Make block or character special files
  
  @pindex mknod
-@@ -10984,7 +10966,7 @@ Set the mode of created files to @var{mo
+@@ -11041,7 +11023,7 @@ Set the mode of created files to @var{mo
  @exitstatus
  
  
  @section @command{readlink}: Print value of a symlink or canonical file name
  
  @pindex readlink
-@@ -11008,7 +10990,7 @@ of a symbolic link, it produces no outpu
+@@ -11065,7 +11047,7 @@ of a symbolic link, it produces no outpu
  @command{readlink} outputs the absolute name of the given files which contain
  no @file{.}, @file{..} components nor any repeated separators
  (@file{/}) or symbolic links.  Note the @command{realpath} command is the
  
  @end table
  
-@@ -11083,7 +11065,7 @@ The @command{realpath} command without o
+@@ -11140,7 +11122,7 @@ The @command{realpath} command without o
  @exitstatus
  
  
  @section @command{rmdir}: Remove empty directories
  
  @pindex rmdir
-@@ -11131,7 +11113,7 @@ Give a diagnostic for each successful re
+@@ -11188,7 +11170,7 @@ Give a diagnostic for each successful re
  
  @end table
  
  
  To remove all empty directories under @var{dirname}, including
  directories that become empty because other directories are removed,
-@@ -11148,7 +11130,7 @@ find @var{dirname} -depth -type d -exec
+@@ -11205,7 +11187,7 @@ find @var{dirname} -depth -type d -exec
  @exitstatus
  
  
  @section @command{unlink}: Remove files via the unlink syscall
  
  @pindex unlink
-@@ -11159,7 +11141,7 @@ It is a minimalist interface to the syst
+@@ -11216,7 +11198,7 @@ It is a minimalist interface to the syst
  @code{unlink} function.  @xref{Deleting Files, , , libc,
  The GNU C Library Reference Manual}.  Synopsis:
  It avoids the bells and whistles of the more commonly-used
  
  @example
  unlink @var{filename}
-@@ -11193,14 +11175,14 @@ timestamps, and other information.  Coll
+@@ -11250,14 +11232,14 @@ timestamps, and other information.  Coll
  These commands change file attributes.
  
  @menu
  @section @command{chown}: Change file owner and group
  
  @pindex chown
-@@ -11427,7 +11409,7 @@ chown -hR root /u
+@@ -11485,7 +11467,7 @@ chown -hR root /u
  @end example
  
  
  @section @command{chgrp}: Change group ownership
  
  @pindex chgrp
-@@ -11436,7 +11418,7 @@ chown -hR root /u
+@@ -11494,7 +11476,7 @@ chown -hR root /u
  
  @command{chgrp} changes the group ownership of each given @var{file}
  to @var{group} (which can be either a group name or a numeric group ID)
  Synopsis:
  
  @example
-@@ -11555,7 +11537,7 @@ chgrp -hR staff /u
+@@ -11613,7 +11595,7 @@ chgrp -hR staff /u
  @end example
  
  
  @section @command{chmod}: Change access permissions
  
  @pindex chmod
-@@ -11677,7 +11659,7 @@ chmod -R a=,+rwX dir
+@@ -11735,7 +11717,7 @@ chmod -R a=,+rwX dir
  @end smallexample
  
  
  @section @command{touch}: Change file timestamps
  
  @pindex touch
-@@ -11852,15 +11834,15 @@ how much storage is in use or available,
+@@ -11910,15 +11892,15 @@ how much storage is in use or available,
  file status information, and write buffers to file systems.
  
  @menu
  @section @command{df}: Report file system space usage
  
  @pindex df
-@@ -12168,7 +12150,7 @@ be read and one or more of the options @
+@@ -12226,7 +12208,7 @@ be read and one or more of the options @
  or @option{-x} is used together with a file name argument.
  
  
  @section @command{du}: Estimate file space usage
  
  @pindex du
-@@ -12426,7 +12408,7 @@ be one of the following:
+@@ -12484,7 +12466,7 @@ be one of the following:
  @item +@var{format}
  @vindex LC_TIME
  List timestamps using @var{format}, where @var{format} is interpreted
  For example, @option{--time-style="+%Y-%m-%d %H:%M:%S"} causes
  @command{du} to list timestamps like @samp{2020-07-21 23:45:56}.  As
  with @command{date}, @var{format}'s interpretation is affected by the
-@@ -12494,7 +12476,7 @@ in HP-UX; it also affects the HP-UX @com
+@@ -12552,7 +12534,7 @@ in HP-UX; it also affects the HP-UX @com
  @exitstatus
  
  
  @section @command{stat}: Report file or file system status
  
  @pindex stat
-@@ -12735,7 +12717,7 @@ with @env{TZ}, libc, The GNU C Library R
+@@ -12794,7 +12776,7 @@ with @env{TZ}, libc, The GNU C Library R
  @exitstatus
  
  
  @section @command{sync}: Synchronize cached writes to persistent storage
  
  @pindex sync
-@@ -12795,7 +12777,7 @@ write barriers, than a global sync(2) us
+@@ -12854,7 +12836,7 @@ write barriers, than a global sync(2) us
  @exitstatus
  
  
  @section @command{truncate}: Shrink or extend the size of a file
  
  @pindex truncate
-@@ -12872,13 +12854,13 @@ the size of each @var{file} based on its
+@@ -12931,13 +12913,13 @@ the size of each @var{file} based on its
  This section describes commands that display text strings.
  
  @menu
  @section @command{echo}: Print a line of text
  
  @pindex echo
-@@ -12967,12 +12949,12 @@ that the behavior of @command{echo} is i
- @var{string} contains a backslash or if the first argument is
- @option{-n}.  Portable programs can use the @command{printf} command
- if they need to omit trailing newlines or output control characters or
--backslashes.  @xref{printf invocation}.
-+backslashes.  @xref{printf}.
+@@ -12960,7 +12942,7 @@ strings cannot be passed to @command{ech
+ It is therefore not advisable to use @command{echo} for printing unknown or
+ variable arguments.  The @command{printf} command is recommended as a more
+ portable and flexible replacement for tasks historically performed by
+-@command{echo}.  @xref{printf invocation}.
++@command{echo}.  @xref{printf}.
+ The program accepts the following options.  Also see @ref{Common options}.
+ Options must precede operands, and the normally-special argument
+@@ -13035,12 +13017,12 @@ POSIX does not require support for any o
+ that the behavior of @command{echo} is implementation-defined if any
+ @var{string} contains a backslash or if the first argument is @option{-n}.
+ Portable programs should use the @command{printf} command instead.
+-@xref{printf invocation}.
++@xref{printf}.
  
  @exitstatus
  
  @section @command{printf}: Format and print data
  
  @pindex printf
-@@ -13134,7 +13116,7 @@ $ recode BIG5..JAVA < sample.txt \
+@@ -13202,7 +13184,7 @@ $ recode BIG5..JAVA < sample.txt \
  @exitstatus
  
  
  @section @command{yes}: Print a string until interrupted
  
  @pindex yes
-@@ -13165,14 +13147,14 @@ condition of shell @code{if} statements,
+@@ -13233,14 +13215,14 @@ condition of shell @code{if} statements,
  pipeline.
  
  @menu
  @section @command{false}: Do nothing, unsuccessfully
  
  @pindex false
-@@ -13202,7 +13184,7 @@ Portable programs should not assume that
+@@ -13270,7 +13252,7 @@ Portable programs should not assume that
  non-GNU hosts.
  
  
  @section @command{true}: Do nothing, successfully
  
  @pindex true
-@@ -13238,7 +13220,7 @@ This version of @command{true} is implem
+@@ -13306,7 +13288,7 @@ This version of @command{true} is implem
  more secure and faster than a shell script implementation, and may safely
  be used as a dummy shell for the purpose of disabling accounts.
  
  @section @command{test}: Check file types and compare values
  
  @pindex test
-@@ -13609,7 +13591,7 @@ True if either @var{expr1} or @var{expr2
+@@ -13677,7 +13659,7 @@ True if either @var{expr1} or @var{expr2
  @end table
  
  
  @section @command{expr}: Evaluate expressions
  
  @pindex expr
-@@ -13886,11 +13868,11 @@ useful redirection is performed by a sep
+@@ -13954,11 +13936,11 @@ useful redirection is performed by a sep
  it's described here.
  
  @menu
  @section @command{tee}: Redirect output to multiple files or processes
  
  @pindex tee
-@@ -14098,15 +14080,15 @@ tar chof - "$tardir" \
+@@ -14166,15 +14148,15 @@ tar chof - "$tardir" \
  This section describes commands that manipulate file names.
  
  @menu
  @section @command{basename}: Strip directory and suffix from a file name
  
  @pindex basename
-@@ -14188,7 +14170,7 @@ basename -a -s .h include/stdio.h includ
+@@ -14256,7 +14238,7 @@ basename -a -s .h include/stdio.h includ
  @end example
  
  
  @section @command{dirname}: Strip last file name component
  
  @pindex dirname
-@@ -14241,7 +14223,7 @@ dirname stdio.h
+@@ -14309,7 +14291,7 @@ dirname stdio.h
  @end example
  
  
  @section @command{pathchk}: Check file name validity and portability
  
  @pindex pathchk
-@@ -14317,7 +14299,7 @@ Exit status:
+@@ -14385,7 +14367,7 @@ Exit status:
  1 otherwise.
  @end display
  
  @section @command{mktemp}: Create temporary file or directory
  
  @pindex mktemp
-@@ -14492,7 +14474,7 @@ Exit status:
+@@ -14560,7 +14542,7 @@ Exit status:
  @end display
  
  
  @section @command{realpath}: Print the resolved file name.
  
  @pindex realpath
-@@ -14684,14 +14666,14 @@ which you are working: the current direc
+@@ -14752,14 +14734,14 @@ which you are working: the current direc
  so forth.  See also the user-related commands in the next section.
  
  @menu
  @section @command{pwd}: Print working directory
  
  @pindex pwd
-@@ -14738,7 +14720,7 @@ environment variable is set.
+@@ -14806,7 +14788,7 @@ environment variable is set.
  @exitstatus
  
  
  @section @command{stty}: Print or change terminal characteristics
  
  @pindex stty
-@@ -15480,7 +15462,7 @@ or
+@@ -15548,7 +15530,7 @@ or
  @end table
  
  
  @section @command{printenv}: Print all or some environment variables
  
  @pindex printenv
-@@ -15515,7 +15497,7 @@ Exit status:
+@@ -15583,7 +15565,7 @@ Exit status:
  @end display
  
  
  @section @command{tty}: Print file name of terminal on standard input
  
  @pindex tty
-@@ -15565,16 +15547,16 @@ This section describes commands that pri
+@@ -15633,16 +15615,16 @@ This section describes commands that pri
  logins, groups, and so forth.
  
  @menu
  @section @command{id}: Print user identity
  
  @pindex id
-@@ -15681,7 +15663,7 @@ database to be consulted afresh, and so
+@@ -15749,7 +15731,7 @@ database to be consulted afresh, and so
  
  @exitstatus
  
  @section @command{logname}: Print current login name
  
  @pindex logname
-@@ -15702,7 +15684,7 @@ options}.
+@@ -15770,7 +15752,7 @@ options}.
  @exitstatus
  
  
  @section @command{whoami}: Print effective user name
  
  @pindex whoami
-@@ -15718,7 +15700,7 @@ options}.
+@@ -15786,7 +15768,7 @@ options}.
  @exitstatus
  
  
  @section @command{groups}: Print group names a user is in
  
  @pindex groups
-@@ -15745,7 +15727,7 @@ options}.
+@@ -15813,7 +15795,7 @@ options}.
  
  @exitstatus
  
  @section @command{users}: Print login names of users currently logged in
  
  @pindex users
-@@ -15780,7 +15762,7 @@ should not rely on its existence on non-
+@@ -15848,7 +15830,7 @@ should not rely on its existence on non-
  @exitstatus
  
  
  @section @command{who}: Print who is currently logged in
  
  @pindex who
-@@ -15943,16 +15925,14 @@ This section describes commands that pri
+@@ -16011,16 +15993,14 @@ This section describes commands that pri
  information.
  
  @menu
  @section @command{date}: Print or set system date and time
  
  @pindex date
-@@ -16675,7 +16655,7 @@ date --date='2017-01-01 00:00:00 +0000'
+@@ -16770,7 +16750,7 @@ date --date='2017-01-01 00:00:00 +0000'
  @end itemize
  
  
  @section @command{arch}: Print machine hardware name
  
  @pindex arch
-@@ -16698,7 +16678,7 @@ not rely on its existence.
+@@ -16793,7 +16773,7 @@ not rely on its existence.
  @exitstatus
  
  
  @section @command{nproc}: Print the number of available processors
  
  @pindex nproc
-@@ -16737,7 +16717,7 @@ If possible, exclude this @var{number} o
+@@ -16832,7 +16812,7 @@ If possible, exclude this @var{number} o
  @exitstatus
  
  
  @section @command{uname}: Print system information
  
  @pindex uname
-@@ -16867,35 +16847,7 @@ Print the kernel version.
+@@ -16962,35 +16942,7 @@ Print the kernel version.
  @exitstatus
  
  
  @section @command{hostid}: Print numeric host identifier
  
  @pindex hostid
-@@ -16923,44 +16875,6 @@ existence.
+@@ -17018,44 +16970,6 @@ existence.
  
  @exitstatus
  
  @node SELinux context
  @chapter SELinux context
  
-@@ -16972,11 +16886,11 @@ This section describes commands for oper
+@@ -17067,11 +16981,11 @@ This section describes commands for oper
  contexts.
  
  @menu
  @section @command{chcon}: Change SELinux context of file
  
  @pindex chcon
-@@ -17079,7 +16993,7 @@ Set range @var{range} in the target secu
+@@ -17174,7 +17088,7 @@ Set range @var{range} in the target secu
  
  @exitstatus
  
  @section @command{runcon}: Run a command in specified SELinux context
  
  @pindex runcon
-@@ -17171,16 +17085,16 @@ different than the current one: a modifi
+@@ -17266,16 +17180,16 @@ different than the current one: a modifi
  user, etc.
  
  @menu
  @section @command{chroot}: Run a command with a different root directory
  
  @pindex chroot
-@@ -17296,7 +17210,7 @@ the exit status of @var{command} otherwi
+@@ -17391,7 +17305,7 @@ the exit status of @var{command} otherwi
  @end display
  
  
  @section @command{env}: Run a command in a modified environment
  
  @pindex env
-@@ -17916,7 +17830,7 @@ OLDUSER=gordon
+@@ -18011,7 +17925,7 @@ OLDUSER=gordon
  
  
  
  @section @command{nice}: Run a command with modified niceness
  
  @pindex nice
-@@ -18047,7 +17961,7 @@ $ sudo nice -n -1 nice
+@@ -18142,7 +18056,7 @@ $ sudo nice -n -1 nice
  @end example
  
  
  @section @command{nohup}: Run a command immune to hangups
  
  @pindex nohup
-@@ -18121,7 +18035,7 @@ If @env{POSIXLY_CORRECT} is set, interna
+@@ -18216,7 +18130,7 @@ If @env{POSIXLY_CORRECT} is set, interna
  instead of 125.
  
  
  @section @command{stdbuf}: Run a command with modified I/O stream buffering
  
  @pindex stdbuf
-@@ -18215,7 +18129,7 @@ the exit status of @var{command} otherwi
+@@ -18310,7 +18224,7 @@ the exit status of @var{command} otherwi
  @end display
  
  
  @section @command{timeout}: Run a command with a time limit
  
  @pindex timeout
-@@ -18350,90 +18264,6 @@ timeout -s INT 5s env --ignore-signal=IN
+@@ -18446,90 +18360,6 @@ timeout -s INT 5s env --ignore-signal=IN
  timeout -s INT -k 3s 5s env --ignore-signal=INT sleep 20
  @end example
  
  @node Delaying
  @chapter Delaying
  
-@@ -18443,11 +18273,11 @@ signal names and numbers.
+@@ -18539,11 +18369,11 @@ signal names and numbers.
  @c Perhaps @command{wait} or other commands should be described here also?
  
  @menu
  @section @command{sleep}: Delay for a specified time
  
  @pindex sleep
-@@ -18510,13 +18340,13 @@ options}.
+@@ -18606,13 +18436,13 @@ options}.
  These programs do numerically-related operations.
  
  @menu
  @section @command{factor}: Print prime factors
  
  @pindex factor
-@@ -18577,7 +18407,7 @@ are the product of two large primes), ot
+@@ -18673,7 +18503,7 @@ are the product of two large primes), ot
  @exitstatus
  
  
  @section @command{numfmt}: Reformat numbers
  
  @pindex numfmt
-@@ -18917,7 +18747,7 @@ $ LC_ALL=ta_IN numfmt --from=iec --forma
+@@ -19013,7 +18843,7 @@ $ LC_ALL=ta_IN numfmt --from=iec --forma
  @end example
  
  
  @section @command{seq}: Print numeric sequences
  
  @pindex seq
-@@ -19092,7 +18922,7 @@ Naively, a file's atime, mtime, and ctim
+@@ -19188,7 +19018,7 @@ Naively, a file's atime, mtime, and ctim
  whenever you read, write, or change the attributes of the file
  respectively, and searching a directory counts as reading it.  A
  file's atime and mtime can also be set directly, via the
index b6b83c03383d50e02ebdcd42e335a61cf1e244fe..5ec76d0314dd9a8cc98214320e1b27634eef9ef3 100644 (file)
@@ -10,20 +10,21 @@ diff -urNp -x '*.orig' coreutils-8.32.org/src/uname.c coreutils-8.32/src/uname.c
  static struct option const uname_long_options[] =
  {
    {"all", no_argument, NULL, 'a'},
-@@ -301,13 +303,9 @@ main (int argc, char **argv)
-   if (toprint & PRINT_PROCESSOR)
-     {
-       char const *element = unknown;
+@@ -323,14 +323,12 @@
+       element = "powerpc";
+ # endif
+ #endif
 -#if HAVE_SYSINFO && defined SI_ARCHITECTURE
--      {
--        static char processor[257];
--        if (0 <= sysinfo (SI_ARCHITECTURE, processor, sizeof processor))
--          element = processor;
--      }
+       if (element == unknown)
+         {
+-          static char processor[257];
+-          if (0 <= sysinfo (SI_ARCHITECTURE, processor, sizeof processor))
+-            element = processor;
++          char processor[BUFSIZ];
++          __sysinfo_processor_type(processor);
++          element = processor;
+         }
 -#endif
-+      char processor[BUFSIZ];
-+      __sysinfo_processor_type(processor);
-+      element = processor;
  #ifdef UNAME_PROCESSOR
        if (element == unknown)
          {
index a286284bc4223489fc49da557d7792ffbed59fb2..5d37ac64c17b0f9e559a672d7163660da774eaec 100644 (file)
@@ -8,12 +8,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       9.0
-Release:       3
+Version:       9.1
+Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 0d79ae8a6124546e3b94171375e5e5d0
+# Source0-md5: 8b1ca4e018a7dce9bb937faec6618671
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -34,7 +34,6 @@ Patch8:               %{name}-pl.po-update.patch
 # https://github.com/jarun/advcpmv
 Patch9:                %{name}-advcopy.patch
 Patch10:       tests.patch
-Patch11:       ignore-symlinks.patch
 URL:           http://www.gnu.org/software/coreutils/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -125,7 +124,6 @@ Programy zawarte w tym pakiecie to:
 %patch9 -p1
 %endif
 %patch10 -p1
-%patch11 -p1
 
 %{__mv} man/pt_BR man/pt