]> TLD Linux GIT Repositories - packages/dracut.git/commitdiff
- compress with xz by default (like geninitrd)
authorMarcin Krol <hawk@tld-linux.org>
Sat, 17 May 2014 14:59:03 +0000 (14:59 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 17 May 2014 14:59:03 +0000 (14:59 +0000)
dracut.spec
xz_compressor.patch [new file with mode: 0644]

index 0db48be02ea3b41ef3575e1a739c85edad034e8c..bdc6f12894c883e5aafaaafbc1bc3e9f426d3665 100644 (file)
@@ -15,7 +15,8 @@ Patch4:               arch-libdir.patch
 Patch5:                systemd-paths.patch
 Patch6:                prelink-libs.patch
 Patch7:                config.patch
-Patch8:                misc_fixes.patch
+Patch8:                xz_compressor.patch
+Patch9:                misc_fixes.patch
 Patch100:      git.patch
 URL:           https://dracut.wiki.kernel.org/
 BuildRequires: asciidoc
@@ -199,6 +200,7 @@ Bashowe dopeÅ‚nianie skÅ‚adni dla polecenia dracut.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 %patch100 -p1
 
 %{__sed} -i -e 's,@lib@,%{_lib},g' modules.d/50plymouth/module-setup.sh
diff --git a/xz_compressor.patch b/xz_compressor.patch
new file mode 100644 (file)
index 0000000..4bdc4ea
--- /dev/null
@@ -0,0 +1,38 @@
+diff -urN dracut-037.orig/dracut.sh dracut-037/dracut.sh
+--- dracut-037.orig/dracut.sh  2014-03-19 16:16:08.000000000 +0000
++++ dracut-037/dracut.sh       2014-05-17 14:56:39.530999661 +0000
+@@ -159,8 +159,6 @@
+   -I, --install [LIST]  Install the space separated list of files into the
+                          initramfs.
+   --gzip                Compress the generated initramfs using gzip.
+-                         This will be done by default, unless another
+-                         compression option or --no-compress is passed.
+   --bzip2               Compress the generated initramfs using bzip2.
+                          Make sure your kernel has bzip2 decompression support
+                          compiled in, otherwise you will not be able to boot.
+@@ -168,12 +166,14 @@
+                          Make sure your kernel has lzma support compiled in,
+                          otherwise you will not be able to boot.
+   --xz                  Compress the generated initramfs using xz.
++                         This will be done by default, unless another
++                         compression option or --no-compress is passed.
+                          Make sure that your kernel has xz support compiled
+                          in, otherwise you will not be able to boot.
+-  --lzo                  Compress the generated initramfs using lzop.
++  --lzo                 Compress the generated initramfs using lzop.
+                          Make sure that your kernel has lzo support compiled
+                          in, otherwise you will not be able to boot.
+-  --lz4                  Compress the generated initramfs using lz4.
++  --lz4                 Compress the generated initramfs using lz4.
+                          Make sure that your kernel has lz4 support compiled
+                          in, otherwise you will not be able to boot.
+   --compress [COMPRESSION] Compress the generated initramfs with the
+@@ -789,7 +789,7 @@
+ fw_dir=${fw_dir//:/ }
+ # handle compression options.
+-[[ $compress ]] || compress="gzip"
++[[ $compress ]] || compress="xz"
+ case $compress in
+     bzip2) compress="bzip2 -9";;
+     lzma)  compress="lzma -9 -T0";;