]> TLD Linux GIT Repositories - packages/gcc.git/blobdiff - branch.sh
- updated to 7.3.0
[packages/gcc.git] / branch.sh
index 7cc296844c0a0f1cec4e13c6b4e85f6d818da045..9073aa459b9060790af9b696af091313dd6fbc74 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -3,13 +3,15 @@ set -e
 package=gcc
 svn=svn://gcc.gnu.org/svn/$package
 branch=branches/$package-7-branch
-tag=tags/${package}_7_2_0_release
+tag=tags/${package}_7_3_0_release
 out=$package-branch.diff
 
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
        # remove revno's for smaller diffs
-       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+       # replace svn nonexistend with '0' date, so patch will know that file needs to be removed from disk
+       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,' | \
+       sed -e 's,^\([-+]\{3\} .*\t\)(nonexistent)$,\11970-01-01 01:00:00.000000000 +0100,'
 }
 
 old=$svn/$tag
@@ -25,3 +27,6 @@ if cmp -s $out{,.tmp}; then
        exit 0
 fi
 mv -f $out{.tmp,}
+
+../md5 $package.spec
+../dropin $out