]> TLD Linux GIT Repositories - packages/gcc.git/commitdiff
- updated to 7.3.0
authorMarcin Krol <hawk@tld-linux.org>
Thu, 8 Mar 2018 13:45:20 +0000 (13:45 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 8 Mar 2018 13:45:20 +0000 (13:45 +0000)
Revert-eeb6872bf.patch [deleted file]
branch.sh
gcc.spec

diff --git a/Revert-eeb6872bf.patch b/Revert-eeb6872bf.patch
deleted file mode 100644 (file)
index 1688c14..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-commit 43d83a70267a9e5c456d28de8e7348820446b712
-Author: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-Date:   Tue May 16 07:50:42 2017 +0200
-
-    Revert "Prevent LTO wrappers to process a recursive execution"
-    
-    This reverts commit eeb6872bfdfd1e71b27de6f62a5f5c08a2efb015.
-
-diff --git a/gcc/file-find.c b/gcc/file-find.c
-index b072a4993d76..b5a1fe8494e8 100644
---- a/gcc/file-find.c
-+++ b/gcc/file-find.c
-@@ -208,38 +208,3 @@ prefix_from_string (const char *p, struct path_prefix *pprefix)
-     }
-   free (nstore);
- }
--
--void
--remove_prefix (const char *prefix, struct path_prefix *pprefix)
--{
--  struct prefix_list *remove, **prev, **remove_prev = NULL;
--  int max_len = 0;
--
--  if (pprefix->plist)
--    {
--      prev = &pprefix->plist;
--      for (struct prefix_list *pl = pprefix->plist; pl->next; pl = pl->next)
--      {
--        if (strcmp (prefix, pl->prefix) == 0)
--          {
--            remove = pl;
--            remove_prev = prev;
--            continue;
--          }
--
--        int l = strlen (pl->prefix);
--        if (l > max_len)
--          max_len = l;
--
--        prev = &pl;
--      }
--
--      if (remove_prev)
--      {
--        *remove_prev = remove->next;
--        free (remove);
--      }
--
--      pprefix->max_len = max_len;
--    }
--}
-diff --git a/gcc/file-find.h b/gcc/file-find.h
-index 8f49a3af273e..407feba26e74 100644
---- a/gcc/file-find.h
-+++ b/gcc/file-find.h
-@@ -41,7 +41,6 @@ extern void find_file_set_debug (bool);
- extern char *find_a_file (struct path_prefix *, const char *, int);
- extern void add_prefix (struct path_prefix *, const char *);
- extern void add_prefix_begin (struct path_prefix *, const char *);
--extern void remove_prefix (const char *prefix, struct path_prefix *);
- extern void prefix_from_env (const char *, struct path_prefix *);
- extern void prefix_from_string (const char *, struct path_prefix *);
-diff --git a/gcc/gcc-ar.c b/gcc/gcc-ar.c
-index 78d2fc1ad306..d5d80e042e5a 100644
---- a/gcc/gcc-ar.c
-+++ b/gcc/gcc-ar.c
-@@ -194,14 +194,6 @@ main (int ac, char **av)
- #ifdef CROSS_DIRECTORY_STRUCTURE
-       real_exe_name = concat (target_machine, "-", PERSONALITY, NULL);
- #endif
--      /* Do not search original location in the same folder.  */
--      char *exe_folder = lrealpath (av[0]);
--      exe_folder[strlen (exe_folder) - strlen (lbasename (exe_folder))] = '\0';
--      char *location = concat (exe_folder, PERSONALITY, NULL);
--
--      if (access (location, X_OK) == 0)
--      remove_prefix (exe_folder, &path);
--
-       exe_name = find_a_file (&path, real_exe_name, X_OK);
-       if (!exe_name)
-       {
index 7cc296844c0a0f1cec4e13c6b4e85f6d818da045..9073aa459b9060790af9b696af091313dd6fbc74 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -3,13 +3,15 @@ set -e
 package=gcc
 svn=svn://gcc.gnu.org/svn/$package
 branch=branches/$package-7-branch
-tag=tags/${package}_7_2_0_release
+tag=tags/${package}_7_3_0_release
 out=$package-branch.diff
 
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
        # remove revno's for smaller diffs
-       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+       # replace svn nonexistend with '0' date, so patch will know that file needs to be removed from disk
+       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,' | \
+       sed -e 's,^\([-+]\{3\} .*\t\)(nonexistent)$,\11970-01-01 01:00:00.000000000 +0100,'
 }
 
 old=$svn/$tag
@@ -25,3 +27,6 @@ if cmp -s $out{,.tmp}; then
        exit 0
 fi
 mv -f $out{.tmp,}
+
+../md5 $package.spec
+../dropin $out
index 5e89046d70207c4f269e71dfbb61b560ff7f10f0..d3379ea255c2b89c11b01f2fbdc12e7fe7ab4840 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -76,7 +76,7 @@
 # Stable is: any major_ver and minor_ver >= 1.0
 # For TLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
 %define                major_ver       7
-%define                minor_ver       2.0
+%define                minor_ver       3.0
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -89,18 +89,17 @@ Epoch:              6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://ftp.gnu.org/pub/gnu/gcc/gcc-%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: ff370482573133a7fcdd96cd2f552292
+# Source0-md5: be2da21680f27624f3a87055c4ba5af2
 Source1:       %{name}-optimize-la.pl
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update glibc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        3410627f44b63a23f63e0cc7247db55a
+# Patch100-md5:        1e19dfcc43bffa292bf5f5b3bc80bc4e
 Patch0:                %{name}-info.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
-Patch5:                Revert-eeb6872bf.patch
 
 Patch11:       %{name}-install-libffi.patch
 URL:           http://gcc.gnu.org/
@@ -1898,7 +1897,6 @@ Extensions dla języka C. W tym pakiecie znajduje się wersja 32-bitowa.
 %patch0 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
 
 %if %{with gcc_libffi}
 %patch11 -p0