]> TLD Linux GIT Repositories - packages/gcc.git/commitdiff
- fix build
authorBartosz Świątek <shadzik@tld-linux.org>
Sat, 20 Apr 2013 06:50:03 +0000 (08:50 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Sat, 20 Apr 2013 06:50:03 +0000 (08:50 +0200)
gcc-siginfo_t.patch [new file with mode: 0644]
gcc.spec

diff --git a/gcc-siginfo_t.patch b/gcc-siginfo_t.patch
new file mode 100644 (file)
index 0000000..f01c177
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/gcc/config/i386/linux-unwind.h   2011-01-03 20:52:22.000000000 +0000
++++ b/gcc/config/i386/linux-unwind.h   2012-07-06 12:23:51.562859470 +0100
+@@ -133,9 +133,9 @@
+     {
+       struct rt_sigframe {
+       int sig;
+-      struct siginfo *pinfo;
++      siginfo_t *pinfo;
+       void *puc;
+-      struct siginfo info;
++      siginfo_t info;
+       struct ucontext uc;
+       } *rt_ = context->cfa;
+       /* The void * cast is necessary to avoid an aliasing warning.
index c6a0e98cc28397597b7a55b97c719278e4d2e3a5..e28f298bbe103aceaa7276653ba01eb3fb54ffca 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -88,6 +88,7 @@ Patch8:               %{name}-enable-java-awt-qt.patch
 Patch9:                %{name}-hash-style-gnu.patch
 Patch11:       %{name}-build-id.patch
 Patch12:       %{name}-plugin-decl-hook.patch
+Patch13:       %{name}-siginfo_t.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}