]> TLD Linux GIT Repositories - packages/gcc.git/commitdiff
- merged 13.2.0 from PLD
authorMarcin Krol <hawk@tld-linux.org>
Mon, 1 Apr 2024 12:03:48 +0000 (14:03 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 1 Apr 2024 12:03:48 +0000 (14:03 +0200)
branch.sh
gcc-bug-111413.patch [new file with mode: 0644]
gcc.spec

index f3296d475044629a7e65acdf1ce958510e220471..28866e8ed3b71708a7bc3eabeec61366a831d86b 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,7 +2,7 @@
 set -e
 url=git://gcc.gnu.org/git/gcc.git
 package=gcc
-tag=releases/gcc-13.1.0
+tag=releases/gcc-13.2.0
 branch=releases/gcc-13
 out=$package-branch.diff
 repo=$package.git
diff --git a/gcc-bug-111413.patch b/gcc-bug-111413.patch
new file mode 100644 (file)
index 0000000..1035051
--- /dev/null
@@ -0,0 +1,10 @@
+--- gcc-13.2.0/libgomp/env.c~  2023-07-27 10:13:08.000000000 +0200
++++ gcc-13.2.0/libgomp/env.c   2024-01-03 15:32:23.542720713 +0100
+@@ -2059,6 +2059,7 @@
+   none = gomp_get_initial_icv_item (GOMP_DEVICE_NUM_FOR_NO_SUFFIX);
+   initialize_icvs (&none->icvs);
++  if ( environ )
+   for (env = environ; *env != 0; env++)
+     {
+       if (!startswith (*env, "OMP_"))
index 37e05340be761d920d5b0a83512a7a2fa90c19d0..09ce6a0c8ff2c928de53ec4c4062918e3db5c5e1 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 # Stable is: any major_ver and minor_ver >= 1.0
 # For TLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
 %define                major_ver       13
-%define                minor_ver       1.0
+%define                minor_ver       2.0
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -109,19 +109,19 @@ Summary(pl.UTF-8):        Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       3
+Release:       2
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://gcc.gnu.org/pub/gcc/releases/%{name}-%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 43e4de77f2218c83ca675257ea1af9ef
+# Source0-md5: e0e48554cc6e4f261d55ddee9ab69075
 Source1:       %{name}-optimize-la.pl
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        b3f29f19ec6ac2e71d7e209ce49e8621
+# Patch100-md5:        4bfd0ad4dfc7a4f8cfb8cf55e1ce8d32
 Patch0:                %{name}-info.patch
 Patch1:                all-library-paths.patch
 Patch2:                %{name}-nodebug.patch
@@ -130,6 +130,7 @@ Patch4:             %{name}-ada-x32.patch
 
 Patch10:       %{name}-moresparcs.patch
 Patch11:       %{name}-install-libffi.patch
+Patch12:       %{name}-bug-111413.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
 %{?with_tests:BuildRequires:   autogen >= 5.5.4}
@@ -184,6 +185,7 @@ BuildRequires:      gmp-c++-devel >= 4.3.2
 BuildRequires: gmp-devel >= 4.3.2
 BuildRequires: isl-devel >= 0.15
 BuildRequires: libmpc-devel >= 0.8.1
+BuildRequires: libstdc++-devel
 BuildRequires: mpfr-devel >= 3.1.0
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.211
@@ -2772,6 +2774,7 @@ więc wtyczki muszą być przebudowywane przy każdej aktualizacji GCC.
 %if %{with gcc_libffi}
 %patch11 -p0
 %endif
+%patch12 -p1
 
 %{__mv} ChangeLog ChangeLog.general