]> TLD Linux GIT Repositories - packages/gcc.git/commitdiff
- rel 9; add patch 14 GCC_4_5
authorBartosz Świątek <shadzik@tld-linux.org>
Sat, 20 Apr 2013 10:54:00 +0000 (12:54 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Sat, 20 Apr 2013 10:54:00 +0000 (12:54 +0200)
gcc-prism.patch [new file with mode: 0644]
gcc.spec

diff --git a/gcc-prism.patch b/gcc-prism.patch
new file mode 100644 (file)
index 0000000..e780d03
--- /dev/null
@@ -0,0 +1,60 @@
+--- gcc-4_5-branch/libjava/prims.cc    2010/04/06 11:07:48     157989
++++ gcc-4_5-branch/libjava/prims.cc    2011/11/24 07:23:16     181687
+@@ -38,7 +38,6 @@
+ #endif
+ #ifndef DISABLE_GETENV_PROPERTIES
+-#include <ctype.h>
+ #include <java-props.h>
+ #define PROCESS_GCJ_PROPERTIES process_gcj_properties()
+ #else
+@@ -985,6 +984,8 @@
+ #ifndef DISABLE_GETENV_PROPERTIES
++#define c_isspace(c) (memchr (" \t\n\r\v\f", c, 6) != NULL)
++
+ static char *
+ next_property_key (char *s, size_t *length)
+ {
+@@ -993,7 +994,7 @@
+   JvAssert (s);
+   // Skip over whitespace
+-  while (isspace (*s))
++  while (c_isspace (*s))
+     s++;
+   // If we've reached the end, return NULL.  Also return NULL if for
+@@ -1005,7 +1006,7 @@
+   // Determine the length of the property key.
+   while (s[l] != 0
+-       && ! isspace (s[l])
++       && ! c_isspace (s[l])
+        && s[l] != ':'
+        && s[l] != '=')
+     {
+@@ -1027,19 +1028,19 @@
+   JvAssert (s);
+-  while (isspace (*s))
++  while (c_isspace (*s))
+     s++;
+   if (*s == ':'
+       || *s == '=')
+     s++;
+-  while (isspace (*s))
++  while (c_isspace (*s))
+     s++;
+   // Determine the length of the property value.
+   while (s[l] != 0
+-       && ! isspace (s[l])
++       && ! c_isspace (s[l])
+        && s[l] != ':'
+        && s[l] != '=')
+     {
index 96ba4c0c0dd00d603b13b7058b8747e9fce683eb..e6669311e24ede07c7806e4686690e24c68535b4 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -68,7 +68,7 @@ Summary(pl.UTF-8):    Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       8
+Release:       9
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
@@ -89,6 +89,7 @@ Patch9:               %{name}-hash-style-gnu.patch
 Patch11:       %{name}-build-id.patch
 Patch12:       %{name}-plugin-decl-hook.patch
 Patch13:       %{name}-siginfo_t.patch
+Patch14:       %{name}-prism.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
@@ -1221,6 +1222,7 @@ Statyczna biblioteki Obiektowego C - wersja 32-bitowa.
 %patch11 -p0
 %patch12 -p0
 %patch13 -p1
+%patch14 -p1
 
 mv ChangeLog ChangeLog.general