]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- blah... use single hand-made tarball instead of playing with official
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 %define beta    beta2
48 Name:           grub2
49 Version:        2.02
50 Release:        0.%{beta}.2
51 License:        GPL v2
52 Group:          Base
53 # http://git.savannah.gnu.org/cgit/grub.git
54 Source0:        grub-%{version}-%{beta}.tar.xz
55 # Source0-md5:  f262e61eba2e76a6f60b39a810814284
56 Source1:        update-grub
57 Source2:        update-grub.8
58 Source3:        grub.sysconfig
59 Source4:        grub-custom.cfg
60 Patch1:         pld-sysconfdir.patch
61 Patch2:         grub-garbage.patch
62 Patch3:         grub-lvmdevice.patch
63 Patch4:         pld-mkconfigdir.patch
64 Patch5:         grub-mkconfig-diagnostics.patch
65 Patch6:         posix.patch
66 Patch7:         %{name}-fonts_path.patch
67 Patch8:         add-vlan-tag-support.patch
68 Patch9:         just-say-linux.patch
69 Patch10:        ignore-kernel-symlinks.patch
70 Patch11:        choose-preferred-initrd.patch
71 Patch12:        %{name}-cfg.patch
72 URL:            http://www.gnu.org/software/grub/
73 BuildRequires:  autoconf >= 2.53
74 BuildRequires:  automake >= 1:1.11.1-1
75 BuildRequires:  bison
76 BuildRequires:  device-mapper-devel
77 BuildRequires:  flex >= 2.5.35
78 BuildRequires:  fonts-TTF-DejaVu
79 BuildRequires:  freetype-devel >= 2
80 BuildRequires:  gawk
81 BuildRequires:  gettext-devel
82 BuildRequires:  glibc-localedb-all
83 BuildRequires:  glibc-static
84 BuildRequires:  help2man
85 BuildRequires:  libfuse-devel
86 BuildRequires:  libtool
87 BuildRequires:  ncurses-devel
88 BuildRequires:  python
89 BuildRequires:  python-modules
90 BuildRequires:  rpm >= 4.4.9-56
91 BuildRequires:  rpmbuild(macros) >= 1.213
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  tar >= 1:1.22
94 BuildRequires:  texinfo
95 BuildRequires:  xz
96 BuildRequires:  xz-devel
97 %ifarch %{x8664}
98 BuildRequires:  /usr/lib/libc.so
99 %if "%{pld_release}" == "ac"
100 BuildRequires:  libgcc32
101 %else
102 BuildRequires:  gcc-multilib
103 %endif
104 %endif
105 Requires:       %{name}-platform = %{version}-%{release}
106 Requires:       issue
107 Requires:       which
108 %ifarch %{ix86} %{x8664}
109 Suggests:       %{name}-platform-pc
110 %endif
111 Suggests:       cdrkit-mkisofs
112 Suggests:       os-prober
113 Provides:       bootloader
114 Conflicts:      grub
115 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         _sbindir        /sbin
119 %define         _bindir         %{_sbindir}
120 %define         _libdir         /lib
121 %define         _datadir        %{_libdir}
122 %define         _libexecdir     %{_libdir}/grub
123 %define         _grubdir        /boot/grub
124 %define         _localedir      /usr/share/locale
125
126 # part of grub code is not relocable (these are not Linux libs)
127 # stack protector also breaks non-Linux binaries
128 # any kind of forced optimizations makes grub2 unreliable (random
129 # reboots and hangs on boot menu screen)
130 %define         filterout_c     -fPIC -O.
131 %undefine       _ssp_cflags
132 %undefine       _fortify_cflags
133
134 %description
135 GRUB is a GPLed bootloader intended to unify bootloading across x86
136 operating systems. In addition to loading the Linux and *BSD kernels,
137 it implements the Multiboot standard, which allows for flexible
138 loading of multiple boot images (needed for modular kernels such as
139 the GNU Hurd).
140
141 GRUB 2 is derived from PUPA which was a research project to
142 investigate the next generation of GRUB. GRUB 2 has been rewritten
143 from scratch to clean up everything for modularity and portability.
144
145 GRUB 2 targets at the following goals:
146 - Scripting support, such as conditionals, loops, variables and
147   functions.
148 - Graphical interface.
149 - Dynamic loading of modules in order to extend itself at the run time
150   rather than at the build time.
151 - Portability for various architectures.
152 - Internationalization. This includes support for non-ASCII character
153   code, message catalogs like gettext, fonts, graphics console, and so
154   on.
155 - Real memory management, to make GNU GRUB more extensible.
156 - Modular, hierarchical, object-oriented framework for file systems,
157   files, devices, drives, terminals, commands, partition tables and OS
158   loaders.
159 - Cross-platform installation which allows for installing GRUB from a
160   different architecture.
161 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
162 - Fix design mistakes in GRUB Legacy, which could not be solved for
163   backward-compatibility, such as the way of numbering partitions.
164
165 %description -l de.UTF-8
166 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
167 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
168 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
169
170 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
171 und wird unter der GPL vertrieben. Aufgrund seiner höheren
172 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
173 traditionellen Boot-Loader LILO.
174
175 %description -l hu.UTF-8
176 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
177 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
178 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
179 GNU Hurd).
180
181 GRUB2 céljai a következők:
182 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
183   függvények.
184 - grafikus felület
185 - modulok dinamikus betöltése futási időben
186 - hordozhatóság több architektúrára
187 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
188   mint gettext, betűtípusok, grafikus konzolon, és így tovább
189 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
190 - moduláris, hierarchikus, objektum-orientált keretrendszer
191   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
192   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
193
194 %description -l es.UTF-8
195 Éste es GRUB - Grand Unified Boot Loader - un administrador de
196 inicialización capaz de entrar en la mayoría de los sistemas
197 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
198 también en la mayoría de los sistemas operacionales comerciales para
199 PC.
200
201 El administrador GRUB puede ser una buena alternativa a LILO, para
202 usuarios conmás experiencia y que deseen obtener más recursos de su
203 cargador de inicialización (boot loader).
204
205 %description -l pl.UTF-8
206 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
207 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
208 Linuksa i *BSD: posiada również implementację standardu Multiboot,
209 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
210 (czego wymagają modułowe jądra, takie jak GNU Hurd).
211
212 %description -l pt_BR.UTF-8
213 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
214 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
215 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
216 operacionais comerciais para PC.
217
218 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
219 avançados e que querem mais recursos de seu boot loader.
220
221 %package -n bash-completion-%{name}
222 Summary:        bash-completion for GRUB
223 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
224 Group:          Applications/Shells
225 Requires:       bash-completion
226
227 %description -n bash-completion-%{name}
228 This package provides bash-completion for GRUB.
229
230 %description -n bash-completion-%{name} -l pl.UTF-8
231 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
232
233 %package platform-pc
234 Summary:        PC BIOS platform support for GRUB
235 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
236 Group:          Base
237 Provides:       %{name}-platform = %{version}-%{release}
238
239 %description platform-pc
240 PC BIOS platform support for GRUB.
241
242 %description platform-pc -l pl.UTF-8
243 Obsługa platformy PC BIOS dla GRUB-a.
244
245 %package platform-efi
246 Summary:        (U)EFI platform support for GRUB
247 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
248 Group:          Base
249 Suggests:       efibootmgr
250 Provides:       %{name}-platform = %{version}-%{release}
251
252 %description platform-efi
253 (U)EFI platform support for GRUB.
254
255 %description platform-efi -l pl.UTF-8
256 Obsługa platformy (U)EFI dla GRUB-a.
257
258 %package mkfont
259 Summary:        GRUB font files converter
260 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
261 Group:          Base
262
263 %description mkfont
264 Converts common font file formats into PF2.
265
266 %description mkfont -l pl.UTF-8
267 Program do konwersji popularnych formatów plików fontów do PF2.
268
269 %package theme-starfield
270 Summary:        starfield theme for GRUB
271 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
272 Group:          Base
273
274 %description theme-starfield
275 starfield theme for GRUB.
276
277 %description theme-starfield -l pl.UTF-8
278 Motyw starfield dla GRUB-a.
279
280 %prep
281 %setup -q -n grub-%{version}-%{beta}
282 %patch1 -p1
283 %patch2 -p1
284 %patch3 -p1
285 %patch4 -p1
286 %patch5 -p1
287 %patch6 -p1
288 %patch7 -p1
289 %patch8 -p1
290 %patch9 -p1
291 %patch10 -p1
292 %patch11 -p1
293 %patch12 -p0
294
295 # we don't have C.utf-8 and need an UTF-8 locale for build
296 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
297
298 %build
299 # if gold is used then grub doesn't even boot
300 # https://savannah.gnu.org/bugs/?34539
301 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
302 install -d our-ld
303 ln -s /usr/bin/ld.bfd our-ld/ld
304 export PATH=$(pwd)/our-ld:$PATH
305
306 ## not only the typicall autotools stuff
307 #./autogen.sh
308
309 %{__gettextize}
310 %{__aclocal} -I m4
311 %{__autoconf}
312 %{__autoheader}
313 %{__automake}
314
315 for platform in %{platforms} ; do
316         install -d build-${platform}
317         cd build-${platform}
318
319         if [ "$platform" != "efi" ] ; then
320                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
321         else
322                 platform_opts=""
323         fi
324
325         ln -s ../configure .
326         # mawk stalls at ./genmoddep.awk, so force gawk
327         AWK=gawk \
328         %configure \
329                 --with-platform=${platform} \
330                 --disable-werror \
331         %if %{with grubemu}
332                 --enable-grub-emu-usb \
333                 --enable-grub-emu-sdl \
334                 --enable-grub-emu-pci \
335         %endif
336                 $platform_opts \
337                 TARGET_LDFLAGS=-static
338
339         %{__make} -j1 -C po update-gmo
340         %{__make}
341         cd ..
342 done
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346
347 for platform in %{platforms} ; do
348         cd build-${platform}
349         %{__make} install \
350                 pkgdatadir=%{_libexecdir} \
351                 pkglibdir=%{_libexecdir} \
352                 DESTDIR=$RPM_BUILD_ROOT
353         cd ..
354 done
355
356 # not in Th (?)
357 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
358 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
359
360 %find_lang grub
361
362 # this must be after 'make install'
363 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
364
365 install -d $RPM_BUILD_ROOT%{_grubdir}
366 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
367
368 # grub.d/41_custom
369 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
370 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
371
372 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
373 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
374
375 install -d $RPM_BUILD_ROOT/etc/sysconfig
376 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
377
378 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
379 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
380
381 # platform specific, unnecessarily always installed
382 %ifnarch %{ix86} %{x8664}
383 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
384 %endif
385 %ifnarch sparc64
386 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
387 %endif
388
389 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
390 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
391 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
392
393 # needs to be exactly 1KiB
394 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
395 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
396
397 %clean
398 rm -rf $RPM_BUILD_ROOT
399
400 %post -p %{_sbindir}/postshell
401 -/usr/sbin/fix-info-dir -c %{_infodir}
402
403 %postun -p %{_sbindir}/postshell
404 -/usr/sbin/fix-info-dir -c %{_infodir}
405
406 %triggerpostun -- %{name} < 2.00-2
407 # Note this trigger on version upgrade needed only for upgrade from
408 # old grub2 packages which contained modules in /boot/grub
409 # or were built with optimizations enabled
410 # don't do anything on --downgrade
411 if [ $1 -le 1 ]; then
412         exit 0
413 fi
414 echo "Grub was upgraded, trying to setup it to boot sector"
415 /sbin/grub-install '(hd0)' || :
416
417 %triggerpostun -- %{name} < 1.99-7.3
418 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
419 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
420         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
421         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
422 fi
423
424 %files -f grub.lang
425 %defattr(644,root,root,755)
426 %doc AUTHORS ChangeLog NEWS README THANKS TODO
427 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
428 %attr(755,root,root) %{_sbindir}/grub-editenv
429 %attr(755,root,root) %{_sbindir}/grub-fstest
430 %attr(755,root,root) %{_sbindir}/grub-file
431 %attr(755,root,root) %{_sbindir}/grub-glue-efi
432 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
433 %attr(755,root,root) %{_sbindir}/grub-install
434 %attr(755,root,root) %{_sbindir}/grub-macbless
435 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
436 %attr(755,root,root) %{_sbindir}/grub-mkconfig
437 %attr(755,root,root) %{_sbindir}/grub-mklayout
438 %attr(755,root,root) %{_sbindir}/grub-mknetdir
439 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
440 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
441 %attr(755,root,root) %{_sbindir}/grub-mkrescue
442 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
443 %attr(755,root,root) %{_sbindir}/grub-mount
444 %attr(755,root,root) %{_sbindir}/grub-ofpathname
445 %attr(755,root,root) %{_sbindir}/grub-reboot
446 %attr(755,root,root) %{_sbindir}/grub-render-label
447 %attr(755,root,root) %{_sbindir}/grub-script-check
448 %attr(755,root,root) %{_sbindir}/grub-set-default
449 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
450 %attr(755,root,root) %{_sbindir}/update-grub
451 %ifarch %{ix86} %{x8664}
452 %attr(755,root,root) %{_sbindir}/grub-bios-setup
453 %{_mandir}/man8/grub-bios-setup.8*
454 %endif
455 %ifarch %{ix86} %{x8664}
456 %attr(755,root,root) %{_sbindir}/grub-mkimage
457 %{_mandir}/man1/grub-mkimage.1*
458 %else
459 %attr(755,root,root) %{_sbindir}/grub-probe
460 %{_mandir}/man8/grub-probe.8*
461 %endif
462 %ifarch sparc64
463 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
464 %{_mandir}/man8/grub-sparc64-setup.8*
465 %endif
466 %{_mandir}/man1/grub-editenv.1*
467 %{_mandir}/man1/grub-file.1*
468 %{_mandir}/man1/grub-fstest.1*
469 %{_mandir}/man1/grub-glue-efi.1*
470 %{_mandir}/man1/grub-kbdcomp.1*
471 %{_mandir}/man1/grub-macbless.1*
472 %{_mandir}/man1/grub-menulst2cfg.1*
473 %{_mandir}/man1/grub-mklayout.1*
474 %{_mandir}/man1/grub-mknetdir.1*
475 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
476 %{_mandir}/man1/grub-mkrelpath.1*
477 %{_mandir}/man1/grub-mkrescue.1*
478 %{_mandir}/man1/grub-mkstandalone.1*
479 %{_mandir}/man1/grub-mount.1*
480 %{_mandir}/man1/grub-render-label.1*
481 %{_mandir}/man1/grub-script-check.1*
482 %{_mandir}/man1/grub-syslinux2cfg.1*
483 %{_mandir}/man8/grub-install.8*
484 %{_mandir}/man8/grub-mkconfig.8*
485 %{_mandir}/man8/grub-ofpathname.8*
486 %{_mandir}/man8/grub-reboot.8*
487 %{_mandir}/man8/grub-set-default.8*
488 %{_mandir}/man8/update-grub.8*
489 %if %{with grubemu}
490 %attr(755,root,root) %{_sbindir}/grub-emu
491 %{_mandir}/man8/grub-emu.8*
492 %endif
493 %{_libexecdir}/grub-mkconfig_lib
494
495 %dir %{_grubdir}
496 %dir %{_libexecdir}
497 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
498
499 %dir %{_libexecdir}/locale
500 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
501 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
502
503 # generated by grub at runtime
504 %ghost %{_grubdir}/device.map
505 %ghost %{_grubdir}/core.img
506 %ghost %{_grubdir}/grubenv
507
508 %dir /lib/grub.d
509 %doc /lib/grub.d/README
510 %attr(755,root,root) /lib/grub.d/00_header
511 %attr(755,root,root) /lib/grub.d/10_linux
512 %attr(755,root,root) /lib/grub.d/20_linux_xen
513 %attr(755,root,root) /lib/grub.d/30_os-prober
514 %attr(755,root,root) /lib/grub.d/41_custom
515
516 # these are now installed only on matching hosts
517 #%attr(755,root,root) /lib/grub.d/10_hurd
518 #%attr(755,root,root) /lib/grub.d/10_illumos
519 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
520 #%attr(755,root,root) /lib/grub.d/10_netbsd
521 #%attr(755,root,root) /lib/grub.d/10_xnu
522
523 %ifarch %{ix86} %{x8664}
524 %attr(755,root,root) %{_sbindir}/grub-probe
525 %{_mandir}/man8/grub-probe.8*
526 %endif
527
528 %{_infodir}/grub*.info*
529
530 %dir %{_datadir}/grub/themes
531
532 %if %{with pc}
533 %files platform-pc
534 %defattr(644,root,root,755)
535 %dir %{_libexecdir}/*-pc
536 %{_libexecdir}/*-pc/modinfo.sh
537 %{_libexecdir}/*-pc/*.exec
538 %{_libexecdir}/*-pc/*.image
539 %{_libexecdir}/*-pc/*.lst
540 %{_libexecdir}/*-pc/*.mod
541 %{_libexecdir}/*-pc/*.module
542 %{_libexecdir}/*-pc/lzma_decompress.img
543 %{_libexecdir}/*-pc/config.h
544 %{_libexecdir}/*-pc/gdb_grub
545 %{_libexecdir}/*-pc/gmodule.pl
546 %if %{with efiemu}
547 %{_libexecdir}/*-pc/efiemu*.o
548 %endif
549 %{_libexecdir}/*-pc/kernel.img
550 %ifarch %{ix86} %{x8664} sparc sparc64
551 %{_libexecdir}/*-pc/boot.img
552 %{_libexecdir}/*-pc/boot_hybrid.img
553 %{_libexecdir}/*-pc/cdboot.img
554 %{_libexecdir}/*-pc/diskboot.img
555 %{_libexecdir}/*-pc/lnxboot.img
556 %{_libexecdir}/*-pc/pxeboot.img
557 %endif
558 %endif
559
560 %if %{with efi}
561 %files platform-efi
562 %defattr(644,root,root,755)
563 %dir %{_libexecdir}/*-efi
564 %{_libexecdir}/*-efi/modinfo.sh
565 %{_libexecdir}/*-efi/*.exec
566 %{_libexecdir}/*-efi/*.lst
567 %{_libexecdir}/*-efi/*.mod
568 %{_libexecdir}/*-efi/*.module
569 %{_libexecdir}/*-efi/config.h
570 %{_libexecdir}/*-efi/gdb_grub
571 %{_libexecdir}/*-efi/gmodule.pl
572 %{_libexecdir}/*-efi/kernel.img
573 %endif
574
575 %files mkfont
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_sbindir}/grub-mkfont
578 %{_mandir}/man1/grub-mkfont.1*
579
580 %files theme-starfield
581 %defattr(644,root,root,755)
582 %{_datadir}/grub/themes/starfield
583
584 %files -n bash-completion-%{name}
585 %defattr(644,root,root,755)
586 /etc/bash_completion.d/grub