]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- merged 2.12 from PLD
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664}
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664}
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32
33 %define         rel     1
34 Summary:        GRand Unified Bootloader
35 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86
36 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 gépekhez
37 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86
38 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
39 Name:           grub2
40 Version:        2.04
41 Release:        1
42 License:        GPL v2
43 Group:          Base
44 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
45 # Source0-md5:  5aaca6713b47ca2456d8324a58755ac7
46 Source1:        update-grub
47 Source2:        update-grub.8
48 Source3:        grub.sysconfig
49 Source4:        grub-custom.cfg
50 Patch1:         tld-sysconfdir.patch
51 Patch2:         grub-garbage.patch
52 Patch3:         grub-lvmdevice.patch
53 Patch4:         tld-mkconfigdir.patch
54 Patch5:         grub-mkconfig-diagnostics.patch
55 Patch6:         posix.patch
56 Patch7:         %{name}-fonts_path.patch
57 Patch8:         just-say-linux.patch
58 Patch9:         ignore-kernel-symlinks.patch
59 Patch10:        initrd-search.patch
60 Patch11:        %{name}-cfg.patch
61 Patch12:        efi-net-fix.patch
62 Patch13:        blscfg.patch
63 Patch14:        restricted.patch
64 URL:            http://www.gnu.org/software/grub/
65 BuildRequires:  autoconf >= 2.53
66 BuildRequires:  automake >= 1:1.11.1-1
67 BuildRequires:  bison
68 BuildRequires:  device-mapper-devel
69 BuildRequires:  flex >= 2.5.35
70 BuildRequires:  fonts-TTF-DejaVu
71 BuildRequires:  freetype-devel >= 2
72 BuildRequires:  gawk
73 BuildRequires:  gcc >= 5:3.4
74 BuildRequires:  gettext-tools
75 BuildRequires:  glibc-localedb-all
76 BuildRequires:  glibc-static
77 BuildRequires:  help2man
78 BuildRequires:  libfuse-devel
79 BuildRequires:  libtool
80 BuildRequires:  ncurses-devel
81 BuildRequires:  python
82 BuildRequires:  python-modules
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.213
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  tar >= 1:1.22
87 BuildRequires:  texinfo
88 BuildRequires:  xz
89 BuildRequires:  xz-devel
90 %ifarch %{x8664}
91 BuildRequires:  /usr/lib/libc.so
92 BuildRequires:  gcc-multilib
93 %endif
94 Requires:       %{name}-platform = %{version}-%{release}
95 Requires:       issue
96 Requires:       which
97 %ifarch %{ix86} %{x8664}
98 Suggests:       %{name}-platform-pc
99 %endif
100 Suggests:       cdrkit-mkisofs
101 Suggests:       os-prober
102 Provides:       bootloader
103 Conflicts:      grub
104 ExclusiveArch:  %{ix86} %{x8664}
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _sbindir        /sbin
108 %define         _bindir         %{_sbindir}
109 %define         _libdir         /lib
110 %define         _datadir        %{_libdir}
111 %define         _libexecdir     %{_libdir}/grub
112 %define         _grubdir        /boot/grub
113 %define         _localedir      /usr/share/locale
114
115 # part of grub code is not relocable (these are not Linux libs)
116 # stack protector also breaks non-Linux binaries
117 # any kind of forced optimizations makes grub2 unreliable (random
118 # reboots and hangs on boot menu screen)
119 %define         filterout_c     -fPIC -O.
120 %undefine       _ssp_cflags
121 %undefine       _fortify_cflags
122
123 %description
124 GRUB is a GPLed bootloader intended to unify bootloading across x86
125 operating systems. In addition to loading the Linux and *BSD kernels,
126 it implements the Multiboot standard, which allows for flexible
127 loading of multiple boot images (needed for modular kernels such as
128 the GNU Hurd).
129
130 GRUB 2 is derived from PUPA which was a research project to
131 investigate the next generation of GRUB. GRUB 2 has been rewritten
132 from scratch to clean up everything for modularity and portability.
133
134 GRUB 2 targets at the following goals:
135 - Scripting support, such as conditionals, loops, variables and
136   functions.
137 - Graphical interface.
138 - Dynamic loading of modules in order to extend itself at the run time
139   rather than at the build time.
140 - Portability for various architectures.
141 - Internationalization. This includes support for non-ASCII character
142   code, message catalogs like gettext, fonts, graphics console, and so
143   on.
144 - Real memory management, to make GNU GRUB more extensible.
145 - Modular, hierarchical, object-oriented framework for file systems,
146   files, devices, drives, terminals, commands, partition tables and OS
147   loaders.
148 - Cross-platform installation which allows for installing GRUB from a
149   different architecture.
150 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
151 - Fix design mistakes in GRUB Legacy, which could not be solved for
152   backward-compatibility, such as the way of numbering partitions.
153
154 %description -l de.UTF-8
155 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
156 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
157 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
158
159 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
160 und wird unter der GPL vertrieben. Aufgrund seiner höheren
161 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
162 traditionellen Boot-Loader LILO.
163
164 %description -l hu.UTF-8
165 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
166 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
167 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
168 GNU Hurd).
169
170 GRUB2 céljai a következők:
171 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
172   függvények.
173 - grafikus felület
174 - modulok dinamikus betöltése futási időben
175 - hordozhatóság több architektúrára
176 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
177   mint gettext, betűtípusok, grafikus konzolon, és így tovább
178 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
179 - moduláris, hierarchikus, objektum-orientált keretrendszer
180   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
181   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
182
183 %description -l es.UTF-8
184 Éste es GRUB - Grand Unified Boot Loader - un administrador de
185 inicialización capaz de entrar en la mayoría de los sistemas
186 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
187 también en la mayoría de los sistemas operacionales comerciales para
188 PC.
189
190 El administrador GRUB puede ser una buena alternativa a LILO, para
191 usuarios conmás experiencia y que deseen obtener más recursos de su
192 cargador de inicialización (boot loader).
193
194 %description -l pl.UTF-8
195 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
196 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
197 Linuksa i *BSD: posiada również implementację standardu Multiboot,
198 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
199 (czego wymagają modułowe jądra, takie jak GNU Hurd).
200
201 %description -l pt_BR.UTF-8
202 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
203 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
204 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
205 operacionais comerciais para PC.
206
207 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
208 avançados e que querem mais recursos de seu boot loader.
209
210 %package -n bash-completion-%{name}
211 Summary:        bash-completion for GRUB
212 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
213 Group:          Applications/Shells
214 Requires:       bash-completion
215
216 %description -n bash-completion-%{name}
217 This package provides bash-completion for GRUB.
218
219 %description -n bash-completion-%{name} -l pl.UTF-8
220 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
221
222 %package platform-pc
223 Summary:        PC BIOS platform support for GRUB
224 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
225 Group:          Base
226 Provides:       %{name}-platform = %{version}-%{release}
227
228 %description platform-pc
229 PC BIOS platform support for GRUB.
230
231 %description platform-pc -l pl.UTF-8
232 Obsługa platformy PC BIOS dla GRUB-a.
233
234 %package platform-efi
235 Summary:        (U)EFI platform support for GRUB
236 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
237 Group:          Base
238 Suggests:       efibootmgr
239 Provides:       %{name}-platform = %{version}-%{release}
240
241 %description platform-efi
242 (U)EFI platform support for GRUB.
243
244 %description platform-efi -l pl.UTF-8
245 Obsługa platformy (U)EFI dla GRUB-a.
246
247 %package mkfont
248 Summary:        GRUB font files converter
249 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
250 Group:          Base
251
252 %description mkfont
253 Converts common font file formats into PF2.
254
255 %description mkfont -l pl.UTF-8
256 Program do konwersji popularnych formatów plików fontów do PF2.
257
258 %package theme-starfield
259 Summary:        starfield theme for GRUB
260 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
261 Group:          Base
262
263 %description theme-starfield
264 starfield theme for GRUB.
265
266 %description theme-starfield -l pl.UTF-8
267 Motyw starfield dla GRUB-a.
268
269 %prep
270 %setup -q -n grub-%{version}
271 %patch1 -p1
272 %patch2 -p1
273 %patch3 -p1
274 %patch4 -p1
275 %patch5 -p1
276 %patch6 -p1
277 %patch7 -p1
278 %patch8 -p1
279 %patch9 -p1
280 %patch10 -p1
281 %patch11 -p1
282 %patch12 -p1
283 %patch13 -p1
284 %patch14 -p1
285
286 # we don't have C.utf-8 and need an UTF-8 locale for build
287 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
288
289 %build
290 # if gold is used then grub doesn't even boot
291 # https://savannah.gnu.org/bugs/?34539
292 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
293 install -d our-ld
294 ln -f -s /usr/bin/ld.bfd our-ld/ld
295 export PATH=$(pwd)/our-ld:$PATH
296
297 ## not only the typicall autotools stuff
298 #./autogen.sh
299
300 #{__gettextize}
301 %{__aclocal} -I m4
302 %{__autoconf}
303 %{__autoheader}
304 %{__automake}
305
306 for platform in %{platforms} ; do
307         install -d build-${platform}
308         cd build-${platform}
309
310         if [ "$platform" != "efi" ] ; then
311                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
312         else
313                 platform_opts=""
314         fi
315
316         ln -f -s ../configure .
317         # mawk stalls at ./genmoddep.awk, so force gawk
318         AWK=gawk \
319         %configure \
320                 --with-platform=${platform} \
321                 --disable-werror \
322         %if %{with grubemu}
323                 --enable-grub-emu-usb \
324                 --enable-grub-emu-sdl \
325                 --enable-grub-emu-pci \
326         %endif
327                 $platform_opts \
328                 TARGET_LDFLAGS=-static
329
330         %{__make} -j1 -C po update-gmo
331         %{__make}
332         cd ..
333 done
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337
338 for platform in %{platforms} ; do
339         cd build-${platform}
340         %{__make} install \
341                 pkgdatadir=%{_libexecdir} \
342                 pkglibdir=%{_libexecdir} \
343                 DESTDIR=$RPM_BUILD_ROOT
344         cd ..
345 done
346
347 # not in Th (?)
348 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
349 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
350
351 %find_lang grub
352
353 # this must be after 'make install'
354 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
355
356 install -d $RPM_BUILD_ROOT%{_grubdir}
357 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
358
359 # grub.d/41_custom
360 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
361 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
362
363 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
364 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
365
366 install -d $RPM_BUILD_ROOT/etc/sysconfig
367 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
368
369 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
370 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
371
372 # platform specific, unnecessarily always installed
373 %ifnarch %{ix86} %{x8664}
374 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
375 %endif
376 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
377
378 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
379 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
380 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
381
382 # needs to be exactly 1KiB
383 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
384 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %post -p %{_sbindir}/postshell
390 -/usr/sbin/fix-info-dir -c %{_infodir}
391
392 %postun -p %{_sbindir}/postshell
393 -/usr/sbin/fix-info-dir -c %{_infodir}
394
395 %triggerpostun -- %{name} < 2.00-2
396 # Note this trigger on version upgrade needed only for upgrade from
397 # old grub2 packages which contained modules in /boot/grub
398 # or were built with optimizations enabled
399 # don't do anything on --downgrade
400 if [ $1 -le 1 ]; then
401         exit 0
402 fi
403 echo "Grub was upgraded, trying to setup it to boot sector"
404 /sbin/grub-install '(hd0)' || :
405
406 %triggerpostun -- %{name} < 1.99-7.3
407 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
408 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
409         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
410         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
411 fi
412
413 %files -f grub.lang
414 %defattr(644,root,root,755)
415 %doc AUTHORS NEWS README THANKS TODO
416 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
417 %attr(755,root,root) %{_sbindir}/grub-editenv
418 %attr(755,root,root) %{_sbindir}/grub-fstest
419 %attr(755,root,root) %{_sbindir}/grub-file
420 %attr(755,root,root) %{_sbindir}/grub-glue-efi
421 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
422 %attr(755,root,root) %{_sbindir}/grub-install
423 %attr(755,root,root) %{_sbindir}/grub-macbless
424 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
425 %attr(755,root,root) %{_sbindir}/grub-mkconfig
426 %attr(755,root,root) %{_sbindir}/grub-mklayout
427 %attr(755,root,root) %{_sbindir}/grub-mknetdir
428 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
429 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
430 %attr(755,root,root) %{_sbindir}/grub-mkrescue
431 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
432 %attr(755,root,root) %{_sbindir}/grub-mount
433 %attr(755,root,root) %{_sbindir}/grub-ofpathname
434 %attr(755,root,root) %{_sbindir}/grub-reboot
435 %attr(755,root,root) %{_sbindir}/grub-render-label
436 %attr(755,root,root) %{_sbindir}/grub-script-check
437 %attr(755,root,root) %{_sbindir}/grub-set-default
438 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
439 %attr(755,root,root) %{_sbindir}/update-grub
440 %ifarch %{ix86} %{x8664}
441 %attr(755,root,root) %{_sbindir}/grub-bios-setup
442 %{_mandir}/man8/grub-bios-setup.8*
443 %endif
444 %ifarch %{ix86} %{x8664}
445 %attr(755,root,root) %{_sbindir}/grub-mkimage
446 %{_mandir}/man1/grub-mkimage.1*
447 %else
448 %attr(755,root,root) %{_sbindir}/grub-probe
449 %{_mandir}/man8/grub-probe.8*
450 %endif
451 %{_mandir}/man1/grub-editenv.1*
452 %{_mandir}/man1/grub-file.1*
453 %{_mandir}/man1/grub-fstest.1*
454 %{_mandir}/man1/grub-glue-efi.1*
455 %{_mandir}/man1/grub-kbdcomp.1*
456 %{_mandir}/man1/grub-menulst2cfg.1*
457 %{_mandir}/man1/grub-mklayout.1*
458 %{_mandir}/man1/grub-mknetdir.1*
459 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
460 %{_mandir}/man1/grub-mkrelpath.1*
461 %{_mandir}/man1/grub-mkrescue.1*
462 %{_mandir}/man1/grub-mkstandalone.1*
463 %{_mandir}/man1/grub-mount.1*
464 %{_mandir}/man1/grub-render-label.1*
465 %{_mandir}/man1/grub-script-check.1*
466 %{_mandir}/man1/grub-syslinux2cfg.1*
467 %{_mandir}/man8/grub-install.8*
468 %{_mandir}/man8/grub-macbless.8*
469 %{_mandir}/man8/grub-mkconfig.8*
470 %{_mandir}/man8/grub-ofpathname.8*
471 %{_mandir}/man8/grub-reboot.8*
472 %{_mandir}/man8/grub-set-default.8*
473 %{_mandir}/man8/update-grub.8*
474 %if %{with grubemu}
475 %attr(755,root,root) %{_sbindir}/grub-emu
476 %{_mandir}/man8/grub-emu.8*
477 %endif
478 %{_libexecdir}/grub-mkconfig_lib
479
480 %dir %{_grubdir}
481 %dir %{_libexecdir}
482 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
483
484 %dir %{_libexecdir}/locale
485 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
486 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
487
488 # generated by grub at runtime
489 %ghost %{_grubdir}/device.map
490 %ghost %{_grubdir}/core.img
491 %ghost %{_grubdir}/grubenv
492
493 %dir /lib/grub.d
494 %doc /lib/grub.d/README
495 %attr(755,root,root) /lib/grub.d/00_header
496 %attr(755,root,root) /lib/grub.d/10_linux
497 %attr(755,root,root) /lib/grub.d/20_linux_xen
498 %attr(755,root,root) /lib/grub.d/30_os-prober
499 %attr(755,root,root) /lib/grub.d/41_custom
500
501 # these are now installed only on matching hosts
502 #%attr(755,root,root) /lib/grub.d/10_hurd
503 #%attr(755,root,root) /lib/grub.d/10_illumos
504 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
505 #%attr(755,root,root) /lib/grub.d/10_netbsd
506 #%attr(755,root,root) /lib/grub.d/10_xnu
507
508 %ifarch %{ix86} %{x8664}
509 %attr(755,root,root) %{_sbindir}/grub-probe
510 %{_mandir}/man8/grub-probe.8*
511 %endif
512
513 %{_infodir}/grub*.info*
514
515 %dir %{_datadir}/grub/themes
516
517 %if %{with pc}
518 %files platform-pc
519 %defattr(644,root,root,755)
520 %dir %{_libexecdir}/*-pc
521 %{_libexecdir}/*-pc/modinfo.sh
522 %{_libexecdir}/*-pc/*.exec
523 %{_libexecdir}/*-pc/*.image
524 %{_libexecdir}/*-pc/*.lst
525 %{_libexecdir}/*-pc/*.mod
526 %{_libexecdir}/*-pc/*.module
527 %{_libexecdir}/*-pc/lzma_decompress.img
528 %{_libexecdir}/*-pc/config.h
529 %{_libexecdir}/*-pc/gdb_grub
530 %{_libexecdir}/*-pc/gmodule.pl
531 %if %{with efiemu}
532 %{_libexecdir}/*-pc/efiemu*.o
533 %endif
534 %{_libexecdir}/*-pc/kernel.img
535 %ifarch %{ix86} %{x8664}
536 %{_libexecdir}/*-pc/boot.img
537 %{_libexecdir}/*-pc/boot_hybrid.img
538 %{_libexecdir}/*-pc/cdboot.img
539 %{_libexecdir}/*-pc/diskboot.img
540 %{_libexecdir}/*-pc/lnxboot.img
541 %{_libexecdir}/*-pc/pxeboot.img
542 %endif
543 %endif
544
545 %if %{with efi}
546 %files platform-efi
547 %defattr(644,root,root,755)
548 %dir %{_libexecdir}/*-efi
549 %{_libexecdir}/*-efi/modinfo.sh
550 %{_libexecdir}/*-efi/*.exec
551 %{_libexecdir}/*-efi/*.lst
552 %{_libexecdir}/*-efi/*.mod
553 %{_libexecdir}/*-efi/*.module
554 %{_libexecdir}/*-efi/config.h
555 %{_libexecdir}/*-efi/gdb_grub
556 %{_libexecdir}/*-efi/gmodule.pl
557 %{_libexecdir}/*-efi/kernel.img
558 %endif
559
560 %files mkfont
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_sbindir}/grub-mkfont
563 %{_mandir}/man1/grub-mkfont.1*
564
565 %files theme-starfield
566 %defattr(644,root,root,755)
567 %{_datadir}/grub/themes/starfield
568
569 %files -n bash-completion-%{name}
570 %defattr(644,root,root,755)
571 /etc/bash_completion.d/grub