]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- md5, drop source5 for now
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 %define beta    beta2
48 Name:           grub2
49 Version:        2.02
50 Release:        0.%{beta}.2
51 License:        GPL v2
52 Group:          Base
53 # http://git.savannah.gnu.org/cgit/grub.git
54 Source0:        http://git.savannah.gnu.org/cgit/grub.git/snapshot/grub-%{version}-%{beta}.tar.gz
55 # Source0-md5:  b6f4c2947ee2b972c124fea85c21d92c
56 Source1:        update-grub
57 Source2:        update-grub.8
58 Source3:        grub.sysconfig
59 Source4:        grub-custom.cfg
60 # ./linguas.sh
61 # TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
62 #Source5:       grub-po-%{version}.git20140104.tar.bz2
63 # Source5-md5:  aeef3e636178093cf9d780d92da7afdb
64 Patch1:         pld-sysconfdir.patch
65 Patch2:         grub-garbage.patch
66 Patch3:         grub-lvmdevice.patch
67 Patch4:         pld-mkconfigdir.patch
68 Patch5:         grub-mkconfig-diagnostics.patch
69 Patch6:         posix.patch
70 Patch7:         %{name}-fonts_path.patch
71 Patch8:         add-vlan-tag-support.patch
72 Patch9:         just-say-linux.patch
73 Patch10:        ignore-kernel-symlinks.patch
74 Patch11:        choose-preferred-initrd.patch
75 Patch12:        %{name}-cfg.patch
76 URL:            http://www.gnu.org/software/grub/
77 BuildRequires:  autoconf >= 2.53
78 BuildRequires:  automake >= 1:1.11.1-1
79 BuildRequires:  bison
80 BuildRequires:  device-mapper-devel
81 BuildRequires:  flex >= 2.5.35
82 BuildRequires:  fonts-TTF-DejaVu
83 BuildRequires:  freetype-devel >= 2
84 BuildRequires:  gawk
85 BuildRequires:  gettext-devel
86 BuildRequires:  glibc-localedb-all
87 BuildRequires:  glibc-static
88 BuildRequires:  help2man
89 BuildRequires:  libfuse-devel
90 BuildRequires:  libtool
91 BuildRequires:  ncurses-devel
92 BuildRequires:  python
93 BuildRequires:  python-modules
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.213
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  tar >= 1:1.22
98 BuildRequires:  texinfo
99 BuildRequires:  xz
100 BuildRequires:  xz-devel
101 %ifarch %{x8664}
102 BuildRequires:  /usr/lib/libc.so
103 %if "%{pld_release}" == "ac"
104 BuildRequires:  libgcc32
105 %else
106 BuildRequires:  gcc-multilib
107 %endif
108 %endif
109 Requires:       %{name}-platform = %{version}-%{release}
110 Requires:       pld-release
111 Requires:       which
112 %ifarch %{ix86} %{x8664}
113 Suggests:       %{name}-platform-pc
114 %endif
115 Suggests:       cdrkit-mkisofs
116 Suggests:       os-prober
117 Provides:       bootloader
118 Conflicts:      grub
119 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sbindir        /sbin
123 %define         _bindir         %{_sbindir}
124 %define         _libdir         /lib
125 %define         _datadir        %{_libdir}
126 %define         _libexecdir     %{_libdir}/grub
127 %define         _grubdir        /boot/grub
128 %define         _localedir      /usr/share/locale
129
130 # part of grub code is not relocable (these are not Linux libs)
131 # stack protector also breaks non-Linux binaries
132 # any kind of forced optimizations makes grub2 unreliable (random
133 # reboots and hangs on boot menu screen)
134 %define         filterout_c     -fPIC -O.
135 %undefine       _ssp_cflags
136 %undefine       _fortify_cflags
137
138 %description
139 GRUB is a GPLed bootloader intended to unify bootloading across x86
140 operating systems. In addition to loading the Linux and *BSD kernels,
141 it implements the Multiboot standard, which allows for flexible
142 loading of multiple boot images (needed for modular kernels such as
143 the GNU Hurd).
144
145 GRUB 2 is derived from PUPA which was a research project to
146 investigate the next generation of GRUB. GRUB 2 has been rewritten
147 from scratch to clean up everything for modularity and portability.
148
149 GRUB 2 targets at the following goals:
150 - Scripting support, such as conditionals, loops, variables and
151   functions.
152 - Graphical interface.
153 - Dynamic loading of modules in order to extend itself at the run time
154   rather than at the build time.
155 - Portability for various architectures.
156 - Internationalization. This includes support for non-ASCII character
157   code, message catalogs like gettext, fonts, graphics console, and so
158   on.
159 - Real memory management, to make GNU GRUB more extensible.
160 - Modular, hierarchical, object-oriented framework for file systems,
161   files, devices, drives, terminals, commands, partition tables and OS
162   loaders.
163 - Cross-platform installation which allows for installing GRUB from a
164   different architecture.
165 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
166 - Fix design mistakes in GRUB Legacy, which could not be solved for
167   backward-compatibility, such as the way of numbering partitions.
168
169 %description -l de.UTF-8
170 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
171 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
172 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
173
174 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
175 und wird unter der GPL vertrieben. Aufgrund seiner höheren
176 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
177 traditionellen Boot-Loader LILO.
178
179 %description -l hu.UTF-8
180 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
181 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
182 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
183 GNU Hurd).
184
185 GRUB2 céljai a következők:
186 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
187   függvények.
188 - grafikus felület
189 - modulok dinamikus betöltése futási időben
190 - hordozhatóság több architektúrára
191 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
192   mint gettext, betűtípusok, grafikus konzolon, és így tovább
193 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
194 - moduláris, hierarchikus, objektum-orientált keretrendszer
195   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
196   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
197
198 %description -l es.UTF-8
199 Éste es GRUB - Grand Unified Boot Loader - un administrador de
200 inicialización capaz de entrar en la mayoría de los sistemas
201 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
202 también en la mayoría de los sistemas operacionales comerciales para
203 PC.
204
205 El administrador GRUB puede ser una buena alternativa a LILO, para
206 usuarios conmás experiencia y que deseen obtener más recursos de su
207 cargador de inicialización (boot loader).
208
209 %description -l pl.UTF-8
210 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
211 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
212 Linuksa i *BSD: posiada również implementację standardu Multiboot,
213 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
214 (czego wymagają modułowe jądra, takie jak GNU Hurd).
215
216 %description -l pt_BR.UTF-8
217 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
218 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
219 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
220 operacionais comerciais para PC.
221
222 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
223 avançados e que querem mais recursos de seu boot loader.
224
225 %package -n bash-completion-%{name}
226 Summary:        bash-completion for GRUB
227 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
228 Group:          Applications/Shells
229 Requires:       bash-completion
230
231 %description -n bash-completion-%{name}
232 This package provides bash-completion for GRUB.
233
234 %description -n bash-completion-%{name} -l pl.UTF-8
235 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
236
237 %package platform-pc
238 Summary:        PC BIOS platform support for GRUB
239 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
240 Group:          Base
241 Provides:       %{name}-platform = %{version}-%{release}
242
243 %description platform-pc
244 PC BIOS platform support for GRUB.
245
246 %description platform-pc -l pl.UTF-8
247 Obsługa platformy PC BIOS dla GRUB-a.
248
249 %package platform-efi
250 Summary:        (U)EFI platform support for GRUB
251 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
252 Group:          Base
253 Suggests:       efibootmgr
254 Provides:       %{name}-platform = %{version}-%{release}
255
256 %description platform-efi
257 (U)EFI platform support for GRUB.
258
259 %description platform-efi -l pl.UTF-8
260 Obsługa platformy (U)EFI dla GRUB-a.
261
262 %package mkfont
263 Summary:        GRUB font files converter
264 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
265 Group:          Base
266
267 %description mkfont
268 Converts common font file formats into PF2.
269
270 %description mkfont -l pl.UTF-8
271 Program do konwersji popularnych formatów plików fontów do PF2.
272
273 %package theme-starfield
274 Summary:        starfield theme for GRUB
275 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
276 Group:          Base
277
278 %description theme-starfield
279 starfield theme for GRUB.
280
281 %description theme-starfield -l pl.UTF-8
282 Motyw starfield dla GRUB-a.
283
284 %prep
285 %setup -q -n grub-%{version}~%{beta}
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289 %patch4 -p1
290 %patch5 -p1
291 %patch6 -p1
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch10 -p1
296 %patch11 -p1
297 %patch12 -p0
298
299 # we don't have C.utf-8 and need an UTF-8 locale for build
300 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
301
302 %build
303 # if gold is used then grub doesn't even boot
304 # https://savannah.gnu.org/bugs/?34539
305 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
306 install -d our-ld
307 ln -s /usr/bin/ld.bfd our-ld/ld
308 export PATH=$(pwd)/our-ld:$PATH
309
310 ## not only the typicall autotools stuff
311 #./autogen.sh
312
313 %{__gettextize}
314 %{__aclocal} -I m4
315 %{__autoconf}
316 %{__autoheader}
317 %{__automake}
318
319 for platform in %{platforms} ; do
320         install -d build-${platform}
321         cd build-${platform}
322
323         if [ "$platform" != "efi" ] ; then
324                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
325         else
326                 platform_opts=""
327         fi
328
329         ln -s ../configure .
330         # mawk stalls at ./genmoddep.awk, so force gawk
331         AWK=gawk \
332         %configure \
333                 --with-platform=${platform} \
334                 --disable-werror \
335         %if %{with grubemu}
336                 --enable-grub-emu-usb \
337                 --enable-grub-emu-sdl \
338                 --enable-grub-emu-pci \
339         %endif
340                 $platform_opts \
341                 TARGET_LDFLAGS=-static
342
343         %{__make} -j1 -C po update-gmo
344         %{__make}
345         cd ..
346 done
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350
351 for platform in %{platforms} ; do
352         cd build-${platform}
353         %{__make} install \
354                 pkgdatadir=%{_libexecdir} \
355                 pkglibdir=%{_libexecdir} \
356                 DESTDIR=$RPM_BUILD_ROOT
357         cd ..
358 done
359
360 # not in Th (?)
361 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
362 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
363
364 %find_lang grub
365
366 # this must be after 'make install'
367 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
368
369 install -d $RPM_BUILD_ROOT%{_grubdir}
370 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
371
372 # grub.d/41_custom
373 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
374 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
375
376 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
377 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
378
379 install -d $RPM_BUILD_ROOT/etc/sysconfig
380 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
381
382 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
383 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
384
385 # platform specific, unnecessarily always installed
386 %ifnarch %{ix86} %{x8664}
387 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
388 %endif
389 %ifnarch sparc64
390 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
391 %endif
392
393 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
394 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
395 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
396
397 # needs to be exactly 1KiB
398 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
399 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
400
401 %clean
402 rm -rf $RPM_BUILD_ROOT
403
404 %post -p %{_sbindir}/postshell
405 -/usr/sbin/fix-info-dir -c %{_infodir}
406
407 %postun -p %{_sbindir}/postshell
408 -/usr/sbin/fix-info-dir -c %{_infodir}
409
410 %triggerpostun -- %{name} < 2.00-2
411 # Note this trigger on version upgrade needed only for upgrade from
412 # old grub2 packages which contained modules in /boot/grub
413 # or were built with optimizations enabled
414 # don't do anything on --downgrade
415 if [ $1 -le 1 ]; then
416         exit 0
417 fi
418 echo "Grub was upgraded, trying to setup it to boot sector"
419 /sbin/grub-install '(hd0)' || :
420
421 %triggerpostun -- %{name} < 1.99-7.3
422 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
423 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
424         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
425         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
426 fi
427
428 %files -f grub.lang
429 %defattr(644,root,root,755)
430 %doc AUTHORS ChangeLog NEWS README THANKS TODO
431 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
432 %attr(755,root,root) %{_sbindir}/grub-editenv
433 %attr(755,root,root) %{_sbindir}/grub-fstest
434 %attr(755,root,root) %{_sbindir}/grub-file
435 %attr(755,root,root) %{_sbindir}/grub-glue-efi
436 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
437 %attr(755,root,root) %{_sbindir}/grub-install
438 %attr(755,root,root) %{_sbindir}/grub-macbless
439 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
440 %attr(755,root,root) %{_sbindir}/grub-mkconfig
441 %attr(755,root,root) %{_sbindir}/grub-mklayout
442 %attr(755,root,root) %{_sbindir}/grub-mknetdir
443 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
444 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
445 %attr(755,root,root) %{_sbindir}/grub-mkrescue
446 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
447 %attr(755,root,root) %{_sbindir}/grub-mount
448 %attr(755,root,root) %{_sbindir}/grub-ofpathname
449 %attr(755,root,root) %{_sbindir}/grub-reboot
450 %attr(755,root,root) %{_sbindir}/grub-render-label
451 %attr(755,root,root) %{_sbindir}/grub-script-check
452 %attr(755,root,root) %{_sbindir}/grub-set-default
453 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
454 %attr(755,root,root) %{_sbindir}/update-grub
455 %ifarch %{ix86} %{x8664}
456 %attr(755,root,root) %{_sbindir}/grub-bios-setup
457 %{_mandir}/man8/grub-bios-setup.8*
458 %endif
459 %ifarch %{ix86} %{x8664}
460 %attr(755,root,root) %{_sbindir}/grub-mkimage
461 %{_mandir}/man1/grub-mkimage.1*
462 %else
463 %attr(755,root,root) %{_sbindir}/grub-probe
464 %{_mandir}/man8/grub-probe.8*
465 %endif
466 %ifarch sparc64
467 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
468 %{_mandir}/man8/grub-sparc64-setup.8*
469 %endif
470 %{_mandir}/man1/grub-editenv.1*
471 %{_mandir}/man1/grub-file.1*
472 %{_mandir}/man1/grub-fstest.1*
473 %{_mandir}/man1/grub-glue-efi.1*
474 %{_mandir}/man1/grub-kbdcomp.1*
475 %{_mandir}/man1/grub-macbless.1*
476 %{_mandir}/man1/grub-menulst2cfg.1*
477 %{_mandir}/man1/grub-mklayout.1*
478 %{_mandir}/man1/grub-mknetdir.1*
479 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
480 %{_mandir}/man1/grub-mkrelpath.1*
481 %{_mandir}/man1/grub-mkrescue.1*
482 %{_mandir}/man1/grub-mkstandalone.1*
483 %{_mandir}/man1/grub-mount.1*
484 %{_mandir}/man1/grub-render-label.1*
485 %{_mandir}/man1/grub-script-check.1*
486 %{_mandir}/man1/grub-syslinux2cfg.1*
487 %{_mandir}/man8/grub-install.8*
488 %{_mandir}/man8/grub-mkconfig.8*
489 %{_mandir}/man8/grub-ofpathname.8*
490 %{_mandir}/man8/grub-reboot.8*
491 %{_mandir}/man8/grub-set-default.8*
492 %{_mandir}/man8/update-grub.8*
493 %if %{with grubemu}
494 %attr(755,root,root) %{_sbindir}/grub-emu
495 %{_mandir}/man8/grub-emu.8*
496 %endif
497 %{_libexecdir}/grub-mkconfig_lib
498
499 %dir %{_grubdir}
500 %dir %{_libexecdir}
501 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
502
503 %dir %{_libexecdir}/locale
504 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
505 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
506
507 # generated by grub at runtime
508 %ghost %{_grubdir}/device.map
509 %ghost %{_grubdir}/core.img
510 %ghost %{_grubdir}/grubenv
511
512 %dir /lib/grub.d
513 %doc /lib/grub.d/README
514 %attr(755,root,root) /lib/grub.d/00_header
515 %attr(755,root,root) /lib/grub.d/10_linux
516 %attr(755,root,root) /lib/grub.d/20_linux_xen
517 %attr(755,root,root) /lib/grub.d/30_os-prober
518 %attr(755,root,root) /lib/grub.d/41_custom
519
520 # these are now installed only on matching hosts
521 #%attr(755,root,root) /lib/grub.d/10_hurd
522 #%attr(755,root,root) /lib/grub.d/10_illumos
523 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
524 #%attr(755,root,root) /lib/grub.d/10_netbsd
525 #%attr(755,root,root) /lib/grub.d/10_xnu
526
527 %ifarch %{ix86} %{x8664}
528 %attr(755,root,root) %{_sbindir}/grub-probe
529 %{_mandir}/man8/grub-probe.8*
530 %endif
531
532 %{_infodir}/grub*.info*
533
534 %dir %{_datadir}/grub/themes
535
536 %if %{with pc}
537 %files platform-pc
538 %defattr(644,root,root,755)
539 %dir %{_libexecdir}/*-pc
540 %{_libexecdir}/*-pc/modinfo.sh
541 %{_libexecdir}/*-pc/*.exec
542 %{_libexecdir}/*-pc/*.image
543 %{_libexecdir}/*-pc/*.lst
544 %{_libexecdir}/*-pc/*.mod
545 %{_libexecdir}/*-pc/*.module
546 %{_libexecdir}/*-pc/lzma_decompress.img
547 %{_libexecdir}/*-pc/config.h
548 %{_libexecdir}/*-pc/gdb_grub
549 %{_libexecdir}/*-pc/gmodule.pl
550 %if %{with efiemu}
551 %{_libexecdir}/*-pc/efiemu*.o
552 %endif
553 %{_libexecdir}/*-pc/kernel.img
554 %ifarch %{ix86} %{x8664} sparc sparc64
555 %{_libexecdir}/*-pc/boot.img
556 %{_libexecdir}/*-pc/boot_hybrid.img
557 %{_libexecdir}/*-pc/cdboot.img
558 %{_libexecdir}/*-pc/diskboot.img
559 %{_libexecdir}/*-pc/lnxboot.img
560 %{_libexecdir}/*-pc/pxeboot.img
561 %endif
562 %endif
563
564 %if %{with efi}
565 %files platform-efi
566 %defattr(644,root,root,755)
567 %dir %{_libexecdir}/*-efi
568 %{_libexecdir}/*-efi/modinfo.sh
569 %{_libexecdir}/*-efi/*.exec
570 %{_libexecdir}/*-efi/*.lst
571 %{_libexecdir}/*-efi/*.mod
572 %{_libexecdir}/*-efi/*.module
573 %{_libexecdir}/*-efi/config.h
574 %{_libexecdir}/*-efi/gdb_grub
575 %{_libexecdir}/*-efi/gmodule.pl
576 %{_libexecdir}/*-efi/kernel.img
577 %endif
578
579 %files mkfont
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_sbindir}/grub-mkfont
582 %{_mandir}/man1/grub-mkfont.1*
583
584 %files theme-starfield
585 %defattr(644,root,root,755)
586 %{_datadir}/grub/themes/starfield
587
588 %files -n bash-completion-%{name}
589 %defattr(644,root,root,755)
590 /etc/bash_completion.d/grub