]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- partial PLD merge
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664}
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664}
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32
33 %define         rel     6
34 Summary:        GRand Unified Bootloader
35 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86
36 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 gépekhez
37 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86
38 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
39 %define beta    beta2
40 Name:           grub2
41 Version:        2.02
42 Release:        0.%{beta}.%{rel}
43 License:        GPL v2
44 Group:          Base
45 # 1. Download and unpack latest official beta snapshot from http://git.savannah.gnu.org/cgit/grub.git
46 # 2. Run ./autogen.sh and ./linguas.sh
47 # 3. Recompress and upload to DF
48 Source0:        grub-%{version}-%{beta}.tar.xz
49 # Source0-md5: f262e61eba2e76a6f60b39a810814284
50 Source1:        update-grub
51 Source2:        update-grub.8
52 Source3:        grub.sysconfig
53 Source4:        grub-custom.cfg
54 Patch1:         pld-sysconfdir.patch
55 Patch2:         grub-garbage.patch
56 Patch3:         grub-lvmdevice.patch
57 Patch4:         pld-mkconfigdir.patch
58 Patch5:         grub-mkconfig-diagnostics.patch
59 Patch6:         posix.patch
60 Patch7:         %{name}-fonts_path.patch
61 Patch8:         add-vlan-tag-support.patch
62 Patch9:         just-say-linux.patch
63 Patch10:        ignore-kernel-symlinks.patch
64 Patch11:        choose-preferred-initrd.patch
65 Patch12:        %{name}-cfg.patch
66 Patch13:        efi-net-fix.patch
67 Patch14:        grub2-xfs-Add-helper-for-inode-size.patch
68 Patch15:        grub2-xfs-Convert-inode-numbers-to-cpu-endianity-immediate.patch
69 Patch16:        grub2-xfs-Fix-termination-loop-for-directory-iteration.patch
70 Patch17:        grub2-xfs-V5-filesystem-format-support.patch
71 Patch18:        blscfg.patch
72 URL:            http://www.gnu.org/software/grub/
73 BuildRequires:  autoconf >= 2.53
74 BuildRequires:  automake >= 1:1.11.1-1
75 BuildRequires:  bison
76 BuildRequires:  device-mapper-devel
77 BuildRequires:  flex >= 2.5.35
78 BuildRequires:  fonts-TTF-DejaVu
79 BuildRequires:  freetype-devel >= 2
80 BuildRequires:  gawk
81 BuildRequires:  gcc >= 5:3.4
82 BuildRequires:  gettext-tools
83 BuildRequires:  glibc-localedb-all
84 BuildRequires:  glibc-static
85 BuildRequires:  help2man
86 BuildRequires:  libfuse-devel
87 BuildRequires:  libtool
88 BuildRequires:  ncurses-devel
89 BuildRequires:  python
90 BuildRequires:  python-modules
91 BuildRequires:  rpm >= 4.4.9-56
92 BuildRequires:  rpmbuild(macros) >= 1.213
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  tar >= 1:1.22
95 BuildRequires:  texinfo
96 BuildRequires:  xz
97 BuildRequires:  xz-devel
98 %ifarch %{x8664}
99 BuildRequires:  /usr/lib/libc.so
100 BuildRequires:  gcc-multilib
101 %endif
102 Requires:       %{name}-platform = %{version}-%{release}
103 Requires:       issue
104 Requires:       which
105 %ifarch %{ix86} %{x8664}
106 Suggests:       %{name}-platform-pc
107 %endif
108 Suggests:       cdrkit-mkisofs
109 Suggests:       os-prober
110 Provides:       bootloader
111 Conflicts:      grub
112 ExclusiveArch:  %{ix86} %{x8664}
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         _sbindir        /sbin
116 %define         _bindir         %{_sbindir}
117 %define         _libdir         /lib
118 %define         _datadir        %{_libdir}
119 %define         _libexecdir     %{_libdir}/grub
120 %define         _grubdir        /boot/grub
121 %define         _localedir      /usr/share/locale
122
123 # part of grub code is not relocable (these are not Linux libs)
124 # stack protector also breaks non-Linux binaries
125 # any kind of forced optimizations makes grub2 unreliable (random
126 # reboots and hangs on boot menu screen)
127 %define         filterout_c     -fPIC -O.
128 %undefine       _ssp_cflags
129 %undefine       _fortify_cflags
130
131 %description
132 GRUB is a GPLed bootloader intended to unify bootloading across x86
133 operating systems. In addition to loading the Linux and *BSD kernels,
134 it implements the Multiboot standard, which allows for flexible
135 loading of multiple boot images (needed for modular kernels such as
136 the GNU Hurd).
137
138 GRUB 2 is derived from PUPA which was a research project to
139 investigate the next generation of GRUB. GRUB 2 has been rewritten
140 from scratch to clean up everything for modularity and portability.
141
142 GRUB 2 targets at the following goals:
143 - Scripting support, such as conditionals, loops, variables and
144   functions.
145 - Graphical interface.
146 - Dynamic loading of modules in order to extend itself at the run time
147   rather than at the build time.
148 - Portability for various architectures.
149 - Internationalization. This includes support for non-ASCII character
150   code, message catalogs like gettext, fonts, graphics console, and so
151   on.
152 - Real memory management, to make GNU GRUB more extensible.
153 - Modular, hierarchical, object-oriented framework for file systems,
154   files, devices, drives, terminals, commands, partition tables and OS
155   loaders.
156 - Cross-platform installation which allows for installing GRUB from a
157   different architecture.
158 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
159 - Fix design mistakes in GRUB Legacy, which could not be solved for
160   backward-compatibility, such as the way of numbering partitions.
161
162 %description -l de.UTF-8
163 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
164 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
165 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
166
167 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
168 und wird unter der GPL vertrieben. Aufgrund seiner höheren
169 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
170 traditionellen Boot-Loader LILO.
171
172 %description -l hu.UTF-8
173 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
174 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
175 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
176 GNU Hurd).
177
178 GRUB2 céljai a következők:
179 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
180   függvények.
181 - grafikus felület
182 - modulok dinamikus betöltése futási időben
183 - hordozhatóság több architektúrára
184 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
185   mint gettext, betűtípusok, grafikus konzolon, és így tovább
186 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
187 - moduláris, hierarchikus, objektum-orientált keretrendszer
188   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
189   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
190
191 %description -l es.UTF-8
192 Éste es GRUB - Grand Unified Boot Loader - un administrador de
193 inicialización capaz de entrar en la mayoría de los sistemas
194 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
195 también en la mayoría de los sistemas operacionales comerciales para
196 PC.
197
198 El administrador GRUB puede ser una buena alternativa a LILO, para
199 usuarios conmás experiencia y que deseen obtener más recursos de su
200 cargador de inicialización (boot loader).
201
202 %description -l pl.UTF-8
203 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
204 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
205 Linuksa i *BSD: posiada również implementację standardu Multiboot,
206 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
207 (czego wymagają modułowe jądra, takie jak GNU Hurd).
208
209 %description -l pt_BR.UTF-8
210 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
211 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
212 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
213 operacionais comerciais para PC.
214
215 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
216 avançados e que querem mais recursos de seu boot loader.
217
218 %package -n bash-completion-%{name}
219 Summary:        bash-completion for GRUB
220 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
221 Group:          Applications/Shells
222 Requires:       bash-completion
223
224 %description -n bash-completion-%{name}
225 This package provides bash-completion for GRUB.
226
227 %description -n bash-completion-%{name} -l pl.UTF-8
228 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
229
230 %package platform-pc
231 Summary:        PC BIOS platform support for GRUB
232 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
233 Group:          Base
234 Provides:       %{name}-platform = %{version}-%{release}
235
236 %description platform-pc
237 PC BIOS platform support for GRUB.
238
239 %description platform-pc -l pl.UTF-8
240 Obsługa platformy PC BIOS dla GRUB-a.
241
242 %package platform-efi
243 Summary:        (U)EFI platform support for GRUB
244 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
245 Group:          Base
246 Suggests:       efibootmgr
247 Provides:       %{name}-platform = %{version}-%{release}
248
249 %description platform-efi
250 (U)EFI platform support for GRUB.
251
252 %description platform-efi -l pl.UTF-8
253 Obsługa platformy (U)EFI dla GRUB-a.
254
255 %package mkfont
256 Summary:        GRUB font files converter
257 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
258 Group:          Base
259
260 %description mkfont
261 Converts common font file formats into PF2.
262
263 %description mkfont -l pl.UTF-8
264 Program do konwersji popularnych formatów plików fontów do PF2.
265
266 %package theme-starfield
267 Summary:        starfield theme for GRUB
268 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
269 Group:          Base
270
271 %description theme-starfield
272 starfield theme for GRUB.
273
274 %description theme-starfield -l pl.UTF-8
275 Motyw starfield dla GRUB-a.
276
277 %prep
278 %setup -q -n grub-%{version}~%{beta}
279 %patch1 -p1
280 %patch2 -p1
281 %patch3 -p1
282 %patch4 -p1
283 %patch5 -p1
284 %patch6 -p1
285 %patch7 -p1
286 %patch8 -p1
287 %patch9 -p1
288 %patch10 -p1
289 %patch11 -p1
290 %patch12 -p0
291 %patch13 -p1
292 %patch14 -p1
293 %patch15 -p1
294 %patch16 -p1
295 %patch17 -p1
296 %patch18 -p1
297
298 # we don't have C.utf-8 and need an UTF-8 locale for build
299 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
300
301 %build
302 # if gold is used then grub doesn't even boot
303 # https://savannah.gnu.org/bugs/?34539
304 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
305 install -d our-ld
306 ln -f -s /usr/bin/ld.bfd our-ld/ld
307 export PATH=$(pwd)/our-ld:$PATH
308
309 ## not only the typicall autotools stuff
310 #./autogen.sh
311
312 #{__gettextize}
313 %{__aclocal} -I m4
314 %{__autoconf}
315 %{__autoheader}
316 %{__automake}
317
318 for platform in %{platforms} ; do
319         install -d build-${platform}
320         cd build-${platform}
321
322         if [ "$platform" != "efi" ] ; then
323                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
324         else
325                 platform_opts=""
326         fi
327
328         ln -f -s ../configure .
329         # mawk stalls at ./genmoddep.awk, so force gawk
330         AWK=gawk \
331         %configure \
332                 --with-platform=${platform} \
333                 --disable-werror \
334         %if %{with grubemu}
335                 --enable-grub-emu-usb \
336                 --enable-grub-emu-sdl \
337                 --enable-grub-emu-pci \
338         %endif
339                 $platform_opts \
340                 TARGET_LDFLAGS=-static
341
342         %{__make} -j1 -C po update-gmo
343         %{__make}
344         cd ..
345 done
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349
350 for platform in %{platforms} ; do
351         cd build-${platform}
352         %{__make} install \
353                 pkgdatadir=%{_libexecdir} \
354                 pkglibdir=%{_libexecdir} \
355                 DESTDIR=$RPM_BUILD_ROOT
356         cd ..
357 done
358
359 # not in Th (?)
360 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
361 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
362
363 %find_lang grub
364
365 # this must be after 'make install'
366 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
367
368 install -d $RPM_BUILD_ROOT%{_grubdir}
369 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
370
371 # grub.d/41_custom
372 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
373 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
374
375 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
376 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
377
378 install -d $RPM_BUILD_ROOT/etc/sysconfig
379 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
380
381 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
382 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
383
384 # platform specific, unnecessarily always installed
385 %ifnarch %{ix86} %{x8664}
386 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
387 %endif
388 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
389
390 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
391 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
392 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
393
394 # needs to be exactly 1KiB
395 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
396 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
397
398 %clean
399 rm -rf $RPM_BUILD_ROOT
400
401 %post -p %{_sbindir}/postshell
402 -/usr/sbin/fix-info-dir -c %{_infodir}
403
404 %postun -p %{_sbindir}/postshell
405 -/usr/sbin/fix-info-dir -c %{_infodir}
406
407 %triggerpostun -- %{name} < 2.00-2
408 # Note this trigger on version upgrade needed only for upgrade from
409 # old grub2 packages which contained modules in /boot/grub
410 # or were built with optimizations enabled
411 # don't do anything on --downgrade
412 if [ $1 -le 1 ]; then
413         exit 0
414 fi
415 echo "Grub was upgraded, trying to setup it to boot sector"
416 /sbin/grub-install '(hd0)' || :
417
418 %triggerpostun -- %{name} < 1.99-7.3
419 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
420 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
421         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
422         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
423 fi
424
425 %files -f grub.lang
426 %defattr(644,root,root,755)
427 %doc AUTHORS ChangeLog NEWS README THANKS TODO
428 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
429 %attr(755,root,root) %{_sbindir}/grub-editenv
430 %attr(755,root,root) %{_sbindir}/grub-fstest
431 %attr(755,root,root) %{_sbindir}/grub-file
432 %attr(755,root,root) %{_sbindir}/grub-glue-efi
433 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
434 %attr(755,root,root) %{_sbindir}/grub-install
435 %attr(755,root,root) %{_sbindir}/grub-macbless
436 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
437 %attr(755,root,root) %{_sbindir}/grub-mkconfig
438 %attr(755,root,root) %{_sbindir}/grub-mklayout
439 %attr(755,root,root) %{_sbindir}/grub-mknetdir
440 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
441 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
442 %attr(755,root,root) %{_sbindir}/grub-mkrescue
443 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
444 %attr(755,root,root) %{_sbindir}/grub-mount
445 %attr(755,root,root) %{_sbindir}/grub-ofpathname
446 %attr(755,root,root) %{_sbindir}/grub-reboot
447 %attr(755,root,root) %{_sbindir}/grub-render-label
448 %attr(755,root,root) %{_sbindir}/grub-script-check
449 %attr(755,root,root) %{_sbindir}/grub-set-default
450 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
451 %attr(755,root,root) %{_sbindir}/update-grub
452 %ifarch %{ix86} %{x8664}
453 %attr(755,root,root) %{_sbindir}/grub-bios-setup
454 %{_mandir}/man8/grub-bios-setup.8*
455 %endif
456 %ifarch %{ix86} %{x8664}
457 %attr(755,root,root) %{_sbindir}/grub-mkimage
458 %{_mandir}/man1/grub-mkimage.1*
459 %else
460 %attr(755,root,root) %{_sbindir}/grub-probe
461 %{_mandir}/man8/grub-probe.8*
462 %endif
463 %{_mandir}/man1/grub-editenv.1*
464 %{_mandir}/man1/grub-file.1*
465 %{_mandir}/man1/grub-fstest.1*
466 %{_mandir}/man1/grub-glue-efi.1*
467 %{_mandir}/man1/grub-kbdcomp.1*
468 %{_mandir}/man1/grub-macbless.1*
469 %{_mandir}/man1/grub-menulst2cfg.1*
470 %{_mandir}/man1/grub-mklayout.1*
471 %{_mandir}/man1/grub-mknetdir.1*
472 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
473 %{_mandir}/man1/grub-mkrelpath.1*
474 %{_mandir}/man1/grub-mkrescue.1*
475 %{_mandir}/man1/grub-mkstandalone.1*
476 %{_mandir}/man1/grub-mount.1*
477 %{_mandir}/man1/grub-render-label.1*
478 %{_mandir}/man1/grub-script-check.1*
479 %{_mandir}/man1/grub-syslinux2cfg.1*
480 %{_mandir}/man8/grub-install.8*
481 %{_mandir}/man8/grub-mkconfig.8*
482 %{_mandir}/man8/grub-ofpathname.8*
483 %{_mandir}/man8/grub-reboot.8*
484 %{_mandir}/man8/grub-set-default.8*
485 %{_mandir}/man8/update-grub.8*
486 %if %{with grubemu}
487 %attr(755,root,root) %{_sbindir}/grub-emu
488 %{_mandir}/man8/grub-emu.8*
489 %endif
490 %{_libexecdir}/grub-mkconfig_lib
491
492 %dir %{_grubdir}
493 %dir %{_libexecdir}
494 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
495
496 %dir %{_libexecdir}/locale
497 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
498 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
499
500 # generated by grub at runtime
501 %ghost %{_grubdir}/device.map
502 %ghost %{_grubdir}/core.img
503 %ghost %{_grubdir}/grubenv
504
505 %dir /lib/grub.d
506 %doc /lib/grub.d/README
507 %attr(755,root,root) /lib/grub.d/00_header
508 %attr(755,root,root) /lib/grub.d/10_linux
509 %attr(755,root,root) /lib/grub.d/20_linux_xen
510 %attr(755,root,root) /lib/grub.d/30_os-prober
511 %attr(755,root,root) /lib/grub.d/41_custom
512
513 # these are now installed only on matching hosts
514 #%attr(755,root,root) /lib/grub.d/10_hurd
515 #%attr(755,root,root) /lib/grub.d/10_illumos
516 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
517 #%attr(755,root,root) /lib/grub.d/10_netbsd
518 #%attr(755,root,root) /lib/grub.d/10_xnu
519
520 %ifarch %{ix86} %{x8664}
521 %attr(755,root,root) %{_sbindir}/grub-probe
522 %{_mandir}/man8/grub-probe.8*
523 %endif
524
525 %{_infodir}/grub*.info*
526
527 %dir %{_datadir}/grub/themes
528
529 %if %{with pc}
530 %files platform-pc
531 %defattr(644,root,root,755)
532 %dir %{_libexecdir}/*-pc
533 %{_libexecdir}/*-pc/modinfo.sh
534 %{_libexecdir}/*-pc/*.exec
535 %{_libexecdir}/*-pc/*.image
536 %{_libexecdir}/*-pc/*.lst
537 %{_libexecdir}/*-pc/*.mod
538 %{_libexecdir}/*-pc/*.module
539 %{_libexecdir}/*-pc/lzma_decompress.img
540 %{_libexecdir}/*-pc/config.h
541 %{_libexecdir}/*-pc/gdb_grub
542 %{_libexecdir}/*-pc/gmodule.pl
543 %if %{with efiemu}
544 %{_libexecdir}/*-pc/efiemu*.o
545 %endif
546 %{_libexecdir}/*-pc/kernel.img
547 %ifarch %{ix86} %{x8664}
548 %{_libexecdir}/*-pc/boot.img
549 %{_libexecdir}/*-pc/boot_hybrid.img
550 %{_libexecdir}/*-pc/cdboot.img
551 %{_libexecdir}/*-pc/diskboot.img
552 %{_libexecdir}/*-pc/lnxboot.img
553 %{_libexecdir}/*-pc/pxeboot.img
554 %endif
555 %endif
556
557 %if %{with efi}
558 %files platform-efi
559 %defattr(644,root,root,755)
560 %dir %{_libexecdir}/*-efi
561 %{_libexecdir}/*-efi/modinfo.sh
562 %{_libexecdir}/*-efi/*.exec
563 %{_libexecdir}/*-efi/*.lst
564 %{_libexecdir}/*-efi/*.mod
565 %{_libexecdir}/*-efi/*.module
566 %{_libexecdir}/*-efi/config.h
567 %{_libexecdir}/*-efi/gdb_grub
568 %{_libexecdir}/*-efi/gmodule.pl
569 %{_libexecdir}/*-efi/kernel.img
570 %endif
571
572 %files mkfont
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_sbindir}/grub-mkfont
575 %{_mandir}/man1/grub-mkfont.1*
576
577 %files theme-starfield
578 %defattr(644,root,root,755)
579 %{_datadir}/grub/themes/starfield
580
581 %files -n bash-completion-%{name}
582 %defattr(644,root,root,755)
583 /etc/bash_completion.d/grub