]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- PLD merge - grub 2.02 beta 2, no changes
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 %define beta    beta2
48 Name:           grub2
49 Version:        2.02
50 Release:        0.%{beta}.2
51 License:        GPL v2
52 Group:          Base
53 # git://git.savannah.gnu.org/grub.git
54 # git checkout %{version}~%{beta} ; make dist
55 Source0:        grub-%{version}~%{beta}.tar.gz
56 # Source0-md5:  ca6c18f6c5f1ed05b7444017a40573d9
57 Source1:        update-grub
58 Source2:        update-grub.8
59 Source3:        grub.sysconfig
60 Source4:        grub-custom.cfg
61 # ./linguas.sh
62 # TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
63 Source5:        grub-po-%{version}.git20140104.tar.bz2
64 # Source5-md5:  aeef3e636178093cf9d780d92da7afdb
65 Patch1:         pld-sysconfdir.patch
66 Patch2:         grub-garbage.patch
67 Patch3:         grub-lvmdevice.patch
68 Patch4:         pld-mkconfigdir.patch
69 Patch5:         grub-mkconfig-diagnostics.patch
70 Patch6:         posix.patch
71 Patch7:         %{name}-fonts_path.patch
72 Patch8:         add-vlan-tag-support.patch
73 Patch9:         just-say-linux.patch
74 Patch10:        ignore-kernel-symlinks.patch
75 Patch11:        choose-preferred-initrd.patch
76 Patch12:        %{name}-cfg.patch
77 URL:            http://www.gnu.org/software/grub/
78 BuildRequires:  autoconf >= 2.53
79 BuildRequires:  automake >= 1:1.11.1-1
80 BuildRequires:  bison
81 BuildRequires:  device-mapper-devel
82 BuildRequires:  flex >= 2.5.35
83 BuildRequires:  fonts-TTF-DejaVu
84 BuildRequires:  freetype-devel >= 2
85 BuildRequires:  gawk
86 BuildRequires:  gettext-devel
87 BuildRequires:  glibc-localedb-all
88 BuildRequires:  glibc-static
89 BuildRequires:  help2man
90 BuildRequires:  libfuse-devel
91 BuildRequires:  libtool
92 BuildRequires:  ncurses-devel
93 BuildRequires:  python
94 BuildRequires:  python-modules
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.213
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  tar >= 1:1.22
99 BuildRequires:  texinfo
100 BuildRequires:  xz
101 BuildRequires:  xz-devel
102 %ifarch %{x8664}
103 BuildRequires:  /usr/lib/libc.so
104 %if "%{pld_release}" == "ac"
105 BuildRequires:  libgcc32
106 %else
107 BuildRequires:  gcc-multilib
108 %endif
109 %endif
110 Requires:       %{name}-platform = %{version}-%{release}
111 Requires:       pld-release
112 Requires:       which
113 %ifarch %{ix86} %{x8664}
114 Suggests:       %{name}-platform-pc
115 %endif
116 Suggests:       cdrkit-mkisofs
117 Suggests:       os-prober
118 Provides:       bootloader
119 Conflicts:      grub
120 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _sbindir        /sbin
124 %define         _bindir         %{_sbindir}
125 %define         _libdir         /lib
126 %define         _datadir        %{_libdir}
127 %define         _libexecdir     %{_libdir}/grub
128 %define         _grubdir        /boot/grub
129 %define         _localedir      /usr/share/locale
130
131 # part of grub code is not relocable (these are not Linux libs)
132 # stack protector also breaks non-Linux binaries
133 # any kind of forced optimizations makes grub2 unreliable (random
134 # reboots and hangs on boot menu screen)
135 %define         filterout_c     -fPIC -O.
136 %undefine       _ssp_cflags
137 %undefine       _fortify_cflags
138
139 %description
140 GRUB is a GPLed bootloader intended to unify bootloading across x86
141 operating systems. In addition to loading the Linux and *BSD kernels,
142 it implements the Multiboot standard, which allows for flexible
143 loading of multiple boot images (needed for modular kernels such as
144 the GNU Hurd).
145
146 GRUB 2 is derived from PUPA which was a research project to
147 investigate the next generation of GRUB. GRUB 2 has been rewritten
148 from scratch to clean up everything for modularity and portability.
149
150 GRUB 2 targets at the following goals:
151 - Scripting support, such as conditionals, loops, variables and
152   functions.
153 - Graphical interface.
154 - Dynamic loading of modules in order to extend itself at the run time
155   rather than at the build time.
156 - Portability for various architectures.
157 - Internationalization. This includes support for non-ASCII character
158   code, message catalogs like gettext, fonts, graphics console, and so
159   on.
160 - Real memory management, to make GNU GRUB more extensible.
161 - Modular, hierarchical, object-oriented framework for file systems,
162   files, devices, drives, terminals, commands, partition tables and OS
163   loaders.
164 - Cross-platform installation which allows for installing GRUB from a
165   different architecture.
166 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167 - Fix design mistakes in GRUB Legacy, which could not be solved for
168   backward-compatibility, such as the way of numbering partitions.
169
170 %description -l de.UTF-8
171 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
173 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
174
175 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
176 und wird unter der GPL vertrieben. Aufgrund seiner höheren
177 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
178 traditionellen Boot-Loader LILO.
179
180 %description -l hu.UTF-8
181 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184 GNU Hurd).
185
186 GRUB2 céljai a következők:
187 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188   függvények.
189 - grafikus felület
190 - modulok dinamikus betöltése futási időben
191 - hordozhatóság több architektúrára
192 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193   mint gettext, betűtípusok, grafikus konzolon, és így tovább
194 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195 - moduláris, hierarchikus, objektum-orientált keretrendszer
196   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
199 %description -l es.UTF-8
200 Éste es GRUB - Grand Unified Boot Loader - un administrador de
201 inicialización capaz de entrar en la mayoría de los sistemas
202 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
203 también en la mayoría de los sistemas operacionales comerciales para
204 PC.
205
206 El administrador GRUB puede ser una buena alternativa a LILO, para
207 usuarios conmás experiencia y que deseen obtener más recursos de su
208 cargador de inicialización (boot loader).
209
210 %description -l pl.UTF-8
211 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
212 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
213 Linuksa i *BSD: posiada również implementację standardu Multiboot,
214 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215 (czego wymagają modułowe jądra, takie jak GNU Hurd).
216
217 %description -l pt_BR.UTF-8
218 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
219 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221 operacionais comerciais para PC.
222
223 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224 avançados e que querem mais recursos de seu boot loader.
225
226 %package -n bash-completion-%{name}
227 Summary:        bash-completion for GRUB
228 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
229 Group:          Applications/Shells
230 Requires:       bash-completion
231
232 %description -n bash-completion-%{name}
233 This package provides bash-completion for GRUB.
234
235 %description -n bash-completion-%{name} -l pl.UTF-8
236 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
237
238 %package platform-pc
239 Summary:        PC BIOS platform support for GRUB
240 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
241 Group:          Base
242 Provides:       %{name}-platform = %{version}-%{release}
243
244 %description platform-pc
245 PC BIOS platform support for GRUB.
246
247 %description platform-pc -l pl.UTF-8
248 Obsługa platformy PC BIOS dla GRUB-a.
249
250 %package platform-efi
251 Summary:        (U)EFI platform support for GRUB
252 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
253 Group:          Base
254 Suggests:       efibootmgr
255 Provides:       %{name}-platform = %{version}-%{release}
256
257 %description platform-efi
258 (U)EFI platform support for GRUB.
259
260 %description platform-efi -l pl.UTF-8
261 Obsługa platformy (U)EFI dla GRUB-a.
262
263 %package mkfont
264 Summary:        GRUB font files converter
265 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
266 Group:          Base
267
268 %description mkfont
269 Converts common font file formats into PF2.
270
271 %description mkfont -l pl.UTF-8
272 Program do konwersji popularnych formatów plików fontów do PF2.
273
274 %package theme-starfield
275 Summary:        starfield theme for GRUB
276 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
277 Group:          Base
278
279 %description theme-starfield
280 starfield theme for GRUB.
281
282 %description theme-starfield -l pl.UTF-8
283 Motyw starfield dla GRUB-a.
284
285 %prep
286 %setup -q -n grub-%{version}~%{beta} -a5
287 %patch1 -p1
288 %patch2 -p1
289 %patch3 -p1
290 %patch4 -p1
291 %patch5 -p1
292 %patch6 -p1
293 %patch7 -p1
294 %patch8 -p1
295 %patch9 -p1
296 %patch10 -p1
297 %patch11 -p1
298 %patch12 -p0
299
300 # we don't have C.utf-8 and need an UTF-8 locale for build
301 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
302
303 %build
304 # if gold is used then grub doesn't even boot
305 # https://savannah.gnu.org/bugs/?34539
306 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
307 install -d our-ld
308 ln -s /usr/bin/ld.bfd our-ld/ld
309 export PATH=$(pwd)/our-ld:$PATH
310
311 ## not only the typicall autotools stuff
312 #./autogen.sh
313
314 %{__gettextize}
315 %{__aclocal} -I m4
316 %{__autoconf}
317 %{__autoheader}
318 %{__automake}
319
320 for platform in %{platforms} ; do
321         install -d build-${platform}
322         cd build-${platform}
323
324         if [ "$platform" != "efi" ] ; then
325                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
326         else
327                 platform_opts=""
328         fi
329
330         ln -s ../configure .
331         # mawk stalls at ./genmoddep.awk, so force gawk
332         AWK=gawk \
333         %configure \
334                 --with-platform=${platform} \
335                 --disable-werror \
336         %if %{with grubemu}
337                 --enable-grub-emu-usb \
338                 --enable-grub-emu-sdl \
339                 --enable-grub-emu-pci \
340         %endif
341                 $platform_opts \
342                 TARGET_LDFLAGS=-static
343
344         %{__make} -j1 -C po update-gmo
345         %{__make}
346         cd ..
347 done
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351
352 for platform in %{platforms} ; do
353         cd build-${platform}
354         %{__make} install \
355                 pkgdatadir=%{_libexecdir} \
356                 pkglibdir=%{_libexecdir} \
357                 DESTDIR=$RPM_BUILD_ROOT
358         cd ..
359 done
360
361 # not in Th (?)
362 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
363 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
364
365 %find_lang grub
366
367 # this must be after 'make install'
368 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
369
370 install -d $RPM_BUILD_ROOT%{_grubdir}
371 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
372
373 # grub.d/41_custom
374 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
375 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
376
377 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
378 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
379
380 install -d $RPM_BUILD_ROOT/etc/sysconfig
381 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
382
383 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
384 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
385
386 # platform specific, unnecessarily always installed
387 %ifnarch %{ix86} %{x8664}
388 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
389 %endif
390 %ifnarch sparc64
391 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
392 %endif
393
394 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
395 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
396 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
397
398 # needs to be exactly 1KiB
399 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
400 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %post -p %{_sbindir}/postshell
406 -/usr/sbin/fix-info-dir -c %{_infodir}
407
408 %postun -p %{_sbindir}/postshell
409 -/usr/sbin/fix-info-dir -c %{_infodir}
410
411 %triggerpostun -- %{name} < 2.00-2
412 # Note this trigger on version upgrade needed only for upgrade from
413 # old grub2 packages which contained modules in /boot/grub
414 # or were built with optimizations enabled
415 # don't do anything on --downgrade
416 if [ $1 -le 1 ]; then
417         exit 0
418 fi
419 echo "Grub was upgraded, trying to setup it to boot sector"
420 /sbin/grub-install '(hd0)' || :
421
422 %triggerpostun -- %{name} < 1.99-7.3
423 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
424 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
425         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
426         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
427 fi
428
429 %files -f grub.lang
430 %defattr(644,root,root,755)
431 %doc AUTHORS ChangeLog NEWS README THANKS TODO
432 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
433 %attr(755,root,root) %{_sbindir}/grub-editenv
434 %attr(755,root,root) %{_sbindir}/grub-fstest
435 %attr(755,root,root) %{_sbindir}/grub-file
436 %attr(755,root,root) %{_sbindir}/grub-glue-efi
437 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
438 %attr(755,root,root) %{_sbindir}/grub-install
439 %attr(755,root,root) %{_sbindir}/grub-macbless
440 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
441 %attr(755,root,root) %{_sbindir}/grub-mkconfig
442 %attr(755,root,root) %{_sbindir}/grub-mklayout
443 %attr(755,root,root) %{_sbindir}/grub-mknetdir
444 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
445 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
446 %attr(755,root,root) %{_sbindir}/grub-mkrescue
447 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
448 %attr(755,root,root) %{_sbindir}/grub-mount
449 %attr(755,root,root) %{_sbindir}/grub-ofpathname
450 %attr(755,root,root) %{_sbindir}/grub-reboot
451 %attr(755,root,root) %{_sbindir}/grub-render-label
452 %attr(755,root,root) %{_sbindir}/grub-script-check
453 %attr(755,root,root) %{_sbindir}/grub-set-default
454 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
455 %attr(755,root,root) %{_sbindir}/update-grub
456 %ifarch %{ix86} %{x8664}
457 %attr(755,root,root) %{_sbindir}/grub-bios-setup
458 %{_mandir}/man8/grub-bios-setup.8*
459 %endif
460 %ifarch %{ix86} %{x8664}
461 %attr(755,root,root) %{_sbindir}/grub-mkimage
462 %{_mandir}/man1/grub-mkimage.1*
463 %else
464 %attr(755,root,root) %{_sbindir}/grub-probe
465 %{_mandir}/man8/grub-probe.8*
466 %endif
467 %ifarch sparc64
468 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
469 %{_mandir}/man8/grub-sparc64-setup.8*
470 %endif
471 %{_mandir}/man1/grub-editenv.1*
472 %{_mandir}/man1/grub-file.1*
473 %{_mandir}/man1/grub-fstest.1*
474 %{_mandir}/man1/grub-glue-efi.1*
475 %{_mandir}/man1/grub-kbdcomp.1*
476 %{_mandir}/man1/grub-macbless.1*
477 %{_mandir}/man1/grub-menulst2cfg.1*
478 %{_mandir}/man1/grub-mklayout.1*
479 %{_mandir}/man1/grub-mknetdir.1*
480 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
481 %{_mandir}/man1/grub-mkrelpath.1*
482 %{_mandir}/man1/grub-mkrescue.1*
483 %{_mandir}/man1/grub-mkstandalone.1*
484 %{_mandir}/man1/grub-mount.1*
485 %{_mandir}/man1/grub-render-label.1*
486 %{_mandir}/man1/grub-script-check.1*
487 %{_mandir}/man1/grub-syslinux2cfg.1*
488 %{_mandir}/man8/grub-install.8*
489 %{_mandir}/man8/grub-mkconfig.8*
490 %{_mandir}/man8/grub-ofpathname.8*
491 %{_mandir}/man8/grub-reboot.8*
492 %{_mandir}/man8/grub-set-default.8*
493 %{_mandir}/man8/update-grub.8*
494 %if %{with grubemu}
495 %attr(755,root,root) %{_sbindir}/grub-emu
496 %{_mandir}/man8/grub-emu.8*
497 %endif
498 %{_libexecdir}/grub-mkconfig_lib
499
500 %dir %{_grubdir}
501 %dir %{_libexecdir}
502 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
503
504 %dir %{_libexecdir}/locale
505 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
506 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
507
508 # generated by grub at runtime
509 %ghost %{_grubdir}/device.map
510 %ghost %{_grubdir}/core.img
511 %ghost %{_grubdir}/grubenv
512
513 %dir /lib/grub.d
514 %doc /lib/grub.d/README
515 %attr(755,root,root) /lib/grub.d/00_header
516 %attr(755,root,root) /lib/grub.d/10_linux
517 %attr(755,root,root) /lib/grub.d/20_linux_xen
518 %attr(755,root,root) /lib/grub.d/30_os-prober
519 %attr(755,root,root) /lib/grub.d/41_custom
520
521 # these are now installed only on matching hosts
522 #%attr(755,root,root) /lib/grub.d/10_hurd
523 #%attr(755,root,root) /lib/grub.d/10_illumos
524 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
525 #%attr(755,root,root) /lib/grub.d/10_netbsd
526 #%attr(755,root,root) /lib/grub.d/10_xnu
527
528 %ifarch %{ix86} %{x8664}
529 %attr(755,root,root) %{_sbindir}/grub-probe
530 %{_mandir}/man8/grub-probe.8*
531 %endif
532
533 %{_infodir}/grub*.info*
534
535 %dir %{_datadir}/grub/themes
536
537 %if %{with pc}
538 %files platform-pc
539 %defattr(644,root,root,755)
540 %dir %{_libexecdir}/*-pc
541 %{_libexecdir}/*-pc/modinfo.sh
542 %{_libexecdir}/*-pc/*.exec
543 %{_libexecdir}/*-pc/*.image
544 %{_libexecdir}/*-pc/*.lst
545 %{_libexecdir}/*-pc/*.mod
546 %{_libexecdir}/*-pc/*.module
547 %{_libexecdir}/*-pc/lzma_decompress.img
548 %{_libexecdir}/*-pc/config.h
549 %{_libexecdir}/*-pc/gdb_grub
550 %{_libexecdir}/*-pc/gmodule.pl
551 %if %{with efiemu}
552 %{_libexecdir}/*-pc/efiemu*.o
553 %endif
554 %{_libexecdir}/*-pc/kernel.img
555 %ifarch %{ix86} %{x8664} sparc sparc64
556 %{_libexecdir}/*-pc/boot.img
557 %{_libexecdir}/*-pc/boot_hybrid.img
558 %{_libexecdir}/*-pc/cdboot.img
559 %{_libexecdir}/*-pc/diskboot.img
560 %{_libexecdir}/*-pc/lnxboot.img
561 %{_libexecdir}/*-pc/pxeboot.img
562 %endif
563 %endif
564
565 %if %{with efi}
566 %files platform-efi
567 %defattr(644,root,root,755)
568 %dir %{_libexecdir}/*-efi
569 %{_libexecdir}/*-efi/modinfo.sh
570 %{_libexecdir}/*-efi/*.exec
571 %{_libexecdir}/*-efi/*.lst
572 %{_libexecdir}/*-efi/*.mod
573 %{_libexecdir}/*-efi/*.module
574 %{_libexecdir}/*-efi/config.h
575 %{_libexecdir}/*-efi/gdb_grub
576 %{_libexecdir}/*-efi/gmodule.pl
577 %{_libexecdir}/*-efi/kernel.img
578 %endif
579
580 %files mkfont
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_sbindir}/grub-mkfont
583 %{_mandir}/man1/grub-mkfont.1*
584
585 %files theme-starfield
586 %defattr(644,root,root,755)
587 %{_datadir}/grub/themes/starfield
588
589 %files -n bash-completion-%{name}
590 %defattr(644,root,root,755)
591 /etc/bash_completion.d/grub