]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- R: issue for /etc/os-release
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 Name:           grub2
48 Version:        2.00
49 Release:        5
50 License:        GPL v2
51 Group:          Base
52 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
53 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
54 Source1:        update-grub
55 Source2:        update-grub.8
56 Source3:        grub.sysconfig
57 Source4:        grub-custom.cfg
58 Patch1:         pld-sysconfdir.patch
59 Patch2:         grub-garbage.patch
60 Patch3:         grub-lvmdevice.patch
61 Patch4:         pld-mkconfigdir.patch
62 Patch5:         grub-mkconfig-diagnostics.patch
63 Patch6:         ppc.patch
64 Patch7:         %{name}-awk.patch
65 Patch8:         posix.patch
66 Patch9:         %{name}-gets.patch
67 Patch10:        %{name}-fonts_path.patch
68 Patch11:        %{name}-tftp_fix.patch
69 Patch12:        add-vlan-tag-support.patch
70 Patch13:        just-say-linux.patch
71 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
72 Patch15:        add-X-option-to-printf-functions.patch
73 Patch16:        dhcp-client-id-and-uuid-options-added.patch
74 Patch17:        fix-http-crash.patch
75 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
76 Patch19:        search-for-specific-config-file-for-netboot.patch
77 Patch20:        ignore-kernel-symlinks.patch
78 Patch21:        choose-preferred-initrd.patch
79 URL:            http://www.gnu.org/software/grub/
80 BuildRequires:  autoconf >= 2.53
81 BuildRequires:  automake >= 1:1.11.1-1
82 BuildRequires:  bison
83 BuildRequires:  device-mapper-devel
84 BuildRequires:  flex >= 2.5.35
85 BuildRequires:  fonts-TTF-DejaVu
86 BuildRequires:  freetype-devel >= 2
87 BuildRequires:  gawk
88 BuildRequires:  gettext-devel
89 BuildRequires:  glibc-static
90 BuildRequires:  help2man
91 BuildRequires:  libfuse-devel
92 BuildRequires:  libtool
93 BuildRequires:  ncurses-devel
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.213
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  tar >= 1:1.22
98 BuildRequires:  texinfo
99 BuildRequires:  xz
100 BuildRequires:  xz-devel
101 %ifarch %{x8664}
102 BuildRequires:  /usr/lib/libc.so
103 %if "%{pld_release}" == "ac"
104 BuildRequires:  libgcc32
105 %else
106 BuildRequires:  gcc-multilib
107 %endif
108 %endif
109 Requires:       %{name}-platform = %{version}-%{release}
110 Requires:       issue
111 Requires:       which
112 %ifarch %{ix86} %{x8664}
113 Suggests:       %{name}-platform-pc
114 %endif
115 Suggests:       cdrkit-mkisofs
116 Suggests:       os-prober
117 Provides:       bootloader
118 Conflicts:      grub
119 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sbindir        /sbin
123 %define         _bindir         %{_sbindir}
124 %define         _libdir         /lib
125 %define         _datadir        %{_libdir}
126 %define         _libexecdir     %{_libdir}/grub
127 %define         _grubdir        /boot/grub
128 %define         _localedir      /usr/share/locale
129
130 # part of grub code is not relocable (these are not Linux libs)
131 # stack protector also breaks non-Linux binaries
132 # any kind of forced optimizations makes grub2 unreliable (random
133 # reboots and hangs on boot menu screen)
134 %define         filterout_c     -fPIC -O.
135 %undefine       _ssp_cflags
136 %undefine       _fortify_cflags
137
138 %description
139 GRUB is a GPLed bootloader intended to unify bootloading across x86
140 operating systems. In addition to loading the Linux and *BSD kernels,
141 it implements the Multiboot standard, which allows for flexible
142 loading of multiple boot images (needed for modular kernels such as
143 the GNU Hurd).
144
145 GRUB 2 is derived from PUPA which was a research project to
146 investigate the next generation of GRUB. GRUB 2 has been rewritten
147 from scratch to clean up everything for modularity and portability.
148
149 GRUB 2 targets at the following goals:
150 - Scripting support, such as conditionals, loops, variables and
151   functions.
152 - Graphical interface.
153 - Dynamic loading of modules in order to extend itself at the run time
154   rather than at the build time.
155 - Portability for various architectures.
156 - Internationalization. This includes support for non-ASCII character
157   code, message catalogs like gettext, fonts, graphics console, and so
158   on.
159 - Real memory management, to make GNU GRUB more extensible.
160 - Modular, hierarchical, object-oriented framework for file systems,
161   files, devices, drives, terminals, commands, partition tables and OS
162   loaders.
163 - Cross-platform installation which allows for installing GRUB from a
164   different architecture.
165 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
166 - Fix design mistakes in GRUB Legacy, which could not be solved for
167   backward-compatibility, such as the way of numbering partitions.
168
169 %description -l de.UTF-8
170 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
171 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
172 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
173
174 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
175 und wird unter der GPL vertrieben. Aufgrund seiner höheren
176 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
177 traditionellen Boot-Loader LILO.
178
179 %description -l hu.UTF-8
180 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
181 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
182 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
183 GNU Hurd).
184
185 GRUB2 céljai a következők:
186 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
187   függvények.
188 - grafikus felület
189 - modulok dinamikus betöltése futási időben
190 - hordozhatóság több architektúrára
191 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
192   mint gettext, betűtípusok, grafikus konzolon, és így tovább
193 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
194 - moduláris, hierarchikus, objektum-orientált keretrendszer
195   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
196   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
197
198 %description -l es.UTF-8
199 Éste es GRUB - Grand Unified Boot Loader - un administrador de
200 inicialización capaz de entrar en la mayoría de los sistemas
201 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
202 también en la mayoría de los sistemas operacionales comerciales para
203 PC.
204
205 El administrador GRUB puede ser una buena alternativa a LILO, para
206 usuarios conmás experiencia y que deseen obtener más recursos de su
207 cargador de inicialización (boot loader).
208
209 %description -l pl.UTF-8
210 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
211 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
212 Linuksa i *BSD: posiada również implementację standardu Multiboot,
213 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
214 (czego wymagają modułowe jądra, takie jak GNU Hurd).
215
216 %description -l pt_BR.UTF-8
217 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
218 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
219 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
220 operacionais comerciais para PC.
221
222 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
223 avançados e que querem mais recursos de seu boot loader.
224
225 %package -n bash-completion-%{name}
226 Summary:        bash-completion for GRUB
227 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
228 Group:          Applications/Shells
229 Requires:       bash-completion
230
231 %description -n bash-completion-%{name}
232 This package provides bash-completion for GRUB.
233
234 %description -n bash-completion-%{name} -l pl.UTF-8
235 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
236
237 %package platform-pc
238 Summary:        PC BIOS platform support for GRUB
239 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
240 Group:          Base
241 Provides:       %{name}-platform = %{version}-%{release}
242
243 %description platform-pc
244 PC BIOS platform support for GRUB.
245
246 %description platform-pc -l pl.UTF-8
247 Obsługa platformy PC BIOS dla GRUB-a.
248
249 %package platform-efi
250 Summary:        (U)EFI platform support for GRUB
251 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
252 Group:          Base
253 Suggests:       efibootmgr
254 Provides:       %{name}-platform = %{version}-%{release}
255
256 %description platform-efi
257 (U)EFI platform support for GRUB.
258
259 %description platform-efi -l pl.UTF-8
260 Obsługa platformy (U)EFI dla GRUB-a.
261
262 %package mkfont
263 Summary:        GRUB font files converter
264 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
265 Group:          Base
266
267 %description mkfont
268 Converts common font file formats into PF2.
269
270 %description mkfont -l pl.UTF-8
271 Program do konwersji popularnych formatów plików fontów do PF2.
272
273 %package theme-starfield
274 Summary:        starfield theme for GRUB
275 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
276 Group:          Base
277
278 %description theme-starfield
279 starfield theme for GRUB.
280
281 %description theme-starfield -l pl.UTF-8
282 Motyw starfield dla GRUB-a.
283
284 %prep
285 %setup -q -n grub-%{version}
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289 %patch4 -p1
290 %patch5 -p1
291 %patch6 -p1
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch10 -p1
296 %patch11 -p1
297 %patch12 -p1
298 %patch13 -p1
299 %patch14 -p1
300 %patch15 -p1
301 %patch16 -p1
302 %patch17 -p1
303 %patch18 -p1
304 %patch19 -p1
305 %patch20 -p1
306 %patch21 -p1
307
308 %build
309 # if gold is used then grub doesn't even boot
310 # https://savannah.gnu.org/bugs/?34539
311 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
312 install -d our-ld
313 ln -s /usr/bin/ld.bfd our-ld/ld
314 export PATH=$(pwd)/our-ld:$PATH
315
316 cp -f /usr/share/automake/config.sub .
317 %{__libtoolize}
318 %{__aclocal} -I m4
319 %{__autoheader}
320 echo timestamp > stamp-h.in
321 %{__autoconf}
322 %{__automake}
323
324 for platform in %{platforms} ; do
325         install -d build-${platform}
326         cd build-${platform}
327
328         if [ "$platform" != "efi" ] ; then
329                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
330         else
331                 platform_opts=""
332         fi
333
334         ln -s ../configure .
335         # mawk stalls at ./genmoddep.awk, so force gawk
336         AWK=gawk \
337         %configure \
338                 --with-platform=${platform} \
339                 --disable-werror \
340         %if %{with grubemu}
341                 --enable-grub-emu-usb \
342                 --enable-grub-emu-sdl \
343                 --enable-grub-emu-pci \
344         %endif
345                 $platform_opts \
346                 TARGET_LDFLAGS=-static
347
348         %{__make}
349         cd ..
350 done
351
352 %install
353 rm -rf $RPM_BUILD_ROOT
354
355 for platform in %{platforms} ; do
356         cd build-${platform}
357         %{__make} install \
358                 pkgdatadir=%{_libexecdir} \
359                 pkglibdir=%{_libexecdir} \
360                 DESTDIR=$RPM_BUILD_ROOT
361         cd ..
362 done
363
364 # not in Th (?)
365 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
366 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
367
368 %find_lang grub
369
370 # this must be after 'make install'
371 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
372
373 install -d $RPM_BUILD_ROOT%{_grubdir}
374 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
375
376 # grub.d/41_custom
377 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
378 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
379
380 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
381 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
382
383 install -d $RPM_BUILD_ROOT/etc/sysconfig
384 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
385
386 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
387 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
388
389 # platform specific, unnecessarily always installed
390 %ifnarch %{ix86} %{x8664}
391 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
392 %endif
393 %ifnarch sparc64
394 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
395 %endif
396
397 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
398 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
399 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
400
401 # needs to be exactly 1KiB
402 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
403 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
404
405 %clean
406 rm -rf $RPM_BUILD_ROOT
407
408 %post -p %{_sbindir}/postshell
409 -/usr/sbin/fix-info-dir -c %{_infodir}
410
411 %postun -p %{_sbindir}/postshell
412 -/usr/sbin/fix-info-dir -c %{_infodir}
413
414 %triggerpostun -- %{name} < 2.00-2
415 # Note this trigger on version upgrade needed only for upgrade from
416 # old grub2 packages which contained modules in /boot/grub
417 # or were built with optimizations enabled
418 # don't do anything on --downgrade
419 if [ $1 -le 1 ]; then
420         exit 0
421 fi
422 echo "Grub was upgraded, trying to setup it to boot sector"
423 /sbin/grub-install '(hd0)' || :
424
425 %triggerpostun -- %{name} < 1.99-7.3
426 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
427 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
428         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
429         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
430 fi
431
432 %files -f grub.lang
433 %defattr(644,root,root,755)
434 %doc AUTHORS ChangeLog NEWS README THANKS TODO
435 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
436 %attr(755,root,root) %{_sbindir}/grub-editenv
437 %attr(755,root,root) %{_sbindir}/grub-fstest
438 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
439 %attr(755,root,root) %{_sbindir}/grub-install
440 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
441 %attr(755,root,root) %{_sbindir}/grub-mkconfig
442 %attr(755,root,root) %{_sbindir}/grub-mklayout
443 %attr(755,root,root) %{_sbindir}/grub-mknetdir
444 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
445 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
446 %attr(755,root,root) %{_sbindir}/grub-mkrescue
447 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
448 %attr(755,root,root) %{_sbindir}/grub-mount
449 %attr(755,root,root) %{_sbindir}/grub-ofpathname
450 %attr(755,root,root) %{_sbindir}/grub-reboot
451 %attr(755,root,root) %{_sbindir}/grub-script-check
452 %attr(755,root,root) %{_sbindir}/grub-set-default
453 %attr(755,root,root) %{_sbindir}/update-grub
454 %ifarch %{ix86} %{x8664}
455 %attr(755,root,root) %{_sbindir}/grub-bios-setup
456 %{_mandir}/man8/grub-bios-setup.8*
457 %endif
458 %ifarch %{ix86} %{x8664}
459 %attr(755,root,root) %{_sbindir}/grub-mkimage
460 %{_mandir}/man1/grub-mkimage.1*
461 %else
462 %attr(755,root,root) %{_sbindir}/grub-probe
463 %{_mandir}/man8/grub-probe.8*
464 %endif
465 %ifarch sparc64
466 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
467 %{_mandir}/man8/grub-sparc64-setup.8*
468 %endif
469 %{_mandir}/man1/grub-editenv.1*
470 %{_mandir}/man1/grub-fstest.1*
471 %{_mandir}/man1/grub-kbdcomp.1*
472 %{_mandir}/man1/grub-menulst2cfg.1*
473 %{_mandir}/man1/grub-mklayout.1*
474 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
475 %{_mandir}/man1/grub-mkrelpath.1*
476 %{_mandir}/man1/grub-mkrescue.1*
477 %{_mandir}/man1/grub-mkstandalone.1*
478 %{_mandir}/man1/grub-mount.1*
479 %{_mandir}/man1/grub-script-check.1*
480 %{_mandir}/man8/grub-install.8*
481 %{_mandir}/man8/grub-mkconfig.8*
482 %{_mandir}/man8/grub-mknetdir.8*
483 %{_mandir}/man8/grub-ofpathname.8*
484 %{_mandir}/man8/grub-reboot.8*
485 %{_mandir}/man8/grub-set-default.8*
486 %{_mandir}/man8/update-grub.8*
487 %if %{with grubemu}
488 %attr(755,root,root) %{_sbindir}/grub-emu
489 %{_mandir}/man8/grub-emu.8*
490 %endif
491 %{_libexecdir}/grub-mkconfig_lib
492
493 %dir %{_grubdir}
494 %dir %{_libexecdir}
495 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
496
497 %dir %{_libexecdir}/locale
498 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
499 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
500
501 # generated by grub at runtime
502 %ghost %{_grubdir}/device.map
503 %ghost %{_grubdir}/core.img
504 %ghost %{_grubdir}/grubenv
505
506 %dir /lib/grub.d
507 %doc /lib/grub.d/README
508 %attr(755,root,root) /lib/grub.d/00_header
509 %attr(755,root,root) /lib/grub.d/10_linux
510 %attr(755,root,root) /lib/grub.d/20_linux_xen
511 %attr(755,root,root) /lib/grub.d/30_os-prober
512 %attr(755,root,root) /lib/grub.d/41_custom
513
514 %ifarch %{ix86} %{x8664}
515 %attr(755,root,root) %{_sbindir}/grub-probe
516 %{_mandir}/man8/grub-probe.8*
517 %endif
518
519 %{_infodir}/grub*.info*
520
521 %dir %{_datadir}/grub/themes
522
523 %if %{with pc}
524 %files platform-pc
525 %defattr(644,root,root,755)
526 %dir %{_libexecdir}/*-pc
527 %{_libexecdir}/*-pc/modinfo.sh
528 %{_libexecdir}/*-pc/*.exec
529 %{_libexecdir}/*-pc/*.image
530 %{_libexecdir}/*-pc/*.lst
531 %{_libexecdir}/*-pc/*.mod
532 %{_libexecdir}/*-pc/*.module
533 %{_libexecdir}/*-pc/lzma_decompress.img
534 %{_libexecdir}/*-pc/config.h
535 %{_libexecdir}/*-pc/gdb_grub
536 %{_libexecdir}/*-pc/gmodule.pl
537 %if %{with efiemu}
538 %{_libexecdir}/*-pc/efiemu*.o
539 %endif
540 %{_libexecdir}/*-pc/kernel.img
541 %ifarch %{ix86} %{x8664} sparc sparc64
542 %{_libexecdir}/*-pc/boot.img
543 %{_libexecdir}/*-pc/cdboot.img
544 %{_libexecdir}/*-pc/diskboot.img
545 %{_libexecdir}/*-pc/lnxboot.img
546 %{_libexecdir}/*-pc/pxeboot.img
547 %endif
548 %endif
549
550 %if %{with efi}
551 %files platform-efi
552 %defattr(644,root,root,755)
553 %dir %{_libexecdir}/*-efi
554 %{_libexecdir}/*-efi/modinfo.sh
555 %{_libexecdir}/*-efi/*.exec
556 %{_libexecdir}/*-efi/*.lst
557 %{_libexecdir}/*-efi/*.mod
558 %{_libexecdir}/*-efi/*.module
559 %{_libexecdir}/*-efi/config.h
560 %{_libexecdir}/*-efi/gdb_grub
561 %{_libexecdir}/*-efi/gmodule.pl
562 %{_libexecdir}/*-efi/kernel.img
563 %endif
564
565 %files mkfont
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_sbindir}/grub-mkfont
568 %{_mandir}/man1/grub-mkfont.1*
569
570 %files theme-starfield
571 %defattr(644,root,root,755)
572 %{_datadir}/grub/themes/starfield
573
574 %files -n bash-completion-%{name}
575 %defattr(644,root,root,755)
576 /etc/bash_completion.d/grub