]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- info how to generate new tarball
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 %define beta    beta2
48 Name:           grub2
49 Version:        2.02
50 Release:        0.%{beta}.2
51 License:        GPL v2
52 Group:          Base
53 # 1. Download and unpack latest official beta snapshot from http://git.savannah.gnu.org/cgit/grub.git
54 # 2. Run ./autogen.sh and ./linguas.sh
55 # 3. Recompress and upload to DF
56 Source0:        grub-%{version}-%{beta}.tar.xz
57 # Source0-md5:  f262e61eba2e76a6f60b39a810814284
58 Source1:        update-grub
59 Source2:        update-grub.8
60 Source3:        grub.sysconfig
61 Source4:        grub-custom.cfg
62 Patch1:         pld-sysconfdir.patch
63 Patch2:         grub-garbage.patch
64 Patch3:         grub-lvmdevice.patch
65 Patch4:         pld-mkconfigdir.patch
66 Patch5:         grub-mkconfig-diagnostics.patch
67 Patch6:         posix.patch
68 Patch7:         %{name}-fonts_path.patch
69 Patch8:         add-vlan-tag-support.patch
70 Patch9:         just-say-linux.patch
71 Patch10:        ignore-kernel-symlinks.patch
72 Patch11:        choose-preferred-initrd.patch
73 Patch12:        %{name}-cfg.patch
74 URL:            http://www.gnu.org/software/grub/
75 BuildRequires:  autoconf >= 2.53
76 BuildRequires:  automake >= 1:1.11.1-1
77 BuildRequires:  bison
78 BuildRequires:  device-mapper-devel
79 BuildRequires:  flex >= 2.5.35
80 BuildRequires:  fonts-TTF-DejaVu
81 BuildRequires:  freetype-devel >= 2
82 BuildRequires:  gawk
83 BuildRequires:  gettext-devel
84 BuildRequires:  glibc-localedb-all
85 BuildRequires:  glibc-static
86 BuildRequires:  help2man
87 BuildRequires:  libfuse-devel
88 BuildRequires:  libtool
89 BuildRequires:  ncurses-devel
90 BuildRequires:  python
91 BuildRequires:  python-modules
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.213
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  tar >= 1:1.22
96 BuildRequires:  texinfo
97 BuildRequires:  xz
98 BuildRequires:  xz-devel
99 %ifarch %{x8664}
100 BuildRequires:  /usr/lib/libc.so
101 %if "%{pld_release}" == "ac"
102 BuildRequires:  libgcc32
103 %else
104 BuildRequires:  gcc-multilib
105 %endif
106 %endif
107 Requires:       %{name}-platform = %{version}-%{release}
108 Requires:       issue
109 Requires:       which
110 %ifarch %{ix86} %{x8664}
111 Suggests:       %{name}-platform-pc
112 %endif
113 Suggests:       cdrkit-mkisofs
114 Suggests:       os-prober
115 Provides:       bootloader
116 Conflicts:      grub
117 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _sbindir        /sbin
121 %define         _bindir         %{_sbindir}
122 %define         _libdir         /lib
123 %define         _datadir        %{_libdir}
124 %define         _libexecdir     %{_libdir}/grub
125 %define         _grubdir        /boot/grub
126 %define         _localedir      /usr/share/locale
127
128 # part of grub code is not relocable (these are not Linux libs)
129 # stack protector also breaks non-Linux binaries
130 # any kind of forced optimizations makes grub2 unreliable (random
131 # reboots and hangs on boot menu screen)
132 %define         filterout_c     -fPIC -O.
133 %undefine       _ssp_cflags
134 %undefine       _fortify_cflags
135
136 %description
137 GRUB is a GPLed bootloader intended to unify bootloading across x86
138 operating systems. In addition to loading the Linux and *BSD kernels,
139 it implements the Multiboot standard, which allows for flexible
140 loading of multiple boot images (needed for modular kernels such as
141 the GNU Hurd).
142
143 GRUB 2 is derived from PUPA which was a research project to
144 investigate the next generation of GRUB. GRUB 2 has been rewritten
145 from scratch to clean up everything for modularity and portability.
146
147 GRUB 2 targets at the following goals:
148 - Scripting support, such as conditionals, loops, variables and
149   functions.
150 - Graphical interface.
151 - Dynamic loading of modules in order to extend itself at the run time
152   rather than at the build time.
153 - Portability for various architectures.
154 - Internationalization. This includes support for non-ASCII character
155   code, message catalogs like gettext, fonts, graphics console, and so
156   on.
157 - Real memory management, to make GNU GRUB more extensible.
158 - Modular, hierarchical, object-oriented framework for file systems,
159   files, devices, drives, terminals, commands, partition tables and OS
160   loaders.
161 - Cross-platform installation which allows for installing GRUB from a
162   different architecture.
163 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
164 - Fix design mistakes in GRUB Legacy, which could not be solved for
165   backward-compatibility, such as the way of numbering partitions.
166
167 %description -l de.UTF-8
168 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
169 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
170 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
171
172 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
173 und wird unter der GPL vertrieben. Aufgrund seiner höheren
174 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
175 traditionellen Boot-Loader LILO.
176
177 %description -l hu.UTF-8
178 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
179 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
180 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
181 GNU Hurd).
182
183 GRUB2 céljai a következők:
184 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
185   függvények.
186 - grafikus felület
187 - modulok dinamikus betöltése futási időben
188 - hordozhatóság több architektúrára
189 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
190   mint gettext, betűtípusok, grafikus konzolon, és így tovább
191 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
192 - moduláris, hierarchikus, objektum-orientált keretrendszer
193   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
194   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
195
196 %description -l es.UTF-8
197 Éste es GRUB - Grand Unified Boot Loader - un administrador de
198 inicialización capaz de entrar en la mayoría de los sistemas
199 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
200 también en la mayoría de los sistemas operacionales comerciales para
201 PC.
202
203 El administrador GRUB puede ser una buena alternativa a LILO, para
204 usuarios conmás experiencia y que deseen obtener más recursos de su
205 cargador de inicialización (boot loader).
206
207 %description -l pl.UTF-8
208 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
209 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
210 Linuksa i *BSD: posiada również implementację standardu Multiboot,
211 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
212 (czego wymagają modułowe jądra, takie jak GNU Hurd).
213
214 %description -l pt_BR.UTF-8
215 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
216 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
217 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
218 operacionais comerciais para PC.
219
220 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
221 avançados e que querem mais recursos de seu boot loader.
222
223 %package -n bash-completion-%{name}
224 Summary:        bash-completion for GRUB
225 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
226 Group:          Applications/Shells
227 Requires:       bash-completion
228
229 %description -n bash-completion-%{name}
230 This package provides bash-completion for GRUB.
231
232 %description -n bash-completion-%{name} -l pl.UTF-8
233 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
234
235 %package platform-pc
236 Summary:        PC BIOS platform support for GRUB
237 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
238 Group:          Base
239 Provides:       %{name}-platform = %{version}-%{release}
240
241 %description platform-pc
242 PC BIOS platform support for GRUB.
243
244 %description platform-pc -l pl.UTF-8
245 Obsługa platformy PC BIOS dla GRUB-a.
246
247 %package platform-efi
248 Summary:        (U)EFI platform support for GRUB
249 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
250 Group:          Base
251 Suggests:       efibootmgr
252 Provides:       %{name}-platform = %{version}-%{release}
253
254 %description platform-efi
255 (U)EFI platform support for GRUB.
256
257 %description platform-efi -l pl.UTF-8
258 Obsługa platformy (U)EFI dla GRUB-a.
259
260 %package mkfont
261 Summary:        GRUB font files converter
262 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
263 Group:          Base
264
265 %description mkfont
266 Converts common font file formats into PF2.
267
268 %description mkfont -l pl.UTF-8
269 Program do konwersji popularnych formatów plików fontów do PF2.
270
271 %package theme-starfield
272 Summary:        starfield theme for GRUB
273 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
274 Group:          Base
275
276 %description theme-starfield
277 starfield theme for GRUB.
278
279 %description theme-starfield -l pl.UTF-8
280 Motyw starfield dla GRUB-a.
281
282 %prep
283 %setup -q -n grub-%{version}-%{beta}
284 %patch1 -p1
285 %patch2 -p1
286 %patch3 -p1
287 %patch4 -p1
288 %patch5 -p1
289 %patch6 -p1
290 %patch7 -p1
291 %patch8 -p1
292 %patch9 -p1
293 %patch10 -p1
294 %patch11 -p1
295 %patch12 -p0
296
297 # we don't have C.utf-8 and need an UTF-8 locale for build
298 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
299
300 %build
301 # if gold is used then grub doesn't even boot
302 # https://savannah.gnu.org/bugs/?34539
303 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
304 install -d our-ld
305 ln -s /usr/bin/ld.bfd our-ld/ld
306 export PATH=$(pwd)/our-ld:$PATH
307
308 ## not only the typicall autotools stuff
309 #./autogen.sh
310
311 %{__gettextize}
312 %{__aclocal} -I m4
313 %{__autoconf}
314 %{__autoheader}
315 %{__automake}
316
317 for platform in %{platforms} ; do
318         install -d build-${platform}
319         cd build-${platform}
320
321         if [ "$platform" != "efi" ] ; then
322                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
323         else
324                 platform_opts=""
325         fi
326
327         ln -s ../configure .
328         # mawk stalls at ./genmoddep.awk, so force gawk
329         AWK=gawk \
330         %configure \
331                 --with-platform=${platform} \
332                 --disable-werror \
333         %if %{with grubemu}
334                 --enable-grub-emu-usb \
335                 --enable-grub-emu-sdl \
336                 --enable-grub-emu-pci \
337         %endif
338                 $platform_opts \
339                 TARGET_LDFLAGS=-static
340
341         %{__make} -j1 -C po update-gmo
342         %{__make}
343         cd ..
344 done
345
346 %install
347 rm -rf $RPM_BUILD_ROOT
348
349 for platform in %{platforms} ; do
350         cd build-${platform}
351         %{__make} install \
352                 pkgdatadir=%{_libexecdir} \
353                 pkglibdir=%{_libexecdir} \
354                 DESTDIR=$RPM_BUILD_ROOT
355         cd ..
356 done
357
358 # not in Th (?)
359 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
360 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
361
362 %find_lang grub
363
364 # this must be after 'make install'
365 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
366
367 install -d $RPM_BUILD_ROOT%{_grubdir}
368 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
369
370 # grub.d/41_custom
371 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
372 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
373
374 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
375 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
376
377 install -d $RPM_BUILD_ROOT/etc/sysconfig
378 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
379
380 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
381 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
382
383 # platform specific, unnecessarily always installed
384 %ifnarch %{ix86} %{x8664}
385 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
386 %endif
387 %ifnarch sparc64
388 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
389 %endif
390
391 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
392 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
393 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
394
395 # needs to be exactly 1KiB
396 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
397 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
398
399 %clean
400 rm -rf $RPM_BUILD_ROOT
401
402 %post -p %{_sbindir}/postshell
403 -/usr/sbin/fix-info-dir -c %{_infodir}
404
405 %postun -p %{_sbindir}/postshell
406 -/usr/sbin/fix-info-dir -c %{_infodir}
407
408 %triggerpostun -- %{name} < 2.00-2
409 # Note this trigger on version upgrade needed only for upgrade from
410 # old grub2 packages which contained modules in /boot/grub
411 # or were built with optimizations enabled
412 # don't do anything on --downgrade
413 if [ $1 -le 1 ]; then
414         exit 0
415 fi
416 echo "Grub was upgraded, trying to setup it to boot sector"
417 /sbin/grub-install '(hd0)' || :
418
419 %triggerpostun -- %{name} < 1.99-7.3
420 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
421 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
422         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
423         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
424 fi
425
426 %files -f grub.lang
427 %defattr(644,root,root,755)
428 %doc AUTHORS ChangeLog NEWS README THANKS TODO
429 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
430 %attr(755,root,root) %{_sbindir}/grub-editenv
431 %attr(755,root,root) %{_sbindir}/grub-fstest
432 %attr(755,root,root) %{_sbindir}/grub-file
433 %attr(755,root,root) %{_sbindir}/grub-glue-efi
434 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
435 %attr(755,root,root) %{_sbindir}/grub-install
436 %attr(755,root,root) %{_sbindir}/grub-macbless
437 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
438 %attr(755,root,root) %{_sbindir}/grub-mkconfig
439 %attr(755,root,root) %{_sbindir}/grub-mklayout
440 %attr(755,root,root) %{_sbindir}/grub-mknetdir
441 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
442 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
443 %attr(755,root,root) %{_sbindir}/grub-mkrescue
444 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
445 %attr(755,root,root) %{_sbindir}/grub-mount
446 %attr(755,root,root) %{_sbindir}/grub-ofpathname
447 %attr(755,root,root) %{_sbindir}/grub-reboot
448 %attr(755,root,root) %{_sbindir}/grub-render-label
449 %attr(755,root,root) %{_sbindir}/grub-script-check
450 %attr(755,root,root) %{_sbindir}/grub-set-default
451 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
452 %attr(755,root,root) %{_sbindir}/update-grub
453 %ifarch %{ix86} %{x8664}
454 %attr(755,root,root) %{_sbindir}/grub-bios-setup
455 %{_mandir}/man8/grub-bios-setup.8*
456 %endif
457 %ifarch %{ix86} %{x8664}
458 %attr(755,root,root) %{_sbindir}/grub-mkimage
459 %{_mandir}/man1/grub-mkimage.1*
460 %else
461 %attr(755,root,root) %{_sbindir}/grub-probe
462 %{_mandir}/man8/grub-probe.8*
463 %endif
464 %ifarch sparc64
465 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
466 %{_mandir}/man8/grub-sparc64-setup.8*
467 %endif
468 %{_mandir}/man1/grub-editenv.1*
469 %{_mandir}/man1/grub-file.1*
470 %{_mandir}/man1/grub-fstest.1*
471 %{_mandir}/man1/grub-glue-efi.1*
472 %{_mandir}/man1/grub-kbdcomp.1*
473 %{_mandir}/man1/grub-macbless.1*
474 %{_mandir}/man1/grub-menulst2cfg.1*
475 %{_mandir}/man1/grub-mklayout.1*
476 %{_mandir}/man1/grub-mknetdir.1*
477 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
478 %{_mandir}/man1/grub-mkrelpath.1*
479 %{_mandir}/man1/grub-mkrescue.1*
480 %{_mandir}/man1/grub-mkstandalone.1*
481 %{_mandir}/man1/grub-mount.1*
482 %{_mandir}/man1/grub-render-label.1*
483 %{_mandir}/man1/grub-script-check.1*
484 %{_mandir}/man1/grub-syslinux2cfg.1*
485 %{_mandir}/man8/grub-install.8*
486 %{_mandir}/man8/grub-mkconfig.8*
487 %{_mandir}/man8/grub-ofpathname.8*
488 %{_mandir}/man8/grub-reboot.8*
489 %{_mandir}/man8/grub-set-default.8*
490 %{_mandir}/man8/update-grub.8*
491 %if %{with grubemu}
492 %attr(755,root,root) %{_sbindir}/grub-emu
493 %{_mandir}/man8/grub-emu.8*
494 %endif
495 %{_libexecdir}/grub-mkconfig_lib
496
497 %dir %{_grubdir}
498 %dir %{_libexecdir}
499 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
500
501 %dir %{_libexecdir}/locale
502 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
503 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
504
505 # generated by grub at runtime
506 %ghost %{_grubdir}/device.map
507 %ghost %{_grubdir}/core.img
508 %ghost %{_grubdir}/grubenv
509
510 %dir /lib/grub.d
511 %doc /lib/grub.d/README
512 %attr(755,root,root) /lib/grub.d/00_header
513 %attr(755,root,root) /lib/grub.d/10_linux
514 %attr(755,root,root) /lib/grub.d/20_linux_xen
515 %attr(755,root,root) /lib/grub.d/30_os-prober
516 %attr(755,root,root) /lib/grub.d/41_custom
517
518 # these are now installed only on matching hosts
519 #%attr(755,root,root) /lib/grub.d/10_hurd
520 #%attr(755,root,root) /lib/grub.d/10_illumos
521 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
522 #%attr(755,root,root) /lib/grub.d/10_netbsd
523 #%attr(755,root,root) /lib/grub.d/10_xnu
524
525 %ifarch %{ix86} %{x8664}
526 %attr(755,root,root) %{_sbindir}/grub-probe
527 %{_mandir}/man8/grub-probe.8*
528 %endif
529
530 %{_infodir}/grub*.info*
531
532 %dir %{_datadir}/grub/themes
533
534 %if %{with pc}
535 %files platform-pc
536 %defattr(644,root,root,755)
537 %dir %{_libexecdir}/*-pc
538 %{_libexecdir}/*-pc/modinfo.sh
539 %{_libexecdir}/*-pc/*.exec
540 %{_libexecdir}/*-pc/*.image
541 %{_libexecdir}/*-pc/*.lst
542 %{_libexecdir}/*-pc/*.mod
543 %{_libexecdir}/*-pc/*.module
544 %{_libexecdir}/*-pc/lzma_decompress.img
545 %{_libexecdir}/*-pc/config.h
546 %{_libexecdir}/*-pc/gdb_grub
547 %{_libexecdir}/*-pc/gmodule.pl
548 %if %{with efiemu}
549 %{_libexecdir}/*-pc/efiemu*.o
550 %endif
551 %{_libexecdir}/*-pc/kernel.img
552 %ifarch %{ix86} %{x8664} sparc sparc64
553 %{_libexecdir}/*-pc/boot.img
554 %{_libexecdir}/*-pc/boot_hybrid.img
555 %{_libexecdir}/*-pc/cdboot.img
556 %{_libexecdir}/*-pc/diskboot.img
557 %{_libexecdir}/*-pc/lnxboot.img
558 %{_libexecdir}/*-pc/pxeboot.img
559 %endif
560 %endif
561
562 %if %{with efi}
563 %files platform-efi
564 %defattr(644,root,root,755)
565 %dir %{_libexecdir}/*-efi
566 %{_libexecdir}/*-efi/modinfo.sh
567 %{_libexecdir}/*-efi/*.exec
568 %{_libexecdir}/*-efi/*.lst
569 %{_libexecdir}/*-efi/*.mod
570 %{_libexecdir}/*-efi/*.module
571 %{_libexecdir}/*-efi/config.h
572 %{_libexecdir}/*-efi/gdb_grub
573 %{_libexecdir}/*-efi/gmodule.pl
574 %{_libexecdir}/*-efi/kernel.img
575 %endif
576
577 %files mkfont
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_sbindir}/grub-mkfont
580 %{_mandir}/man1/grub-mkfont.1*
581
582 %files theme-starfield
583 %defattr(644,root,root,755)
584 %{_datadir}/grub/themes/starfield
585
586 %files -n bash-completion-%{name}
587 %defattr(644,root,root,755)
588 /etc/bash_completion.d/grub