]> TLD Linux GIT Repositories - packages/grub2.git/blob - grub2.spec
- added options to enable unrestricted boot
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664}
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664}
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32
33 %define         rel     1
34 Summary:        GRand Unified Bootloader
35 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86
36 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 gépekhez
37 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86
38 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
39 Name:           grub2
40 Version:        2.02
41 Release:        3
42 License:        GPL v2
43 Group:          Base
44 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
45 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
46 Source1:        update-grub
47 Source2:        update-grub.8
48 Source3:        grub.sysconfig
49 Source4:        grub-custom.cfg
50 Patch1:         tld-sysconfdir.patch
51 Patch2:         grub-garbage.patch
52 Patch3:         grub-lvmdevice.patch
53 Patch4:         tld-mkconfigdir.patch
54 Patch5:         grub-mkconfig-diagnostics.patch
55 Patch6:         posix.patch
56 Patch7:         %{name}-fonts_path.patch
57 Patch8:         add-vlan-tag-support.patch
58 Patch9:         just-say-linux.patch
59 Patch10:        ignore-kernel-symlinks.patch
60 Patch11:        initrd-search.patch
61 Patch12:        %{name}-cfg.patch
62 Patch13:        efi-net-fix.patch
63 Patch14:        blscfg.patch
64 Patch15:        restricted.patch
65 Patch16:        gcc8.patch
66 URL:            http://www.gnu.org/software/grub/
67 BuildRequires:  autoconf >= 2.53
68 BuildRequires:  automake >= 1:1.11.1-1
69 BuildRequires:  bison
70 BuildRequires:  device-mapper-devel
71 BuildRequires:  flex >= 2.5.35
72 BuildRequires:  fonts-TTF-DejaVu
73 BuildRequires:  freetype-devel >= 2
74 BuildRequires:  gawk
75 BuildRequires:  gcc >= 5:3.4
76 BuildRequires:  gettext-tools
77 BuildRequires:  glibc-localedb-all
78 BuildRequires:  glibc-static
79 BuildRequires:  help2man
80 BuildRequires:  libfuse-devel
81 BuildRequires:  libtool
82 BuildRequires:  ncurses-devel
83 BuildRequires:  python
84 BuildRequires:  python-modules
85 BuildRequires:  rpm >= 4.4.9-56
86 BuildRequires:  rpmbuild(macros) >= 1.213
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  tar >= 1:1.22
89 BuildRequires:  texinfo
90 BuildRequires:  xz
91 BuildRequires:  xz-devel
92 %ifarch %{x8664}
93 BuildRequires:  /usr/lib/libc.so
94 BuildRequires:  gcc-multilib
95 %endif
96 Requires:       %{name}-platform = %{version}-%{release}
97 Requires:       issue
98 Requires:       which
99 %ifarch %{ix86} %{x8664}
100 Suggests:       %{name}-platform-pc
101 %endif
102 Suggests:       cdrkit-mkisofs
103 Suggests:       os-prober
104 Provides:       bootloader
105 Conflicts:      grub
106 ExclusiveArch:  %{ix86} %{x8664}
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _sbindir        /sbin
110 %define         _bindir         %{_sbindir}
111 %define         _libdir         /lib
112 %define         _datadir        %{_libdir}
113 %define         _libexecdir     %{_libdir}/grub
114 %define         _grubdir        /boot/grub
115 %define         _localedir      /usr/share/locale
116
117 # part of grub code is not relocable (these are not Linux libs)
118 # stack protector also breaks non-Linux binaries
119 # any kind of forced optimizations makes grub2 unreliable (random
120 # reboots and hangs on boot menu screen)
121 %define         filterout_c     -fPIC -O.
122 %undefine       _ssp_cflags
123 %undefine       _fortify_cflags
124
125 %description
126 GRUB is a GPLed bootloader intended to unify bootloading across x86
127 operating systems. In addition to loading the Linux and *BSD kernels,
128 it implements the Multiboot standard, which allows for flexible
129 loading of multiple boot images (needed for modular kernels such as
130 the GNU Hurd).
131
132 GRUB 2 is derived from PUPA which was a research project to
133 investigate the next generation of GRUB. GRUB 2 has been rewritten
134 from scratch to clean up everything for modularity and portability.
135
136 GRUB 2 targets at the following goals:
137 - Scripting support, such as conditionals, loops, variables and
138   functions.
139 - Graphical interface.
140 - Dynamic loading of modules in order to extend itself at the run time
141   rather than at the build time.
142 - Portability for various architectures.
143 - Internationalization. This includes support for non-ASCII character
144   code, message catalogs like gettext, fonts, graphics console, and so
145   on.
146 - Real memory management, to make GNU GRUB more extensible.
147 - Modular, hierarchical, object-oriented framework for file systems,
148   files, devices, drives, terminals, commands, partition tables and OS
149   loaders.
150 - Cross-platform installation which allows for installing GRUB from a
151   different architecture.
152 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
153 - Fix design mistakes in GRUB Legacy, which could not be solved for
154   backward-compatibility, such as the way of numbering partitions.
155
156 %description -l de.UTF-8
157 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
158 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
159 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
160
161 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
162 und wird unter der GPL vertrieben. Aufgrund seiner höheren
163 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
164 traditionellen Boot-Loader LILO.
165
166 %description -l hu.UTF-8
167 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
168 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
169 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
170 GNU Hurd).
171
172 GRUB2 céljai a következők:
173 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
174   függvények.
175 - grafikus felület
176 - modulok dinamikus betöltése futási időben
177 - hordozhatóság több architektúrára
178 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
179   mint gettext, betűtípusok, grafikus konzolon, és így tovább
180 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
181 - moduláris, hierarchikus, objektum-orientált keretrendszer
182   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
183   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
184
185 %description -l es.UTF-8
186 Éste es GRUB - Grand Unified Boot Loader - un administrador de
187 inicialización capaz de entrar en la mayoría de los sistemas
188 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
189 también en la mayoría de los sistemas operacionales comerciales para
190 PC.
191
192 El administrador GRUB puede ser una buena alternativa a LILO, para
193 usuarios conmás experiencia y que deseen obtener más recursos de su
194 cargador de inicialización (boot loader).
195
196 %description -l pl.UTF-8
197 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
198 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
199 Linuksa i *BSD: posiada również implementację standardu Multiboot,
200 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
201 (czego wymagają modułowe jądra, takie jak GNU Hurd).
202
203 %description -l pt_BR.UTF-8
204 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
205 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
206 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
207 operacionais comerciais para PC.
208
209 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
210 avançados e que querem mais recursos de seu boot loader.
211
212 %package -n bash-completion-%{name}
213 Summary:        bash-completion for GRUB
214 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
215 Group:          Applications/Shells
216 Requires:       bash-completion
217
218 %description -n bash-completion-%{name}
219 This package provides bash-completion for GRUB.
220
221 %description -n bash-completion-%{name} -l pl.UTF-8
222 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
223
224 %package platform-pc
225 Summary:        PC BIOS platform support for GRUB
226 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
227 Group:          Base
228 Provides:       %{name}-platform = %{version}-%{release}
229
230 %description platform-pc
231 PC BIOS platform support for GRUB.
232
233 %description platform-pc -l pl.UTF-8
234 Obsługa platformy PC BIOS dla GRUB-a.
235
236 %package platform-efi
237 Summary:        (U)EFI platform support for GRUB
238 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
239 Group:          Base
240 Suggests:       efibootmgr
241 Provides:       %{name}-platform = %{version}-%{release}
242
243 %description platform-efi
244 (U)EFI platform support for GRUB.
245
246 %description platform-efi -l pl.UTF-8
247 Obsługa platformy (U)EFI dla GRUB-a.
248
249 %package mkfont
250 Summary:        GRUB font files converter
251 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
252 Group:          Base
253
254 %description mkfont
255 Converts common font file formats into PF2.
256
257 %description mkfont -l pl.UTF-8
258 Program do konwersji popularnych formatów plików fontów do PF2.
259
260 %package theme-starfield
261 Summary:        starfield theme for GRUB
262 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
263 Group:          Base
264
265 %description theme-starfield
266 starfield theme for GRUB.
267
268 %description theme-starfield -l pl.UTF-8
269 Motyw starfield dla GRUB-a.
270
271 %prep
272 %setup -q -n grub-%{version}
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch6 -p1
279 %patch7 -p1
280 %patch8 -p1
281 %patch9 -p1
282 %patch10 -p1
283 %patch11 -p1
284 %patch12 -p1
285 %patch13 -p1
286 %patch14 -p1
287 %patch15 -p1
288 %patch16 -p1
289
290 # we don't have C.utf-8 and need an UTF-8 locale for build
291 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
292
293 %build
294 # if gold is used then grub doesn't even boot
295 # https://savannah.gnu.org/bugs/?34539
296 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
297 install -d our-ld
298 ln -f -s /usr/bin/ld.bfd our-ld/ld
299 export PATH=$(pwd)/our-ld:$PATH
300
301 ## not only the typicall autotools stuff
302 #./autogen.sh
303
304 #{__gettextize}
305 %{__aclocal} -I m4
306 %{__autoconf}
307 %{__autoheader}
308 %{__automake}
309
310 for platform in %{platforms} ; do
311         install -d build-${platform}
312         cd build-${platform}
313
314         if [ "$platform" != "efi" ] ; then
315                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
316         else
317                 platform_opts=""
318         fi
319
320         ln -f -s ../configure .
321         # mawk stalls at ./genmoddep.awk, so force gawk
322         AWK=gawk \
323         %configure \
324                 --with-platform=${platform} \
325                 --disable-werror \
326         %if %{with grubemu}
327                 --enable-grub-emu-usb \
328                 --enable-grub-emu-sdl \
329                 --enable-grub-emu-pci \
330         %endif
331                 $platform_opts \
332                 TARGET_LDFLAGS=-static
333
334         %{__make} -j1 -C po update-gmo
335         %{__make}
336         cd ..
337 done
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341
342 for platform in %{platforms} ; do
343         cd build-${platform}
344         %{__make} install \
345                 pkgdatadir=%{_libexecdir} \
346                 pkglibdir=%{_libexecdir} \
347                 DESTDIR=$RPM_BUILD_ROOT
348         cd ..
349 done
350
351 # not in Th (?)
352 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
353 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
354
355 %find_lang grub
356
357 # this must be after 'make install'
358 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
359
360 install -d $RPM_BUILD_ROOT%{_grubdir}
361 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
362
363 # grub.d/41_custom
364 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
365 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
366
367 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
368 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
369
370 install -d $RPM_BUILD_ROOT/etc/sysconfig
371 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
372
373 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
374 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
375
376 # platform specific, unnecessarily always installed
377 %ifnarch %{ix86} %{x8664}
378 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
379 %endif
380 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
381
382 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
383 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
384 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
385
386 # needs to be exactly 1KiB
387 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
388 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
389
390 %clean
391 rm -rf $RPM_BUILD_ROOT
392
393 %post -p %{_sbindir}/postshell
394 -/usr/sbin/fix-info-dir -c %{_infodir}
395
396 %postun -p %{_sbindir}/postshell
397 -/usr/sbin/fix-info-dir -c %{_infodir}
398
399 %triggerpostun -- %{name} < 2.00-2
400 # Note this trigger on version upgrade needed only for upgrade from
401 # old grub2 packages which contained modules in /boot/grub
402 # or were built with optimizations enabled
403 # don't do anything on --downgrade
404 if [ $1 -le 1 ]; then
405         exit 0
406 fi
407 echo "Grub was upgraded, trying to setup it to boot sector"
408 /sbin/grub-install '(hd0)' || :
409
410 %triggerpostun -- %{name} < 1.99-7.3
411 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
412 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
413         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
414         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
415 fi
416
417 %files -f grub.lang
418 %defattr(644,root,root,755)
419 %doc AUTHORS NEWS README THANKS TODO
420 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
421 %attr(755,root,root) %{_sbindir}/grub-editenv
422 %attr(755,root,root) %{_sbindir}/grub-fstest
423 %attr(755,root,root) %{_sbindir}/grub-file
424 %attr(755,root,root) %{_sbindir}/grub-glue-efi
425 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
426 %attr(755,root,root) %{_sbindir}/grub-install
427 %attr(755,root,root) %{_sbindir}/grub-macbless
428 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
429 %attr(755,root,root) %{_sbindir}/grub-mkconfig
430 %attr(755,root,root) %{_sbindir}/grub-mklayout
431 %attr(755,root,root) %{_sbindir}/grub-mknetdir
432 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
433 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
434 %attr(755,root,root) %{_sbindir}/grub-mkrescue
435 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
436 %attr(755,root,root) %{_sbindir}/grub-mount
437 %attr(755,root,root) %{_sbindir}/grub-ofpathname
438 %attr(755,root,root) %{_sbindir}/grub-reboot
439 %attr(755,root,root) %{_sbindir}/grub-render-label
440 %attr(755,root,root) %{_sbindir}/grub-script-check
441 %attr(755,root,root) %{_sbindir}/grub-set-default
442 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
443 %attr(755,root,root) %{_sbindir}/update-grub
444 %ifarch %{ix86} %{x8664}
445 %attr(755,root,root) %{_sbindir}/grub-bios-setup
446 %{_mandir}/man8/grub-bios-setup.8*
447 %endif
448 %ifarch %{ix86} %{x8664}
449 %attr(755,root,root) %{_sbindir}/grub-mkimage
450 %{_mandir}/man1/grub-mkimage.1*
451 %else
452 %attr(755,root,root) %{_sbindir}/grub-probe
453 %{_mandir}/man8/grub-probe.8*
454 %endif
455 %{_mandir}/man1/grub-editenv.1*
456 %{_mandir}/man1/grub-file.1*
457 %{_mandir}/man1/grub-fstest.1*
458 %{_mandir}/man1/grub-glue-efi.1*
459 %{_mandir}/man1/grub-kbdcomp.1*
460 %{_mandir}/man1/grub-menulst2cfg.1*
461 %{_mandir}/man1/grub-mklayout.1*
462 %{_mandir}/man1/grub-mknetdir.1*
463 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
464 %{_mandir}/man1/grub-mkrelpath.1*
465 %{_mandir}/man1/grub-mkrescue.1*
466 %{_mandir}/man1/grub-mkstandalone.1*
467 %{_mandir}/man1/grub-mount.1*
468 %{_mandir}/man1/grub-render-label.1*
469 %{_mandir}/man1/grub-script-check.1*
470 %{_mandir}/man1/grub-syslinux2cfg.1*
471 %{_mandir}/man8/grub-install.8*
472 %{_mandir}/man8/grub-macbless.8*
473 %{_mandir}/man8/grub-mkconfig.8*
474 %{_mandir}/man8/grub-ofpathname.8*
475 %{_mandir}/man8/grub-reboot.8*
476 %{_mandir}/man8/grub-set-default.8*
477 %{_mandir}/man8/update-grub.8*
478 %if %{with grubemu}
479 %attr(755,root,root) %{_sbindir}/grub-emu
480 %{_mandir}/man8/grub-emu.8*
481 %endif
482 %{_libexecdir}/grub-mkconfig_lib
483
484 %dir %{_grubdir}
485 %dir %{_libexecdir}
486 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
487
488 %dir %{_libexecdir}/locale
489 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
490 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
491
492 # generated by grub at runtime
493 %ghost %{_grubdir}/device.map
494 %ghost %{_grubdir}/core.img
495 %ghost %{_grubdir}/grubenv
496
497 %dir /lib/grub.d
498 %doc /lib/grub.d/README
499 %attr(755,root,root) /lib/grub.d/00_header
500 %attr(755,root,root) /lib/grub.d/10_linux
501 %attr(755,root,root) /lib/grub.d/20_linux_xen
502 %attr(755,root,root) /lib/grub.d/30_os-prober
503 %attr(755,root,root) /lib/grub.d/41_custom
504
505 # these are now installed only on matching hosts
506 #%attr(755,root,root) /lib/grub.d/10_hurd
507 #%attr(755,root,root) /lib/grub.d/10_illumos
508 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
509 #%attr(755,root,root) /lib/grub.d/10_netbsd
510 #%attr(755,root,root) /lib/grub.d/10_xnu
511
512 %ifarch %{ix86} %{x8664}
513 %attr(755,root,root) %{_sbindir}/grub-probe
514 %{_mandir}/man8/grub-probe.8*
515 %endif
516
517 %{_infodir}/grub*.info*
518
519 %dir %{_datadir}/grub/themes
520
521 %if %{with pc}
522 %files platform-pc
523 %defattr(644,root,root,755)
524 %dir %{_libexecdir}/*-pc
525 %{_libexecdir}/*-pc/modinfo.sh
526 %{_libexecdir}/*-pc/*.exec
527 %{_libexecdir}/*-pc/*.image
528 %{_libexecdir}/*-pc/*.lst
529 %{_libexecdir}/*-pc/*.mod
530 %{_libexecdir}/*-pc/*.module
531 %{_libexecdir}/*-pc/lzma_decompress.img
532 %{_libexecdir}/*-pc/config.h
533 %{_libexecdir}/*-pc/gdb_grub
534 %{_libexecdir}/*-pc/gmodule.pl
535 %if %{with efiemu}
536 %{_libexecdir}/*-pc/efiemu*.o
537 %endif
538 %{_libexecdir}/*-pc/kernel.img
539 %ifarch %{ix86} %{x8664}
540 %{_libexecdir}/*-pc/boot.img
541 %{_libexecdir}/*-pc/boot_hybrid.img
542 %{_libexecdir}/*-pc/cdboot.img
543 %{_libexecdir}/*-pc/diskboot.img
544 %{_libexecdir}/*-pc/lnxboot.img
545 %{_libexecdir}/*-pc/pxeboot.img
546 %endif
547 %endif
548
549 %if %{with efi}
550 %files platform-efi
551 %defattr(644,root,root,755)
552 %dir %{_libexecdir}/*-efi
553 %{_libexecdir}/*-efi/modinfo.sh
554 %{_libexecdir}/*-efi/*.exec
555 %{_libexecdir}/*-efi/*.lst
556 %{_libexecdir}/*-efi/*.mod
557 %{_libexecdir}/*-efi/*.module
558 %{_libexecdir}/*-efi/config.h
559 %{_libexecdir}/*-efi/gdb_grub
560 %{_libexecdir}/*-efi/gmodule.pl
561 %{_libexecdir}/*-efi/kernel.img
562 %endif
563
564 %files mkfont
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_sbindir}/grub-mkfont
567 %{_mandir}/man1/grub-mkfont.1*
568
569 %files theme-starfield
570 %defattr(644,root,root,755)
571 %{_datadir}/grub/themes/starfield
572
573 %files -n bash-completion-%{name}
574 %defattr(644,root,root,755)
575 /etc/bash_completion.d/grub