]> TLD Linux GIT Repositories - packages/kernel.git/commitdiff
- update grub.cfg by default
authorMarcin Krol <hawk@tld-linux.org>
Sat, 20 Apr 2013 18:04:12 +0000 (18:04 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 20 Apr 2013 18:04:12 +0000 (18:04 +0000)
kernel-vanilla.spec

index 9f75ff384034ddb71038a67aaaa4ed5ba9b8b55d..a1fde4dbb38e7bd4572387ab559f233ca22fb4e7 100644 (file)
@@ -516,11 +516,10 @@ if [[ "$USE_DRACUT" != [Nn][Oo] ]] && [ -x /sbin/dracut ]; then
        /sbin/dracut --force --quiet /boot/initramfs-%{kernel_release}.img %{kernel_release}
 fi
 
-# update boot loaders when old package files are gone from filesystem
-if [ -x /sbin/update-grub -a -f /etc/sysconfig/grub ]; then
-       if [ "$(. /etc/sysconfig/grub; echo ${UPDATE_GRUB:-no})" = "yes" ]; then
-               /sbin/update-grub >/dev/null
-       fi
+# update boot loader
+[ -x /sbin/update-grub -a -f /etc/sysconfig/grub ] && . /etc/sysconfig/grub
+if [[ "$UPDATE_GRUB" != [Nn][Oo] ]]; then
+       /sbin/update-grub
 fi
 
 if [ -x /sbin/new-kernel-pkg ]; then