]> TLD Linux GIT Repositories - packages/libvirt.git/commitdiff
- fix from upstream for shared daemon startup code
authorMarcin Krol <hawk@tld-linux.org>
Wed, 8 Apr 2020 00:03:22 +0000 (02:03 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 8 Apr 2020 00:03:22 +0000 (02:03 +0200)
libvirt-daemon-fix.patch [new file with mode: 0644]
libvirt.spec

diff --git a/libvirt-daemon-fix.patch b/libvirt-daemon-fix.patch
new file mode 100644 (file)
index 0000000..4b32700
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/src/util/virdaemon.c b/src/util/virdaemon.c
+index 5d92c7def7..99530fd146 100644
+--- a/src/util/virdaemon.c
++++ b/src/util/virdaemon.c
+@@ -97,15 +97,14 @@ virDaemonForkIntoBackground(const char *argv0)
+     default:
+         {
+             /* parent */
+-            int got, exitstatus = 0;
++            int exitstatus = 0;
+             int ret;
+             char status;
+             VIR_FORCE_CLOSE(statuspipe[1]);
+             /* We wait to make sure the first child forked successfully */
+-            if ((got = virProcessWait(pid, &exitstatus, 0)) < 0 ||
+-                got != pid ||
++            if (virProcessWait(pid, &exitstatus, 0) < 0 ||
+                 exitstatus != 0) {
+                 goto error;
+             }
index f1eaa55d58b9eda41737879f46a095a448a095fe..a8c571d4f4d008f5879b2d0a5f4aab0e73b6e5ab 100644 (file)
@@ -44,7 +44,7 @@ Summary:      Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
 Version:       6.2.0
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://libvirt.org/sources/libvirt-%{version}.tar.xz
@@ -62,6 +62,7 @@ Patch1:               %{name}-qemu-acl.patch
 Patch2:                %{name}-udevadm-settle.patch
 Patch3:                bashisms.patch
 Patch4:                %{name}-sysctl-dir.patch
+Patch5:                %{name}-daemon-fix.patch
 URL:           http://www.libvirt.org/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -449,6 +450,7 @@ Moduł sekcji Wiresharka do pakietów libvirt.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}