]> TLD Linux GIT Repositories - packages/lighttpd.git/commitdiff
- merged 1.4.49 from PLD
authorMarcin Krol <hawk@tld-linux.org>
Sat, 14 Apr 2018 12:34:23 +0000 (12:34 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 14 Apr 2018 12:34:23 +0000 (12:34 +0000)
lighttpd-bug-2876.patch [new file with mode: 0644]
lighttpd.spec

diff --git a/lighttpd-bug-2876.patch b/lighttpd-bug-2876.patch
new file mode 100644 (file)
index 0000000..b1c03e1
--- /dev/null
@@ -0,0 +1,31 @@
+From e21906b3b41cda3cefebcc8b96ae6ad08549e504 Mon Sep 17 00:00:00 2001
+From: Glenn Strauss <gstrauss@gluelogic.com>
+Date: Thu, 15 Mar 2018 23:21:37 -0400
+Subject: [PATCH] [core] fix crash if 'host' empty in config (fixes #2876)
+
+x-ref:
+ "segfault with fastcgi app"
+  https://redmine.lighttpd.net/issues/2876
+---
+ src/gw_backend.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/gw_backend.c b/src/gw_backend.c
+index dbef6328..7b5ef190 100644
+--- a/src/gw_backend.c
++++ b/src/gw_backend.c
+@@ -1399,8 +1399,12 @@ int gw_set_defaults_backend(server *srv, gw_plugin_data *p, data_unset *du, size
+                     host->port = 80;
+                 }
+-                host->family = (!buffer_string_is_empty(host->host)
+-                                && NULL != strchr(host->host->ptr, ':'))
++                if (buffer_string_is_empty(host->host)) {
++                    buffer_copy_string_len(host->host,
++                                           CONST_STR_LEN("127.0.0.1"));
++                }
++
++                host->family = (NULL != strchr(host->host->ptr, ':'))
+                   ? AF_INET6
+                   : AF_INET;
+             }
index 931061f57032a0ade363c2cf2c2e2eb444a04f78..2982c7918555757c486e7d5fbba05dcdf39f9185 100644 (file)
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.48
-Release:       2
+Version:       1.4.49
+Release:       1
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
-# Source0-md5: 1e3a9eb5078f481e3a8a1d0aaac8c3c8
+# Source0-md5: aaf8165379351c3766e5ad1e5c9dbe8b
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -115,6 +115,7 @@ Patch2:             %{name}-mod_h264_streaming.patch
 Patch3:                %{name}-branding.patch
 Patch6:                test-port-setup.patch
 Patch7:                env-documentroot.patch
+Patch8:                lighttpd-bug-2876.patch
 URL:           https://www.lighttpd.net/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 %{?with_xattr:BuildRequires:   attr-devel}
@@ -943,6 +944,7 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %patch3 -p1
 %patch6 -p1
 #%patch7 -p1 probably fixed upstream
+%patch8 -p1
 
 rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead