]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- release 2
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
4 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
5 #    note: dmeventd requires mirrors=internal)
6 #
7 # Conditional build:
8 # - functionality
9 %bcond_without  cluster         # disable all cluster support (cmirrord)
10 %bcond_without  lvmdbusd        # lvmdbusd
11 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
12 %bcond_without  lvmlockd        # lvmlockd
13 %bcond_with     sanlock         # sanlock support in lvmlockd
14 %bcond_with     replicator      # internal replicator support
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # for convenience
23 %if %{without python}
24 %undefine       with_python2
25 %undefine       with_python3
26 %endif
27 %if %{without python3}
28 %undefine       with_lvmdbusd
29 %endif
30
31 Summary:        The new version of Logical Volume Manager for Linux
32 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
33 Name:           lvm2
34 Version:        2.03.05
35 Release:        2
36 License:        GPL v2 and LGPL v2.1
37 Group:          Applications/System
38 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
39 # Source0-md5:  22e4a9e66b94bbfcf81444472ed32a2d
40 Patch0:         %{name}-selinux.patch
41 Patch1:         device-mapper-dmsetup-export.patch
42 Patch2:         %{name}-tld_init.patch
43 Patch3:         %{name}-run-dir.patch
44 Patch4:         device-mapper-dmsetup-deps-export.patch
45 Patch5:         %{name}-thin.patch
46 Patch6:         %{name}-no-systemd.patch
47 Patch7:         bashizm.patch
48 Patch8:         link.patch
49 URL:            http://www.sourceware.org/lvm2/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 # for /run detection
53 BuildRequires:  filesystem >= 3.0-43
54 BuildRequires:  libblkid-devel >= 2.24
55 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
56 %{?with_selinux:BuildRequires:  libsepol-devel}
57 BuildRequires:  ncurses-devel
58 BuildRequires:  pkgconfig
59 %{?with_python2:BuildRequires:  python-devel >= 2}
60 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
61 %if %{with lvmdbusd}
62 BuildRequires:  python3-dbus
63 BuildRequires:  python3-pyudev
64 %endif
65 BuildRequires:  readline-devel
66 BuildRequires:  rpmbuild(macros) >= 1.647
67 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
68 BuildRequires:  udev-devel >= 1:176
69 %if %{with cluster}
70 BuildRequires:  corosync-devel
71 BuildRequires:  dlm-devel >= 3.99.5
72 %endif
73 Requires(post,postun):  /sbin/chkconfig
74 Requires:       device-mapper >= %{version}-%{release}
75 %{?with_selinux:Requires:       libselinux >= 1.10}
76 # doesn't work with 2.4 kernels
77 Requires:       uname(release) >= 2.6
78 Suggests:       thin-provisioning-tools >= 0.5.4
79 Obsoletes:      lvm
80 Obsoletes:      lvm2-clvmd
81 Obsoletes:      lvm2-systemd
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _sbindir        /sbin
85 %define         _usrsbindir     /usr/sbin
86
87 # changing CFLAGS in the middle confuses confcache
88 %undefine       configure_cache
89
90 # borken on AC
91 %define         filterout_ld    -Wl,--as-needed
92
93 # causes: undefined reference to `__stack_chk_fail_local'
94 %define         filterout_c     -fstack-protector
95
96 %define         skip_post_check_so      '.*(libdevmapper-event.so|libdevmapper-event-lvm2.so).*'
97
98 %description
99 This package includes a number of utilities for creating, checking,
100 and repairing logical volumes.
101
102 %description -l pl.UTF-8
103 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
104 logicznych wolumenów dyskowych (LVM2).
105
106 %package cmirrord
107 Summary:        Cluster mirror log daemon
108 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
109 Group:          Applications/System
110 Requires:       %{name} = %{version}-%{release}
111
112 %description cmirrord
113 cmirrord is the daemon that tracks mirror log information in a
114 cluster. It is specific to device-mapper based mirrors (and by
115 extension, LVM cluster mirrors). Cluster mirrors are not possible
116 without this daemon running.
117
118 This daemon relies on the cluster infrastructure provided by the
119 Cluster MANager (CMAN), which must be set up and running in order for
120 cmirrord to function.
121
122 %description cmirrord
123 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
124 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
125 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
126 lustrzanych ten demon jest niezbędny.
127
128 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
129 (Cluster MANager), który musi być skonfigurowany i działający, aby
130 działał cmirrord.
131
132 %package dbusd
133 Summary:        LVM2 D-Bus daemon
134 Summary(pl.UTF-8):      Demon LVM2 D-Bus
135 Group:          Daemons
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       python3-dbus
138 Requires:       python3-pygobject3 >= 3
139 Requires:       python3-pyudev
140
141 %description dbusd
142 Daemon for access to LVM2 functionality through a D-Bus interface.
143
144 %description dbusd -l pl.UTF-8
145 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
146 D-Bus.
147
148 %package lockd
149 Summary:        LVM2 locking daemon
150 Summary(pl.UTF-8):      Demon blokad LVM2
151 Group:          Daemons
152 Requires:       %{name} = %{version}-%{release}
153 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
154 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
155
156 %description lockd
157 LVM commands use lvmlockd to coordinate access to shared storage.
158
159 %description lockd -l pl.UTF-8
160 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
161 współdzielonej pamięci masowej.
162
163 %package resource-agents
164 Summary:        OCF Resource Agents for LVM2 processes
165 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
166 Group:          Applications/System
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       resource-agents
169
170 %description resource-agents
171 OCF Resource Agents for LVM2 processes.
172
173 %description resource-agents -l pl.UTF-8
174 Agenci OCF do monitorowania procesów LVM2.
175
176 %package -n python-lvm
177 Summary:        Python 2 interface to LVM2
178 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
179 Group:          Libraries/Python
180 Requires:       device-mapper-libs = %{version}-%{release}
181
182 %description -n python-lvm
183 Python 2 interface to LVM2.
184
185 %description -n python-lvm -l pl.UTF-8
186 Interfejs Pythona 2 do LVM2.
187
188 %package -n python3-lvm
189 Summary:        Python 3 interface to LVM2
190 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
191 Group:          Libraries/Python
192 Requires:       device-mapper-libs = %{version}-%{release}
193
194 %description -n python3-lvm
195 Python 3 interface to LVM2.
196
197 %description -n python3-lvm -l pl.UTF-8
198 Interfejs Pythona 3 do LVM2.
199
200 %package -n device-mapper
201 Summary:        Userspace support for the device-mapper
202 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
203 Group:          Base
204 Requires(post,postun):  /sbin/ldconfig
205 Requires:       device-mapper-libs = %{version}-%{release}
206
207 %description -n device-mapper
208 The goal of this driver is to support volume management. The driver
209 enables the definition of new block devices composed of ranges of
210 sectors of existing devices. This can be used to define disk
211 partitions - or logical volumes. This light-weight kernel component
212 can support user-space tools for logical volume management.
213
214 %description -n device-mapper -l pl.UTF-8
215 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
216 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
217 sektorów na istniejących urządzeniach. Może to być wykorzystane do
218 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
219 składnik jądra może wspierać działające w przestrzeni użytkownika
220 narzędzia do zarządzania logicznymi wolumenami.
221
222 %package -n device-mapper-libs
223 Summary:        Device-mapper shared libraries
224 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
225 Group:          Libraries
226 Requires:       libblkid >= 2.24
227 Requires:       udev-libs >= 1:176
228 Conflicts:      device-mapper < 2.02.119-1
229
230 %description -n device-mapper-libs
231 Device-mapper shared libraries.
232
233 %description -n device-mapper-libs -l pl.UTF-8
234 Biblioteki współdzielone device-mappera.
235
236 %package -n device-mapper-devel
237 Summary:        Header files for device-mapper libraries
238 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
239 Group:          Development/Libraries
240 Requires:       device-mapper-libs = %{version}-%{release}
241 Requires:       libblkid-devel >= 2.24
242 %if %{with selinux}
243 Requires:       libselinux-devel
244 Requires:       libsepol-devel
245 %endif
246 Requires:       udev-devel >= 1:176
247
248 %description -n device-mapper-devel
249 Header files for device-mapper libraries.
250
251 %description -n device-mapper-devel -l pl.UTF-8
252 Pliki nagłówkowe bibliotek device-mappera.
253
254 %package -n device-mapper-static
255 Summary:        Static devmapper library
256 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
257 License:        LGPL v2.1
258 Group:          Development/Libraries
259 Requires:       device-mapper-devel = %{version}-%{release}
260
261 %description -n device-mapper-static
262 Static devmapper library.
263
264 %description -n device-mapper-static -l pl.UTF-8
265 Statyczna biblioteka devmapper.
266
267 %package -n device-mapper-dietlibc
268 Summary:        Static devmapper library built with dietlibc
269 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
270 License:        LGPL v2.1
271 Group:          Development/Libraries
272 Requires:       device-mapper-devel = %{version}-%{release}
273
274 %description -n device-mapper-dietlibc
275 Static devmapper library built with dietlibc.
276
277 %description -n device-mapper-dietlibc -l pl.UTF-8
278 Statyczna biblioteka devmapper zbudowana z dietlibc.
279
280 %prep
281 %setup -q -n LVM2.%{version}
282 %{?with_selinux:%patch0 -p1}
283 %patch1 -p1
284 %patch2 -p1
285 %patch3 -p1
286 %patch4 -p1
287 %patch5 -p1
288 %patch6 -p1
289 %patch7 -p1
290 %patch8 -p1
291
292 # do not force --export-symbol linker option for e.g. statically linked executables
293 # -rdynamic compiler option drives linker in the right way.
294 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
295
296 %build
297 cp -f /usr/share/automake/config.sub autoconf
298 %{__aclocal}
299 %{__autoconf}
300
301 %configure \
302         --enable-applib \
303         --enable-cache_check_needs_check \
304         --enable-cmdlib \
305         %{?with_lvmdbusd:--enable-dbus-service} \
306         %{?debug:--enable-debug} \
307         --enable-dmeventd \
308         --enable-fsadm \
309         --with-default-locking-dir=/var/lock/lvm \
310 %if %{with lvmlockd}
311         %{?with_cluster:--enable-lvmlockd-dlm} \
312         %{?with_sanlock:--enable-lvmlockd-sanlock} \
313 %endif
314         --enable-lvmpolld \
315         --enable-ocf \
316         %{?with_python2:--enable-python2_bindings} \
317         %{?with_python3:--enable-python3_bindings} \
318         --enable-readline \
319         %{!?with_selinux:--disable-selinux} \
320         --enable-pkgconfig \
321         --enable-thin_check_needs_check \
322         --enable-udev_sync \
323         --enable-udev_rules \
324         --disable-udev-systemd-background-jobs \
325         --with-cache=internal \
326         --with-cache-check=/usr/sbin/cache_check \
327         --with-cache-dump=/usr/sbin/cache_dump \
328         --with-cache-repair=/usr/sbin/cache_repair \
329         --with-cache-restore=/usr/sbin/cache_restore \
330         --with-cluster=internal \
331 %if %{with cluster}
332         --enable-cmirrord \
333 %endif
334         --with-dmeventd-path=%{_sbindir}/dmeventd \
335         --with-interface=ioctl \
336         --with-lvm1=internal \
337         --with-mirrors=internal \
338         --with-optimisation="%{rpmcflags}" \
339         --with-pool=internal \
340         %{?with_replicator:--with-replicators=internal} \
341         --with-snapshots=internal \
342         --with-thin=internal \
343         --with-thin-check=/usr/sbin/thin_check \
344         --with-thin-dump=/usr/sbin/thin_dump \
345         --with-thin-repair=/usr/sbin/thin_repair \
346         --with-thin-restore=/usr/sbin/thin_restore \
347         --with-udev-prefix=/ \
348         --with-usrlibdir=%{_libdir}
349 # use bash because of "set -o pipefail"
350 %{__make} -j1 \
351         SHELL=/bin/bash
352 %{__make} -j1 -C libdm \
353         LIB_STATIC=libdevmapper.a
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
358
359 %{__make} install install_system_dirs install_initscripts \
360         DESTDIR=$RPM_BUILD_ROOT \
361         OWNER="" \
362         GROUP="" \
363         python3dir=%{py3_sitescriptdir}
364
365 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
366 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
367         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
368         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
369         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
370 done
371
372 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
373
374 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
375
376 %clean
377 rm -rf $RPM_BUILD_ROOT
378
379 %triggerin -- lvm2 < 2.03.00
380 %service lvm2-lvmetad stop
381 /sbin/chkconfig --del lvm2-lvmetad
382
383 %triggerin -- lvm2-clvmd
384 %service clvmd stop
385 /sbin/chkconfig --del clvmd
386
387 %post
388 /sbin/chkconfig --add lvm2-monitor
389 %service lvm2-monitor restart
390 /sbin/chkconfig --add lvm2-lvmpolld
391 %service lvm2-lvmpolld restart
392 # no service restart available
393 /sbin/chkconfig --add blk-availability
394 # no service blk-availability restart
395
396 %preun
397 if [ "$1" = "0" ]; then
398         %service lvm2-lvmpolld stop
399         /sbin/chkconfig --del lvm2-lvmpolld
400         %service lvm2-monitor stop
401         /sbin/chkconfig --del lvm2-monitor
402         #no service blk-availability stop
403         /sbin/chkconfig --del blk-availability
404 fi
405
406 %post   -n device-mapper-libs -p /sbin/ldconfig
407 %postun -n device-mapper-libs -p /sbin/ldconfig
408
409 %files
410 %defattr(644,root,root,755)
411 %doc README WHATS_NEW doc/*
412 %attr(755,root,root) %{_sbindir}/blkdeactivate
413 %attr(755,root,root) %{_sbindir}/fsadm
414 %attr(755,root,root) %{_sbindir}/lvchange
415 %attr(755,root,root) %{_sbindir}/lvconvert
416 %attr(755,root,root) %{_sbindir}/lvcreate
417 %attr(755,root,root) %{_sbindir}/lvdisplay
418 %attr(755,root,root) %{_sbindir}/lvextend
419 %attr(755,root,root) %{_sbindir}/lvm
420 %attr(755,root,root) %{_sbindir}/lvmconfig
421 %attr(755,root,root) %{_sbindir}/lvmdiskscan
422 %attr(755,root,root) %{_sbindir}/lvmdump
423 %attr(755,root,root) %{_sbindir}/lvmsadc
424 %attr(755,root,root) %{_sbindir}/lvmsar
425 %attr(755,root,root) %{_sbindir}/lvreduce
426 %attr(755,root,root) %{_sbindir}/lvremove
427 %attr(755,root,root) %{_sbindir}/lvrename
428 %attr(755,root,root) %{_sbindir}/lvresize
429 %attr(755,root,root) %{_sbindir}/lvs
430 %attr(755,root,root) %{_sbindir}/lvscan
431 %attr(755,root,root) %{_sbindir}/pvchange
432 %attr(755,root,root) %{_sbindir}/pvck
433 %attr(755,root,root) %{_sbindir}/pvcreate
434 %attr(755,root,root) %{_sbindir}/pvdisplay
435 %attr(755,root,root) %{_sbindir}/pvmove
436 %attr(755,root,root) %{_sbindir}/pvremove
437 %attr(755,root,root) %{_sbindir}/pvresize
438 %attr(755,root,root) %{_sbindir}/pvs
439 %attr(755,root,root) %{_sbindir}/pvscan
440 %attr(755,root,root) %{_sbindir}/vgcfgbackup
441 %attr(755,root,root) %{_sbindir}/vgcfgrestore
442 %attr(755,root,root) %{_sbindir}/vgchange
443 %attr(755,root,root) %{_sbindir}/vgck
444 %attr(755,root,root) %{_sbindir}/vgconvert
445 %attr(755,root,root) %{_sbindir}/vgcreate
446 %attr(755,root,root) %{_sbindir}/vgdisplay
447 %attr(755,root,root) %{_sbindir}/vgexport
448 %attr(755,root,root) %{_sbindir}/vgextend
449 %attr(755,root,root) %{_sbindir}/vgimport
450 %attr(755,root,root) %{_sbindir}/vgimportclone
451 %attr(755,root,root) %{_sbindir}/vgmerge
452 %attr(755,root,root) %{_sbindir}/vgmknodes
453 %attr(755,root,root) %{_sbindir}/vgreduce
454 %attr(755,root,root) %{_sbindir}/vgremove
455 %attr(755,root,root) %{_sbindir}/vgrename
456 %attr(755,root,root) %{_sbindir}/vgs
457 %attr(755,root,root) %{_sbindir}/vgscan
458 %attr(755,root,root) %{_sbindir}/vgsplit
459 %{_mandir}/man5/lvm.conf.5*
460 %{_mandir}/man7/lvmcache.7*
461 %{_mandir}/man7/lvmraid.7*
462 %{_mandir}/man7/lvmreport.7*
463 %{_mandir}/man7/lvmsystemid.7*
464 %{_mandir}/man7/lvmthin.7*
465 %{_mandir}/man7/lvmvdo.7*
466 %{_mandir}/man8/blkdeactivate.8*
467 %{_mandir}/man8/fsadm.8*
468 %{_mandir}/man8/lvchange.8*
469 %{_mandir}/man8/lvconvert.8*
470 %{_mandir}/man8/lvcreate.8*
471 %{_mandir}/man8/lvdisplay.8*
472 %{_mandir}/man8/lvextend.8*
473 %{_mandir}/man8/lvm-config.8*
474 %{_mandir}/man8/lvm-dumpconfig.8*
475 %{_mandir}/man8/lvm-fullreport.8*
476 %{_mandir}/man8/lvm-lvpoll.8*
477 %{_mandir}/man8/lvm.8*
478 %{_mandir}/man8/lvmconfig.8*
479 %{_mandir}/man8/lvmdiskscan.8*
480 %{_mandir}/man8/lvmdump.8*
481 %{_mandir}/man8/lvmsadc.8*
482 %{_mandir}/man8/lvmsar.8*
483 %{_mandir}/man8/lvreduce.8*
484 %{_mandir}/man8/lvremove.8*
485 %{_mandir}/man8/lvrename.8*
486 %{_mandir}/man8/lvresize.8*
487 %{_mandir}/man8/lvs.8*
488 %{_mandir}/man8/lvscan.8*
489 %{_mandir}/man8/pvchange.8*
490 %{_mandir}/man8/pvck.8*
491 %{_mandir}/man8/pvcreate.8*
492 %{_mandir}/man8/pvdisplay.8*
493 %{_mandir}/man8/pvmove.8*
494 %{_mandir}/man8/pvremove.8*
495 %{_mandir}/man8/pvresize.8*
496 %{_mandir}/man8/pvs.8*
497 %{_mandir}/man8/pvscan.8*
498 %{_mandir}/man8/vgcfgbackup.8*
499 %{_mandir}/man8/vgcfgrestore.8*
500 %{_mandir}/man8/vgchange.8*
501 %{_mandir}/man8/vgck.8*
502 %{_mandir}/man8/vgconvert.8*
503 %{_mandir}/man8/vgcreate.8*
504 %{_mandir}/man8/vgdisplay.8*
505 %{_mandir}/man8/vgexport.8*
506 %{_mandir}/man8/vgextend.8*
507 %{_mandir}/man8/vgimport.8*
508 %{_mandir}/man8/vgimportclone.8*
509 %{_mandir}/man8/vgmerge.8*
510 %{_mandir}/man8/vgmknodes.8*
511 %{_mandir}/man8/vgreduce.8*
512 %{_mandir}/man8/vgremove.8*
513 %{_mandir}/man8/vgrename.8*
514 %{_mandir}/man8/vgs.8*
515 %{_mandir}/man8/vgscan.8*
516 %{_mandir}/man8/vgsplit.8*
517 %attr(750,root,root) %dir %{_sysconfdir}/lvm
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
520 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
528 %dir %{_sysconfdir}/lvm/cache
529 %ghost %{_sysconfdir}/lvm/cache/.cache
530 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
531 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
532 %attr(700,root,root) %dir /var/run/lvm
533 %attr(700,root,root) %dir /var/lock/lvm
534 %if %{with lvmlockd}
535 %attr(755,root,root) %{_sbindir}/lvmlockctl
536 %attr(755,root,root) %{_sbindir}/lvmlockd
537 %{_mandir}/man8/lvmlockctl.8*
538 %{_mandir}/man8/lvmlockd.8*
539 %endif
540 %if %{with lvmpolld}
541 %attr(755,root,root) %{_sbindir}/lvmpolld
542 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
543 %{_mandir}/man8/lvmpolld.8*
544 %endif
545
546 %if %{with cluster}
547 %files cmirrord
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_usrsbindir}/cmirrord
550 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
551 %{_mandir}/man8/cmirrord.8*
552 %endif
553
554 %if %{with lvmdbusd}
555 %files dbusd
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_sbindir}/lvmdbusd
558 %{py3_sitescriptdir}/lvmdbusd
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
560 %{_mandir}/man8/lvmdbusd.8*
561 %endif
562
563 %files resource-agents
564 %defattr(644,root,root,755)
565 %dir %{_prefix}/lib/ocf/resource.d/lvm2
566 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
567
568 %if %{with python2}
569 %files -n python-lvm
570 %defattr(644,root,root,755)
571 #%attr(755,root,root) %{py_sitedir}/lvm.so
572 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
573 %endif
574
575 %if %{with python3}
576 %files -n python3-lvm
577 %defattr(644,root,root,755)
578 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
579 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
580 %endif
581
582 %files -n device-mapper
583 %defattr(644,root,root,755)
584 %doc *_DM
585 /lib/udev/rules.d/10-dm.rules
586 /lib/udev/rules.d/11-dm-lvm.rules
587 /lib/udev/rules.d/13-dm-disk.rules
588 /lib/udev/rules.d/69-dm-lvm-metad.rules
589 /lib/udev/rules.d/95-dm-notify.rules
590 %attr(755,root,root) %{_sbindir}/dmeventd
591 %attr(755,root,root) %{_sbindir}/dmsetup
592 %attr(755,root,root) %{_sbindir}/dmstats
593 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
594 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
595 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
596 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
597 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
598 %dir %{_libdir}/device-mapper
599 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
600 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
601 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
602 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
603 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
604 %{_mandir}/man8/dmsetup.8*
605 %{_mandir}/man8/dmstats.8*
606 %{_mandir}/man8/dmeventd.8*
607
608 %files -n device-mapper-libs
609 %defattr(644,root,root,755)
610 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
611 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
612 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
613 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
614
615 %files -n device-mapper-devel
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libdevmapper.so
618 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
619 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
620 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
621 %{_includedir}/libdevmapper.h
622 %{_includedir}/libdevmapper-event.h
623 %{_includedir}/lvm2cmd.h
624 %{_pkgconfigdir}/devmapper.pc
625 %{_pkgconfigdir}/devmapper-event.pc
626
627 %files -n device-mapper-static
628 %defattr(644,root,root,755)
629 %{_libdir}/libdevmapper.a