]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- fix run dir problems (got messed up during update)
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
4 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
5 #    note: dmeventd requires mirrors=internal)
6 #
7 # Conditional build:
8 # - functionality
9 %bcond_without  cluster         # disable all cluster support (cmirrord)
10 %bcond_without  lvmdbusd        # lvmdbusd
11 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
12 %bcond_without  lvmlockd        # lvmlockd
13 %bcond_with     sanlock         # sanlock support in lvmlockd
14 %bcond_with     replicator      # internal replicator support
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # for convenience
23 %if %{without python}
24 %undefine       with_python2
25 %undefine       with_python3
26 %endif
27 %if %{without python3}
28 %undefine       with_lvmdbusd
29 %endif
30
31 Summary:        The new version of Logical Volume Manager for Linux
32 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
33 Name:           lvm2
34 Version:        2.03.00
35 Release:        1.1
36 License:        GPL v2 and LGPL v2.1
37 Group:          Applications/System
38 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
39 # Source0-md5:  f63cc5feaadd3000138e73f7143ed370
40 Patch0:         %{name}-selinux.patch
41 Patch1:         device-mapper-dmsetup-export.patch
42 Patch2:         %{name}-tld_init.patch
43 Patch3:         dl-dlsym.patch
44 Patch4:         %{name}-run-dir.patch
45 Patch5:         device-mapper-dmsetup-deps-export.patch
46 Patch6:         %{name}-thin.patch
47 Patch7:         %{name}-no-systemd.patch
48 URL:            http://www.sourceware.org/lvm2/
49 BuildRequires:  autoconf >= 2.69
50 BuildRequires:  automake
51 # for /run detection
52 BuildRequires:  filesystem >= 3.0-43
53 BuildRequires:  libblkid-devel >= 2.24
54 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
55 %{?with_selinux:BuildRequires:  libsepol-devel}
56 BuildRequires:  ncurses-devel
57 BuildRequires:  pkgconfig
58 %{?with_python2:BuildRequires:  python-devel >= 2}
59 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
60 %if %{with lvmdbusd}
61 BuildRequires:  python3-dbus
62 BuildRequires:  python3-pyudev
63 %endif
64 BuildRequires:  readline-devel
65 BuildRequires:  rpmbuild(macros) >= 1.647
66 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
67 BuildRequires:  udev-devel >= 1:176
68 %if %{with cluster}
69 BuildRequires:  corosync-devel
70 BuildRequires:  dlm-devel >= 3.99.5
71 %endif
72 Requires(post,postun):  /sbin/chkconfig
73 Requires:       device-mapper >= %{version}-%{release}
74 %{?with_selinux:Requires:       libselinux >= 1.10}
75 # doesn't work with 2.4 kernels
76 Requires:       uname(release) >= 2.6
77 Suggests:       thin-provisioning-tools >= 0.5.4
78 Obsoletes:      lvm
79 Obsoletes:      lvm2-clvmd
80 Obsoletes:      lvm2-systemd
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _sbindir        /sbin
84 %define         _usrsbindir     /usr/sbin
85
86 # changing CFLAGS in the middle confuses confcache
87 %undefine       configure_cache
88
89 # borken on AC
90 %define         filterout_ld    -Wl,--as-needed
91
92 # causes: undefined reference to `__stack_chk_fail_local'
93 %define         filterout_c     -fstack-protector
94
95 %define         skip_post_check_so      '.*(libdevmapper-event.so|libdevmapper-event-lvm2.so).*'
96
97 %description
98 This package includes a number of utilities for creating, checking,
99 and repairing logical volumes.
100
101 %description -l pl.UTF-8
102 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
103 logicznych wolumenów dyskowych (LVM2).
104
105 %package cmirrord
106 Summary:        Cluster mirror log daemon
107 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
108 Group:          Applications/System
109 Requires:       %{name} = %{version}-%{release}
110
111 %description cmirrord
112 cmirrord is the daemon that tracks mirror log information in a
113 cluster. It is specific to device-mapper based mirrors (and by
114 extension, LVM cluster mirrors). Cluster mirrors are not possible
115 without this daemon running.
116
117 This daemon relies on the cluster infrastructure provided by the
118 Cluster MANager (CMAN), which must be set up and running in order for
119 cmirrord to function.
120
121 %description cmirrord
122 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
123 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
124 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
125 lustrzanych ten demon jest niezbędny.
126
127 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
128 (Cluster MANager), który musi być skonfigurowany i działający, aby
129 działał cmirrord.
130
131 %package dbusd
132 Summary:        LVM2 D-Bus daemon
133 Summary(pl.UTF-8):      Demon LVM2 D-Bus
134 Group:          Daemons
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       python3-dbus
137 Requires:       python3-pygobject3 >= 3
138 Requires:       python3-pyudev
139
140 %description dbusd
141 Daemon for access to LVM2 functionality through a D-Bus interface.
142
143 %description dbusd -l pl.UTF-8
144 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
145 D-Bus.
146
147 %package lockd
148 Summary:        LVM2 locking daemon
149 Summary(pl.UTF-8):      Demon blokad LVM2
150 Group:          Daemons
151 Requires:       %{name} = %{version}-%{release}
152 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
153 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
154
155 %description lockd
156 LVM commands use lvmlockd to coordinate access to shared storage.
157
158 %description lockd -l pl.UTF-8
159 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
160 współdzielonej pamięci masowej.
161
162 %package resource-agents
163 Summary:        OCF Resource Agents for LVM2 processes
164 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
165 Group:          Applications/System
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       resource-agents
168
169 %description resource-agents
170 OCF Resource Agents for LVM2 processes.
171
172 %description resource-agents -l pl.UTF-8
173 Agenci OCF do monitorowania procesów LVM2.
174
175 %package -n python-lvm
176 Summary:        Python 2 interface to LVM2
177 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
178 Group:          Libraries/Python
179 Requires:       device-mapper-libs = %{version}-%{release}
180
181 %description -n python-lvm
182 Python 2 interface to LVM2.
183
184 %description -n python-lvm -l pl.UTF-8
185 Interfejs Pythona 2 do LVM2.
186
187 %package -n python3-lvm
188 Summary:        Python 3 interface to LVM2
189 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
190 Group:          Libraries/Python
191 Requires:       device-mapper-libs = %{version}-%{release}
192
193 %description -n python3-lvm
194 Python 3 interface to LVM2.
195
196 %description -n python3-lvm -l pl.UTF-8
197 Interfejs Pythona 3 do LVM2.
198
199 %package -n device-mapper
200 Summary:        Userspace support for the device-mapper
201 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
202 Group:          Base
203 Requires(post,postun):  /sbin/ldconfig
204 Requires:       device-mapper-libs = %{version}-%{release}
205
206 %description -n device-mapper
207 The goal of this driver is to support volume management. The driver
208 enables the definition of new block devices composed of ranges of
209 sectors of existing devices. This can be used to define disk
210 partitions - or logical volumes. This light-weight kernel component
211 can support user-space tools for logical volume management.
212
213 %description -n device-mapper -l pl.UTF-8
214 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
215 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
216 sektorów na istniejących urządzeniach. Może to być wykorzystane do
217 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
218 składnik jądra może wspierać działające w przestrzeni użytkownika
219 narzędzia do zarządzania logicznymi wolumenami.
220
221 %package -n device-mapper-libs
222 Summary:        Device-mapper shared libraries
223 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
224 Group:          Libraries
225 Requires:       libblkid >= 2.24
226 Requires:       udev-libs >= 1:176
227 Conflicts:      device-mapper < 2.02.119-1
228
229 %description -n device-mapper-libs
230 Device-mapper shared libraries.
231
232 %description -n device-mapper-libs -l pl.UTF-8
233 Biblioteki współdzielone device-mappera.
234
235 %package -n device-mapper-devel
236 Summary:        Header files for device-mapper libraries
237 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
238 Group:          Development/Libraries
239 Requires:       device-mapper-libs = %{version}-%{release}
240 Requires:       libblkid-devel >= 2.24
241 %if %{with selinux}
242 Requires:       libselinux-devel
243 Requires:       libsepol-devel
244 %endif
245 Requires:       udev-devel >= 1:176
246
247 %description -n device-mapper-devel
248 Header files for device-mapper libraries.
249
250 %description -n device-mapper-devel -l pl.UTF-8
251 Pliki nagłówkowe bibliotek device-mappera.
252
253 %package -n device-mapper-static
254 Summary:        Static devmapper library
255 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
256 License:        LGPL v2.1
257 Group:          Development/Libraries
258 Requires:       device-mapper-devel = %{version}-%{release}
259
260 %description -n device-mapper-static
261 Static devmapper library.
262
263 %description -n device-mapper-static -l pl.UTF-8
264 Statyczna biblioteka devmapper.
265
266 %package -n device-mapper-dietlibc
267 Summary:        Static devmapper library built with dietlibc
268 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
269 License:        LGPL v2.1
270 Group:          Development/Libraries
271 Requires:       device-mapper-devel = %{version}-%{release}
272
273 %description -n device-mapper-dietlibc
274 Static devmapper library built with dietlibc.
275
276 %description -n device-mapper-dietlibc -l pl.UTF-8
277 Statyczna biblioteka devmapper zbudowana z dietlibc.
278
279 %prep
280 %setup -q -n LVM2.%{version}
281 %{?with_selinux:%patch0 -p1}
282 %patch1 -p1
283 %patch2 -p1
284 %patch3 -p1
285 %patch4 -p1
286 %patch5 -p1
287 %patch6 -p1
288 %patch7 -p1
289
290 # do not force --export-symbol linker option for e.g. statically linked executables
291 # -rdynamic compiler option drives linker in the right way.
292 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
293
294 %build
295 cp -f /usr/share/automake/config.sub autoconf
296 %{__aclocal}
297 %{__autoconf}
298
299 %configure \
300         --enable-applib \
301         --enable-cache_check_needs_check \
302         --enable-cmdlib \
303         %{?with_lvmdbusd:--enable-dbus-service} \
304         %{?debug:--enable-debug} \
305         --enable-dmeventd \
306         --enable-fsadm \
307         --with-default-locking-dir=/var/lock/lvm \
308 %if %{with lvmlockd}
309         %{?with_cluster:--enable-lvmlockd-dlm} \
310         %{?with_sanlock:--enable-lvmlockd-sanlock} \
311 %endif
312         --enable-lvmpolld \
313         --enable-ocf \
314         %{?with_python2:--enable-python2_bindings} \
315         %{?with_python3:--enable-python3_bindings} \
316         --enable-readline \
317         %{!?with_selinux:--disable-selinux} \
318         --enable-pkgconfig \
319         --enable-thin_check_needs_check \
320         --enable-udev_sync \
321         --enable-udev_rules \
322         --disable-udev-systemd-background-jobs \
323         --with-cache=internal \
324         --with-cache-check=/usr/sbin/cache_check \
325         --with-cache-dump=/usr/sbin/cache_dump \
326         --with-cache-repair=/usr/sbin/cache_repair \
327         --with-cache-restore=/usr/sbin/cache_restore \
328         --with-cluster=internal \
329 %if %{with cluster}
330         --enable-cmirrord \
331 %endif
332         --with-dmeventd-path=%{_sbindir}/dmeventd \
333         --with-interface=ioctl \
334         --with-lvm1=internal \
335         --with-mirrors=internal \
336         --with-optimisation="%{rpmcflags}" \
337         --with-pool=internal \
338         %{?with_replicator:--with-replicators=internal} \
339         --with-snapshots=internal \
340         --with-thin=internal \
341         --with-thin-check=/usr/sbin/thin_check \
342         --with-thin-dump=/usr/sbin/thin_dump \
343         --with-thin-repair=/usr/sbin/thin_repair \
344         --with-thin-restore=/usr/sbin/thin_restore \
345         --with-udev-prefix=/ \
346         --with-usrlibdir=%{_libdir}
347 # use bash because of "set -o pipefail"
348 %{__make} -j1 \
349         SHELL=/bin/bash
350 %{__make} -j1 -C libdm \
351         LIB_STATIC=libdevmapper.a
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
356
357 %{__make} install install_system_dirs install_initscripts \
358         DESTDIR=$RPM_BUILD_ROOT \
359         OWNER="" \
360         GROUP="" \
361         python3dir=%{py3_sitescriptdir}
362
363 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
364 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
365         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
366         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
367         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
368 done
369
370 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
371
372 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
373
374 %clean
375 rm -rf $RPM_BUILD_ROOT
376
377 %triggerin -- lvm2 < 2.03.00
378 %service lvm2-lvmetad stop
379 /sbin/chkconfig --del lvm2-lvmetad
380
381 %triggerin -- lvm2-clvmd
382 %service clvmd stop
383 /sbin/chkconfig --del clvmd
384
385 %post
386 /sbin/chkconfig --add lvm2-monitor
387 %service lvm2-monitor restart
388 /sbin/chkconfig --add lvm2-lvmpolld
389 %service lvm2-lvmpolld restart
390 # no service restart available
391 /sbin/chkconfig --add blk-availability
392 # no service blk-availability restart
393
394 %preun
395 if [ "$1" = "0" ]; then
396         %service lvm2-lvmpolld stop
397         /sbin/chkconfig --del lvm2-lvmpolld
398         %service lvm2-monitor stop
399         /sbin/chkconfig --del lvm2-monitor
400         #no service blk-availability stop
401         /sbin/chkconfig --del blk-availability
402 fi
403
404 %post   -n device-mapper-libs -p /sbin/ldconfig
405 %postun -n device-mapper-libs -p /sbin/ldconfig
406
407 %files
408 %defattr(644,root,root,755)
409 %doc README WHATS_NEW doc/*
410 %attr(755,root,root) %{_sbindir}/blkdeactivate
411 %attr(755,root,root) %{_sbindir}/fsadm
412 %attr(755,root,root) %{_sbindir}/lvchange
413 %attr(755,root,root) %{_sbindir}/lvconvert
414 %attr(755,root,root) %{_sbindir}/lvcreate
415 %attr(755,root,root) %{_sbindir}/lvdisplay
416 %attr(755,root,root) %{_sbindir}/lvextend
417 %attr(755,root,root) %{_sbindir}/lvm
418 %attr(755,root,root) %{_sbindir}/lvmconfig
419 %attr(755,root,root) %{_sbindir}/lvmdiskscan
420 %attr(755,root,root) %{_sbindir}/lvmdump
421 %attr(755,root,root) %{_sbindir}/lvmsadc
422 %attr(755,root,root) %{_sbindir}/lvmsar
423 %attr(755,root,root) %{_sbindir}/lvreduce
424 %attr(755,root,root) %{_sbindir}/lvremove
425 %attr(755,root,root) %{_sbindir}/lvrename
426 %attr(755,root,root) %{_sbindir}/lvresize
427 %attr(755,root,root) %{_sbindir}/lvs
428 %attr(755,root,root) %{_sbindir}/lvscan
429 %attr(755,root,root) %{_sbindir}/pvchange
430 %attr(755,root,root) %{_sbindir}/pvck
431 %attr(755,root,root) %{_sbindir}/pvcreate
432 %attr(755,root,root) %{_sbindir}/pvdisplay
433 %attr(755,root,root) %{_sbindir}/pvmove
434 %attr(755,root,root) %{_sbindir}/pvremove
435 %attr(755,root,root) %{_sbindir}/pvresize
436 %attr(755,root,root) %{_sbindir}/pvs
437 %attr(755,root,root) %{_sbindir}/pvscan
438 %attr(755,root,root) %{_sbindir}/vgcfgbackup
439 %attr(755,root,root) %{_sbindir}/vgcfgrestore
440 %attr(755,root,root) %{_sbindir}/vgchange
441 %attr(755,root,root) %{_sbindir}/vgck
442 %attr(755,root,root) %{_sbindir}/vgconvert
443 %attr(755,root,root) %{_sbindir}/vgcreate
444 %attr(755,root,root) %{_sbindir}/vgdisplay
445 %attr(755,root,root) %{_sbindir}/vgexport
446 %attr(755,root,root) %{_sbindir}/vgextend
447 %attr(755,root,root) %{_sbindir}/vgimport
448 %attr(755,root,root) %{_sbindir}/vgimportclone
449 %attr(755,root,root) %{_sbindir}/vgmerge
450 %attr(755,root,root) %{_sbindir}/vgmknodes
451 %attr(755,root,root) %{_sbindir}/vgreduce
452 %attr(755,root,root) %{_sbindir}/vgremove
453 %attr(755,root,root) %{_sbindir}/vgrename
454 %attr(755,root,root) %{_sbindir}/vgs
455 %attr(755,root,root) %{_sbindir}/vgscan
456 %attr(755,root,root) %{_sbindir}/vgsplit
457 %{_mandir}/man5/lvm.conf.5*
458 %{_mandir}/man7/lvmcache.7*
459 %{_mandir}/man7/lvmraid.7*
460 %{_mandir}/man7/lvmreport.7*
461 %{_mandir}/man7/lvmsystemid.7*
462 %{_mandir}/man7/lvmthin.7*
463 %{_mandir}/man8/blkdeactivate.8*
464 %{_mandir}/man8/fsadm.8*
465 %{_mandir}/man8/lvchange.8*
466 %{_mandir}/man8/lvconvert.8*
467 %{_mandir}/man8/lvcreate.8*
468 %{_mandir}/man8/lvdisplay.8*
469 %{_mandir}/man8/lvextend.8*
470 %{_mandir}/man8/lvm-config.8*
471 %{_mandir}/man8/lvm-dumpconfig.8*
472 %{_mandir}/man8/lvm-fullreport.8*
473 %{_mandir}/man8/lvm-lvpoll.8*
474 %{_mandir}/man8/lvm.8*
475 %{_mandir}/man8/lvmconfig.8*
476 %{_mandir}/man8/lvmdiskscan.8*
477 %{_mandir}/man8/lvmdump.8*
478 %{_mandir}/man8/lvmsadc.8*
479 %{_mandir}/man8/lvmsar.8*
480 %{_mandir}/man8/lvreduce.8*
481 %{_mandir}/man8/lvremove.8*
482 %{_mandir}/man8/lvrename.8*
483 %{_mandir}/man8/lvresize.8*
484 %{_mandir}/man8/lvs.8*
485 %{_mandir}/man8/lvscan.8*
486 %{_mandir}/man8/pvchange.8*
487 %{_mandir}/man8/pvck.8*
488 %{_mandir}/man8/pvcreate.8*
489 %{_mandir}/man8/pvdisplay.8*
490 %{_mandir}/man8/pvmove.8*
491 %{_mandir}/man8/pvremove.8*
492 %{_mandir}/man8/pvresize.8*
493 %{_mandir}/man8/pvs.8*
494 %{_mandir}/man8/pvscan.8*
495 %{_mandir}/man8/vgcfgbackup.8*
496 %{_mandir}/man8/vgcfgrestore.8*
497 %{_mandir}/man8/vgchange.8*
498 %{_mandir}/man8/vgck.8*
499 %{_mandir}/man8/vgconvert.8*
500 %{_mandir}/man8/vgcreate.8*
501 %{_mandir}/man8/vgdisplay.8*
502 %{_mandir}/man8/vgexport.8*
503 %{_mandir}/man8/vgextend.8*
504 %{_mandir}/man8/vgimport.8*
505 %{_mandir}/man8/vgimportclone.8*
506 %{_mandir}/man8/vgmerge.8*
507 %{_mandir}/man8/vgmknodes.8*
508 %{_mandir}/man8/vgreduce.8*
509 %{_mandir}/man8/vgremove.8*
510 %{_mandir}/man8/vgrename.8*
511 %{_mandir}/man8/vgs.8*
512 %{_mandir}/man8/vgscan.8*
513 %{_mandir}/man8/vgsplit.8*
514 %attr(750,root,root) %dir %{_sysconfdir}/lvm
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
517 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
525 %dir %{_sysconfdir}/lvm/cache
526 %ghost %{_sysconfdir}/lvm/cache/.cache
527 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
528 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
529 %attr(700,root,root) %dir /var/run/lvm
530 %attr(700,root,root) %dir /var/lock/lvm
531 %if %{with lvmlockd}
532 %attr(755,root,root) %{_sbindir}/lvmlockctl
533 %attr(755,root,root) %{_sbindir}/lvmlockd
534 %{_mandir}/man8/lvmlockctl.8*
535 %{_mandir}/man8/lvmlockd.8*
536 %endif
537 %if %{with lvmpolld}
538 %attr(755,root,root) %{_sbindir}/lvmpolld
539 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
540 %{_mandir}/man8/lvmpolld.8*
541 %endif
542
543 %if %{with cluster}
544 %files cmirrord
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_usrsbindir}/cmirrord
547 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
548 %{_mandir}/man8/cmirrord.8*
549 %endif
550
551 %if %{with lvmdbusd}
552 %files dbusd
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_sbindir}/lvmdbusd
555 %{py3_sitescriptdir}/lvmdbusd
556 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
557 %{_mandir}/man8/lvmdbusd.8*
558 %endif
559
560 %files resource-agents
561 %defattr(644,root,root,755)
562 %dir %{_prefix}/lib/ocf/resource.d/lvm2
563 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
564
565 %if %{with python2}
566 %files -n python-lvm
567 %defattr(644,root,root,755)
568 #%attr(755,root,root) %{py_sitedir}/lvm.so
569 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
570 %endif
571
572 %if %{with python3}
573 %files -n python3-lvm
574 %defattr(644,root,root,755)
575 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
576 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
577 %endif
578
579 %files -n device-mapper
580 %defattr(644,root,root,755)
581 %doc *_DM
582 /lib/udev/rules.d/10-dm.rules
583 /lib/udev/rules.d/11-dm-lvm.rules
584 /lib/udev/rules.d/13-dm-disk.rules
585 /lib/udev/rules.d/95-dm-notify.rules
586 %attr(755,root,root) %{_sbindir}/dmeventd
587 %attr(755,root,root) %{_sbindir}/dmsetup
588 %attr(755,root,root) %{_sbindir}/dmstats
589 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
590 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
591 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
592 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
593 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
594 %dir %{_libdir}/device-mapper
595 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
596 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
597 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
598 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
599 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
600 %{_mandir}/man8/dmsetup.8*
601 %{_mandir}/man8/dmstats.8*
602 %{_mandir}/man8/dmeventd.8*
603
604 %files -n device-mapper-libs
605 %defattr(644,root,root,755)
606 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
607 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
608 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
609 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
610
611 %files -n device-mapper-devel
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/libdevmapper.so
614 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
615 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
616 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
617 %{_includedir}/libdevmapper.h
618 %{_includedir}/libdevmapper-event.h
619 %{_includedir}/lvm2cmd.h
620 %{_pkgconfigdir}/devmapper.pc
621 %{_pkgconfigdir}/devmapper-event.pc
622
623 %files -n device-mapper-static
624 %defattr(644,root,root,755)
625 %{_libdir}/libdevmapper.a