]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- PLD merge
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # don't build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad
12 %bcond_without  selinux         # disable SELinux
13
14 %ifarch sparc64 sparc
15 %define         with_glibc 1
16 %endif
17
18 # if one of the *libc is enabled disable default dietlibc
19 %if %{with dietlibc} && %{with uClibc}
20 %undefine       with_dietlibc
21 %endif
22
23 # with glibc disables default dietlibc
24 %if %{with glibc} && %{with dietlibc}
25 %undefine       with_dietlibc
26 %endif
27
28 # fallback is glibc if neither alternatives are enabled
29 %if %{without dietlibc} && %{without uClibc}
30 %define         with_glibc      1
31 %endif
32
33 Summary:        The new version of Logical Volume Manager for Linux
34 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
35 Name:           lvm2
36 Version:        2.02.105
37 Release:        1
38 License:        GPL v2 and LGPL v2.1
39 Group:          Applications/System
40 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
41 # Source0-md5:  b5b3540661fc70bf329b526c1cfbcf3a
42 Source1:        %{name}-tmpfiles.conf
43 Source2:        clvmd.service
44 Source3:        clvmd.sysconfig
45 Patch0:         %{name}-selinux.patch
46 Patch1:         %{name}-diet.patch
47 Patch2:         device-mapper-dmsetup-export.patch
48 Patch3:         %{name}-pld_init.patch
49 Patch4:         dl-dlsym.patch
50 Patch5:         %{name}-wrapper.patch
51 Patch6:         %{name}-lvm_path.patch
52 Patch7:         %{name}-sd_notify.patch
53 Patch8:         %{name}-clvmd_cmd_timeout.patch
54 Patch9:         device-mapper-dmsetup-deps-export.patch
55 URL:            http://sources.redhat.com/lvm2/
56 BuildRequires:  autoconf >= 2.61
57 BuildRequires:  automake
58 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
59 %{?with_selinux:BuildRequires:  libsepol-devel}
60 BuildRequires:  ncurses-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  readline-devel
63 BuildRequires:  rpmbuild(macros) >= 1.647
64 BuildRequires:  udev-devel >= 1:143
65 %if %{with initrd}
66 %if %{with dietlibc}
67 BuildRequires:  dietlibc-static >= 2:0.32-7
68 BuildConflicts: device-mapper-dietlibc
69 %endif
70 %if %{with glibc}
71 %{?with_selinux:BuildRequires:  libselinux-static}
72 %{?with_selinux:BuildRequires:  libsepol-static}
73 %endif
74 %{?with_glibc:BuildRequires:    glibc-static}
75 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
76 %endif
77 %if %{with cluster}
78 BuildRequires:  corosync-devel
79 BuildRequires:  dlm-devel >= 3.99.5
80 BuildRequires:  systemd-devel
81 %endif
82 Requires(post,preun,postun):    systemd-units >= 38
83 Requires(post,postun):  /sbin/chkconfig
84 Requires:       device-mapper >= %{version}-%{release}
85 %{?with_selinux:Requires:       libselinux >= 1.10}
86 Requires:       systemd-units >= 38
87 # doesn't work with 2.4 kernels
88 Requires:       uname(release) >= 2.6
89 Obsoletes:      lvm
90 Obsoletes:      lvm2-systemd
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _sbindir        /sbin
94 %define         _usrsbindir     /usr/sbin
95
96 # changing CFLAGS in the middle confuses confcache
97 %undefine       configure_cache
98
99 # borken on AC
100 %define         filterout_ld    -Wl,--as-needed
101
102 # causes: undefined reference to `__stack_chk_fail_local'
103 %define         filterout_c     -fstack-protector
104
105 # for some reason known only to rpm there must be "\\|" not "\|" here
106 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
107 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
108
109 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
110
111 %description
112 This package includes a number of utilities for creating, checking,
113 and repairing logical volumes.
114
115 %description -l pl.UTF-8
116 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
117 logicznych wolumenów dyskowych (LVM2).
118
119 %package initrd
120 Summary:        The new version of Logical Volume Manager for Linux - initrd version
121 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
122 Group:          Base
123 Conflicts:      geninitrd < 10000.18
124
125 %description initrd
126 This package includes a number of utilities for creating, checking,
127 and repairing logical volumes - staticaly linked for initrd.
128
129 %description initrd -l pl.UTF-8
130 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
131 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
132 potrzeby initrd.
133
134 %package clvmd
135 Summary:        Cluster LVM daemon
136 Summary(pl.UTF-8):      Demon clustra LVM
137 Group:          Applications/System
138 Requires:       %{name} = %{version}-%{release}
139
140 %description clvmd
141 clvmd is the daemon that distributes LVM metadata updates around a
142 cluster. It must be running on all nodes in the cluster and will give
143 an error if a node in the cluster does not have this daemon running.
144
145 %description clvmd -l pl.UTF-8
146 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
147 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
148 węzeł w klastrze nie ma tego demona uruchomionego.
149
150 %package cmirrord
151 Summary:        Cluster mirror log daemon
152 Group:          Applications/System
153 Requires:       %{name} = %{version}-%{release}
154
155 %description cmirrord
156 cmirrord is the daemon that tracks mirror log information in a
157 cluster. It is specific to device-mapper based mirrors (and by
158 extension, LVM cluster mirrors). Cluster mirrors are not possible
159 without this daemon running.
160
161 This daemon relies on the cluster infrastructure provided by the
162 Cluster MANager (CMAN), which must be set up and running in order for
163 cmirrord to function.
164
165 %package resource-agents
166 Summary:        OCF Resource Agents for LVM2 processes
167 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
168 Group:          Applications/System
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       resource-agents
171
172 %description resource-agents
173 OCF Resource Agents for LVM2 processes.
174
175 %description resource-agents -l pl.UTF-8
176 Agenci OCF do monitorowania procesów LVM2.
177
178 %package -n device-mapper
179 Summary:        Userspace support for the device-mapper
180 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
181 Group:          Base
182 Requires(post,postun):  /sbin/ldconfig
183 Requires:       systemd-units >= 38
184
185 %description -n device-mapper
186 The goal of this driver is to support volume management. The driver
187 enables the definition of new block devices composed of ranges of
188 sectors of existing devices. This can be used to define disk
189 partitions - or logical volumes. This light-weight kernel component
190 can support user-space tools for logical volume management.
191
192 %description -n device-mapper -l pl.UTF-8
193 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
194 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
195 sektorów na istniejących urządzeniach. Może to być wykorzystane do
196 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
197 składnik jądra może wspierać działające w przestrzeni użytkownika
198 narzędzia do zarządzania logicznymi wolumenami.
199
200 %package -n device-mapper-devel
201 Summary:        Header files and development documentation for %{name}
202 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do %{name}
203 Group:          Development/Libraries
204 Requires:       device-mapper = %{version}-%{release}
205 %if %{with selinux}
206 Requires:       libselinux-devel
207 Requires:       libsepol-devel
208 %endif
209
210 %description -n device-mapper-devel
211 Header files and development documentation for %{name}.
212
213 %description -n device-mapper-devel -l pl.UTF-8
214 Pliki nagłówkowe i dokumentacja do %{name}.
215
216 %package -n device-mapper-static
217 Summary:        Static devmapper library
218 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
219 License:        LGPL v2.1
220 Group:          Development/Libraries
221 Requires:       device-mapper-devel = %{version}-%{release}
222
223 %description -n device-mapper-static
224 Static devmapper library.
225
226 %description -n device-mapper-static -l pl.UTF-8
227 Statyczna biblioteka devmapper.
228
229 %package -n device-mapper-dietlibc
230 Summary:        Static devmapper library built with dietlibc
231 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
232 License:        LGPL v2.1
233 Group:          Development/Libraries
234 Requires:       device-mapper-devel = %{version}-%{release}
235
236 %description -n device-mapper-dietlibc
237 Static devmapper library built with dietlibc.
238
239 %description -n device-mapper-dietlibc -l pl.UTF-8
240 Statyczna biblioteka devmapper zbudowana z dietlibc.
241
242 %package -n device-mapper-initrd
243 Summary:        Userspace support for the device-mapper - initrd version
244 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
245 Group:          Base
246 Obsoletes:      device-mapper-initrd-devel
247 Conflicts:      geninitrd < 10000.10
248
249 %description -n device-mapper-initrd
250 The goal of this driver is to support volume management. The driver
251 enables the definition of new block devices composed of ranges of
252 sectors of existing devices. This can be used to define disk
253 partitions - or logical volumes. This light-weight kernel component
254 can support user-space tools for logical volume management.
255
256 This package contains dmsetup program linked staticaly for use in
257 initrd.
258
259 %description -n device-mapper-initrd -l pl.UTF-8
260 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
261 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
262 sektorów na istniejących urządzeniach. Może to być wykorzystane do
263 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
264 składnik jądra może wspierać działające w przestrzeni użytkownika
265 narzędzia do zarządzania logicznymi wolumenami.
266
267 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
268 potrzeby initrd.
269
270 %prep
271 %setup -q -n LVM2.%{version}
272 %{?with_selinux:%patch0 -p1}
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch6 -p1
279 %patch7 -p1
280 %patch8 -p1
281 %patch9 -p1
282
283 # do not force --export-symbol linker option for e.g. statically linked executables
284 # -rdynamic compiler option drives linker in the right way.
285 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
286
287 %build
288 %if %{with initrd}
289 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
290 %endif
291 cp -f /usr/share/automake/config.sub autoconf
292 %{__aclocal}
293 %{__autoconf}
294
295 %if %{with initrd}
296 %{?with_glibc:export CC="%{__cc}"}
297 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
298 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
299
300 %configure \
301         ac_cv_lib_dl_dlopen=no \
302         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
303         %{?debug:--enable-debug} \
304         --disable-nls \
305         --disable-readline \
306         --enable-selinux%{!?with_glibc:=no} \
307         --enable-static_link \
308         --with-lvm1=internal \
309         --with-optimisation="%{rpmcflags} -Os"
310 # glibc version links with normal static libdevicemapper which has selinux enabled
311 # and we need to keep these in sync between device-mapper and lvm2
312
313 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
314 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
315
316 %{__make} -j1 -C include
317 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
318 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
319 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
320 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
321 mv -f tools/lvm.static initrd-lvm
322 mv -f tools/dmsetup.static initrd-dmsetup
323
324 # check if tools works
325 for tool in initrd-lvm initrd-dmsetup; do
326         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
327         if [ $rc -gt 127 ]; then
328                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
329                 exit 1
330         fi
331 done
332
333
334 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
335 %{__make} clean
336
337 unset CC
338 %endif
339
340 %configure \
341         --enable-applib \
342         --enable-cmdlib \
343         %{?debug:--enable-debug} \
344         --enable-dmeventd \
345         --enable-fsadm \
346         %{?with_lvmetad:--enable-lvmetad} \
347         --enable-ocf \
348         --enable-readline \
349         %{!?with_selinux:--disable-selinux} \
350         --enable-pkgconfig \
351         --enable-udev_sync \
352         --enable-udev_rules \
353         --with-cluster=internal \
354 %if %{with cluster}
355         --with-clvmd=corosync \
356         --enable-cmirrord \
357 %endif
358         --with-dmeventd-path=%{_sbindir}/dmeventd \
359         --with-interface=ioctl \
360         --with-lvm1=internal \
361         --with-mirrors=internal \
362         --with-optimisation="%{rpmcflags}" \
363         --with-pool=internal \
364         --with-snapshots=internal \
365         --with-systemdsystemunitdir=%{systemdunitdir} \
366         --with-thin=internal \
367         --with-thin-check=%{_sbindir}/thin_check \
368         --with-thin-dump=%{_sbindir}/thin_dump \
369         --with-thin-repair=%{_sbindir}/thin_repair \
370         --with-udev-prefix=/ \
371         --with-usrlibdir=%{_libdir}
372
373 %{__make} -j1
374 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
375
376 %install
377 rm -rf $RPM_BUILD_ROOT
378 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
379 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
380
381 %{__make} install install_system_dirs install_systemd_units install_initscripts \
382         DESTDIR=$RPM_BUILD_ROOT \
383         OWNER="" \
384         GROUP=""
385
386 install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
387 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
388
389 %if %{with cluster}
390 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
391 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
392 %endif
393
394 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
395 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
396         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
397         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
398         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
399 done
400
401 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
402
403 %if %{with initrd}
404 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
405 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
406 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
407
408 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
409 %endif
410
411 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
412
413 %clean
414 rm -rf $RPM_BUILD_ROOT
415
416 %post
417 /sbin/chkconfig --add lvm2-monitor
418 %service lvm2-monitor restart
419 %systemd_post lvm2-monitor.service
420 /sbin/chkconfig --add blk-availability
421 # no service blk-availability restart
422 %systemd_post blk-availability.service
423
424 %preun
425 %systemd_preun lvm2-monitor.service
426 %systemd_preun blk-availability.service
427
428 %postun
429 if [ "$1" = "0" ]; then
430         %service lvm2-monitor stop
431         /sbin/chkconfig --del lvm2-monitor
432         #no service blk-availability stop
433         /sbin/chkconfig --del blk-availability
434 fi
435 %systemd_reload
436
437 %triggerpostun -- %{name} < 2.02.94-1
438 %systemd_trigger lvm2-monitor.service
439
440 %post -n device-mapper
441 /sbin/ldconfig
442 %systemd_post dm-event.socket
443
444 %preun -n device-mapper
445 %systemd_preun dm-event.socket dm-event.service
446
447 %postun -n device-mapper
448 /sbin/ldconfig
449 %systemd_reload
450
451 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
452 %systemd_trigger dm-event.socket
453
454 %post clvmd
455 /sbin/chkconfig --add clvmd
456 # no service restart - it breaks current locks!
457 export NORESTART=1
458 %systemd_post clvmd.service
459 # re-exec instead
460 /usr/sbin/clvmd -S 2>/dev/null || :
461
462 %preun clvmd
463 %systemd_preun clvmd.service
464
465 %postun clvmd
466 if [ "$1" = "0" ]; then
467         %service clvmd stop
468         /sbin/chkconfig --del clvmd
469 fi
470 %systemd_reload
471
472 %files
473 %defattr(644,root,root,755)
474 %doc README WHATS_NEW doc/*
475 %attr(755,root,root) %{_sbindir}/blkdeactivate
476 %attr(755,root,root) %{_sbindir}/fsadm
477 %attr(755,root,root) %{_sbindir}/lv*
478 %attr(755,root,root) %{_sbindir}/pv*
479 %attr(755,root,root) %{_sbindir}/vg*
480 %{_mandir}/man5/lvm.conf.5*
481 %{_mandir}/man8/blkdeactivate.8*
482 %{_mandir}/man8/fsadm.8*
483 %{_mandir}/man8/lv*.8*
484 %{_mandir}/man8/pv*.8*
485 %{_mandir}/man8/vg*.8*
486 %attr(750,root,root) %dir %{_sysconfdir}/lvm
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
488 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/default.profile
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
491 %if %{with lvmetad}
492 /lib/udev/rules.d/69-dm-lvm-metad.rules
493 %endif
494 %{_sysconfdir}/tmpfiles.d/lvm2.conf
495 %{systemdunitdir}/blk-availability.service
496 %if %{with lvmetad}
497 %{systemdunitdir}/lvm2-lvmetad.service
498 %{systemdunitdir}/lvm2-lvmetad.socket
499 %endif
500 %{systemdunitdir}/lvm2-monitor.service
501 %{systemdunitdir}/lvm2-pvscan@.service
502 %dir %{_sysconfdir}/lvm/cache
503 %ghost %{_sysconfdir}/lvm/cache/.cache
504 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
505 %if %{with lvmetad}
506 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
507 %endif
508 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
509 %dir %attr(700,root,root) /var/run/lvm
510
511 %if %{with cluster}
512 %files clvmd
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_usrsbindir}/clvmd
515 %attr(754,root,root) /etc/rc.d/init.d/clvmd
516 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
517 %{systemdunitdir}/clvmd.service
518 %{_mandir}/man8/clvmd.8*
519
520 %files cmirrord
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_usrsbindir}/cmirrord
523 %{_mandir}/man8/cmirrord.8*
524 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
525 %endif
526
527 %files resource-agents
528 %defattr(644,root,root,755)
529 %dir %{_prefix}/lib/ocf/resource.d/lvm2
530 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
531
532 %files -n device-mapper
533 %defattr(644,root,root,755)
534 %doc *_DM
535 %{systemdunitdir}/dm-event.service
536 %{systemdunitdir}/dm-event.socket
537 /lib/udev/rules.d/10-dm.rules
538 /lib/udev/rules.d/11-dm-lvm.rules
539 /lib/udev/rules.d/13-dm-disk.rules
540 /lib/udev/rules.d/95-dm-notify.rules
541 %attr(755,root,root) %{_sbindir}/dmeventd
542 %attr(755,root,root) %{_sbindir}/dmsetup
543 %attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
544 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
545 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
546 %dir %{_libdir}/device-mapper
547 %attr(755,root,root) %{_libdir}/device-mapper/*.so
548 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
549 %{_mandir}/man8/dmsetup.8*
550 %{_mandir}/man8/dmeventd.8*
551
552 %files -n device-mapper-devel
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/libdevmapper.so
555 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
556 %attr(755,root,root) %{_libdir}/liblvm2app.so
557 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
558 %{_includedir}/libdevmapper*.h
559 %{_includedir}/lvm2app.h
560 %{_includedir}/lvm2cmd.h
561 %{_pkgconfigdir}/devmapper*.pc
562 %{_pkgconfigdir}/lvm2app.pc
563
564 %files -n device-mapper-static
565 %defattr(644,root,root,755)
566 %{_libdir}/libdevmapper*.a
567
568 %if %{with initrd}
569 %if %{with dietlibc}
570 %files -n device-mapper-dietlibc
571 %defattr(644,root,root,755)
572 %{dietlibdir}/libdevmapper.a
573 %endif
574
575 %files -n device-mapper-initrd
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/initrd/dmsetup
578
579 %files initrd
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/initrd/lvm
582 %endif