]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- updated to 2.03.21
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - functionality
8 %bcond_without  cluster         # disable all cluster support (cmirrord, dlm support in lvmlockd)
9 %bcond_without  lvmdbusd        # lvmdbusd
10 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
11 %bcond_without  lvmlockd        # lvmlockd
12 %bcond_with     sanlock         # sanlock support in lvmlockd
13 # - additional features
14 %bcond_without  selinux         # SELinux support
15 # - bindings
16 %bcond_without  python          # Python bindings
17 %bcond_without  python2         # Python 2 binding
18 %bcond_without  python3         # Python 3 binding and lvmdbusd
19
20 # for convenience
21 %if %{without python}
22 %undefine       with_python2
23 %undefine       with_python3
24 %endif
25 %if %{without python3}
26 %undefine       with_lvmdbusd
27 %endif
28
29 Summary:        The new version of Logical Volume Manager for Linux
30 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
31 Name:           lvm2
32 Version:        2.03.21
33 Release:        1
34 License:        GPL v2 and LGPL v2.1
35 Group:          Applications/System
36 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
37 # Source0-md5:  1730b322321bed204487ba241105e005
38 Patch0:         %{name}-selinux.patch
39 Patch1:         device-mapper-dmsetup-export.patch
40 Patch2:         %{name}-tld_init.patch
41 Patch3:         %{name}-run-dir.patch
42 Patch4:         %{name}-thin.patch
43 Patch5:         link.patch
44 URL:            http://www.sourceware.org/lvm2/
45 BuildRequires:  autoconf >= 2.69
46 BuildRequires:  autoconf-archive
47 BuildRequires:  automake
48 # for /run detection
49 BuildRequires:  filesystem >= 3.0-43
50 BuildRequires:  libaio-devel
51 BuildRequires:  libblkid-devel >= 2.24
52 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
53 %{?with_selinux:BuildRequires:  libsepol-devel}
54 BuildRequires:  ncurses-devel
55 BuildRequires:  pkgconfig
56 %{?with_python2:BuildRequires:  python-devel >= 2}
57 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
58 %if %{with lvmdbusd}
59 BuildRequires:  python3-dbus
60 BuildRequires:  python3-pyudev
61 %endif
62 BuildRequires:  readline-devel
63 BuildRequires:  rpmbuild(macros) >= 1.647
64 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
65 BuildRequires:  udev-devel >= 1:176
66 %if %{with cluster}
67 BuildRequires:  corosync-devel
68 BuildRequires:  dlm-devel >= 3.99.5
69 %endif
70 Requires(post,postun):  /sbin/chkconfig
71 Requires:       device-mapper >= %{version}-%{release}
72 %{?with_selinux:Requires:       libselinux >= 1.10}
73 # doesn't work with 2.4 kernels
74 Requires:       uname(release) >= 2.6
75 Suggests:       thin-provisioning-tools >= 0.5.4
76 Obsoletes:      lvm
77 Obsoletes:      lvm2-clvmd
78 Obsoletes:      lvm2-systemd
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _sbindir        /sbin
82 %define         _usrsbindir     /usr/sbin
83
84 # changing CFLAGS in the middle confuses confcache
85 %undefine       configure_cache
86
87 # causes: undefined reference to `__stack_chk_fail_local'
88 %define         filterout_c     -fstack-protector
89
90 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
91
92 %description
93 This package includes a number of utilities for creating, checking,
94 and repairing logical volumes.
95
96 %description -l pl.UTF-8
97 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
98 logicznych wolumenów dyskowych (LVM2).
99
100 %package cmirrord
101 Summary:        Cluster mirror log daemon
102 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
103 Group:          Applications/System
104 Requires:       %{name} = %{version}-%{release}
105
106 %description cmirrord
107 cmirrord is the daemon that tracks mirror log information in a
108 cluster. It is specific to device-mapper based mirrors (and by
109 extension, LVM cluster mirrors). Cluster mirrors are not possible
110 without this daemon running.
111
112 This daemon relies on the cluster infrastructure provided by the
113 Cluster MANager (CMAN), which must be set up and running in order for
114 cmirrord to function.
115
116 %description cmirrord -l pl.UTF-8
117 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
118 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
119 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
120 lustrzanych ten demon jest niezbędny.
121
122 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
123 (Cluster MANager), który musi być skonfigurowany i działający, aby
124 działał cmirrord.
125
126 %package dbusd
127 Summary:        LVM2 D-Bus daemon
128 Summary(pl.UTF-8):      Demon LVM2 D-Bus
129 Group:          Daemons
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       python3-dbus
132 Requires:       python3-pygobject3 >= 3
133 Requires:       python3-pyudev
134
135 %description dbusd
136 Daemon for access to LVM2 functionality through a D-Bus interface.
137
138 %description dbusd -l pl.UTF-8
139 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
140 D-Bus.
141
142 %package lockd
143 Summary:        LVM2 locking daemon
144 Summary(pl.UTF-8):      Demon blokad LVM2
145 Group:          Daemons
146 Requires:       %{name} = %{version}-%{release}
147 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
148 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
149
150 %description lockd
151 LVM commands use lvmlockd to coordinate access to shared storage.
152
153 %description lockd -l pl.UTF-8
154 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
155 współdzielonej pamięci masowej.
156
157 %package resource-agents
158 Summary:        OCF Resource Agents for LVM2 processes
159 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
160 Group:          Applications/System
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       resource-agents
163
164 %description resource-agents
165 OCF Resource Agents for LVM2 processes.
166
167 %description resource-agents -l pl.UTF-8
168 Agenci OCF do monitorowania procesów LVM2.
169
170 %package -n python-lvm
171 Summary:        Python 2 interface to LVM2
172 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
173 Group:          Libraries/Python
174 Requires:       device-mapper-libs = %{version}-%{release}
175
176 %description -n python-lvm
177 Python 2 interface to LVM2.
178
179 %description -n python-lvm -l pl.UTF-8
180 Interfejs Pythona 2 do LVM2.
181
182 %package -n python3-lvm
183 Summary:        Python 3 interface to LVM2
184 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
185 Group:          Libraries/Python
186 Requires:       device-mapper-libs = %{version}-%{release}
187
188 %description -n python3-lvm
189 Python 3 interface to LVM2.
190
191 %description -n python3-lvm -l pl.UTF-8
192 Interfejs Pythona 3 do LVM2.
193
194 %package -n device-mapper
195 Summary:        Userspace support for the device-mapper
196 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
197 Group:          Base
198 Requires(post,postun):  /sbin/ldconfig
199 Requires:       device-mapper-libs = %{version}-%{release}
200
201 %description -n device-mapper
202 The goal of this driver is to support volume management. The driver
203 enables the definition of new block devices composed of ranges of
204 sectors of existing devices. This can be used to define disk
205 partitions - or logical volumes. This light-weight kernel component
206 can support user-space tools for logical volume management.
207
208 %description -n device-mapper -l pl.UTF-8
209 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
210 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
211 sektorów na istniejących urządzeniach. Może to być wykorzystane do
212 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
213 składnik jądra może wspierać działające w przestrzeni użytkownika
214 narzędzia do zarządzania logicznymi wolumenami.
215
216 %package -n device-mapper-libs
217 Summary:        Device-mapper shared libraries
218 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
219 Group:          Libraries
220 Requires:       libblkid >= 2.24
221 Requires:       udev-libs >= 1:176
222 Conflicts:      device-mapper < 2.02.119-1
223
224 %description -n device-mapper-libs
225 Device-mapper shared libraries.
226
227 %description -n device-mapper-libs -l pl.UTF-8
228 Biblioteki współdzielone device-mappera.
229
230 %package -n device-mapper-devel
231 Summary:        Header files for device-mapper libraries
232 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
233 Group:          Development/Libraries
234 Requires:       device-mapper-libs = %{version}-%{release}
235 Requires:       libblkid-devel >= 2.24
236 %if %{with selinux}
237 Requires:       libselinux-devel
238 Requires:       libsepol-devel
239 %endif
240 Requires:       udev-devel >= 1:176
241
242 %description -n device-mapper-devel
243 Header files for device-mapper libraries.
244
245 %description -n device-mapper-devel -l pl.UTF-8
246 Pliki nagłówkowe bibliotek device-mappera.
247
248 %package -n device-mapper-static
249 Summary:        Static devmapper library
250 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
251 License:        LGPL v2.1
252 Group:          Development/Libraries
253 Requires:       device-mapper-devel = %{version}-%{release}
254
255 %description -n device-mapper-static
256 Static devmapper library.
257
258 %description -n device-mapper-static -l pl.UTF-8
259 Statyczna biblioteka devmapper.
260
261 %package -n device-mapper-dietlibc
262 Summary:        Static devmapper library built with dietlibc
263 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
264 License:        LGPL v2.1
265 Group:          Development/Libraries
266 Requires:       device-mapper-devel = %{version}-%{release}
267
268 %description -n device-mapper-dietlibc
269 Static devmapper library built with dietlibc.
270
271 %description -n device-mapper-dietlibc -l pl.UTF-8
272 Statyczna biblioteka devmapper zbudowana z dietlibc.
273
274 %prep
275 %setup -q -n LVM2.%{version}
276 %{?with_selinux:%patch0 -p1}
277 %patch1 -p1
278 %patch2 -p1
279 %patch3 -p1
280 %patch4 -p1
281 %patch5 -p1
282
283 %build
284 %{__aclocal}
285 %{__autoconf}
286
287 %configure \
288         --enable-applib \
289         --enable-cache_check_needs_check \
290         --enable-cmdlib \
291 %if %{with cluster}
292         --enable-cmirrord \
293 %endif
294         %{?with_lvmdbusd:--enable-dbus-service} \
295         %{?debug:--enable-debug} \
296         --enable-dmeventd \
297         --enable-dmfilemapd \
298         --enable-fsadm \
299 %if %{with lvmlockd}
300         %{?with_cluster:--enable-lvmlockd-dlm} \
301         %{?with_sanlock:--enable-lvmlockd-sanlock} \
302 %endif
303         --enable-lvmpolld \
304         --enable-ocf \
305         %{?with_python2:--enable-python2_bindings} \
306         %{?with_python3:--enable-python3_bindings} \
307         --enable-pkgconfig \
308         --enable-readline \
309         %{!?with_selinux:--disable-selinux} \
310         --disable-silent-rules \
311         --enable-thin_check_needs_check \
312         --enable-udev_sync \
313         --enable-udev_rules \
314         --disable-udev-systemd-background-jobs \
315         --with-cache=internal \
316         --with-cache-check=/usr/sbin/cache_check \
317         --with-cache-dump=/usr/sbin/cache_dump \
318         --with-cache-repair=/usr/sbin/cache_repair \
319         --with-cache-restore=/usr/sbin/cache_restore \
320         --with-default-locking-dir=/var/lock/lvm \
321         --with-dmeventd-path=%{_sbindir}/dmeventd \
322         --with-interface=ioctl \
323         --with-libexecdir=%{_libexecdir} \
324         --with-mirrors=internal \
325         --with-optimisation="%{rpmcflags}" \
326         --with-snapshots=internal \
327         --with-thin=internal \
328         --with-thin-check=/usr/sbin/thin_check \
329         --with-thin-dump=/usr/sbin/thin_dump \
330         --with-thin-repair=/usr/sbin/thin_repair \
331         --with-thin-restore=/usr/sbin/thin_restore \
332         --with-udev-prefix=/ \
333         --with-usrlibdir=%{_libdir}
334 # use bash because of "set -o pipefail"
335 # V=1 still used because of missing --disable-silent-rules support in libdm (as of 2.03.09)
336 %{__make} -j1 \
337         SHELL=/bin/bash \
338         V=1
339 %{__make} -j1 -C libdm \
340         LIB_STATIC=libdevmapper.a \
341         V=1
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
346
347 %{__make} install install_system_dirs install_initscripts \
348         DESTDIR=$RPM_BUILD_ROOT \
349         OWNER="" \
350         GROUP="" \
351         python3dir=%{py3_sitescriptdir}
352
353 %{__make} -C scripts \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
357 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
358         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
359         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
360         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
361 done
362
363 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
364
365 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
366
367 %clean
368 rm -rf $RPM_BUILD_ROOT
369
370 %triggerin -- lvm2 < 2.03.00
371 %service lvm2-lvmetad stop
372 /sbin/chkconfig --del lvm2-lvmetad
373
374 %triggerin -- lvm2-clvmd
375 %service clvmd stop
376 /sbin/chkconfig --del clvmd
377
378 %post
379 /sbin/chkconfig --add lvm2-monitor
380 %service lvm2-monitor restart
381 /sbin/chkconfig --add lvm2-lvmpolld
382 %service lvm2-lvmpolld restart
383 # no service restart available
384 /sbin/chkconfig --add blk-availability
385 # no service blk-availability restart
386
387 %preun
388 if [ "$1" = "0" ]; then
389         %service lvm2-lvmpolld stop
390         /sbin/chkconfig --del lvm2-lvmpolld
391         %service lvm2-monitor stop
392         /sbin/chkconfig --del lvm2-monitor
393         #no service blk-availability stop
394         /sbin/chkconfig --del blk-availability
395 fi
396
397 %post   -n device-mapper-libs -p /sbin/ldconfig
398 %postun -n device-mapper-libs -p /sbin/ldconfig
399
400 %files
401 %defattr(644,root,root,755)
402 %doc README WHATS_NEW doc/*
403 %attr(755,root,root) %{_sbindir}/blkdeactivate
404 %attr(755,root,root) %{_sbindir}/fsadm
405 %attr(755,root,root) %{_sbindir}/lvchange
406 %attr(755,root,root) %{_sbindir}/lvconvert
407 %attr(755,root,root) %{_sbindir}/lvcreate
408 %attr(755,root,root) %{_sbindir}/lvdisplay
409 %attr(755,root,root) %{_sbindir}/lvextend
410 %attr(755,root,root) %{_sbindir}/lvm
411 %attr(755,root,root) %{_sbindir}/lvm_import_vdo
412 %attr(755,root,root) %{_sbindir}/lvmconfig
413 %attr(755,root,root) %{_sbindir}/lvmdevices
414 %attr(755,root,root) %{_sbindir}/lvmdiskscan
415 %attr(755,root,root) %{_sbindir}/lvmdump
416 %attr(755,root,root) %{_sbindir}/lvmsadc
417 %attr(755,root,root) %{_sbindir}/lvmsar
418 %attr(755,root,root) %{_sbindir}/lvreduce
419 %attr(755,root,root) %{_sbindir}/lvremove
420 %attr(755,root,root) %{_sbindir}/lvrename
421 %attr(755,root,root) %{_sbindir}/lvresize
422 %attr(755,root,root) %{_sbindir}/lvs
423 %attr(755,root,root) %{_sbindir}/lvscan
424 %attr(755,root,root) %{_sbindir}/pvchange
425 %attr(755,root,root) %{_sbindir}/pvck
426 %attr(755,root,root) %{_sbindir}/pvcreate
427 %attr(755,root,root) %{_sbindir}/pvdisplay
428 %attr(755,root,root) %{_sbindir}/pvmove
429 %attr(755,root,root) %{_sbindir}/pvremove
430 %attr(755,root,root) %{_sbindir}/pvresize
431 %attr(755,root,root) %{_sbindir}/pvs
432 %attr(755,root,root) %{_sbindir}/pvscan
433 %attr(755,root,root) %{_sbindir}/vgcfgbackup
434 %attr(755,root,root) %{_sbindir}/vgcfgrestore
435 %attr(755,root,root) %{_sbindir}/vgchange
436 %attr(755,root,root) %{_sbindir}/vgck
437 %attr(755,root,root) %{_sbindir}/vgconvert
438 %attr(755,root,root) %{_sbindir}/vgcreate
439 %attr(755,root,root) %{_sbindir}/vgdisplay
440 %attr(755,root,root) %{_sbindir}/vgexport
441 %attr(755,root,root) %{_sbindir}/vgextend
442 %attr(755,root,root) %{_sbindir}/vgimport
443 %attr(755,root,root) %{_sbindir}/vgimportclone
444 %attr(755,root,root) %{_sbindir}/vgimportdevices
445 %attr(755,root,root) %{_sbindir}/vgmerge
446 %attr(755,root,root) %{_sbindir}/vgmknodes
447 %attr(755,root,root) %{_sbindir}/vgreduce
448 %attr(755,root,root) %{_sbindir}/vgremove
449 %attr(755,root,root) %{_sbindir}/vgrename
450 %attr(755,root,root) %{_sbindir}/vgs
451 %attr(755,root,root) %{_sbindir}/vgscan
452 %attr(755,root,root) %{_sbindir}/vgsplit
453 %attr(755,root,root) %{_libexecdir}/lvresize_fs_helper
454 %{_mandir}/man5/lvm.conf.5*
455 %{_mandir}/man7/lvmautoactivation.7*
456 %{_mandir}/man7/lvmcache.7*
457 %{_mandir}/man7/lvmraid.7*
458 %{_mandir}/man7/lvmreport.7*
459 %{_mandir}/man7/lvmsystemid.7*
460 %{_mandir}/man7/lvmthin.7*
461 %{_mandir}/man7/lvmvdo.7*
462 %{_mandir}/man8/blkdeactivate.8*
463 %{_mandir}/man8/fsadm.8*
464 %{_mandir}/man8/lvchange.8*
465 %{_mandir}/man8/lvconvert.8*
466 %{_mandir}/man8/lvcreate.8*
467 %{_mandir}/man8/lvdisplay.8*
468 %{_mandir}/man8/lvextend.8*
469 %{_mandir}/man8/lvm-config.8*
470 %{_mandir}/man8/lvm-dumpconfig.8*
471 %{_mandir}/man8/lvm-fullreport.8*
472 %{_mandir}/man8/lvm-lvpoll.8*
473 %{_mandir}/man8/lvm.8*
474 %{_mandir}/man8/lvm_import_vdo.8*
475 %{_mandir}/man8/lvmconfig.8*
476 %{_mandir}/man8/lvmdevices.8*
477 %{_mandir}/man8/lvmdiskscan.8*
478 %{_mandir}/man8/lvmdump.8*
479 %{_mandir}/man8/lvmsadc.8*
480 %{_mandir}/man8/lvmsar.8*
481 %{_mandir}/man8/lvreduce.8*
482 %{_mandir}/man8/lvremove.8*
483 %{_mandir}/man8/lvrename.8*
484 %{_mandir}/man8/lvresize.8*
485 %{_mandir}/man8/lvs.8*
486 %{_mandir}/man8/lvscan.8*
487 %{_mandir}/man8/pvchange.8*
488 %{_mandir}/man8/pvck.8*
489 %{_mandir}/man8/pvcreate.8*
490 %{_mandir}/man8/pvdisplay.8*
491 %{_mandir}/man8/pvmove.8*
492 %{_mandir}/man8/pvremove.8*
493 %{_mandir}/man8/pvresize.8*
494 %{_mandir}/man8/pvs.8*
495 %{_mandir}/man8/pvscan.8*
496 %{_mandir}/man8/vgcfgbackup.8*
497 %{_mandir}/man8/vgcfgrestore.8*
498 %{_mandir}/man8/vgchange.8*
499 %{_mandir}/man8/vgck.8*
500 %{_mandir}/man8/vgconvert.8*
501 %{_mandir}/man8/vgcreate.8*
502 %{_mandir}/man8/vgdisplay.8*
503 %{_mandir}/man8/vgexport.8*
504 %{_mandir}/man8/vgextend.8*
505 %{_mandir}/man8/vgimport.8*
506 %{_mandir}/man8/vgimportclone.8*
507 %{_mandir}/man8/vgimportdevices.8*
508 %{_mandir}/man8/vgmerge.8*
509 %{_mandir}/man8/vgmknodes.8*
510 %{_mandir}/man8/vgreduce.8*
511 %{_mandir}/man8/vgremove.8*
512 %{_mandir}/man8/vgrename.8*
513 %{_mandir}/man8/vgs.8*
514 %{_mandir}/man8/vgscan.8*
515 %{_mandir}/man8/vgsplit.8*
516 %attr(750,root,root) %dir %{_sysconfdir}/lvm
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
519 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
527 %dir %{_sysconfdir}/lvm/cache
528 %ghost %{_sysconfdir}/lvm/cache/.cache
529 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
530 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
531 %attr(700,root,root) %dir /var/run/lvm
532 %attr(700,root,root) %dir /var/lock/lvm
533 %attr(700,root,root) %dir /var/lock/lvm/subsys
534 %if %{with lvmlockd}
535 %attr(755,root,root) %{_sbindir}/lvmlockctl
536 %attr(755,root,root) %{_sbindir}/lvmlockd
537 %{_mandir}/man8/lvmlockctl.8*
538 %{_mandir}/man8/lvmlockd.8*
539 %endif
540 %if %{with lvmpolld}
541 %attr(755,root,root) %{_sbindir}/lvmpolld
542 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
543 %{_mandir}/man8/lvmpolld.8*
544 %endif
545
546 %if %{with cluster}
547 %files cmirrord
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_usrsbindir}/cmirrord
550 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
551 %{_mandir}/man8/cmirrord.8*
552 %endif
553
554 %if %{with lvmdbusd}
555 %files dbusd
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_sbindir}/lvmdbusd
558 %{py3_sitescriptdir}/lvmdbusd
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
560 %{_mandir}/man8/lvmdbusd.8*
561 %endif
562
563 %files resource-agents
564 %defattr(644,root,root,755)
565 %dir %{_prefix}/lib/ocf/resource.d/lvm2
566 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
567
568 %if %{with python2}
569 %files -n python-lvm
570 %defattr(644,root,root,755)
571 #%attr(755,root,root) %{py_sitedir}/lvm.so
572 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
573 %endif
574
575 %if %{with python3}
576 %files -n python3-lvm
577 %defattr(644,root,root,755)
578 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
579 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
580 %endif
581
582 %files -n device-mapper
583 %defattr(644,root,root,755)
584 %doc *_DM
585 /lib/udev/rules.d/10-dm.rules
586 /lib/udev/rules.d/11-dm-lvm.rules
587 /lib/udev/rules.d/13-dm-disk.rules
588 /lib/udev/rules.d/69-dm-lvm.rules
589 /lib/udev/rules.d/95-dm-notify.rules
590 %attr(755,root,root) %{_sbindir}/dmeventd
591 %attr(755,root,root) %{_sbindir}/dmfilemapd
592 %attr(755,root,root) %{_sbindir}/dmsetup
593 %attr(755,root,root) %{_sbindir}/dmstats
594 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
595 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
596 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
597 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
598 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
599 %dir %{_libdir}/device-mapper
600 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
601 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
602 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
603 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
604 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
605 %{_mandir}/man8/dmfilemapd.8*
606 %{_mandir}/man8/dmsetup.8*
607 %{_mandir}/man8/dmstats.8*
608 %{_mandir}/man8/dmeventd.8*
609
610 %files -n device-mapper-libs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
613 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
614 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
615 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
616
617 %files -n device-mapper-devel
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/libdevmapper.so
620 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
621 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
622 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
623 %{_includedir}/libdevmapper.h
624 %{_includedir}/libdevmapper-event.h
625 %{_includedir}/lvm2cmd.h
626 %{_pkgconfigdir}/devmapper.pc
627 %{_pkgconfigdir}/devmapper-event.pc
628
629 %files -n device-mapper-static
630 %defattr(644,root,root,755)
631 %{_libdir}/libdevmapper.a