]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- init patch was renamed
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # don't build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad
12 %bcond_without  selinux         # disable SELinux
13
14 %ifarch sparc64 sparc
15 %define         with_glibc 1
16 %endif
17
18 # if one of the *libc is enabled disable default dietlibc
19 %if %{with dietlibc} && %{with uClibc}
20 %undefine       with_dietlibc
21 %endif
22
23 # with glibc disables default dietlibc
24 %if %{with glibc} && %{with dietlibc}
25 %undefine       with_dietlibc
26 %endif
27
28 # fallback is glibc if neither alternatives are enabled
29 %if %{without dietlibc} && %{without uClibc}
30 %define         with_glibc      1
31 %endif
32
33 Summary:        The new version of Logical Volume Manager for Linux
34 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
35 Name:           lvm2
36 Version:        2.02.107
37 Release:        2
38 License:        GPL v2 and LGPL v2.1
39 Group:          Applications/System
40 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
41 # Source0-md5:  efa5b0ff0245cbccf53aec1f3d8840ba
42 Source1:        %{name}-tmpfiles.conf
43 Source2:        clvmd.service
44 Source3:        clvmd.sysconfig
45 Patch0:         %{name}-selinux.patch
46 Patch1:         %{name}-diet.patch
47 Patch2:         device-mapper-dmsetup-export.patch
48 Patch3:         %{name}-tld_init.patch
49 Patch4:         dl-dlsym.patch
50 Patch6:         %{name}-lvm_path.patch
51 Patch7:         %{name}-sd_notify.patch
52 Patch8:         %{name}-clvmd_cmd_timeout.patch
53 Patch9:         device-mapper-dmsetup-deps-export.patch
54 URL:            http://sources.redhat.com/lvm2/
55 BuildRequires:  autoconf >= 2.61
56 BuildRequires:  automake
57 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
58 %{?with_selinux:BuildRequires:  libsepol-devel}
59 BuildRequires:  ncurses-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  readline-devel
62 BuildRequires:  rpmbuild(macros) >= 1.647
63 BuildRequires:  udev-devel >= 1:143
64 %if %{with initrd}
65 %if %{with dietlibc}
66 BuildRequires:  dietlibc-static >= 2:0.32-7
67 BuildConflicts: device-mapper-dietlibc
68 %endif
69 %if %{with glibc}
70 %{?with_selinux:BuildRequires:  libselinux-static}
71 %{?with_selinux:BuildRequires:  libsepol-static}
72 %endif
73 %{?with_glibc:BuildRequires:    glibc-static}
74 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
75 %endif
76 %if %{with cluster}
77 BuildRequires:  corosync-devel
78 BuildRequires:  dlm-devel >= 3.99.5
79 BuildRequires:  systemd-devel
80 %endif
81 Requires(post,preun,postun):    systemd-units >= 38
82 Requires(post,postun):  /sbin/chkconfig
83 Requires:       device-mapper >= %{version}-%{release}
84 %{?with_selinux:Requires:       libselinux >= 1.10}
85 Requires:       systemd-units >= 38
86 # doesn't work with 2.4 kernels
87 Requires:       uname(release) >= 2.6
88 Obsoletes:      lvm
89 Obsoletes:      lvm2-systemd
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sbindir        /sbin
93 %define         _usrsbindir     /usr/sbin
94
95 # changing CFLAGS in the middle confuses confcache
96 %undefine       configure_cache
97
98 # borken on AC
99 %define         filterout_ld    -Wl,--as-needed
100
101 # causes: undefined reference to `__stack_chk_fail_local'
102 %define         filterout_c     -fstack-protector
103
104 # for some reason known only to rpm there must be "\\|" not "\|" here
105 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
106 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
107
108 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
109
110 %description
111 This package includes a number of utilities for creating, checking,
112 and repairing logical volumes.
113
114 %description -l pl.UTF-8
115 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
116 logicznych wolumenów dyskowych (LVM2).
117
118 %package initrd
119 Summary:        The new version of Logical Volume Manager for Linux - initrd version
120 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
121 Group:          Base
122 Conflicts:      geninitrd < 10000.18
123
124 %description initrd
125 This package includes a number of utilities for creating, checking,
126 and repairing logical volumes - staticaly linked for initrd.
127
128 %description initrd -l pl.UTF-8
129 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
130 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
131 potrzeby initrd.
132
133 %package clvmd
134 Summary:        Cluster LVM daemon
135 Summary(pl.UTF-8):      Demon clustra LVM
136 Group:          Applications/System
137 Requires:       %{name} = %{version}-%{release}
138
139 %description clvmd
140 clvmd is the daemon that distributes LVM metadata updates around a
141 cluster. It must be running on all nodes in the cluster and will give
142 an error if a node in the cluster does not have this daemon running.
143
144 %description clvmd -l pl.UTF-8
145 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
146 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
147 węzeł w klastrze nie ma tego demona uruchomionego.
148
149 %package cmirrord
150 Summary:        Cluster mirror log daemon
151 Group:          Applications/System
152 Requires:       %{name} = %{version}-%{release}
153
154 %description cmirrord
155 cmirrord is the daemon that tracks mirror log information in a
156 cluster. It is specific to device-mapper based mirrors (and by
157 extension, LVM cluster mirrors). Cluster mirrors are not possible
158 without this daemon running.
159
160 This daemon relies on the cluster infrastructure provided by the
161 Cluster MANager (CMAN), which must be set up and running in order for
162 cmirrord to function.
163
164 %package resource-agents
165 Summary:        OCF Resource Agents for LVM2 processes
166 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
167 Group:          Applications/System
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       resource-agents
170
171 %description resource-agents
172 OCF Resource Agents for LVM2 processes.
173
174 %description resource-agents -l pl.UTF-8
175 Agenci OCF do monitorowania procesów LVM2.
176
177 %package -n device-mapper
178 Summary:        Userspace support for the device-mapper
179 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
180 Group:          Base
181 Requires(post,postun):  /sbin/ldconfig
182 Requires(post,preun,postun):    systemd-units >= 38
183 Requires:       systemd-units >= 38
184
185 %description -n device-mapper
186 The goal of this driver is to support volume management. The driver
187 enables the definition of new block devices composed of ranges of
188 sectors of existing devices. This can be used to define disk
189 partitions - or logical volumes. This light-weight kernel component
190 can support user-space tools for logical volume management.
191
192 %description -n device-mapper -l pl.UTF-8
193 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
194 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
195 sektorów na istniejących urządzeniach. Może to być wykorzystane do
196 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
197 składnik jądra może wspierać działające w przestrzeni użytkownika
198 narzędzia do zarządzania logicznymi wolumenami.
199
200 %package -n device-mapper-devel
201 Summary:        Header files and development documentation for %{name}
202 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do %{name}
203 Group:          Development/Libraries
204 Requires:       device-mapper = %{version}-%{release}
205 %if %{with selinux}
206 Requires:       libselinux-devel
207 Requires:       libsepol-devel
208 %endif
209
210 %description -n device-mapper-devel
211 Header files and development documentation for %{name}.
212
213 %description -n device-mapper-devel -l pl.UTF-8
214 Pliki nagłówkowe i dokumentacja do %{name}.
215
216 %package -n device-mapper-static
217 Summary:        Static devmapper library
218 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
219 License:        LGPL v2.1
220 Group:          Development/Libraries
221 Requires:       device-mapper-devel = %{version}-%{release}
222
223 %description -n device-mapper-static
224 Static devmapper library.
225
226 %description -n device-mapper-static -l pl.UTF-8
227 Statyczna biblioteka devmapper.
228
229 %package -n device-mapper-dietlibc
230 Summary:        Static devmapper library built with dietlibc
231 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
232 License:        LGPL v2.1
233 Group:          Development/Libraries
234 Requires:       device-mapper-devel = %{version}-%{release}
235
236 %description -n device-mapper-dietlibc
237 Static devmapper library built with dietlibc.
238
239 %description -n device-mapper-dietlibc -l pl.UTF-8
240 Statyczna biblioteka devmapper zbudowana z dietlibc.
241
242 %package -n device-mapper-initrd
243 Summary:        Userspace support for the device-mapper - initrd version
244 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
245 Group:          Base
246 Obsoletes:      device-mapper-initrd-devel
247 Conflicts:      geninitrd < 10000.10
248
249 %description -n device-mapper-initrd
250 The goal of this driver is to support volume management. The driver
251 enables the definition of new block devices composed of ranges of
252 sectors of existing devices. This can be used to define disk
253 partitions - or logical volumes. This light-weight kernel component
254 can support user-space tools for logical volume management.
255
256 This package contains dmsetup program linked staticaly for use in
257 initrd.
258
259 %description -n device-mapper-initrd -l pl.UTF-8
260 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
261 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
262 sektorów na istniejących urządzeniach. Może to być wykorzystane do
263 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
264 składnik jądra może wspierać działające w przestrzeni użytkownika
265 narzędzia do zarządzania logicznymi wolumenami.
266
267 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
268 potrzeby initrd.
269
270 %prep
271 %setup -q -n LVM2.%{version}
272 %{?with_selinux:%patch0 -p1}
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch6 -p1
278 %patch7 -p1
279 %patch8 -p1
280 %patch9 -p1
281
282 # do not force --export-symbol linker option for e.g. statically linked executables
283 # -rdynamic compiler option drives linker in the right way.
284 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
285
286 %build
287 %if %{with initrd}
288 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
289 %endif
290 cp -f /usr/share/automake/config.sub autoconf
291 %{__aclocal}
292 %{__autoconf}
293
294 %if %{with initrd}
295 %{?with_glibc:export CC="%{__cc}"}
296 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
297 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
298
299 %configure \
300         ac_cv_lib_dl_dlopen=no \
301         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
302         %{?debug:--enable-debug} \
303         --disable-nls \
304         --disable-readline \
305         --enable-selinux%{!?with_glibc:=no} \
306         --enable-static_link \
307         --with-lvm1=internal \
308         --with-optimisation="%{rpmcflags} -Os"
309 # glibc version links with normal static libdevicemapper which has selinux enabled
310 # and we need to keep these in sync between device-mapper and lvm2
311
312 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
313 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
314
315 %{__make} -j1 -C include
316 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
317 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
318 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
319 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
320 mv -f tools/lvm.static initrd-lvm
321 mv -f tools/dmsetup.static initrd-dmsetup
322
323 # check if tools works
324 for tool in initrd-lvm initrd-dmsetup; do
325         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
326         if [ $rc -gt 127 ]; then
327                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
328                 exit 1
329         fi
330 done
331
332
333 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
334 %{__make} clean
335
336 unset CC
337 %endif
338
339 %configure \
340         --enable-applib \
341         --enable-cmdlib \
342         %{?debug:--enable-debug} \
343         --enable-dmeventd \
344         --enable-fsadm \
345         %{?with_lvmetad:--enable-lvmetad} \
346         --enable-ocf \
347         --enable-readline \
348         %{!?with_selinux:--disable-selinux} \
349         --enable-pkgconfig \
350         --enable-udev_sync \
351         --enable-udev_rules \
352         --with-cluster=internal \
353 %if %{with cluster}
354         --with-clvmd=corosync \
355         --enable-cmirrord \
356 %endif
357         --with-dmeventd-path=%{_sbindir}/dmeventd \
358         --with-interface=ioctl \
359         --with-lvm1=internal \
360         --with-mirrors=internal \
361         --with-optimisation="%{rpmcflags}" \
362         --with-pool=internal \
363         --with-snapshots=internal \
364         --with-systemdsystemunitdir=%{systemdunitdir} \
365         --with-thin=internal \
366         --with-thin-check=%{_sbindir}/thin_check \
367         --with-thin-dump=%{_sbindir}/thin_dump \
368         --with-thin-repair=%{_sbindir}/thin_repair \
369         --with-udev-prefix=/ \
370         --with-usrlibdir=%{_libdir}
371
372 %{__make} -j1
373 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
374
375 %install
376 rm -rf $RPM_BUILD_ROOT
377 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
378 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
379
380 %{__make} install install_system_dirs install_systemd_units install_initscripts \
381         DESTDIR=$RPM_BUILD_ROOT \
382         OWNER="" \
383         GROUP=""
384
385 install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
386 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
387
388 %if %{with cluster}
389 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
390 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
391 %endif
392
393 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
394 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
395         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
396         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
397         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
398 done
399
400 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
401
402 %if %{with initrd}
403 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
404 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
405 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
406
407 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
408 %endif
409
410 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
411
412 %clean
413 rm -rf $RPM_BUILD_ROOT
414
415 %post
416 /sbin/chkconfig --add lvm2-monitor
417 %service lvm2-monitor restart
418 %systemd_post lvm2-monitor.service
419 /sbin/chkconfig --add blk-availability
420 # no service blk-availability restart
421 %systemd_post blk-availability.service
422
423 %preun
424 %systemd_preun lvm2-monitor.service
425 %systemd_preun blk-availability.service
426
427 %postun
428 if [ "$1" = "0" ]; then
429         %service lvm2-monitor stop
430         /sbin/chkconfig --del lvm2-monitor
431         #no service blk-availability stop
432         /sbin/chkconfig --del blk-availability
433 fi
434 %systemd_reload
435
436 %triggerpostun -- %{name} < 2.02.94-1
437 %systemd_trigger lvm2-monitor.service
438
439 %post -n device-mapper
440 /sbin/ldconfig
441 %systemd_post dm-event.socket
442
443 %preun -n device-mapper
444 %systemd_preun dm-event.socket dm-event.service
445
446 %postun -n device-mapper
447 /sbin/ldconfig
448 %systemd_reload
449
450 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
451 %systemd_trigger dm-event.socket
452
453 %post clvmd
454 /sbin/chkconfig --add clvmd
455 # no service restart - it breaks current locks!
456 export NORESTART=1
457 %systemd_post clvmd.service
458 # re-exec instead
459 /usr/sbin/clvmd -S 2>/dev/null || :
460
461 %preun clvmd
462 %systemd_preun clvmd.service
463
464 %postun clvmd
465 if [ "$1" = "0" ]; then
466         %service clvmd stop
467         /sbin/chkconfig --del clvmd
468 fi
469 %systemd_reload
470
471 %files
472 %defattr(644,root,root,755)
473 %doc README WHATS_NEW doc/*
474 %attr(755,root,root) %{_sbindir}/blkdeactivate
475 %attr(755,root,root) %{_sbindir}/fsadm
476 %attr(755,root,root) %{_sbindir}/lv*
477 %attr(755,root,root) %{_sbindir}/pv*
478 %attr(755,root,root) %{_sbindir}/vg*
479 %{_mandir}/man5/lvm.conf.5*
480 %{_mandir}/man7/lvmthin.7*
481 %{_mandir}/man8/blkdeactivate.8*
482 %{_mandir}/man8/fsadm.8*
483 %{_mandir}/man8/lv*.8*
484 %{_mandir}/man8/pv*.8*
485 %{_mandir}/man8/vg*.8*
486 %attr(750,root,root) %dir %{_sysconfdir}/lvm
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
488 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
492 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
493 %if %{with lvmetad}
494 /lib/udev/rules.d/69-dm-lvm-metad.rules
495 %endif
496 %{_sysconfdir}/tmpfiles.d/lvm2.conf
497 %{systemdunitdir}/blk-availability.service
498 %if %{with lvmetad}
499 %{systemdunitdir}/lvm2-lvmetad.service
500 %{systemdunitdir}/lvm2-lvmetad.socket
501 %endif
502 %{systemdunitdir}/lvm2-monitor.service
503 %{systemdunitdir}/lvm2-pvscan@.service
504 %dir %{_sysconfdir}/lvm/cache
505 %ghost %{_sysconfdir}/lvm/cache/.cache
506 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
507 %if %{with lvmetad}
508 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
509 %endif
510 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
511 %dir %attr(700,root,root) /var/run/lvm
512
513 %if %{with cluster}
514 %files clvmd
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_usrsbindir}/clvmd
517 %attr(754,root,root) /etc/rc.d/init.d/clvmd
518 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
519 %attr(755,root,root) /lib/systemd/lvm2-cluster-activation
520 %{systemdunitdir}/clvmd.service
521 %{systemdunitdir}/lvm2-cluster-activation.service
522 %{systemdunitdir}/lvm2-clvmd.service
523 %{_mandir}/man8/clvmd.8*
524
525 %files cmirrord
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_usrsbindir}/cmirrord
528 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
529 %{systemdunitdir}/lvm2-cmirrord.service
530 %{_mandir}/man8/cmirrord.8*
531 %endif
532
533 %files resource-agents
534 %defattr(644,root,root,755)
535 %dir %{_prefix}/lib/ocf/resource.d/lvm2
536 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
537
538 %files -n device-mapper
539 %defattr(644,root,root,755)
540 %doc *_DM
541 %{systemdunitdir}/dm-event.service
542 %{systemdunitdir}/dm-event.socket
543 /lib/udev/rules.d/10-dm.rules
544 /lib/udev/rules.d/11-dm-lvm.rules
545 /lib/udev/rules.d/13-dm-disk.rules
546 /lib/udev/rules.d/95-dm-notify.rules
547 %attr(755,root,root) %{_sbindir}/dmeventd
548 %attr(755,root,root) %{_sbindir}/dmsetup
549 %attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
550 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
551 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
552 %dir %{_libdir}/device-mapper
553 %attr(755,root,root) %{_libdir}/device-mapper/*.so
554 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
555 %{_mandir}/man8/dmsetup.8*
556 %{_mandir}/man8/dmeventd.8*
557
558 %files -n device-mapper-devel
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/libdevmapper.so
561 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
562 %attr(755,root,root) %{_libdir}/liblvm2app.so
563 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
564 %{_includedir}/libdevmapper*.h
565 %{_includedir}/lvm2app.h
566 %{_includedir}/lvm2cmd.h
567 %{_pkgconfigdir}/devmapper*.pc
568 %{_pkgconfigdir}/lvm2app.pc
569
570 %files -n device-mapper-static
571 %defattr(644,root,root,755)
572 %{_libdir}/libdevmapper*.a
573
574 %if %{with initrd}
575 %if %{with dietlibc}
576 %files -n device-mapper-dietlibc
577 %defattr(644,root,root,755)
578 %{dietlibdir}/libdevmapper.a
579 %endif
580
581 %files -n device-mapper-initrd
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/initrd/dmsetup
584
585 %files initrd
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/initrd/lvm
588 %endif