]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- updated python3 BRs
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad (and lvmlockd)
12 %bcond_without  lvmpolld        # disable lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # disable lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 %bcond_with     replicator      # internal replicator support
16 %bcond_without  selinux         # SELinux support
17 %bcond_without  python2         # Python 2.x binding
18 %bcond_without  python3         # Python 3.x binding
19
20 # lvmlockd requires lvmetad and lvmpolld
21 %if %{without lvmetad} || %{without lvmpolld}
22 %undefine       with_lvmpolld
23 %endif
24
25 # if one of the *libc is enabled disable default dietlibc
26 %if %{with dietlibc} && %{with uClibc}
27 %undefine       with_dietlibc
28 %endif
29
30 # with glibc disables default dietlibc
31 %if %{with glibc} && %{with dietlibc}
32 %undefine       with_dietlibc
33 %endif
34
35 # fallback is glibc if neither alternatives are enabled
36 %if %{without dietlibc} && %{without uClibc}
37 %define         with_glibc      1
38 %endif
39
40 Summary:        The new version of Logical Volume Manager for Linux
41 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
42 Name:           lvm2
43 Version:        2.02.146
44 Release:        1
45 License:        GPL v2 and LGPL v2.1
46 Group:          Applications/System
47 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
48 # Source0-md5:  0c922e4c450515fe2d68a946ad04e73b
49 Source1:        clvmd.sysconfig
50 Patch0:         %{name}-selinux.patch
51 Patch1:         %{name}-diet.patch
52 Patch2:         device-mapper-dmsetup-export.patch
53 Patch3:         %{name}-tld_init.patch
54 Patch4:         dl-dlsym.patch
55 Patch6:         %{name}-lvm_path.patch
56 Patch7:         %{name}-clvmd_cmd_timeout.patch
57 Patch8:         device-mapper-dmsetup-deps-export.patch
58 Patch9:         %{name}-run-dir.patch
59 URL:            http://www.sourceware.org/lvm2/
60 BuildRequires:  autoconf >= 2.61
61 BuildRequires:  automake
62 # for /run detection
63 BuildRequires:  autoconf-archive
64 BuildRequires:  filesystem >= 3.0-43
65 BuildRequires:  libblkid-devel >= 2.24
66 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
67 %{?with_selinux:BuildRequires:  libsepol-devel}
68 BuildRequires:  ncurses-devel
69 BuildRequires:  pkgconfig
70 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
71 %if %{with python3}
72 BuildRequires:  python3-devel >= 1:3.2
73 BuildRequires:  python3-modules >= 1:3.2
74 %endif
75 BuildRequires:  readline-devel
76 BuildRequires:  rpmbuild(macros) >= 1.647
77 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.2.4}
78 BuildRequires:  udev-devel >= 1:176
79 %if %{with initrd}
80 %if %{with dietlibc}
81 BuildRequires:  dietlibc-static >= 2:0.32-7
82 BuildConflicts: device-mapper-dietlibc
83 %endif
84 %if %{with glibc}
85 %{?with_selinux:BuildRequires:  libselinux-static}
86 %{?with_selinux:BuildRequires:  libsepol-static}
87 %endif
88 %{?with_glibc:BuildRequires:    glibc-static}
89 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
90 %endif
91 %if %{with cluster}
92 BuildRequires:  corosync-devel
93 BuildRequires:  dlm-devel >= 3.99.5
94 %endif
95 Requires(post,postun):  /sbin/chkconfig
96 Requires:       device-mapper >= %{version}-%{release}
97 %{?with_selinux:Requires:       libselinux >= 1.10}
98 # doesn't work with 2.4 kernels
99 Requires:       uname(release) >= 2.6
100 Suggests:       thin-provisioning-tools >= 0.5.4
101 Obsoletes:      lvm
102 Obsoletes:      lvm2-systemd
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _sbindir        /sbin
106 %define         _usrsbindir     /usr/sbin
107
108 # changing CFLAGS in the middle confuses confcache
109 %undefine       configure_cache
110
111 # borken on AC
112 %define         filterout_ld    -Wl,--as-needed
113
114 # causes: undefined reference to `__stack_chk_fail_local'
115 %define         filterout_c     -fstack-protector
116
117 # for some reason known only to rpm there must be "\\|" not "\|" here
118 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
119 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
120
121 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
122
123 %description
124 This package includes a number of utilities for creating, checking,
125 and repairing logical volumes.
126
127 %description -l pl.UTF-8
128 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
129 logicznych wolumenów dyskowych (LVM2).
130
131 %package initrd
132 Summary:        The new version of Logical Volume Manager for Linux - initrd version
133 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
134 Group:          Base
135 Conflicts:      geninitrd < 10000.18
136
137 %description initrd
138 This package includes a number of utilities for creating, checking,
139 and repairing logical volumes - staticaly linked for initrd.
140
141 %description initrd -l pl.UTF-8
142 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
143 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
144 potrzeby initrd.
145
146 %package clvmd
147 Summary:        Cluster LVM daemon
148 Summary(pl.UTF-8):      Demon clustra LVM
149 Group:          Applications/System
150 Requires:       %{name} = %{version}-%{release}
151
152 %description clvmd
153 clvmd is the daemon that distributes LVM metadata updates around a
154 cluster. It must be running on all nodes in the cluster and will give
155 an error if a node in the cluster does not have this daemon running.
156
157 %description clvmd -l pl.UTF-8
158 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
159 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
160 węzeł w klastrze nie ma tego demona uruchomionego.
161
162 %package cmirrord
163 Summary:        Cluster mirror log daemon
164 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
165 Group:          Applications/System
166 Requires:       %{name} = %{version}-%{release}
167
168 %description cmirrord
169 cmirrord is the daemon that tracks mirror log information in a
170 cluster. It is specific to device-mapper based mirrors (and by
171 extension, LVM cluster mirrors). Cluster mirrors are not possible
172 without this daemon running.
173
174 This daemon relies on the cluster infrastructure provided by the
175 Cluster MANager (CMAN), which must be set up and running in order for
176 cmirrord to function.
177
178 %description cmirrord
179 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
180 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
181 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
182 lustrzanych ten demon jest niezbędny.
183
184 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
185 (Cluster MANager), który musi być skonfigurowany i działający, aby
186 działał cmirrord.
187
188 %package resource-agents
189 Summary:        OCF Resource Agents for LVM2 processes
190 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
191 Group:          Applications/System
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       resource-agents
194
195 %description resource-agents
196 OCF Resource Agents for LVM2 processes.
197
198 %description resource-agents -l pl.UTF-8
199 Agenci OCF do monitorowania procesów LVM2.
200
201 %package -n python-lvm
202 Summary:        Python interface to LVM2
203 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
204 Group:          Libraries/Python
205 Requires:       device-mapper-libs = %{version}-%{release}
206
207 %description -n python-lvm
208 Python interface to LVM2.
209
210 %description -n python-lvm -l pl.UTF-8
211 Interfejs Pythona do LVM2.
212
213 %package -n python3-lvm
214 Summary:        Python interface to LVM2
215 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
216 Group:          Libraries/Python
217 Requires:       device-mapper-libs = %{version}-%{release}
218
219 %description -n python3-lvm
220 Python interface to LVM2.
221
222 %description -n python3-lvm -l pl.UTF-8
223 Interfejs Pythona do LVM2.
224
225 %package -n device-mapper
226 Summary:        Userspace support for the device-mapper
227 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
228 Group:          Base
229 Requires(post,postun):  /sbin/ldconfig
230 Requires:       device-mapper-libs = %{version}-%{release}
231
232 %description -n device-mapper
233 The goal of this driver is to support volume management. The driver
234 enables the definition of new block devices composed of ranges of
235 sectors of existing devices. This can be used to define disk
236 partitions - or logical volumes. This light-weight kernel component
237 can support user-space tools for logical volume management.
238
239 %description -n device-mapper -l pl.UTF-8
240 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
241 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
242 sektorów na istniejących urządzeniach. Może to być wykorzystane do
243 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
244 składnik jądra może wspierać działające w przestrzeni użytkownika
245 narzędzia do zarządzania logicznymi wolumenami.
246
247 %package -n device-mapper-libs
248 Summary:        Device-mapper shared libraries
249 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
250 Group:          Libraries
251 Conflicts:      device-mapper < 2.02.119-1
252 Requires:       libblkid >= 2.24
253 Requires:       udev-libs >= 1:176
254
255 %description -n device-mapper-libs
256 Device-mapper shared libraries.
257
258 %description -n device-mapper-libs -l pl.UTF-8
259 Biblioteki współdzielone device-mappera.
260
261 %package -n device-mapper-devel
262 Summary:        Header files for device-mapper libraries
263 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
264 Group:          Development/Libraries
265 Requires:       device-mapper-libs = %{version}-%{release}
266 Requires:       libblkid-devel >= 2.24
267 %if %{with selinux}
268 Requires:       libselinux-devel
269 Requires:       libsepol-devel
270 %endif
271 Requires:       udev-devel >= 1:176
272
273 %description -n device-mapper-devel
274 Header files for device-mapper libraries.
275
276 %description -n device-mapper-devel -l pl.UTF-8
277 Pliki nagłówkowe bibliotek device-mappera.
278
279 %package -n device-mapper-static
280 Summary:        Static devmapper library
281 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
282 License:        LGPL v2.1
283 Group:          Development/Libraries
284 Requires:       device-mapper-devel = %{version}-%{release}
285
286 %description -n device-mapper-static
287 Static devmapper library.
288
289 %description -n device-mapper-static -l pl.UTF-8
290 Statyczna biblioteka devmapper.
291
292 %package -n device-mapper-dietlibc
293 Summary:        Static devmapper library built with dietlibc
294 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
295 License:        LGPL v2.1
296 Group:          Development/Libraries
297 Requires:       device-mapper-devel = %{version}-%{release}
298
299 %description -n device-mapper-dietlibc
300 Static devmapper library built with dietlibc.
301
302 %description -n device-mapper-dietlibc -l pl.UTF-8
303 Statyczna biblioteka devmapper zbudowana z dietlibc.
304
305 %package -n device-mapper-initrd
306 Summary:        Userspace support for the device-mapper - initrd version
307 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
308 Group:          Base
309 Obsoletes:      device-mapper-initrd-devel
310 Conflicts:      geninitrd < 10000.10
311
312 %description -n device-mapper-initrd
313 The goal of this driver is to support volume management. The driver
314 enables the definition of new block devices composed of ranges of
315 sectors of existing devices. This can be used to define disk
316 partitions - or logical volumes. This light-weight kernel component
317 can support user-space tools for logical volume management.
318
319 This package contains dmsetup program linked staticaly for use in
320 initrd.
321
322 %description -n device-mapper-initrd -l pl.UTF-8
323 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
324 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
325 sektorów na istniejących urządzeniach. Może to być wykorzystane do
326 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
327 składnik jądra może wspierać działające w przestrzeni użytkownika
328 narzędzia do zarządzania logicznymi wolumenami.
329
330 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
331 potrzeby initrd.
332
333 %prep
334 %setup -q -n LVM2.%{version}
335 %{?with_selinux:%patch0 -p1}
336 %patch1 -p1
337 %patch2 -p1
338 %patch3 -p1
339 %patch4 -p1
340 %patch6 -p1
341 %patch7 -p1
342 %patch8 -p1
343 %patch9 -p1
344
345 # do not force --export-symbol linker option for e.g. statically linked executables
346 # -rdynamic compiler option drives linker in the right way.
347 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
348
349 %build
350 %if %{with initrd}
351 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
352 %endif
353 cp -f /usr/share/automake/config.sub autoconf
354 %{__aclocal}
355 %{__autoconf}
356
357 %if %{with initrd}
358 %{?with_glibc:export CC="%{__cc}"}
359 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
360 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
361
362 %configure \
363         ac_cv_lib_dl_dlopen=no \
364         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
365         %{?debug:--enable-debug} \
366         --disable-nls \
367         --disable-readline \
368         --enable-selinux%{!?with_glibc:=no} \
369         --enable-static_link \
370         --with-lvm1=internal \
371         --with-optimisation="%{rpmcflags} -Os"
372 # glibc version links with normal static libdevicemapper which has selinux enabled
373 # and we need to keep these in sync between device-mapper and lvm2
374
375 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
376 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
377
378 %{__make} -j1 -C include
379 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
380 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
381 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
382 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
383 mv -f tools/lvm.static initrd-lvm
384 mv -f tools/dmsetup.static initrd-dmsetup
385
386 # check if tools works
387 for tool in initrd-lvm initrd-dmsetup; do
388         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
389         if [ $rc -gt 127 ]; then
390                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
391                 exit 1
392         fi
393 done
394
395 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
396 %{__make} clean
397
398 unset CC
399 %endif
400
401 %configure \
402         --enable-applib \
403         --enable-cmdlib \
404         %{?debug:--enable-debug} \
405         --enable-dmeventd \
406         --enable-fsadm \
407 %if %{with lvmlockd}
408         %{?with_cluster:--enable-lockd-dlm} \
409         %{?with_sanlock:--enable-lockd-sanlock} \
410 %endif
411         %{?with_lvmetad:--enable-lvmetad} \
412         --enable-ocf \
413         %{?with_python2:--enable-python2-bindings} \
414         %{?with_python3:--enable-python3-bindings} \
415         --enable-readline \
416         %{!?with_selinux:--disable-selinux} \
417         --enable-pkgconfig \
418         --enable-udev_sync \
419         --enable-udev_rules \
420         --with-cache=internal \
421         --with-cache-check=/usr/sbin/cache_check \
422         --with-cache-dump=/usr/sbin/cache_dump \
423         --with-cache-repair=/usr/sbin/cache_repair \
424         --with-cache-restore=/usr/sbin/cache_restore \
425         --with-cluster=internal \
426 %if %{with cluster}
427         --with-clvmd=corosync \
428         --enable-cmirrord \
429 %endif
430         --with-dmeventd-path=%{_sbindir}/dmeventd \
431         --with-interface=ioctl \
432         --with-lvm1=internal \
433         --with-mirrors=internal \
434         --with-optimisation="%{rpmcflags}" \
435         --with-pool=internal \
436         %{?with_replicator:--with-replicators=internal} \
437         --with-snapshots=internal \
438         --with-thin=internal \
439         --with-thin-check=/usr/sbin/thin_check \
440         --with-thin-dump=/usr/sbin/thin_dump \
441         --with-thin-repair=/usr/sbin/thin_repair \
442         --with-thin-restore=/usr/sbin/thin_restore \
443         --with-udev-prefix=/ \
444         --with-usrlibdir=%{_libdir}
445
446 %{__make} -j1
447 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
452 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
453
454 %{__make} install install_system_dirs install_initscripts \
455         DESTDIR=$RPM_BUILD_ROOT \
456         OWNER="" \
457         GROUP=""
458
459 %{__make} -C scripts \
460         DESTDIR=$RPM_BUILD_ROOT \
461
462 %if %{with cluster}
463 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
464 %endif
465
466 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
467 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
468         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
469         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
470         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
471 done
472
473 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
474
475 %if %{with initrd}
476 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
477 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
478 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
479
480 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
481 %endif
482
483 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %post
489 /sbin/chkconfig --add lvm2-lvmetad
490 %service lvm2-lvmetad restart
491 /sbin/chkconfig --add lvm2-monitor
492 %service lvm2-monitor restart
493 /sbin/chkconfig --add lvm2-lvmpolld
494 %service lvm2-lvmpolld restart
495 # no service restart available
496 /sbin/chkconfig --add blk-availability
497
498 %preun
499 if [ "$1" = "0" ]; then
500         %service lvm2-lvmetad stop
501         /sbin/chkconfig --del lvm2-lvmetad
502         %service lvm2-lvmpolld stop
503         /sbin/chkconfig --del lvm2-lvmpolld
504         %service lvm2-monitor stop
505         /sbin/chkconfig --del lvm2-monitor
506         /sbin/chkconfig --del blk-availability
507 fi
508
509 %post   -n device-mapper-libs -p /sbin/ldconfig
510 %postun -n device-mapper-libs -p /sbin/ldconfig
511
512 %post clvmd
513 /sbin/chkconfig --add clvmd
514 # no service restart - it breaks current locks!
515 export NORESTART=1
516 # re-exec instead
517 /usr/sbin/clvmd -S 2>/dev/null || :
518
519 %preun clvmd
520 if [ "$1" = "0" ]; then
521         %service clvmd stop
522         /sbin/chkconfig --del clvmd
523 fi
524
525 %files
526 %defattr(644,root,root,755)
527 %doc README WHATS_NEW doc/*
528 %attr(755,root,root) %{_sbindir}/blkdeactivate
529 %attr(755,root,root) %{_sbindir}/fsadm
530 %attr(755,root,root) %{_sbindir}/lv*
531 %attr(755,root,root) %{_sbindir}/pv*
532 %attr(755,root,root) %{_sbindir}/vg*
533 %{_mandir}/man5/lvm.conf.5*
534 %{_mandir}/man7/lvmcache.7*
535 %{_mandir}/man7/lvmsystemid.7*
536 %{_mandir}/man7/lvmthin.7*
537 %{_mandir}/man8/blkdeactivate.8*
538 %{_mandir}/man8/fsadm.8*
539 %{_mandir}/man8/lv*.8*
540 %{_mandir}/man8/pv*.8*
541 %{_mandir}/man8/vg*.8*
542 %attr(750,root,root) %dir %{_sysconfdir}/lvm
543 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
544 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
545 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
546 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
547 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
548 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
549 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
550 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
551 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
552 %if %{with lvmetad}
553 /lib/udev/rules.d/69-dm-lvm-metad.rules
554 %endif
555 %dir %{_sysconfdir}/lvm/cache
556 %ghost %{_sysconfdir}/lvm/cache/.cache
557 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
558 %if %{with lvmetad}
559 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
560 %endif
561 %if %{with lvmpolld}
562 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
563 %endif
564 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
565 %attr(700,root,root) %dir /var/lock/lvm
566 %attr(700,root,root) %dir /var/run/lvm
567
568 %if %{with cluster}
569 %files clvmd
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_usrsbindir}/clvmd
572 %attr(754,root,root) /etc/rc.d/init.d/clvmd
573 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
574 %{_mandir}/man8/clvmd.8*
575
576 %files cmirrord
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_usrsbindir}/cmirrord
579 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
580 %{_mandir}/man8/cmirrord.8*
581 %endif
582
583 %files resource-agents
584 %defattr(644,root,root,755)
585 %dir %{_prefix}/lib/ocf/resource.d/lvm2
586 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
587
588 %if %{with python2}
589 %files -n python-lvm
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{py_sitedir}/lvm.so
592 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
593 %endif
594
595 %if %{with python3}
596 %files -n python3-lvm
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{py3_sitedir}/lvm*.so
599 %{py3_sitedir}/lvm-%{version}_*-py*.egg-info
600 %endif
601
602 %files -n device-mapper
603 %defattr(644,root,root,755)
604 %doc *_DM
605 /lib/udev/rules.d/10-dm.rules
606 /lib/udev/rules.d/11-dm-lvm.rules
607 /lib/udev/rules.d/13-dm-disk.rules
608 /lib/udev/rules.d/95-dm-notify.rules
609 %attr(755,root,root) %{_sbindir}/dmeventd
610 %attr(755,root,root) %{_sbindir}/dmsetup
611 %attr(755,root,root) %{_sbindir}/dmstats
612 %dir %{_libdir}/device-mapper
613 %attr(755,root,root) %{_libdir}/device-mapper/*.so
614 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
615 %{_mandir}/man8/dmsetup.8*
616 %{_mandir}/man8/dmstats.8*
617 %{_mandir}/man8/dmeventd.8*
618
619 %files -n device-mapper-libs
620 %defattr(644,root,root,755)
621 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
622 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
623 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
624 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
625 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
626
627 %files -n device-mapper-devel
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/libdevmapper.so
630 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
631 %attr(755,root,root) %{_libdir}/liblvm2app.so
632 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
633 %{_includedir}/libdevmapper.h
634 %{_includedir}/libdevmapper-event.h
635 %{_includedir}/lvm2app.h
636 %{_includedir}/lvm2cmd.h
637 %{_pkgconfigdir}/devmapper.pc
638 %{_pkgconfigdir}/devmapper-event.pc
639 %{_pkgconfigdir}/lvm2app.pc
640
641 %files -n device-mapper-static
642 %defattr(644,root,root,755)
643 %{_libdir}/libdevmapper.a
644
645 %if %{with initrd}
646 %if %{with dietlibc}
647 %files -n device-mapper-dietlibc
648 %defattr(644,root,root,755)
649 %{dietlibdir}/libdevmapper.a
650 %endif
651
652 %files -n device-mapper-initrd
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/initrd/dmsetup
655
656 %files initrd
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/initrd/lvm
659 %endif