]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- updated to 2.02.146
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad (and lvmlockd)
12 %bcond_without  lvmpolld        # disable lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # disable lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 %bcond_with     replicator      # internal replicator support
16 %bcond_without  selinux         # SELinux support
17 %bcond_without  python2         # Python 2.x binding
18 %bcond_without  python3         # Python 3.x binding
19
20 # lvmlockd requires lvmetad and lvmpolld
21 %if %{without lvmetad} || %{without lvmpolld}
22 %undefine       with_lvmpolld
23 %endif
24
25 # if one of the *libc is enabled disable default dietlibc
26 %if %{with dietlibc} && %{with uClibc}
27 %undefine       with_dietlibc
28 %endif
29
30 # with glibc disables default dietlibc
31 %if %{with glibc} && %{with dietlibc}
32 %undefine       with_dietlibc
33 %endif
34
35 # fallback is glibc if neither alternatives are enabled
36 %if %{without dietlibc} && %{without uClibc}
37 %define         with_glibc      1
38 %endif
39
40 Summary:        The new version of Logical Volume Manager for Linux
41 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
42 Name:           lvm2
43 Version:        2.02.146
44 Release:        1
45 License:        GPL v2 and LGPL v2.1
46 Group:          Applications/System
47 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
48 # Source0-md5:  0c922e4c450515fe2d68a946ad04e73b
49 Source1:        clvmd.sysconfig
50 Patch0:         %{name}-selinux.patch
51 Patch1:         %{name}-diet.patch
52 Patch2:         device-mapper-dmsetup-export.patch
53 Patch3:         %{name}-tld_init.patch
54 Patch4:         dl-dlsym.patch
55 Patch6:         %{name}-lvm_path.patch
56 Patch7:         %{name}-clvmd_cmd_timeout.patch
57 Patch8:         device-mapper-dmsetup-deps-export.patch
58 Patch9:         %{name}-run-dir.patch
59 URL:            http://www.sourceware.org/lvm2/
60 BuildRequires:  autoconf >= 2.61
61 BuildRequires:  automake
62 # for /run detection
63 BuildRequires:  filesystem >= 3.0-43
64 BuildRequires:  libblkid-devel >= 2.24
65 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
66 %{?with_selinux:BuildRequires:  libsepol-devel}
67 BuildRequires:  ncurses-devel
68 BuildRequires:  pkgconfig
69 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
70 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
71 BuildRequires:  readline-devel
72 BuildRequires:  rpmbuild(macros) >= 1.647
73 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.2.4}
74 BuildRequires:  udev-devel >= 1:176
75 %if %{with initrd}
76 %if %{with dietlibc}
77 BuildRequires:  dietlibc-static >= 2:0.32-7
78 BuildConflicts: device-mapper-dietlibc
79 %endif
80 %if %{with glibc}
81 %{?with_selinux:BuildRequires:  libselinux-static}
82 %{?with_selinux:BuildRequires:  libsepol-static}
83 %endif
84 %{?with_glibc:BuildRequires:    glibc-static}
85 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
86 %endif
87 %if %{with cluster}
88 BuildRequires:  corosync-devel
89 BuildRequires:  dlm-devel >= 3.99.5
90 %endif
91 Requires(post,postun):  /sbin/chkconfig
92 Requires:       device-mapper >= %{version}-%{release}
93 %{?with_selinux:Requires:       libselinux >= 1.10}
94 # doesn't work with 2.4 kernels
95 Requires:       uname(release) >= 2.6
96 Suggests:       thin-provisioning-tools >= 0.5.4
97 Obsoletes:      lvm
98 Obsoletes:      lvm2-systemd
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _sbindir        /sbin
102 %define         _usrsbindir     /usr/sbin
103
104 # changing CFLAGS in the middle confuses confcache
105 %undefine       configure_cache
106
107 # borken on AC
108 %define         filterout_ld    -Wl,--as-needed
109
110 # causes: undefined reference to `__stack_chk_fail_local'
111 %define         filterout_c     -fstack-protector
112
113 # for some reason known only to rpm there must be "\\|" not "\|" here
114 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
115 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
116
117 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
118
119 %description
120 This package includes a number of utilities for creating, checking,
121 and repairing logical volumes.
122
123 %description -l pl.UTF-8
124 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
125 logicznych wolumenów dyskowych (LVM2).
126
127 %package initrd
128 Summary:        The new version of Logical Volume Manager for Linux - initrd version
129 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
130 Group:          Base
131 Conflicts:      geninitrd < 10000.18
132
133 %description initrd
134 This package includes a number of utilities for creating, checking,
135 and repairing logical volumes - staticaly linked for initrd.
136
137 %description initrd -l pl.UTF-8
138 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
139 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
140 potrzeby initrd.
141
142 %package clvmd
143 Summary:        Cluster LVM daemon
144 Summary(pl.UTF-8):      Demon clustra LVM
145 Group:          Applications/System
146 Requires:       %{name} = %{version}-%{release}
147
148 %description clvmd
149 clvmd is the daemon that distributes LVM metadata updates around a
150 cluster. It must be running on all nodes in the cluster and will give
151 an error if a node in the cluster does not have this daemon running.
152
153 %description clvmd -l pl.UTF-8
154 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
155 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
156 węzeł w klastrze nie ma tego demona uruchomionego.
157
158 %package cmirrord
159 Summary:        Cluster mirror log daemon
160 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
161 Group:          Applications/System
162 Requires:       %{name} = %{version}-%{release}
163
164 %description cmirrord
165 cmirrord is the daemon that tracks mirror log information in a
166 cluster. It is specific to device-mapper based mirrors (and by
167 extension, LVM cluster mirrors). Cluster mirrors are not possible
168 without this daemon running.
169
170 This daemon relies on the cluster infrastructure provided by the
171 Cluster MANager (CMAN), which must be set up and running in order for
172 cmirrord to function.
173
174 %description cmirrord
175 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
176 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
177 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
178 lustrzanych ten demon jest niezbędny.
179
180 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
181 (Cluster MANager), który musi być skonfigurowany i działający, aby
182 działał cmirrord.
183
184 %package resource-agents
185 Summary:        OCF Resource Agents for LVM2 processes
186 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
187 Group:          Applications/System
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       resource-agents
190
191 %description resource-agents
192 OCF Resource Agents for LVM2 processes.
193
194 %description resource-agents -l pl.UTF-8
195 Agenci OCF do monitorowania procesów LVM2.
196
197 %package -n python-lvm
198 Summary:        Python interface to LVM2
199 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
200 Group:          Libraries/Python
201 Requires:       device-mapper-libs = %{version}-%{release}
202
203 %description -n python-lvm
204 Python interface to LVM2.
205
206 %description -n python-lvm -l pl.UTF-8
207 Interfejs Pythona do LVM2.
208
209 %package -n python3-lvm
210 Summary:        Python interface to LVM2
211 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
212 Group:          Libraries/Python
213 Requires:       device-mapper-libs = %{version}-%{release}
214
215 %description -n python3-lvm
216 Python interface to LVM2.
217
218 %description -n python3-lvm -l pl.UTF-8
219 Interfejs Pythona do LVM2.
220
221 %package -n device-mapper
222 Summary:        Userspace support for the device-mapper
223 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
224 Group:          Base
225 Requires(post,postun):  /sbin/ldconfig
226 Requires:       device-mapper-libs = %{version}-%{release}
227
228 %description -n device-mapper
229 The goal of this driver is to support volume management. The driver
230 enables the definition of new block devices composed of ranges of
231 sectors of existing devices. This can be used to define disk
232 partitions - or logical volumes. This light-weight kernel component
233 can support user-space tools for logical volume management.
234
235 %description -n device-mapper -l pl.UTF-8
236 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
237 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
238 sektorów na istniejących urządzeniach. Może to być wykorzystane do
239 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
240 składnik jądra może wspierać działające w przestrzeni użytkownika
241 narzędzia do zarządzania logicznymi wolumenami.
242
243 %package -n device-mapper-libs
244 Summary:        Device-mapper shared libraries
245 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
246 Group:          Libraries
247 Conflicts:      device-mapper < 2.02.119-1
248 Requires:       libblkid >= 2.24
249 Requires:       udev-libs >= 1:176
250
251 %description -n device-mapper-libs
252 Device-mapper shared libraries.
253
254 %description -n device-mapper-libs -l pl.UTF-8
255 Biblioteki współdzielone device-mappera.
256
257 %package -n device-mapper-devel
258 Summary:        Header files for device-mapper libraries
259 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
260 Group:          Development/Libraries
261 Requires:       device-mapper-libs = %{version}-%{release}
262 Requires:       libblkid-devel >= 2.24
263 %if %{with selinux}
264 Requires:       libselinux-devel
265 Requires:       libsepol-devel
266 %endif
267 Requires:       udev-devel >= 1:176
268
269 %description -n device-mapper-devel
270 Header files for device-mapper libraries.
271
272 %description -n device-mapper-devel -l pl.UTF-8
273 Pliki nagłówkowe bibliotek device-mappera.
274
275 %package -n device-mapper-static
276 Summary:        Static devmapper library
277 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
278 License:        LGPL v2.1
279 Group:          Development/Libraries
280 Requires:       device-mapper-devel = %{version}-%{release}
281
282 %description -n device-mapper-static
283 Static devmapper library.
284
285 %description -n device-mapper-static -l pl.UTF-8
286 Statyczna biblioteka devmapper.
287
288 %package -n device-mapper-dietlibc
289 Summary:        Static devmapper library built with dietlibc
290 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
291 License:        LGPL v2.1
292 Group:          Development/Libraries
293 Requires:       device-mapper-devel = %{version}-%{release}
294
295 %description -n device-mapper-dietlibc
296 Static devmapper library built with dietlibc.
297
298 %description -n device-mapper-dietlibc -l pl.UTF-8
299 Statyczna biblioteka devmapper zbudowana z dietlibc.
300
301 %package -n device-mapper-initrd
302 Summary:        Userspace support for the device-mapper - initrd version
303 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
304 Group:          Base
305 Obsoletes:      device-mapper-initrd-devel
306 Conflicts:      geninitrd < 10000.10
307
308 %description -n device-mapper-initrd
309 The goal of this driver is to support volume management. The driver
310 enables the definition of new block devices composed of ranges of
311 sectors of existing devices. This can be used to define disk
312 partitions - or logical volumes. This light-weight kernel component
313 can support user-space tools for logical volume management.
314
315 This package contains dmsetup program linked staticaly for use in
316 initrd.
317
318 %description -n device-mapper-initrd -l pl.UTF-8
319 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
320 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
321 sektorów na istniejących urządzeniach. Może to być wykorzystane do
322 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
323 składnik jądra może wspierać działające w przestrzeni użytkownika
324 narzędzia do zarządzania logicznymi wolumenami.
325
326 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
327 potrzeby initrd.
328
329 %prep
330 %setup -q -n LVM2.%{version}
331 %{?with_selinux:%patch0 -p1}
332 %patch1 -p1
333 %patch2 -p1
334 %patch3 -p1
335 %patch4 -p1
336 %patch6 -p1
337 %patch7 -p1
338 %patch8 -p1
339 %patch9 -p1
340
341 # do not force --export-symbol linker option for e.g. statically linked executables
342 # -rdynamic compiler option drives linker in the right way.
343 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
344
345 %build
346 %if %{with initrd}
347 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
348 %endif
349 cp -f /usr/share/automake/config.sub autoconf
350 %{__aclocal}
351 %{__autoconf}
352
353 %if %{with initrd}
354 %{?with_glibc:export CC="%{__cc}"}
355 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
356 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
357
358 %configure \
359         ac_cv_lib_dl_dlopen=no \
360         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
361         %{?debug:--enable-debug} \
362         --disable-nls \
363         --disable-readline \
364         --enable-selinux%{!?with_glibc:=no} \
365         --enable-static_link \
366         --with-lvm1=internal \
367         --with-optimisation="%{rpmcflags} -Os"
368 # glibc version links with normal static libdevicemapper which has selinux enabled
369 # and we need to keep these in sync between device-mapper and lvm2
370
371 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
372 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
373
374 %{__make} -j1 -C include
375 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
376 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
377 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
378 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
379 mv -f tools/lvm.static initrd-lvm
380 mv -f tools/dmsetup.static initrd-dmsetup
381
382 # check if tools works
383 for tool in initrd-lvm initrd-dmsetup; do
384         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
385         if [ $rc -gt 127 ]; then
386                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
387                 exit 1
388         fi
389 done
390
391 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
392 %{__make} clean
393
394 unset CC
395 %endif
396
397 %configure \
398         --enable-applib \
399         --enable-cmdlib \
400         %{?debug:--enable-debug} \
401         --enable-dmeventd \
402         --enable-fsadm \
403 %if %{with lvmlockd}
404         %{?with_cluster:--enable-lockd-dlm} \
405         %{?with_sanlock:--enable-lockd-sanlock} \
406 %endif
407         %{?with_lvmetad:--enable-lvmetad} \
408         --enable-ocf \
409         %{?with_python2:--enable-python2-bindings} \
410         %{?with_python3:--enable-python3-bindings} \
411         --enable-readline \
412         %{!?with_selinux:--disable-selinux} \
413         --enable-pkgconfig \
414         --enable-udev_sync \
415         --enable-udev_rules \
416         --with-cache=internal \
417         --with-cache-check=/usr/sbin/cache_check \
418         --with-cache-dump=/usr/sbin/cache_dump \
419         --with-cache-repair=/usr/sbin/cache_repair \
420         --with-cache-restore=/usr/sbin/cache_restore \
421         --with-cluster=internal \
422 %if %{with cluster}
423         --with-clvmd=corosync \
424         --enable-cmirrord \
425 %endif
426         --with-dmeventd-path=%{_sbindir}/dmeventd \
427         --with-interface=ioctl \
428         --with-lvm1=internal \
429         --with-mirrors=internal \
430         --with-optimisation="%{rpmcflags}" \
431         --with-pool=internal \
432         %{?with_replicator:--with-replicators=internal} \
433         --with-snapshots=internal \
434         --with-thin=internal \
435         --with-thin-check=/usr/sbin/thin_check \
436         --with-thin-dump=/usr/sbin/thin_dump \
437         --with-thin-repair=/usr/sbin/thin_repair \
438         --with-thin-restore=/usr/sbin/thin_restore \
439         --with-udev-prefix=/ \
440         --with-usrlibdir=%{_libdir}
441
442 %{__make} -j1
443 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
444
445 %install
446 rm -rf $RPM_BUILD_ROOT
447 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
448 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
449
450 %{__make} install install_system_dirs install_initscripts \
451         DESTDIR=$RPM_BUILD_ROOT \
452         OWNER="" \
453         GROUP=""
454
455 %{__make} -C scripts \
456         DESTDIR=$RPM_BUILD_ROOT \
457
458 %if %{with cluster}
459 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
460 %endif
461
462 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
463 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
464         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
465         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
466         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
467 done
468
469 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
470
471 %if %{with initrd}
472 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
473 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
474 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
475
476 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
477 %endif
478
479 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
480
481 %clean
482 rm -rf $RPM_BUILD_ROOT
483
484 %post
485 /sbin/chkconfig --add lvm2-lvmetad
486 %service lvm2-lvmetad restart
487 /sbin/chkconfig --add lvm2-monitor
488 %service lvm2-monitor restart
489 /sbin/chkconfig --add lvm2-lvmpolld
490 %service lvm2-lvmpolld restart
491 # no service restart available
492 /sbin/chkconfig --add blk-availability
493
494 %preun
495 if [ "$1" = "0" ]; then
496         %service lvm2-lvmetad stop
497         /sbin/chkconfig --del lvm2-lvmetad
498         %service lvm2-lvmpolld stop
499         /sbin/chkconfig --del lvm2-lvmpolld
500         %service lvm2-monitor stop
501         /sbin/chkconfig --del lvm2-monitor
502         /sbin/chkconfig --del blk-availability
503 fi
504
505 %post   -n device-mapper-libs -p /sbin/ldconfig
506 %postun -n device-mapper-libs -p /sbin/ldconfig
507
508 %post clvmd
509 /sbin/chkconfig --add clvmd
510 # no service restart - it breaks current locks!
511 export NORESTART=1
512 # re-exec instead
513 /usr/sbin/clvmd -S 2>/dev/null || :
514
515 %preun clvmd
516 if [ "$1" = "0" ]; then
517         %service clvmd stop
518         /sbin/chkconfig --del clvmd
519 fi
520
521 %files
522 %defattr(644,root,root,755)
523 %doc README WHATS_NEW doc/*
524 %attr(755,root,root) %{_sbindir}/blkdeactivate
525 %attr(755,root,root) %{_sbindir}/fsadm
526 %attr(755,root,root) %{_sbindir}/lv*
527 %attr(755,root,root) %{_sbindir}/pv*
528 %attr(755,root,root) %{_sbindir}/vg*
529 %{_mandir}/man5/lvm.conf.5*
530 %{_mandir}/man7/lvmcache.7*
531 %{_mandir}/man7/lvmsystemid.7*
532 %{_mandir}/man7/lvmthin.7*
533 %{_mandir}/man8/blkdeactivate.8*
534 %{_mandir}/man8/fsadm.8*
535 %{_mandir}/man8/lv*.8*
536 %{_mandir}/man8/pv*.8*
537 %{_mandir}/man8/vg*.8*
538 %attr(750,root,root) %dir %{_sysconfdir}/lvm
539 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
540 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
541 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
542 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
543 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
544 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
545 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
546 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
547 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
548 %if %{with lvmetad}
549 /lib/udev/rules.d/69-dm-lvm-metad.rules
550 %endif
551 %dir %{_sysconfdir}/lvm/cache
552 %ghost %{_sysconfdir}/lvm/cache/.cache
553 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
554 %if %{with lvmetad}
555 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
556 %endif
557 %if %{with lvmpolld}
558 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
559 %endif
560 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
561 %attr(700,root,root) %dir /var/lock/lvm
562 %attr(700,root,root) %dir /var/run/lvm
563
564 %if %{with cluster}
565 %files clvmd
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_usrsbindir}/clvmd
568 %attr(754,root,root) /etc/rc.d/init.d/clvmd
569 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
570 %{_mandir}/man8/clvmd.8*
571
572 %files cmirrord
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_usrsbindir}/cmirrord
575 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
576 %{_mandir}/man8/cmirrord.8*
577 %endif
578
579 %files resource-agents
580 %defattr(644,root,root,755)
581 %dir %{_prefix}/lib/ocf/resource.d/lvm2
582 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
583
584 %if %{with python2}
585 %files -n python-lvm
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{py_sitedir}/lvm.so
588 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
589 %endif
590
591 %if %{with python3}
592 %files -n python3-lvm
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{py3_sitedir}/lvm*.so
595 %{py3_sitedir}/lvm-%{version}_*-py*.egg-info
596 %endif
597
598 %files -n device-mapper
599 %defattr(644,root,root,755)
600 %doc *_DM
601 /lib/udev/rules.d/10-dm.rules
602 /lib/udev/rules.d/11-dm-lvm.rules
603 /lib/udev/rules.d/13-dm-disk.rules
604 /lib/udev/rules.d/95-dm-notify.rules
605 %attr(755,root,root) %{_sbindir}/dmeventd
606 %attr(755,root,root) %{_sbindir}/dmsetup
607 %attr(755,root,root) %{_sbindir}/dmstats
608 %dir %{_libdir}/device-mapper
609 %attr(755,root,root) %{_libdir}/device-mapper/*.so
610 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
611 %{_mandir}/man8/dmsetup.8*
612 %{_mandir}/man8/dmstats.8*
613 %{_mandir}/man8/dmeventd.8*
614
615 %files -n device-mapper-libs
616 %defattr(644,root,root,755)
617 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
618 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
619 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
620 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
621 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
622
623 %files -n device-mapper-devel
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/libdevmapper.so
626 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
627 %attr(755,root,root) %{_libdir}/liblvm2app.so
628 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
629 %{_includedir}/libdevmapper.h
630 %{_includedir}/libdevmapper-event.h
631 %{_includedir}/lvm2app.h
632 %{_includedir}/lvm2cmd.h
633 %{_pkgconfigdir}/devmapper.pc
634 %{_pkgconfigdir}/devmapper-event.pc
635 %{_pkgconfigdir}/lvm2app.pc
636
637 %files -n device-mapper-static
638 %defattr(644,root,root,755)
639 %{_libdir}/libdevmapper.a
640
641 %if %{with initrd}
642 %if %{with dietlibc}
643 %files -n device-mapper-dietlibc
644 %defattr(644,root,root,755)
645 %{dietlibdir}/libdevmapper.a
646 %endif
647
648 %files -n device-mapper-initrd
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/initrd/dmsetup
651
652 %files initrd
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/initrd/lvm
655 %endif