]> TLD Linux GIT Repositories - packages/lvm2.git/blob - lvm2.spec
- updated to 2.03.19, partial merge of PLD changes
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - functionality
8 %bcond_without  cluster         # disable all cluster support (cmirrord, dlm support in lvmlockd)
9 %bcond_without  lvmdbusd        # lvmdbusd
10 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
11 %bcond_without  lvmlockd        # lvmlockd
12 %bcond_with     sanlock         # sanlock support in lvmlockd
13 # - additional features
14 %bcond_without  selinux         # SELinux support
15 # - bindings
16 %bcond_without  python          # Python bindings
17 %bcond_without  python2         # Python 2 binding
18 %bcond_without  python3         # Python 3 binding and lvmdbusd
19
20 # for convenience
21 %if %{without python}
22 %undefine       with_python2
23 %undefine       with_python3
24 %endif
25 %if %{without python3}
26 %undefine       with_lvmdbusd
27 %endif
28
29 Summary:        The new version of Logical Volume Manager for Linux
30 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
31 Name:           lvm2
32 Version:        2.03.19
33 Release:        1
34 License:        GPL v2 and LGPL v2.1
35 Group:          Applications/System
36 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
37 # Source0-md5:  e805199669c5fb2d87fba9a4082ecada
38 Patch0:         %{name}-selinux.patch
39 Patch1:         device-mapper-dmsetup-export.patch
40 Patch2:         %{name}-tld_init.patch
41 Patch3:         %{name}-run-dir.patch
42 Patch4:         device-mapper-dmsetup-deps-export.patch
43 Patch5:         %{name}-thin.patch
44 Patch6:         link.patch
45 URL:            http://www.sourceware.org/lvm2/
46 BuildRequires:  autoconf >= 2.69
47 BuildRequires:  autoconf-archive
48 BuildRequires:  automake
49 # for /run detection
50 BuildRequires:  filesystem >= 3.0-43
51 BuildRequires:  libaio-devel
52 BuildRequires:  libblkid-devel >= 2.24
53 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
54 %{?with_selinux:BuildRequires:  libsepol-devel}
55 BuildRequires:  ncurses-devel
56 BuildRequires:  pkgconfig
57 %{?with_python2:BuildRequires:  python-devel >= 2}
58 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
59 %if %{with lvmdbusd}
60 BuildRequires:  python3-dbus
61 BuildRequires:  python3-pyudev
62 %endif
63 BuildRequires:  readline-devel
64 BuildRequires:  rpmbuild(macros) >= 1.647
65 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
66 BuildRequires:  udev-devel >= 1:176
67 %if %{with cluster}
68 BuildRequires:  corosync-devel
69 BuildRequires:  dlm-devel >= 3.99.5
70 %endif
71 Requires(post,postun):  /sbin/chkconfig
72 Requires:       device-mapper >= %{version}-%{release}
73 %{?with_selinux:Requires:       libselinux >= 1.10}
74 # doesn't work with 2.4 kernels
75 Requires:       uname(release) >= 2.6
76 Suggests:       thin-provisioning-tools >= 0.5.4
77 Obsoletes:      lvm
78 Obsoletes:      lvm2-clvmd
79 Obsoletes:      lvm2-systemd
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _sbindir        /sbin
83 %define         _usrsbindir     /usr/sbin
84
85 # changing CFLAGS in the middle confuses confcache
86 %undefine       configure_cache
87
88 # causes: undefined reference to `__stack_chk_fail_local'
89 %define         filterout_c     -fstack-protector
90
91 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
92
93 %description
94 This package includes a number of utilities for creating, checking,
95 and repairing logical volumes.
96
97 %description -l pl.UTF-8
98 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
99 logicznych wolumenów dyskowych (LVM2).
100
101 %package cmirrord
102 Summary:        Cluster mirror log daemon
103 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
104 Group:          Applications/System
105 Requires:       %{name} = %{version}-%{release}
106
107 %description cmirrord
108 cmirrord is the daemon that tracks mirror log information in a
109 cluster. It is specific to device-mapper based mirrors (and by
110 extension, LVM cluster mirrors). Cluster mirrors are not possible
111 without this daemon running.
112
113 This daemon relies on the cluster infrastructure provided by the
114 Cluster MANager (CMAN), which must be set up and running in order for
115 cmirrord to function.
116
117 %description cmirrord -l pl.UTF-8
118 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
119 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
120 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
121 lustrzanych ten demon jest niezbędny.
122
123 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
124 (Cluster MANager), który musi być skonfigurowany i działający, aby
125 działał cmirrord.
126
127 %package dbusd
128 Summary:        LVM2 D-Bus daemon
129 Summary(pl.UTF-8):      Demon LVM2 D-Bus
130 Group:          Daemons
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       python3-dbus
133 Requires:       python3-pygobject3 >= 3
134 Requires:       python3-pyudev
135
136 %description dbusd
137 Daemon for access to LVM2 functionality through a D-Bus interface.
138
139 %description dbusd -l pl.UTF-8
140 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
141 D-Bus.
142
143 %package lockd
144 Summary:        LVM2 locking daemon
145 Summary(pl.UTF-8):      Demon blokad LVM2
146 Group:          Daemons
147 Requires:       %{name} = %{version}-%{release}
148 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
149 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
150
151 %description lockd
152 LVM commands use lvmlockd to coordinate access to shared storage.
153
154 %description lockd -l pl.UTF-8
155 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
156 współdzielonej pamięci masowej.
157
158 %package resource-agents
159 Summary:        OCF Resource Agents for LVM2 processes
160 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
161 Group:          Applications/System
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       resource-agents
164
165 %description resource-agents
166 OCF Resource Agents for LVM2 processes.
167
168 %description resource-agents -l pl.UTF-8
169 Agenci OCF do monitorowania procesów LVM2.
170
171 %package -n python-lvm
172 Summary:        Python 2 interface to LVM2
173 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
174 Group:          Libraries/Python
175 Requires:       device-mapper-libs = %{version}-%{release}
176
177 %description -n python-lvm
178 Python 2 interface to LVM2.
179
180 %description -n python-lvm -l pl.UTF-8
181 Interfejs Pythona 2 do LVM2.
182
183 %package -n python3-lvm
184 Summary:        Python 3 interface to LVM2
185 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
186 Group:          Libraries/Python
187 Requires:       device-mapper-libs = %{version}-%{release}
188
189 %description -n python3-lvm
190 Python 3 interface to LVM2.
191
192 %description -n python3-lvm -l pl.UTF-8
193 Interfejs Pythona 3 do LVM2.
194
195 %package -n device-mapper
196 Summary:        Userspace support for the device-mapper
197 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
198 Group:          Base
199 Requires(post,postun):  /sbin/ldconfig
200 Requires:       device-mapper-libs = %{version}-%{release}
201
202 %description -n device-mapper
203 The goal of this driver is to support volume management. The driver
204 enables the definition of new block devices composed of ranges of
205 sectors of existing devices. This can be used to define disk
206 partitions - or logical volumes. This light-weight kernel component
207 can support user-space tools for logical volume management.
208
209 %description -n device-mapper -l pl.UTF-8
210 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
211 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
212 sektorów na istniejących urządzeniach. Może to być wykorzystane do
213 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
214 składnik jądra może wspierać działające w przestrzeni użytkownika
215 narzędzia do zarządzania logicznymi wolumenami.
216
217 %package -n device-mapper-libs
218 Summary:        Device-mapper shared libraries
219 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
220 Group:          Libraries
221 Requires:       libblkid >= 2.24
222 Requires:       udev-libs >= 1:176
223 Conflicts:      device-mapper < 2.02.119-1
224
225 %description -n device-mapper-libs
226 Device-mapper shared libraries.
227
228 %description -n device-mapper-libs -l pl.UTF-8
229 Biblioteki współdzielone device-mappera.
230
231 %package -n device-mapper-devel
232 Summary:        Header files for device-mapper libraries
233 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
234 Group:          Development/Libraries
235 Requires:       device-mapper-libs = %{version}-%{release}
236 Requires:       libblkid-devel >= 2.24
237 %if %{with selinux}
238 Requires:       libselinux-devel
239 Requires:       libsepol-devel
240 %endif
241 Requires:       udev-devel >= 1:176
242
243 %description -n device-mapper-devel
244 Header files for device-mapper libraries.
245
246 %description -n device-mapper-devel -l pl.UTF-8
247 Pliki nagłówkowe bibliotek device-mappera.
248
249 %package -n device-mapper-static
250 Summary:        Static devmapper library
251 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
252 License:        LGPL v2.1
253 Group:          Development/Libraries
254 Requires:       device-mapper-devel = %{version}-%{release}
255
256 %description -n device-mapper-static
257 Static devmapper library.
258
259 %description -n device-mapper-static -l pl.UTF-8
260 Statyczna biblioteka devmapper.
261
262 %package -n device-mapper-dietlibc
263 Summary:        Static devmapper library built with dietlibc
264 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
265 License:        LGPL v2.1
266 Group:          Development/Libraries
267 Requires:       device-mapper-devel = %{version}-%{release}
268
269 %description -n device-mapper-dietlibc
270 Static devmapper library built with dietlibc.
271
272 %description -n device-mapper-dietlibc -l pl.UTF-8
273 Statyczna biblioteka devmapper zbudowana z dietlibc.
274
275 %prep
276 %setup -q -n LVM2.%{version}
277 %{?with_selinux:%patch0 -p1}
278 %patch1 -p1
279 %patch2 -p1
280 %patch3 -p1
281 %patch4 -p1
282 %patch5 -p1
283 %patch6 -p1
284
285 %build
286 %{__aclocal}
287 %{__autoconf}
288
289 %configure \
290         --enable-applib \
291         --enable-cache_check_needs_check \
292         --enable-cmdlib \
293 %if %{with cluster}
294         --enable-cmirrord \
295 %endif
296         %{?with_lvmdbusd:--enable-dbus-service} \
297         %{?debug:--enable-debug} \
298         --enable-dmeventd \
299         --enable-dmfilemapd \
300         --enable-fsadm \
301 %if %{with lvmlockd}
302         %{?with_cluster:--enable-lvmlockd-dlm} \
303         %{?with_sanlock:--enable-lvmlockd-sanlock} \
304 %endif
305         --enable-lvmpolld \
306         --enable-ocf \
307         %{?with_python2:--enable-python2_bindings} \
308         %{?with_python3:--enable-python3_bindings} \
309         --enable-pkgconfig \
310         --enable-readline \
311         %{!?with_selinux:--disable-selinux} \
312         --disable-silent-rules \
313         --enable-thin_check_needs_check \
314         --enable-udev_sync \
315         --enable-udev_rules \
316         --disable-udev-systemd-background-jobs \
317         --with-cache=internal \
318         --with-cache-check=/usr/sbin/cache_check \
319         --with-cache-dump=/usr/sbin/cache_dump \
320         --with-cache-repair=/usr/sbin/cache_repair \
321         --with-cache-restore=/usr/sbin/cache_restore \
322         --with-default-locking-dir=/var/lock/lvm \
323         --with-dmeventd-path=%{_sbindir}/dmeventd \
324         --with-interface=ioctl \
325         --with-libexecdir=%{_libexecdir} \
326         --with-mirrors=internal \
327         --with-optimisation="%{rpmcflags}" \
328         --with-snapshots=internal \
329         --with-thin=internal \
330         --with-thin-check=/usr/sbin/thin_check \
331         --with-thin-dump=/usr/sbin/thin_dump \
332         --with-thin-repair=/usr/sbin/thin_repair \
333         --with-thin-restore=/usr/sbin/thin_restore \
334         --with-udev-prefix=/ \
335         --with-usrlibdir=%{_libdir}
336 # use bash because of "set -o pipefail"
337 # V=1 still used because of missing --disable-silent-rules support in libdm (as of 2.03.09)
338 %{__make} -j1 \
339         SHELL=/bin/bash \
340         V=1
341 %{__make} -j1 -C libdm \
342         LIB_STATIC=libdevmapper.a \
343         V=1
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
348
349 %{__make} install install_system_dirs install_initscripts \
350         DESTDIR=$RPM_BUILD_ROOT \
351         OWNER="" \
352         GROUP="" \
353         python3dir=%{py3_sitescriptdir}
354
355 %{__make} -C scripts \
356         DESTDIR=$RPM_BUILD_ROOT
357
358 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
359 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
360         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
361         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
362         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
363 done
364
365 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
366
367 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
368
369 %clean
370 rm -rf $RPM_BUILD_ROOT
371
372 %triggerin -- lvm2 < 2.03.00
373 %service lvm2-lvmetad stop
374 /sbin/chkconfig --del lvm2-lvmetad
375
376 %triggerin -- lvm2-clvmd
377 %service clvmd stop
378 /sbin/chkconfig --del clvmd
379
380 %post
381 /sbin/chkconfig --add lvm2-monitor
382 %service lvm2-monitor restart
383 /sbin/chkconfig --add lvm2-lvmpolld
384 %service lvm2-lvmpolld restart
385 # no service restart available
386 /sbin/chkconfig --add blk-availability
387 # no service blk-availability restart
388
389 %preun
390 if [ "$1" = "0" ]; then
391         %service lvm2-lvmpolld stop
392         /sbin/chkconfig --del lvm2-lvmpolld
393         %service lvm2-monitor stop
394         /sbin/chkconfig --del lvm2-monitor
395         #no service blk-availability stop
396         /sbin/chkconfig --del blk-availability
397 fi
398
399 %post   -n device-mapper-libs -p /sbin/ldconfig
400 %postun -n device-mapper-libs -p /sbin/ldconfig
401
402 %files
403 %defattr(644,root,root,755)
404 %doc README WHATS_NEW doc/*
405 %attr(755,root,root) %{_sbindir}/blkdeactivate
406 %attr(755,root,root) %{_sbindir}/fsadm
407 %attr(755,root,root) %{_sbindir}/lvchange
408 %attr(755,root,root) %{_sbindir}/lvconvert
409 %attr(755,root,root) %{_sbindir}/lvcreate
410 %attr(755,root,root) %{_sbindir}/lvdisplay
411 %attr(755,root,root) %{_sbindir}/lvextend
412 %attr(755,root,root) %{_sbindir}/lvm
413 %attr(755,root,root) %{_sbindir}/lvm_import_vdo
414 %attr(755,root,root) %{_sbindir}/lvmconfig
415 %attr(755,root,root) %{_sbindir}/lvmdevices
416 %attr(755,root,root) %{_sbindir}/lvmdiskscan
417 %attr(755,root,root) %{_sbindir}/lvmdump
418 %attr(755,root,root) %{_sbindir}/lvmsadc
419 %attr(755,root,root) %{_sbindir}/lvmsar
420 %attr(755,root,root) %{_sbindir}/lvreduce
421 %attr(755,root,root) %{_sbindir}/lvremove
422 %attr(755,root,root) %{_sbindir}/lvrename
423 %attr(755,root,root) %{_sbindir}/lvresize
424 %attr(755,root,root) %{_sbindir}/lvs
425 %attr(755,root,root) %{_sbindir}/lvscan
426 %attr(755,root,root) %{_sbindir}/pvchange
427 %attr(755,root,root) %{_sbindir}/pvck
428 %attr(755,root,root) %{_sbindir}/pvcreate
429 %attr(755,root,root) %{_sbindir}/pvdisplay
430 %attr(755,root,root) %{_sbindir}/pvmove
431 %attr(755,root,root) %{_sbindir}/pvremove
432 %attr(755,root,root) %{_sbindir}/pvresize
433 %attr(755,root,root) %{_sbindir}/pvs
434 %attr(755,root,root) %{_sbindir}/pvscan
435 %attr(755,root,root) %{_sbindir}/vgcfgbackup
436 %attr(755,root,root) %{_sbindir}/vgcfgrestore
437 %attr(755,root,root) %{_sbindir}/vgchange
438 %attr(755,root,root) %{_sbindir}/vgck
439 %attr(755,root,root) %{_sbindir}/vgconvert
440 %attr(755,root,root) %{_sbindir}/vgcreate
441 %attr(755,root,root) %{_sbindir}/vgdisplay
442 %attr(755,root,root) %{_sbindir}/vgexport
443 %attr(755,root,root) %{_sbindir}/vgextend
444 %attr(755,root,root) %{_sbindir}/vgimport
445 %attr(755,root,root) %{_sbindir}/vgimportclone
446 %attr(755,root,root) %{_sbindir}/vgimportdevices
447 %attr(755,root,root) %{_sbindir}/vgmerge
448 %attr(755,root,root) %{_sbindir}/vgmknodes
449 %attr(755,root,root) %{_sbindir}/vgreduce
450 %attr(755,root,root) %{_sbindir}/vgremove
451 %attr(755,root,root) %{_sbindir}/vgrename
452 %attr(755,root,root) %{_sbindir}/vgs
453 %attr(755,root,root) %{_sbindir}/vgscan
454 %attr(755,root,root) %{_sbindir}/vgsplit
455 %attr(755,root,root) %{_libexecdir}/lvresize_fs_helper
456 %{_mandir}/man5/lvm.conf.5*
457 %{_mandir}/man7/lvmautoactivation.7*
458 %{_mandir}/man7/lvmcache.7*
459 %{_mandir}/man7/lvmraid.7*
460 %{_mandir}/man7/lvmreport.7*
461 %{_mandir}/man7/lvmsystemid.7*
462 %{_mandir}/man7/lvmthin.7*
463 %{_mandir}/man7/lvmvdo.7*
464 %{_mandir}/man8/blkdeactivate.8*
465 %{_mandir}/man8/fsadm.8*
466 %{_mandir}/man8/lvchange.8*
467 %{_mandir}/man8/lvconvert.8*
468 %{_mandir}/man8/lvcreate.8*
469 %{_mandir}/man8/lvdisplay.8*
470 %{_mandir}/man8/lvextend.8*
471 %{_mandir}/man8/lvm-config.8*
472 %{_mandir}/man8/lvm-dumpconfig.8*
473 %{_mandir}/man8/lvm-fullreport.8*
474 %{_mandir}/man8/lvm-lvpoll.8*
475 %{_mandir}/man8/lvm.8*
476 %{_mandir}/man8/lvm_import_vdo.8*
477 %{_mandir}/man8/lvmconfig.8*
478 %{_mandir}/man8/lvmdevices.8*
479 %{_mandir}/man8/lvmdiskscan.8*
480 %{_mandir}/man8/lvmdump.8*
481 %{_mandir}/man8/lvmsadc.8*
482 %{_mandir}/man8/lvmsar.8*
483 %{_mandir}/man8/lvreduce.8*
484 %{_mandir}/man8/lvremove.8*
485 %{_mandir}/man8/lvrename.8*
486 %{_mandir}/man8/lvresize.8*
487 %{_mandir}/man8/lvs.8*
488 %{_mandir}/man8/lvscan.8*
489 %{_mandir}/man8/pvchange.8*
490 %{_mandir}/man8/pvck.8*
491 %{_mandir}/man8/pvcreate.8*
492 %{_mandir}/man8/pvdisplay.8*
493 %{_mandir}/man8/pvmove.8*
494 %{_mandir}/man8/pvremove.8*
495 %{_mandir}/man8/pvresize.8*
496 %{_mandir}/man8/pvs.8*
497 %{_mandir}/man8/pvscan.8*
498 %{_mandir}/man8/vgcfgbackup.8*
499 %{_mandir}/man8/vgcfgrestore.8*
500 %{_mandir}/man8/vgchange.8*
501 %{_mandir}/man8/vgck.8*
502 %{_mandir}/man8/vgconvert.8*
503 %{_mandir}/man8/vgcreate.8*
504 %{_mandir}/man8/vgdisplay.8*
505 %{_mandir}/man8/vgexport.8*
506 %{_mandir}/man8/vgextend.8*
507 %{_mandir}/man8/vgimport.8*
508 %{_mandir}/man8/vgimportclone.8*
509 %{_mandir}/man8/vgimportdevices.8*
510 %{_mandir}/man8/vgmerge.8*
511 %{_mandir}/man8/vgmknodes.8*
512 %{_mandir}/man8/vgreduce.8*
513 %{_mandir}/man8/vgremove.8*
514 %{_mandir}/man8/vgrename.8*
515 %{_mandir}/man8/vgs.8*
516 %{_mandir}/man8/vgscan.8*
517 %{_mandir}/man8/vgsplit.8*
518 %attr(750,root,root) %dir %{_sysconfdir}/lvm
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
521 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
527 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
528 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
529 %dir %{_sysconfdir}/lvm/cache
530 %ghost %{_sysconfdir}/lvm/cache/.cache
531 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
532 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
533 %attr(700,root,root) %dir /var/run/lvm
534 %attr(700,root,root) %dir /var/lock/lvm
535 %attr(700,root,root) %dir /var/lock/lvm/subsys
536 %if %{with lvmlockd}
537 %attr(755,root,root) %{_sbindir}/lvmlockctl
538 %attr(755,root,root) %{_sbindir}/lvmlockd
539 %{_mandir}/man8/lvmlockctl.8*
540 %{_mandir}/man8/lvmlockd.8*
541 %endif
542 %if %{with lvmpolld}
543 %attr(755,root,root) %{_sbindir}/lvmpolld
544 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
545 %{_mandir}/man8/lvmpolld.8*
546 %endif
547
548 %if %{with cluster}
549 %files cmirrord
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_usrsbindir}/cmirrord
552 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
553 %{_mandir}/man8/cmirrord.8*
554 %endif
555
556 %if %{with lvmdbusd}
557 %files dbusd
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_sbindir}/lvmdbusd
560 %{py3_sitescriptdir}/lvmdbusd
561 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
562 %{_mandir}/man8/lvmdbusd.8*
563 %endif
564
565 %files resource-agents
566 %defattr(644,root,root,755)
567 %dir %{_prefix}/lib/ocf/resource.d/lvm2
568 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
569
570 %if %{with python2}
571 %files -n python-lvm
572 %defattr(644,root,root,755)
573 #%attr(755,root,root) %{py_sitedir}/lvm.so
574 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
575 %endif
576
577 %if %{with python3}
578 %files -n python3-lvm
579 %defattr(644,root,root,755)
580 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
581 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
582 %endif
583
584 %files -n device-mapper
585 %defattr(644,root,root,755)
586 %doc *_DM
587 /lib/udev/rules.d/10-dm.rules
588 /lib/udev/rules.d/11-dm-lvm.rules
589 /lib/udev/rules.d/13-dm-disk.rules
590 /lib/udev/rules.d/69-dm-lvm.rules
591 /lib/udev/rules.d/95-dm-notify.rules
592 %attr(755,root,root) %{_sbindir}/dmeventd
593 %attr(755,root,root) %{_sbindir}/dmfilemapd
594 %attr(755,root,root) %{_sbindir}/dmsetup
595 %attr(755,root,root) %{_sbindir}/dmstats
596 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
597 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
598 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
599 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
600 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
601 %dir %{_libdir}/device-mapper
602 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
603 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
604 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
605 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
606 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
607 %{_mandir}/man8/dmfilemapd.8*
608 %{_mandir}/man8/dmsetup.8*
609 %{_mandir}/man8/dmstats.8*
610 %{_mandir}/man8/dmeventd.8*
611
612 %files -n device-mapper-libs
613 %defattr(644,root,root,755)
614 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
615 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
616 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
617 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
618
619 %files -n device-mapper-devel
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/libdevmapper.so
622 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
623 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
624 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
625 %{_includedir}/libdevmapper.h
626 %{_includedir}/libdevmapper-event.h
627 %{_includedir}/lvm2cmd.h
628 %{_pkgconfigdir}/devmapper.pc
629 %{_pkgconfigdir}/devmapper-event.pc
630
631 %files -n device-mapper-static
632 %defattr(644,root,root,755)
633 %{_libdir}/libdevmapper.a