]> TLD Linux GIT Repositories - packages/lvm2.git/commitdiff
- updated to 2.02.179
authorMarcin Krol <hawk@tld-linux.org>
Tue, 26 Jun 2018 11:57:46 +0000 (11:57 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Tue, 26 Jun 2018 11:57:46 +0000 (11:57 +0000)
device-mapper-dmsetup-deps-export.patch
device-mapper-dmsetup-export.patch
dl-dlsym.patch
lvm2-diet.patch
lvm2-selinux.patch
lvm2-thin.patch
lvm2.spec

index 9a8e021be441428db6b6ff0437707ceae0b0c70c..cc54e0a352f0a01909805714177af5f03d8d1d04 100644 (file)
@@ -1,7 +1,7 @@
-diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
---- LVM2.2.02.177.orig/tools/dmsetup.c 2018-01-26 15:22:40.000000000 +0000
-+++ LVM2.2.02.177/tools/dmsetup.c      2018-01-26 16:41:10.574224457 +0000
-@@ -2583,6 +2583,7 @@ static int _export(CMD_ARGS)
+diff -urp LVM2.2.02.179.orig/tools/dmsetup.c LVM2.2.02.179/tools/dmsetup.c
+--- LVM2.2.02.179.orig/tools/dmsetup.c 2018-06-26 11:46:19.185819536 +0000
++++ LVM2.2.02.179/tools/dmsetup.c      2018-06-26 11:48:27.746811873 +0000
+@@ -2579,6 +2579,7 @@ static int _export(CMD_ARGS)
        const char *name = NULL;
        const char *uuid = NULL;
        struct dm_info info;
@@ -9,7 +9,7 @@ diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
  
        if (names)
                name = names->name;
-@@ -2652,6 +2653,28 @@ static int _export(CMD_ARGS)
+@@ -2648,6 +2649,28 @@ static int _export(CMD_ARGS)
                printf("\n");
        }
  
index 9a50b7e4a5da43f4da432ad6058e31087bea0765..e5184eae92bf0285a14aa8d52e14257ba382b0cd 100644 (file)
@@ -1,6 +1,6 @@
-diff -urp LVM2.2.02.177.orig/man/dmsetup.8_main LVM2.2.02.177/man/dmsetup.8_main
---- LVM2.2.02.177.orig/man/dmsetup.8_main      2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/man/dmsetup.8_main   2018-01-26 15:24:01.378500379 +0000
+diff -urp LVM2.2.02.179.orig/man/dmsetup.8_main LVM2.2.02.179/man/dmsetup.8_main
+--- LVM2.2.02.179.orig/man/dmsetup.8_main      2018-06-26 11:40:19.080841000 +0000
++++ LVM2.2.02.179/man/dmsetup.8_main   2018-06-26 11:46:19.184819536 +0000
 @@ -59,6 +59,14 @@ dmsetup \(em low level logical volume ma
  .
  .HP
@@ -26,10 +26,10 @@ diff -urp LVM2.2.02.177.orig/man/dmsetup.8_main LVM2.2.02.177/man/dmsetup.8_main
  .CMD_HELP
  .br
  Outputs a summary of the commands available, optionally including
-diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
---- LVM2.2.02.177.orig/tools/dmsetup.c 2018-01-26 15:13:17.000000000 +0000
-+++ LVM2.2.02.177/tools/dmsetup.c      2018-01-26 15:22:40.528505198 +0000
-@@ -2572,6 +2572,93 @@ out:
+diff -urp LVM2.2.02.179.orig/tools/dmsetup.c LVM2.2.02.179/tools/dmsetup.c
+--- LVM2.2.02.179.orig/tools/dmsetup.c 2018-06-26 11:40:23.358840745 +0000
++++ LVM2.2.02.179/tools/dmsetup.c      2018-06-26 11:46:19.185819536 +0000
+@@ -2568,6 +2568,93 @@ out:
        return r;
  }
  
@@ -123,7 +123,7 @@ diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
  /* Show target names and their version numbers */
  static int _targets(CMD_ARGS)
  {
-@@ -6247,6 +6334,7 @@ static struct command _dmsetup_commands[
+@@ -6243,6 +6330,7 @@ static struct command _dmsetup_commands[
        {"stats", "<command> [<options>] [<device>...]", 1, -1, 1, 1, _stats},
        {"status", "[<device>...] [--noflush] [--target <target_type>]", 0, -1, 2, 0, _status},
        {"table", "[<device>...] [--concise] [--target <target_type>] [--showkeys]", 0, -1, 2, 0, _status},
index c4bcd92d8c574c766b36447c51867d2a8c135141..067a72043f87ed68cbf1c7da2989d5539996ef37 100644 (file)
@@ -1,7 +1,7 @@
-diff -urp LVM2.2.02.177.orig/lib/commands/toolcontext.c LVM2.2.02.177/lib/commands/toolcontext.c
---- LVM2.2.02.177.orig/lib/commands/toolcontext.c      2018-01-26 15:13:17.000000000 +0000
-+++ LVM2.2.02.177/lib/commands/toolcontext.c   2018-01-26 16:38:04.214235565 +0000
-@@ -1455,6 +1455,7 @@ int lvm_register_segtype(struct segtype_
+diff -urp LVM2.2.02.179.orig/lib/commands/toolcontext.c LVM2.2.02.179/lib/commands/toolcontext.c
+--- LVM2.2.02.179.orig/lib/commands/toolcontext.c      2018-06-26 11:40:23.355840745 +0000
++++ LVM2.2.02.179/lib/commands/toolcontext.c   2018-06-26 11:47:16.136816141 +0000
+@@ -1438,6 +1438,7 @@ int lvm_register_segtype(struct segtype_
        return 1;
  }
  
@@ -9,7 +9,7 @@ diff -urp LVM2.2.02.177.orig/lib/commands/toolcontext.c LVM2.2.02.177/lib/comman
  static int _init_single_segtype(struct cmd_context *cmd,
                                struct segtype_library *seglib)
  {
-@@ -1472,6 +1473,7 @@ static int _init_single_segtype(struct c
+@@ -1455,6 +1456,7 @@ static int _init_single_segtype(struct c
  
        return lvm_register_segtype(seglib, segtype);
  }
index 3859bbfd8a5e3c32ca2121e4b4f1791c90194c8f..abd2313d9af1dd87f780055562c7961bbcc90ce3 100644 (file)
@@ -1,7 +1,7 @@
-diff -urp LVM2.2.02.177.orig/lib/commands/toolcontext.c LVM2.2.02.177/lib/commands/toolcontext.c
---- LVM2.2.02.177.orig/lib/commands/toolcontext.c      2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/lib/commands/toolcontext.c   2018-01-26 15:13:17.915538732 +0000
-@@ -1840,10 +1840,10 @@ struct cmd_context *create_toolcontext(u
+diff -urp LVM2.2.02.179.orig/lib/commands/toolcontext.c LVM2.2.02.179/lib/commands/toolcontext.c
+--- LVM2.2.02.179.orig/lib/commands/toolcontext.c      2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/lib/commands/toolcontext.c   2018-06-26 11:40:23.355840745 +0000
+@@ -1827,10 +1827,10 @@ struct cmd_context *create_toolcontext(u
  #ifdef M_MMAP_MAX
        mallopt(M_MMAP_MAX, 0);
  #endif
@@ -14,10 +14,10 @@ diff -urp LVM2.2.02.177.orig/lib/commands/toolcontext.c LVM2.2.02.177/lib/comman
  #ifdef INTL_PACKAGE
        bindtextdomain(INTL_PACKAGE, LOCALEDIR);
  #endif
-diff -urp LVM2.2.02.177.orig/lib/config/config.c LVM2.2.02.177/lib/config/config.c
---- LVM2.2.02.177.orig/lib/config/config.c     2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/lib/config/config.c  2018-01-26 15:13:17.917538732 +0000
-@@ -43,6 +43,10 @@ static const char *_config_source_names[
+diff -urp LVM2.2.02.179.orig/lib/config/config.c LVM2.2.02.179/lib/config/config.c
+--- LVM2.2.02.179.orig/lib/config/config.c     2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/lib/config/config.c  2018-06-26 11:40:23.356840745 +0000
+@@ -44,6 +44,10 @@ static const char *_config_source_names[
        [CONFIG_FILE_SPECIAL] = "special purpose"
  };
  
@@ -28,9 +28,9 @@ diff -urp LVM2.2.02.177.orig/lib/config/config.c LVM2.2.02.177/lib/config/config
  struct config_file {
        off_t st_size;
        char *filename;
-diff -urp LVM2.2.02.177.orig/lib/metadata/pv.c LVM2.2.02.177/lib/metadata/pv.c
---- LVM2.2.02.177.orig/lib/metadata/pv.c       2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/lib/metadata/pv.c    2018-01-26 15:13:17.919538732 +0000
+diff -urp LVM2.2.02.179.orig/lib/metadata/pv.c LVM2.2.02.179/lib/metadata/pv.c
+--- LVM2.2.02.179.orig/lib/metadata/pv.c       2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/lib/metadata/pv.c    2018-06-26 11:40:23.356840745 +0000
 @@ -17,6 +17,12 @@
  #include "metadata.h"
  #include "lvmcache.h"
@@ -44,10 +44,10 @@ diff -urp LVM2.2.02.177.orig/lib/metadata/pv.c LVM2.2.02.177/lib/metadata/pv.c
  /*
   * FIXME: Check for valid handle before dereferencing field or log error?
   */
-diff -urp LVM2.2.02.177.orig/lib/misc/lib.h LVM2.2.02.177/lib/misc/lib.h
---- LVM2.2.02.177.orig/lib/misc/lib.h  2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/lib/misc/lib.h       2018-01-26 15:13:17.917538732 +0000
-@@ -94,4 +94,20 @@
+diff -urp LVM2.2.02.179.orig/lib/misc/lib.h LVM2.2.02.179/lib/misc/lib.h
+--- LVM2.2.02.179.orig/lib/misc/lib.h  2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/lib/misc/lib.h       2018-06-26 11:40:23.356840745 +0000
+@@ -93,4 +93,20 @@
  
  #include <unistd.h>
  
@@ -68,9 +68,9 @@ diff -urp LVM2.2.02.177.orig/lib/misc/lib.h LVM2.2.02.177/lib/misc/lib.h
 +#endif
 +
  #endif
-diff -urp LVM2.2.02.177.orig/lib/report/report.c LVM2.2.02.177/lib/report/report.c
---- LVM2.2.02.177.orig/lib/report/report.c     2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/lib/report/report.c  2018-01-26 15:13:17.918538732 +0000
+diff -urp LVM2.2.02.179.orig/lib/report/report.c LVM2.2.02.179/lib/report/report.c
+--- LVM2.2.02.179.orig/lib/report/report.c     2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/lib/report/report.c  2018-06-26 11:40:23.357840745 +0000
 @@ -29,6 +29,11 @@
  #include <float.h> /* DBL_MAX */
  #include <time.h>
@@ -83,9 +83,9 @@ diff -urp LVM2.2.02.177.orig/lib/report/report.c LVM2.2.02.177/lib/report/report
  struct lvm_report_object {
        struct volume_group *vg;
        struct lv_with_info_and_seg_status *lvdm;
-diff -urp LVM2.2.02.177.orig/libdm/libdevmapper.h LVM2.2.02.177/libdm/libdevmapper.h
---- LVM2.2.02.177.orig/libdm/libdevmapper.h    2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/libdm/libdevmapper.h 2018-01-26 15:13:17.916538732 +0000
+diff -urp LVM2.2.02.179.orig/libdm/libdevmapper.h LVM2.2.02.179/libdm/libdevmapper.h
+--- LVM2.2.02.179.orig/libdm/libdevmapper.h    2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/libdm/libdevmapper.h 2018-06-26 11:40:23.357840745 +0000
 @@ -251,6 +251,10 @@ int dm_task_set_add_node(struct dm_task
  /*
   * Control read_ahead.
@@ -97,9 +97,9 @@ diff -urp LVM2.2.02.177.orig/libdm/libdevmapper.h LVM2.2.02.177/libdm/libdevmapp
  #define DM_READ_AHEAD_AUTO UINT32_MAX /* Use kernel default readahead */
  #define DM_READ_AHEAD_NONE 0          /* Disable readahead */
  
-diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
---- LVM2.2.02.177.orig/tools/dmsetup.c 2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/tools/dmsetup.c      2018-01-26 15:13:17.919538732 +0000
+diff -urp LVM2.2.02.179.orig/tools/dmsetup.c LVM2.2.02.179/tools/dmsetup.c
+--- LVM2.2.02.179.orig/tools/dmsetup.c 2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/tools/dmsetup.c      2018-06-26 11:40:23.358840745 +0000
 @@ -37,6 +37,23 @@
  #  include <libudev.h>
  #endif
@@ -124,47 +124,48 @@ diff -urp LVM2.2.02.177.orig/tools/dmsetup.c LVM2.2.02.177/tools/dmsetup.c
  /* FIXME Unused so far */
  #undef HAVE_SYS_STATVFS_H
  
-diff -urp LVM2.2.02.177.orig/tools/Makefile.in LVM2.2.02.177/tools/Makefile.in
---- LVM2.2.02.177.orig/tools/Makefile.in       2018-01-26 15:12:22.000000000 +0000
-+++ LVM2.2.02.177/tools/Makefile.in    2018-01-26 15:17:46.765522708 +0000
-@@ -126,12 +126,13 @@ device-mapper: $(TARGETS_DM)
- CFLAGS_dmsetup.o += $(UDEV_CFLAGS) $(EXTRA_EXEC_CFLAGS)
+diff -urp LVM2.2.02.179.orig/tools/Makefile.in LVM2.2.02.179/tools/Makefile.in
+--- LVM2.2.02.179.orig/tools/Makefile.in       2018-06-26 11:33:19.629866001 +0000
++++ LVM2.2.02.179/tools/Makefile.in    2018-06-26 11:44:55.383824531 +0000
+@@ -127,13 +127,14 @@ CFLAGS_dmsetup.o += $(UDEV_CFLAGS) $(EXT
  
  dmsetup: dmsetup.o $(top_builddir)/libdm/libdevmapper.$(LIB_SUFFIX)
--      $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) \
-+      $(CC) $(CFLAGS) -L$(interfacebuilddir) -L$(top_builddir)/libdm \
+       @echo "    [CC] $@"
+-      $(Q) $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) \
++      $(Q) $(CC) $(CFLAGS) -L$(interfacebuilddir) -L$(top_builddir)/libdm \
 +            $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) \
              -o $@ dmsetup.o -ldevmapper $(LIBS)
  
  dmsetup.static: dmsetup.o $(interfacebuilddir)/libdevmapper.a
--      $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) \
+       @echo "    [CC] $@"
+-      $(Q) $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) \
 -            -o $@ dmsetup.o -ldevmapper $(M_LIBS) $(PTHREAD_LIBS) $(STATIC_LIBS) $(LIBS)
-+      $(CC) $(CFLAGS) -static -L$(interfacebuilddir) $(LDFLAGS) \
++      $(Q) $(CC) $(CFLAGS) -static -L$(interfacebuilddir) $(LDFLAGS) \
 +            -o $@ dmsetup.o -ldevmapper $(M_LIBS) $(PTHREAD_LIBS) $(STATIC_LIBS) $(LIBS) $(DIETLIBC_LIBS)
  
  all: device-mapper
  
-@@ -140,7 +141,7 @@ CFLAGS_lvm.o += $(EXTRA_EXEC_CFLAGS)
- INCLUDES += -I$(top_builddir)/tools
+@@ -143,7 +144,7 @@ INCLUDES += -I$(top_builddir)/tools
  
  lvm: $(OBJECTS) lvm.o $(top_builddir)/lib/liblvm-internal.a
--      $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) -o $@ $(OBJECTS) lvm.o \
-+      $(CC) $(CFLAGS) -L$(interfacebuilddir) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) -o $@ $(OBJECTS) lvm.o \
+       @echo "    [CC] $@"
+-      $(Q) $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) -o $@ $(OBJECTS) lvm.o \
++      $(Q) $(CC) $(CFLAGS) -L$(interfacebuilddir) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) -o $@ $(OBJECTS) lvm.o \
                $(LVMLIBS) $(READLINE_LIBS) $(LIBS)
  
  DEFS_man-generator.o += -DMAN_PAGE_GENERATOR
-@@ -157,7 +158,7 @@ endif
+@@ -163,7 +164,7 @@ endif
  lvm.static: $(OBJECTS) lvm-static.o $(top_builddir)/lib/liblvm-internal.a  $(interfacebuilddir)/libdevmapper.a
-       $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) -o $@ \
+       @echo "    [CC] $@"
+       $(Q) $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) -o $@ \
 -            $(OBJECTS) lvm-static.o $(LVMLIBS) $(STATIC_LIBS) $(LIBS)
 +            $(OBJECTS) lvm-static.o $(LVMLIBS) $(STATIC_LIBS) $(LIBS) $(PTHREAD_LIBS) $(DIETLIBC_LIBS)
  
  liblvm2cmd.a: $(top_builddir)/lib/liblvm-internal.a $(OBJECTS) lvmcmdlib.o lvm2cmd.o
-       cat $(top_builddir)/lib/liblvm-internal.a > $@
-diff -urp LVM2.2.02.177.orig/tools/tools.h LVM2.2.02.177/tools/tools.h
---- LVM2.2.02.177.orig/tools/tools.h   2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/tools/tools.h        2018-01-26 15:13:17.917538732 +0000
+       @echo "    [AR] $@"
+diff -urp LVM2.2.02.179.orig/tools/tools.h LVM2.2.02.179/tools/tools.h
+--- LVM2.2.02.179.orig/tools/tools.h   2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/tools/tools.h        2018-06-26 11:40:23.359840745 +0000
 @@ -47,6 +47,21 @@
  #include <ctype.h>
  #include <sys/types.h>
index 0e53e8ef8307b9a6db859b80d62ed645b92c5c3c..51223adefa6c0f301e90f4e7b08ad24bb64b743b 100644 (file)
@@ -1,9 +1,9 @@
-diff -urp LVM2.2.02.177.orig/tools/Makefile.in LVM2.2.02.177/tools/Makefile.in
---- LVM2.2.02.177.orig/tools/Makefile.in       2017-12-18 20:44:35.000000000 +0000
-+++ LVM2.2.02.177/tools/Makefile.in    2018-01-26 15:12:22.687542024 +0000
+diff -urp LVM2.2.02.179.orig/tools/Makefile.in LVM2.2.02.179/tools/Makefile.in
+--- LVM2.2.02.179.orig/tools/Makefile.in       2018-06-18 05:24:22.000000000 +0000
++++ LVM2.2.02.179/tools/Makefile.in    2018-06-26 11:33:19.629866001 +0000
 @@ -97,6 +97,9 @@ endif
  
- LVMLIBS = $(LVMINTERNAL_LIBS) -ldevmapper
+ LVMLIBS = $(LVMINTERNAL_LIBS) -ldevmapper -laio
  LIB_VERSION = $(LIB_VERSION_LVM)
 +ifneq ("@STATIC_LINK@", "yes")
 +  LVMLIBS += -lselinux -lsepol
index ce2e788d57d9fa21ea297c772c04095a4b9d8504..8c396027ebb84cadec0fa0c4ba420be774ddc9bd 100644 (file)
@@ -1,6 +1,7 @@
---- LVM2.2.02.149/configure.in.orig    2016-04-06 16:05:03.799248008 +0200
-+++ LVM2.2.02.149/configure.in 2016-04-06 20:23:12.388598015 +0200
-@@ -463,7 +463,7 @@
+diff -urp LVM2.2.02.179.orig/configure.ac LVM2.2.02.179/configure.ac
+--- LVM2.2.02.179.orig/configure.ac    2018-06-26 11:40:19.088840999 +0000
++++ LVM2.2.02.179/configure.ac 2018-06-26 11:51:45.460800089 +0000
+@@ -397,7 +397,7 @@ dnl -- thin_check needs-check flag
  AC_ARG_ENABLE(thin_check_needs_check,
              AC_HELP_STRING([--disable-thin_check_needs_check],
                             [required if thin_check version is < 0.3.0]),
@@ -9,7 +10,7 @@
  
  # Test if necessary thin tools are available
  # if not - use plain defaults and warn user
-@@ -478,7 +478,7 @@
+@@ -412,7 +412,7 @@ case "$THIN" in
                        THIN_CONFIGURE_WARN=y
                fi
        fi
@@ -18,7 +19,7 @@
                THIN_CHECK_VSN=`"$THIN_CHECK_CMD" -V 2>/dev/null`
                THIN_CHECK_VSN_MAJOR=`echo "$THIN_CHECK_VSN" | $AWK -F '.' '{print $1}'`
                THIN_CHECK_VSN_MINOR=`echo "$THIN_CHECK_VSN" | $AWK -F '.' '{print $2}'`
-@@ -491,6 +491,8 @@
+@@ -425,6 +425,8 @@ case "$THIN" in
                        AC_MSG_WARN([$THIN_CHECK_CMD: Old version "$THIN_CHECK_VSN" found])
                        THIN_CHECK_VERSION_WARN=y
                        THIN_CHECK_NEEDS_CHECK=no
@@ -27,7 +28,7 @@
                fi
        fi
        # Empty means a config way to ignore thin dumping
-@@ -577,7 +579,7 @@
+@@ -511,7 +513,7 @@ dnl -- cache_check needs-check flag
  AC_ARG_ENABLE(cache_check_needs_check,
              AC_HELP_STRING([--disable-cache_check_needs_check],
                             [required if cache_check version is < 0.5]),
@@ -36,7 +37,7 @@
  
  # Test if necessary cache tools are available
  # if not - use plain defaults and warn user
-@@ -592,7 +594,7 @@
+@@ -526,7 +528,7 @@ case "$CACHE" in
                        CACHE_CONFIGURE_WARN=y
                fi
        fi
@@ -45,9 +46,9 @@
                $CACHE_CHECK_CMD -V 2>/dev/null >conftest.tmp
                read -r CACHE_CHECK_VSN < conftest.tmp
                IFS=.- read -r CACHE_CHECK_VSN_MAJOR CACHE_CHECK_VSN_MINOR CACHE_CHECK_VSN_PATCH LEFTOVER < conftest.tmp
-@@ -612,6 +614,8 @@
+@@ -550,6 +552,8 @@ case "$CACHE" in
+                               AC_MSG_WARN([$CACHE_CHECK_CMD: Old version "$CACHE_CHECK_VSN" does not support new cache format V2])
                                CACHE_CHECK_VERSION_WARN=y
-                               CACHE_CHECK_NEEDS_CHECK=no
                        fi
 +              else
 +                              CACHE_CHECK_NEEDS_CHECK=yes
index 6764bb3fad71d33d688058508f661be450d6f780..d39d289d38fd36b2892335bd7e2856be9eb6157f 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.02.177
-Release:       3
+Version:       2.02.179
+Release:       1
 License:       GPL v2 and LGPL v2.1
 Group:         Applications/System
 Source0:       ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: ee6cfbc5a0c5696ffae79dac04ee7a2b
+# Source0-md5: 308bbdf93a5cb0b20898dbdad53e437f
 Source3:       clvmd.sysconfig
 Patch0:                %{name}-selinux.patch
 Patch1:                %{name}-diet.patch
@@ -387,7 +387,7 @@ potrzeby initrd.
 
 # do not force --export-symbol linker option for e.g. statically linked executables
 # -rdynamic compiler option drives linker in the right way.
-%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
+%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
 
 %build
 %if %{with initrd}