]> TLD Linux GIT Repositories - packages/lvm2.git/commitdiff
- updated for 2.02.132
authorMarcin Krol <hawk@tld-linux.org>
Sat, 3 Oct 2015 18:43:44 +0000 (18:43 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 3 Oct 2015 18:43:44 +0000 (18:43 +0000)
device-mapper-dmsetup-export.patch
lvm2-diet.patch

index d390bda5a9777fbb9e3d4ca62cfff7c5fb06eb10..7ea1a4b863041b9e12b4f26be63f13867937bde1 100644 (file)
@@ -8,26 +8,27 @@ Index: LVM2.2.02.98/man/dmsetup.8.in
 --- LVM2.2.02.116.orig/man/dmsetup.8.in        2015-01-30 16:19:53.000000000 +0000
 +++ LVM2.2.02.116/man/dmsetup.8.in     2015-02-03 21:05:01.635601115 +0000
 @@ -19,6 +19,9 @@ dmsetup \(em low level logical volume ma
- .RI [ + ]< sectors >| auto | none ]
- .RE
- .br
-+.B dmsetup export
-+.I [ device_name ]
-+.br
- .B dmsetup deps
- .RB [ \-o
  .IR options ]
-@@ -309,6 +312,10 @@ device_name in subsequent dmsetup comman
- If successful a device will appear as
- /dev/mapper/<device-name>.
- See below for information on the table format.
-+.IP \fBexport
-+.I [ device_name ]
+ .RI [ device_name ]
+ .HP
++.B dmsetup export
++.RI [ device_name ]
++.HP
+ .B dmsetup help
+ .RB [ \-c | \-C | \-\-columns ]
+ .HP
+@@ -309,6 +312,11 @@ device_name in subsequent dmsetup comman
+ \fBblkdevname\fP (block device name),
+ \fBdevname\fP (map name for device-mapper devices, equal to blkdevname otherwise).
+ .HP
++.B export
++.RI [ device_name ]
 +.br
 +Outputs information in key/value format to be imported by other programs.
++.HP
+ .B help
+ .RB [ \-c | \-C | \-\-columns ]
  .br
- .TP
- .B deps
 Index: LVM2.2.02.98/tools/dmsetup.c
 ===================================================================
 --- LVM2.2.02.98.orig/tools/dmsetup.c
@@ -131,14 +132,14 @@ Index: LVM2.2.02.98/tools/dmsetup.c
        int r = 0;
        struct dm_task *dmt;
 @@ -3056,10 +3143,11 @@ static struct command _commands[] = {
-       {"message", "<device> <sector> <message>", 2, -1, 0, _message},
-       {"ls", "[--target <target_type>] [--exec <command>] [-o options] [--tree]", 0, 0, 0, _ls},
-       {"info", "[<device>]", 0, -1, 1, _info},
-       {"deps", "[-o options] [<device>]", 0, -1, 1, _deps},
-       {"status", "[<device>] [--noflush] [--target <target_type>]", 0, -1, 1, _status},
-+      {"export", "[<device>]", 0, 1, 1, _export},
-       {"table", "[<device>] [--target <target_type>] [--showkeys]", 0, -1, 1, _status},
-       {"wait", "<device> [<event_nr>] [--noflush]", 0, 2, 0, _wait},
-       {"mknodes", "[<device>]", 0, -1, 1, _mknodes},
-       {"mangle", "[<device>]", 0, -1, 1, _mangle},
-       {"udevcreatecookie", "", 0, 0, 0, _udevcreatecookie},
+       {"ls", "[--target <target_type>] [--exec <command>] [-o <options>] [--tree]", 0, 0, 0, 0, _ls},
+       {"info", "[<device>]", 0, -1, 1, 0, _info},
+       {"deps", "[-o <options>] [<device>]", 0, -1, 1, 0, _deps},
+       {"stats", "<command> [<options>] [<devices>]", 1, -1, 1, 1, _stats},
+       {"status", "[<device>] [--noflush] [--target <target_type>]", 0, -1, 1, 0, _status},
++      {"export", "[<device>]", 0, 1, 1, 0, _export},
+       {"table", "[<device>] [--target <target_type>] [--showkeys]", 0, -1, 1, 0, _status},
+       {"wait", "<device> [<event_nr>] [--noflush]", 0, 2, 0, 0, _wait},
+       {"mknodes", "[<device>]", 0, -1, 1, 0, _mknodes},
+       {"mangle", "[<device>]", 0, -1, 1, 0, _mangle},
+       {"udevcreatecookie", "", 0, 0, 0, 0, _udevcreatecookie},
index abf8df35c1459d5db9d4d451cc894490b91e117e..1799ebc8ac594cdb0da5c572e1444ad60a00e315 100644 (file)
 
 --- LVM2.2.02.105/tools/Makefile.in.orig       2014-01-26 18:33:51.531497416 +0100
 +++ LVM2.2.02.105/tools/Makefile.in    2014-01-26 19:14:42.264728615 +0100
-@@ -127,19 +127,19 @@
- CFLAGS_dmsetup.o += $(EXTRA_EXEC_CFLAGS)
+@@ -127,20 +127,20 @@
+ CFLAGS_dmsetup.o += $(UDEV_CFLAGS) $(EXTRA_EXEC_CFLAGS)
  
  dmsetup: dmsetup.o $(top_builddir)/libdm/libdevmapper.$(LIB_SUFFIX)
 -      $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) -L$(top_builddir)/libdm \
  all: device-mapper
  
  CFLAGS_lvm.o += $(EXTRA_EXEC_CFLAGS)
+ CFLAGS_lvmcmdline.o += $(VALGRIND_CFLAGS)
  
  lvm: $(OBJECTS) lvm.o $(top_builddir)/lib/liblvm-internal.a
 -      $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_EXEC_LDFLAGS) $(ELDFLAGS) -o $@ $(OBJECTS) lvm.o \