]> TLD Linux GIT Repositories - packages/mksh.git/commitdiff
- PLD merge
authorMarcin Krol <hawk@tld-linux.org>
Thu, 14 Apr 2016 12:08:52 +0000 (12:08 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 14 Apr 2016 12:08:52 +0000 (12:08 +0000)
get-source.sh [new file with mode: 0755]
mksh-circumflex.patch [new file with mode: 0644]
mksh-cmdline-length.patch
mksh.spec

diff --git a/get-source.sh b/get-source.sh
new file mode 100755 (executable)
index 0000000..07491f1
--- /dev/null
@@ -0,0 +1,28 @@
+#!/bin/sh
+set -e
+
+CVSROOT=_anoncvs@anoncvs.mirbsd.org:/cvs
+module=mksh
+tag=mksh-R50d
+branch=mksh-R50stable
+out=branch.diff
+
+d=$-
+filter() {
+       set -$d
+       # remove revno's for smaller diffs
+       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+}
+
+echo >&2 "Running diff: $tag -> $branch"
+
+cvs -qz8 -d "$CVSROOT" rdiff -u -r"$tag" -r"$branch" "$module" > $out.tmp
+
+if cmp -s $out{,.tmp}; then
+       echo >&2 "No new diffs..."
+       rm -f $out.tmp
+       exit 0
+fi
+mv -f $out{.tmp,}
+
+./dropin $out
diff --git a/mksh-circumflex.patch b/mksh-circumflex.patch
new file mode 100644 (file)
index 0000000..f52bbed
--- /dev/null
@@ -0,0 +1,45 @@
+diff -ur mksh-40.org//eval.c mksh-40/eval.c
+--- mksh-40.org//eval.c        2011-06-12 16:45:57.000000000 +0200
++++ mksh-40/eval.c     2011-07-07 18:27:58.891492090 +0200
+@@ -887,6 +887,7 @@
+                               switch (c) {
+                               case '[':
+                               case '!':
++                              case NOT2:
+                               case '-':
+                               case ']':
+                                       /*
+diff -ur mksh-40.org//misc.c mksh-40/misc.c
+--- mksh-40.org//misc.c        2011-06-12 16:45:58.000000000 +0200
++++ mksh-40/misc.c     2011-07-07 18:28:39.015826686 +0200
+@@ -843,7 +843,7 @@
+       bool notp, found = false;
+       const unsigned char *orig_p = p;
+-      if ((notp = tobool(ISMAGIC(*p) && *++p == '!')))
++      if ((notp = tobool(ISMAGIC(*p) && (*++p == '!' || *p == NOT2))))
+               p++;
+       do {
+               c = *p++;
+diff -ur mksh-40.org//sh.h mksh-40/sh.h
+--- mksh-40.org//sh.h  2011-06-12 16:59:09.000000000 +0200
++++ mksh-40/sh.h       2011-07-07 18:29:16.346761511 +0200
+@@ -380,5 +380,6 @@
+ #define MAGIC         (7)     /* prefix for *?[!{,} during expand */
+ #define ISMAGIC(c)    ((unsigned char)(c) == MAGIC)
++#define NOT2          '^'
+ #define LINE          4096    /* input line size */
+diff -urN mksh.org/check.t mksh/check.t
+--- mksh.org/check.t   2014-01-11 19:10:02.000000000 +0100
++++ mksh/check.t       2014-01-20 14:12:37.924222697 +0100
+@@ -2085,7 +2085,7 @@
+       cbc
+       -bc cbc
+       abc bbc
+-      ^bc abc bbc
++      !bc -bc ^bc cbc
+       !bc -bc ^bc cbc
+ ---
+ name: glob-range-2
index de55b3f1e2cd02037f4f2052381f49c310da9943..0225f51be8b3eaa92ea74bada7949c3a50d637b1 100644 (file)
@@ -4,8 +4,8 @@
  EXTERN char   *current_wd;
  
  /* input line size */
--#define LINE          (4096 - ALLOC_SIZE)
-+#define LINE          (16384 - ALLOC_SIZE)
+-#define LINE          (4096 - ALLOC_OVERHEAD)
++#define LINE          (16384 - ALLOC_OVERHEAD)
  /*
   * Minimum required space to work with on a line - if the prompt leaves
   * less space than this on a line, the prompt is truncated.
index 3f02e7234dffb4bd17ffce812655d6c2df94afe5..7114292122b1dea52200c880cb2c2ee90e0b3362 100644 (file)
--- a/mksh.spec
+++ b/mksh.spec
@@ -6,12 +6,12 @@
 Summary:       MirBSD Korn Shell
 Summary(pl.UTF-8):     Powłoka Korna z MirBSD
 Name:          mksh
-Version:       52b
+Version:       52c
 Release:       1
 License:       BSD
 Group:         Applications/Shells
 Source0:       http://www.mirbsd.org/MirOS/dist/mir/mksh/%{name}-R%{version}.tgz
-# Source0-md5: 123f713e71754da87a455b5fbe0b03b7
+# Source0-md5: cc3884e02314447e7b4a3073b8d65d1e
 Source1:       %{name}-mkshrc
 Patch0:                %{name}-mkshrc_support.patch
 Patch1:                %{name}-cmdline-length.patch