]> TLD Linux GIT Repositories - packages/mysql.git/commitdiff
- rediffed
authorMarcin Krol <hawk@tld-linux.org>
Sun, 17 Dec 2023 21:28:06 +0000 (22:28 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 17 Dec 2023 21:28:06 +0000 (22:28 +0100)
mysql-system-xxhash.patch

index 9ca55141367f81d0bca745b2ecf963683a411080..c2f9f499a2e3acdfc38945e8b33a4b4a919a61a5 100644 (file)
@@ -1,6 +1,26 @@
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc.orig        2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc     2022-10-09 14:33:34.598098038 +0200
-@@ -126,7 +126,7 @@ Gcs_sender_id calculate_sender_id(const
+diff -ur mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/CMakeLists.txt mysql-8.0.35/plugin/group_replication/libmysqlgcs/CMakeLists.txt
+--- mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/CMakeLists.txt      2023-12-17 22:05:20.830721323 +0100
++++ mysql-8.0.35/plugin/group_replication/libmysqlgcs/CMakeLists.txt   2023-12-17 22:07:25.296271792 +0100
+@@ -137,7 +137,6 @@
+   src/bindings/xcom/gcs_xcom_statistics_interface.cc
+   src/bindings/xcom/gcs_xcom_proxy.cc
+   src/bindings/xcom/gcs_xcom_communication_protocol_changer.cc
+-  ${BUNDLED_LZ4_PATH}/xxhash.c # required by gcs_message_stage_split
+   src/bindings/xcom/gcs_message_stage_split.cc
+   src/bindings/xcom/gcs_xcom_synode.cc
+   src/bindings/xcom/gcs_xcom_expels_in_progress.cc)
+@@ -230,6 +229,7 @@
+ # Dependency on mysys from gcs_logging_system.cc
+ # but pick up symbols from the server:
+ # TARGET_LINK_LIBRARIES(mysqlgcs mysys)
++TARGET_LINK_LIBRARIES(mysqlgcs xxhash)
+ IF(LINUX AND WITH_TIRPC STREQUAL "bundled")
+   ADD_DEPENDENCIES(mysqlgcs tirpc_ext)
+diff -ur mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc mysql-8.0.35/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc
+--- mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc        2023-12-17 22:05:20.832721348 +0100
++++ mysql-8.0.35/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc     2023-12-17 22:07:25.295271780 +0100
+@@ -126,7 +126,7 @@
    std::string info(node.get_member_id().get_member_id());
    info.append(node.get_member_uuid().actual_value);
  
@@ -9,8 +29,9 @@
  }
  
  bool Gcs_message_stage_split_v2::update_members_information(
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h   2022-10-09 08:41:35.109178797 +0200
+diff -ur mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h mysql-8.0.35/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h
+--- mysql-8.0.35.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h      2023-12-17 22:05:20.834721373 +0100
++++ mysql-8.0.35/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h   2023-12-17 22:07:25.296271792 +0100
 @@ -25,10 +25,6 @@
    Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
  */
 +#include <xxhash.h>
  
  #endif  // GCS_XXHASH_H_INCLUDED
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/CMakeLists.txt.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/CMakeLists.txt   2022-10-09 08:42:55.768741827 +0200
-@@ -140,7 +140,6 @@ SET(GCS_SOURCES
-   src/bindings/xcom/gcs_xcom_statistics_interface.cc
-   src/bindings/xcom/gcs_xcom_proxy.cc
-   src/bindings/xcom/gcs_xcom_communication_protocol_changer.cc
--  ${BUNDLED_LZ4_PATH}/xxhash.c # required by gcs_message_stage_split
-   src/bindings/xcom/gcs_message_stage_split.cc
-   src/bindings/xcom/gcs_xcom_synode.cc
-   src/bindings/xcom/gcs_xcom_expels_in_progress.cc)
-@@ -219,6 +218,7 @@ ADD_LIBRARY(mysqlgcs STATIC ${XCOM_SOURC
- # Dependency on mysys from gcs_logging_system.cc
- # but pick up symbols from the server:
- # TARGET_LINK_LIBRARIES(mysqlgcs mysys)
-+TARGET_LINK_LIBRARIES(mysqlgcs xxhash)
- IF(CMAKE_VERSION VERSION_GREATER "3.19" AND NOT APPLE_XCODE)
-   # New in version 3.19:
---- mysql-8.0.30/sql/CMakeLists.txt.orig       2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/CMakeLists.txt    2022-10-09 08:53:20.935355008 +0200
-@@ -755,7 +755,6 @@ SET(SQL_SOURCE
+diff -ur mysql-8.0.35.orig/sql/CMakeLists.txt mysql-8.0.35/sql/CMakeLists.txt
+--- mysql-8.0.35.orig/sql/CMakeLists.txt       2023-12-17 22:05:21.077724399 +0100
++++ mysql-8.0.35/sql/CMakeLists.txt    2023-12-17 22:08:35.180142336 +0100
+@@ -762,7 +762,6 @@
    ${CONF_SOURCES}
    ${SQL_SHARED_SOURCES}
    ${SQL_HEADERS}
@@ -51,7 +55,7 @@
    ../libmysql/errmsg.cc
    ../sql-common/client.cc
    ../sql-common/client_plugin.cc
-@@ -813,11 +812,6 @@ IF(WIN32)
+@@ -818,11 +817,6 @@
        )
  ENDIF()
  
@@ -63,7 +67,7 @@
  # Workaround for Apple Clang bug on ARM.
  # When linking mysqld (and executables using server_unittest_library)
  # we get linker warnings about
-@@ -842,13 +836,6 @@ IF(APPLE_ARM)
+@@ -847,13 +841,6 @@
      )
  ENDIF()
  
  # Fixes "C1128: number of sections exceeded object file format limit" in MSVC
  IF(WIN32)
    ADD_COMPILE_FLAGS(
-@@ -924,7 +911,7 @@ ADD_DEPENDENCIES(sql_main GenBootstrapPr
+@@ -941,7 +928,7 @@
  ADD_DEPENDENCIES(sql_main GenSysSchema)
  TARGET_LINK_LIBRARIES(sql_main ${MYSQLD_STATIC_PLUGIN_LIBS}
    mysql_server_component_services mysys strings vio
--  binlogevents_static ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES})
-+  binlogevents_static xxhash ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES})
+-  binlogevents_static ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES}
++  binlogevents_static xxhash ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES}
+   extra::rapidjson)
  
  # sql/immutable_string.h uses
- # google::protobuf::io::CodedOutputStream::WriteVarint64ToArray
---- mysql-8.0.30/sql/iterators/hash_join_iterator.cc.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/iterators/hash_join_iterator.cc   2022-10-09 17:45:57.618897459 +0200
+diff -ur mysql-8.0.35.orig/sql/iterators/hash_join_iterator.cc mysql-8.0.35/sql/iterators/hash_join_iterator.cc
+--- mysql-8.0.35.orig/sql/iterators/hash_join_iterator.cc      2023-12-17 22:05:21.366728000 +0100
++++ mysql-8.0.35/sql/iterators/hash_join_iterator.cc   2023-12-17 22:07:25.297271805 +0100
 @@ -32,7 +32,7 @@
  #include "field_types.h"
  #include "my_alloc.h"
  
  #include "my_inttypes.h"
  #include "my_sys.h"
-@@ -307,7 +307,7 @@ static bool WriteRowToChunk(
+@@ -307,7 +307,7 @@
    const uint64_t join_key_hash =
        join_key_and_row_buffer->length() == 0
            ? kZeroKeyLengthHash
                       join_key_and_row_buffer->length(), xxhash_seed);
  
    assert((chunks->size() & (chunks->size() - 1)) == 0);
---- mysql-8.0.30/sql/rpl_write_set_handler.cc.orig     2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/rpl_write_set_handler.cc  2022-10-09 20:07:41.099496817 +0200
+diff -ur mysql-8.0.35.orig/sql/rpl_write_set_handler.cc mysql-8.0.35/sql/rpl_write_set_handler.cc
+--- mysql-8.0.35.orig/sql/rpl_write_set_handler.cc     2023-12-17 22:05:21.611731051 +0100
++++ mysql-8.0.35/sql/rpl_write_set_handler.cc  2023-12-17 22:07:25.297271805 +0100
 @@ -37,7 +37,7 @@
  #include "my_dbug.h"
  #include "my_inttypes.h"
  #include "mysql_com.h"
  #include "sql-common/json_binary.h"
  #include "sql-common/json_dom.h"
-@@ -75,7 +75,7 @@ uint64 calc_hash(ulong algorithm, type T
+@@ -75,7 +75,7 @@
    if (algorithm == HASH_ALGORITHM_MURMUR32)
      return (murmur3_32((const uchar *)T, len, 0));
    else
  }
  
  #ifndef NDEBUG
---- mysql-8.0.30/unittest/gunit/hash_join-t.cc.orig    2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/unittest/gunit/hash_join-t.cc 2022-10-09 20:36:43.693389709 +0200
-@@ -28,7 +28,7 @@
- #include "include/my_murmur3.h"
- #include "my_alloc.h"
+diff -ur mysql-8.0.35.orig/unittest/gunit/hash_join-t.cc mysql-8.0.35/unittest/gunit/hash_join-t.cc
+--- mysql-8.0.35.orig/unittest/gunit/hash_join-t.cc    2023-12-17 22:05:25.668781591 +0100
++++ mysql-8.0.35/unittest/gunit/hash_join-t.cc 2023-12-17 22:08:05.509772732 +0100
+@@ -37,7 +37,7 @@
+ #include "my_config.h"
+ #include "my_inttypes.h"
+ #include "my_murmur3.h"
 -#include "my_xxhash.h"
 +#include <xxhash.h>
- #include "sql/item_cmpfunc.h"
- #include "sql/iterators/hash_join_buffer.h"
- #include "sql/iterators/hash_join_iterator.h"
-@@ -204,7 +204,7 @@ static void BM_XXHash64ShortData(size_t
+ #include "mysql/components/services/bits/psi_bits.h"
+ #include "prealloced_array.h"
+ #include "sql/field.h"
+@@ -226,7 +226,7 @@
  
    size_t sum = 0;
    for (size_t i = 0; i < num_iterations; ++i) {
    }
    StopBenchmarkTiming();
  
-@@ -223,7 +223,7 @@ static void BM_XXHash64LongData(size_t n
+@@ -245,7 +245,7 @@
  
    size_t sum = 0;
    for (size_t i = 0; i < num_iterations; ++i) {
    }
    StopBenchmarkTiming();
  
---- mysql-8.0.30/unittest/gunit/innodb/ut0rnd-t.cc.orig        2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/unittest/gunit/innodb/ut0rnd-t.cc     2022-10-09 20:46:00.157041753 +0200
+diff -ur mysql-8.0.35.orig/unittest/gunit/innodb/ut0rnd-t.cc mysql-8.0.35/unittest/gunit/innodb/ut0rnd-t.cc
+--- mysql-8.0.35.orig/unittest/gunit/innodb/ut0rnd-t.cc        2023-12-17 22:05:25.830783608 +0100
++++ mysql-8.0.35/unittest/gunit/innodb/ut0rnd-t.cc     2023-12-17 22:07:25.298271817 +0100
 @@ -33,7 +33,7 @@
  #include "storage/innobase/include/ut0crc32.h"
  #include "storage/innobase/include/ut0rnd.h"