]> TLD Linux GIT Repositories - packages/mysql.git/commitdiff
- updated to 5.6.36-82.0
authorMarcin Krol <hawk@tld-linux.org>
Thu, 22 Jun 2017 21:45:20 +0000 (21:45 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 22 Jun 2017 21:45:20 +0000 (21:45 +0000)
mysql.spec

index 80cddd9499723d34006d2698a7ca271c6f98d984..ae907f65a6db2ec95c374501e8fd0ae9933eae34 100644 (file)
@@ -24,7 +24,7 @@
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
 %define                rel     1
-%define                percona_rel     80.0
+%define                percona_rel     82.0
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -35,12 +35,12 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.6.35
+Version:       5.6.36
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 Source0:       http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: cb0d7e91d14b121127dd32fa5fdfa2ff
+# Source0-md5: 4d4932076b133d5e9f45b850694f3408
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 Source1:       %{name}.init
@@ -60,8 +60,11 @@ Patch1:              %{name}-versioning.patch
 Patch2:                %{name}hotcopy-5.0-5.5.patch
 Patch3:                bug-67402.patch
 Patch4:                %{name}-no-default-secure-auth.patch
+Patch5:                %{name}-system-libhsclient.patch
+Patch6:                handlersocket.patch
+
 # from fedora
-Patch6:                %{name}-system-users.patch
+Patch8:                %{name}-system-users.patch
 
 Patch9:                %{name}-build.patch
 Patch11:       %{name}-upgrade.patch
@@ -79,6 +82,7 @@ BuildRequires:        cmake >= 2.6
 BuildRequires: readline-devel >= 6.2
 BuildRequires: libstdc++-devel >= 5:4.0
 BuildRequires: automake
+BuildRequires: libhsclient-devel
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: ncurses-devel >= 4.2
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
@@ -498,9 +502,11 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-
+%patch5 -p1
 %patch6 -p1
 
+%patch8 -p1
+
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
@@ -524,7 +530,7 @@ cd build
 # (it defaults to first cluster but user may change it to whatever
 # cluster it wants)
 
-%cmake \
+%cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
        -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
@@ -551,8 +557,7 @@ cd build
        -DWITHOUT_TOKUDB=1 \
        -DWITHOUT_TOKUDB_STORAGE_ENGINE=1 \
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
-       -DWITH_ZLIB=system \
-       ..
+       -DWITH_ZLIB=system
 
 %{__make}