]> TLD Linux GIT Repositories - packages/openvpn.git/blob - openvpn.spec
- updated to 2.3.10
[packages/openvpn.git] / openvpn.spec
1
2 # Conditional build:
3 %bcond_without  pkcs11          # build without PKCS#11 support
4
5 Summary:        VPN Daemon
6 Summary(pl.UTF-8):      Serwer VPN
7 Name:           openvpn
8 Version:        2.3.10
9 Release:        1
10 License:        GPL v2
11 Group:          Networking/Daemons
12 Source0:        http://swupdate.openvpn.net/community/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  275a640ccfc6a9f9a8faa4c84a74d294
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 Source3:        %{name}-update-resolv-conf
17 Patch0:         %{name}-pam.patch
18 URL:            http://www.openvpn.net/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  libselinux-devel
22 BuildRequires:  lzo-devel
23 BuildRequires:  openssl-devel >= 0.9.7d
24 BuildRequires:  pam-devel
25 %{?with_pkcs11:BuildRequires:   pkcs11-helper-devel}
26 BuildRequires:  rpmbuild(macros) >= 1.671
27 Requires(post,preun):   /sbin/chkconfig
28 Requires:       /sbin/ip
29 Requires:       rc-scripts >= 0.4.3.0
30 Conflicts:      kernel < 2.4
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _localstatedir  /var
34
35 %description
36 OpenVPN is a robust and highly configurable VPN (Virtual Private
37 Network) daemon which can be used to securely link two or more private
38 networks using an encrypted tunnel over the internet.
39
40 %description -l pl.UTF-8
41 OpenVPN jest mocnym i silnie konfigurowalnym serwerem VPN (Wirtualne
42 Sieci Prywatne), który może być użyty do bezpiecznego łączenia dwóch
43 lub więcej prywatnych sieci używając zaszyfrowanego tunelu poprzez
44 internet.
45
46 %package devel
47 Summary:        Header files for OpenVPN plugins development
48 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek OpenVPN
49 Group:          Development/Libraries
50
51 %description devel
52 This is the package containing the header files for OpenVPN plugins
53 development.
54
55 %description devel -l pl.UTF-8
56 Ten pakiet zawiera pliki nagłówkowe do tworzenia wtyczek OpenVPN.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 sed -e 's,/''usr/lib/openvpn,%{_libdir}/%{name},' %{SOURCE3} > contrib/update-resolv-conf
63
64 %build
65 %{__aclocal} -I m4
66 %{__autoheader}
67 %{__autoconf}
68 %{__automake}
69
70 %configure \
71         %{!?with_pkcs11:--disable-pkcs11} \
72         --enable-password-save \
73         --enable-iproute2 \
74         --enable-selinux \
75         IFCONFIG=/sbin/ifconfig \
76         IPROUTE=/sbin/ip \
77         ROUTE=/sbin/route \
78         NETSTAT=/bin/netstat
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/openvpn,%{_sbindir},%{_mandir}/man8} \
85         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/run/openvpn,%{_includedir}} \
86         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
92 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/chkconfig --add openvpn
101 %service openvpn restart "OpenVPN"
102
103 %preun
104 if [ "$1" = "0" ]; then
105         %service openvpn stop
106         /sbin/chkconfig --del openvpn
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS README* ChangeLog sample/sample-{config-files,keys,scripts} doc/management-notes.txt
112 %doc *.IPv6 src/plugins/*/README.*
113 %dir %{_sysconfdir}/openvpn
114 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
115 %attr(755,root,root) %{_sbindir}/openvpn
116 %attr(754,root,root) /etc/rc.d/init.d/%{name}
117 %dir %{_libdir}/%{name}
118 %dir %{_libdir}/%{name}/plugins
119 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
120 %{_mandir}/man8/openvpn.8*
121 %dir /var/run/openvpn
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc doc/README.plugins sample/sample-plugins
126 %{_includedir}/openvpn-plugin.h