]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- PHP 5.6.6
[packages/php.git] / php.spec
index a3681f98062188e324b3653a67bfdcbec93c2a79..45b25191837284f318617729a7266c4137d20cfc 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -8,7 +8,6 @@
 # - update imap myrights patch (needs api porting)
 # --with-libmbfl=DIR      MBSTRING: Use external libmbfl.  DIR is the libmbfl base install directory BUNDLED
 # --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
-# NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
 # TODO:
@@ -40,7 +39,7 @@
 # libxml
 # Reflection
 # standard
-#
+# 
 # Conditional build:
 %bcond_without default_php     # use this PHP as default PHP in distro
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
@@ -60,8 +59,7 @@
 %bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
-# don't turn it on by default; see TODO item for mysqlnd in this spec
-%bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
+%bcond_without mysqlnd         # without mysqlnd support in mysql related extensions
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
 %bcond_without odbc            # without ODBC extension module
 %bcond_without opcache         # without Enable Zend OPcache extension support
@@ -135,7 +133,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     0.1
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -146,13 +144,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.0
+Version:       5.6.6
 Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 642825d75ce2634d9513d5b21dbee521
+# Source0-md5: ed0c9ad2419fffde1d8c03a2d8164179
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -218,6 +216,7 @@ Patch65:    system-libzip.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
 Patch69:       fpm-conf-split.patch
+Patch70:       mysqlnd-ssl.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -546,7 +545,7 @@ Provides:   php(ereg)
 Provides:      php(libxml)
 Provides:      php(reflection)
 Provides:      php(standard)
-%{!?with_mysqlnd:Obsoletes:    php-mysqlnd}
+%{!?with_mysqlnd:Obsoletes:    %{name}-mysqlnd}
 %{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-common < 4:5.3.28-7
 Obsoletes:     php-pecl-domxml
@@ -582,7 +581,6 @@ Requires:   libtool >= 2:2.2
 %{?with_pcre:Requires: pcre-devel >= 8.10}
 Requires:      shtool
 Provides:      php-devel = %{epoch}:%{version}-%{release}
-Obsoletes:     php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
@@ -2008,6 +2006,7 @@ cp -p php.ini-production php.ini
 %patch38 -p1
 %patch39 -p1
 %if %{with fpm}
+%patch69 -p1
 %patch41 -p1
 %patch42 -p1
 %endif
@@ -2031,7 +2030,7 @@ cp -p php.ini-production php.ini
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p1
 %patch67 -p1
-%patch69 -p1
+%patch70 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2409,7 +2408,9 @@ sapis=$(%{__sed} -rne 's/^PHP_INSTALLED_SAPIS = (.+)/\1/p' Makefile.* | tr ' ' '
 cp -af php_config.h.cli main/php_config.h
 cp -af Makefile.cli Makefile
 %{__make} libphp_common.la
-%{__make} build-modules
+# hack: MYSQLND_SHARED_LIBADD not initialized
+%{__make} build-modules \
+       MYSQLND_SHARED_LIBADD="-lssl -lcrypto"
 
 %if %{with apache1}
 %{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1