]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 8.2.2
authorMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2023 21:24:16 +0000 (22:24 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 8 Feb 2023 21:24:16 +0000 (22:24 +0100)
fix-test-run.patch
php-fpm-config.patch
php-ini.patch
php-silent-session-cleanup.patch
php-zlib-for-getimagesize.patch
php.spec

index cde2b04855fbe168e1cc149a7921119d0069950d..7601cc1d321311654a16bd348a426987c7a59e4d 100644 (file)
@@ -10,9 +10,9 @@
  PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
  
  PHP_SUBST(PHP_FASTCGI_OBJS)
---- php-5.5.11/build/Makefile.global   2014-04-27 15:05:38.963814051 +0300
-+++ php-5.5.11/build/Makefile.global   2014-04-27 15:09:54.438443707 +0300
-@@ -81,8 +81,15 @@
+--- php-8.1.10/build/Makefile.global.orig      2022-09-25 19:52:15.520810107 +0200
++++ php-8.1.10/build/Makefile.global   2022-09-25 19:54:52.676625388 +0200
+@@ -81,8 +81,15 @@ install-headers:
                done; \
        fi
  
@@ -28,8 +28,8 @@
 +      fi; \
        if test "x$(PHP_MODULES)" != "x"; then \
                for i in $(PHP_MODULES)""; do \
-                       . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -111,7 +118,9 @@
+                       . $$i; \
+@@ -114,7 +121,9 @@ test: all
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \
index 0557026126306a020fcb0944a1e6942d97b34eb1..84c0fa27cbc145927497f3b5f404cbfe0a6e700a 100644 (file)
@@ -17,9 +17,9 @@
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
---- php-5.6.5/sapi/fpm/www.conf.in~    2015-02-04 19:26:16.000000000 +0200
-+++ php-5.6.5/sapi/fpm/www.conf.in     2015-02-04 19:27:25.275218535 +0200
-@@ -32,7 +32,7 @@
+--- php-8.2.0RC2/sapi/fpm/www.conf.in~ 2022-09-29 01:22:09.000000000 +0300
++++ php-8.2.0RC2/sapi/fpm/www.conf.in  2022-09-29 01:23:24.680196092 +0300
+@@ -33,7 +33,7 @@
  ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
@@ -27,8 +27,8 @@
 +listen = /var/run/php/@processname@.sock
  
  ; Set listen(2) backlog.
- ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
-@@ -46,9 +46,9 @@
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
+@@ -50,9 +50,9 @@ listen = /var/run/php/@processname@.sock
  ; and group can be specified either by name or by their numeric IDs.
  ; Default Values: Owner is set to the master process running user. If the group
  ;                 is not set, the owner's group is used. Mode is set to 0660.
  
  ; When POSIX Access Control Lists are supported you can set them using
  ; these options, value is a comma separated list of user/group names.
-@@ -53,7 +53,7 @@
+@@ -60,7 +60,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Specify the nice(2) priority to apply to the pool processes (only if set)
- ; The value can vary from -19 (highest priority) to 20 (lower priority)
+ ; Set the associated the route table (FIB). FreeBSD only
+ ; Default Value: -1
 @@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
index 156a129e7441e65ce5fddc56221c892b48524be2..f03462ab5c80e902b07ea7cca7eaec1dffea7860 100644 (file)
@@ -1,5 +1,5 @@
---- php-8.1.4/php.ini  2022-03-15 21:18:41.000000000 +0100
-+++ php-8.1.4/php.ini  2022-04-05 01:05:28.031906242 +0200
+--- php-8.2.2/php.ini  2023-01-31 14:31:55.000000000 +0100
++++ php-8.2.2/php.ini  2023-02-08 22:05:00.850660744 +0100
 @@ -82,6 +82,16 @@
  ; much more verbose when it comes to errors. We recommend using the
  ; development version only in development environments, as errors shown to
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -990,19 +942,19 @@
+@@ -996,19 +948,19 @@
  ; Use of this INI entry is deprecated, use global input_encoding instead.
  ; If empty, default_charset or input_encoding or iconv.input_encoding is used.
  ; The precedence is: default_charset < input_encoding < iconv.input_encoding
  
  [imap]
  ; rsh/ssh logins are disabled by default. Use this INI entry if you want to
-@@ -1172,6 +1124,9 @@
+@@ -1178,6 +1130,9 @@
  ; https://php.net/mysqli.default-socket
  mysqli.default_socket =
  
  ; Default host for mysqli_connect() (doesn't apply in safe mode).
  ; https://php.net/mysqli.default-host
  mysqli.default_host =
-@@ -1318,7 +1273,7 @@
+@@ -1331,7 +1286,7 @@
  
  [browscap]
  ; https://php.net/browscap
  
  [Session]
  ; Handler used to store/retrieve data.
-@@ -1741,7 +1696,7 @@
+@@ -1754,7 +1709,7 @@
  
  ; Sets the directory name where SOAP extension will put cache files.
  ; https://php.net/soap.wsdl-cache-dir
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1762,160 +1717,6 @@
+@@ -1775,160 +1730,6 @@
  [dba]
  ;dba.default_handler=
  
index 2fdf68eb6910cd45e181522d375ae22eef04d234..1c004a31a5014b8e310355b7b1730f793a549a9b 100644 (file)
@@ -1,10 +1,10 @@
---- php-7.0/ext/session/mod_files.c~   2015-05-21 17:57:06.000000000 +0300
-+++ php-7.0/ext/session/mod_files.c    2015-05-23 11:18:54.466402493 +0300
-@@ -286,7 +286,6 @@
+--- php-8.2.0RC2/ext/session/mod_files.c~      2022-09-14 12:42:49.000000000 +0300
++++ php-8.2.0RC2/ext/session/mod_files.c       2022-09-29 01:26:03.341783642 +0300
+@@ -287,7 +287,6 @@
  
-       dir = opendir(dirname);
+       dir = opendir(ZSTR_VAL(dirname));
        if (!dir) {
--              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", dirname, strerror(errno), errno);
+-              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", ZSTR_VAL(dirname), strerror(errno), errno);
                return (0);
        }
  
index 9f09b2db1deb90bb67cc6c6be5487f186e0d63b9..c09db176599f4624c1af4a597a6c5a69aae25aba 100644 (file)
@@ -2,41 +2,34 @@ make compressed .swf parsing possible,
 link core php with -lz for getimagesize()
 see also http://bugs.php.net/bug.php?id=29611
 
---- php-8.0.0rc1/ext/standard/image.c~ 2020-10-09 18:50:01.000000000 +0300
-+++ php-8.0.0rc1/ext/standard/image.c  2020-10-09 18:53:44.278879164 +0300
-@@ -31,7 +31,7 @@
+upstream: https://github.com/php/php-src/pull/4681
+
+--- php-8.2.0RC2/ext/standard/image.c~ 2022-09-14 12:42:49.000000000 +0300
++++ php-8.2.0RC2/ext/standard/image.c  2022-09-29 01:20:02.719689289 +0300
+@@ -28,7 +28,7 @@
  #endif
  #include "php_image.h"
  
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
  #include "zlib.h"
  #endif
  
-@@ -80,7 +80,7 @@
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JP2",     IMAGE_FILETYPE_JP2,     CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JPX",     IMAGE_FILETYPE_JPX,     CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JB2",     IMAGE_FILETYPE_JB2,     CONST_CS | CONST_PERSISTENT);
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
-       REGISTER_LONG_CONSTANT("IMAGETYPE_SWC",     IMAGE_FILETYPE_SWC,     CONST_CS | CONST_PERSISTENT);
- #endif
-       REGISTER_LONG_CONSTANT("IMAGETYPE_IFF",     IMAGE_FILETYPE_IFF,     CONST_CS | CONST_PERSISTENT);
-@@ -186,7 +186,7 @@
+@@ -156,7 +156,7 @@
  }
  /* }}} */
  
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
  /* {{{ php_handle_swc */
  static struct gfxinfo *php_handle_swc(php_stream * stream)
  {
-@@ -1321,7 +1321,7 @@
+@@ -1454,7 +1454,7 @@
                        result = php_handle_swf(stream);
                        break;
                case IMAGE_FILETYPE_SWC:
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
                        result = php_handle_swc(stream);
  #else
                        php_error_docref(NULL, E_NOTICE, "The image is a compressed SWF file, but you do not have a static version of the zlib extension enabled");
index 6d5bfe1546270106540a3ce332e30f7fb8c60466..e01819709be4675ce948434f8b310ab024d5b761 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname php
-%define                php_suffix 81
+%define                php_suffix 82
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -124,7 +124,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.1.15
+Version:       8.2.2
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 3c583019384355a2bf14ba42a8dd3e50
+# Source0-md5: fa93816863003f4908f638a3fd7757ac
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -257,9 +257,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20210902
-%define                zend_module_api         20210902
-%define                zend_extension_api      420210902
+%define                php_api_version         20220829
+%define                zend_module_api         20220829
+%define                zend_extension_api      420220829
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -271,7 +271,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.5
+%define                zipver          1.21.1
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}