]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- fixed removing alternatives on uninstall
authorMarcin Krol <hawk@tld-linux.org>
Wed, 22 Aug 2018 12:05:15 +0000 (12:05 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 22 Aug 2018 12:05:15 +0000 (12:05 +0000)
php.spec

index b5e435e3ab320c6167509fc98cfdda8a81b50a35..14e6085a0b955109b9fe390bb50158eca3afa2cf 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -149,7 +149,7 @@ Summary(ru.UTF-8):  PHP Версии 5 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       5.6.37
-Release:       1
+Release:       2
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -2748,7 +2748,7 @@ update-alternatives \
 
 %postun cli
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove php %{_bindir}/php || :
+       update-alternatives --remove php %{_bindir}/php%{php_suffix} || :
 fi
 
 %post  common -p /sbin/ldconfig
@@ -2764,8 +2764,8 @@ update-alternatives \
 
 %postun devel
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phpize %{_bindir}/phpize || :
-       update-alternatives --remove php-config %{_bindir}/php-config || :
+       update-alternatives --remove phpize %{_bindir}/phpize%{php_suffix} || :
+       update-alternatives --remove php-config %{_bindir}/php-config%{php_suffix} || :
 fi
 
 %pre fpm
@@ -2780,7 +2780,7 @@ update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_s
 if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
-       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
+       update-alternatives --remove php-fpm %{_sbindir}/php%{php_suffix}-fpm || :
 fi
 
 %postun fpm
@@ -2946,7 +2946,7 @@ update-alternatives \
 %postun phar
 %ext_postun
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phar %{_bindir}/phar || :
+       update-alternatives --remove phar %{_bindir}/phar%{php_suffix}.phar || :
 fi
 
 %if %{with apache2}