]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- missed in previous commit
authorMarcin Krol <hawk@tld-linux.org>
Wed, 13 Jan 2016 14:01:53 +0000 (14:01 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 13 Jan 2016 14:01:53 +0000 (14:01 +0000)
libdb-info.patch [new file with mode: 0644]
phar-hash-shared.patch [new file with mode: 0644]
php-mysql-ssl-context.patch [new file with mode: 0644]

diff --git a/libdb-info.patch b/libdb-info.patch
new file mode 100644 (file)
index 0000000..ee25732
--- /dev/null
@@ -0,0 +1,24 @@
+--- php-7.0.0beta1/ext/dba/dba.c.libdb 2015-07-08 02:24:59.119020904 +0200
++++ php-7.0.0beta1/ext/dba/dba.c       2015-07-08 07:01:43.158767655 +0200
+@@ -52,6 +52,10 @@
+ #include "php_qdbm.h"
+ #include "php_tcadb.h"
++#ifdef DB4_INCLUDE_FILE
++#include DB4_INCLUDE_FILE
++#endif
++
+ /* {{{ arginfo */
+ ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
+       ZEND_ARG_INFO(0, path)
+@@ -545,6 +549,10 @@ PHP_MINFO_FUNCTION(dba)
+       php_info_print_table_start();
+       php_info_print_table_row(2, "DBA support", "enabled");
++#ifdef DB_VERSION_STRING
++      php_info_print_table_row(2, "libdb header version", DB_VERSION_STRING);
++      php_info_print_table_row(2, "libdb library version", db_version(NULL, NULL, NULL));
++#endif
+       if (handlers.s) {
+               smart_str_0(&handlers);
+               php_info_print_table_row(2, "Supported handlers", ZSTR_VAL(handlers.s));
diff --git a/phar-hash-shared.patch b/phar-hash-shared.patch
new file mode 100644 (file)
index 0000000..621fe6d
--- /dev/null
@@ -0,0 +1,33 @@
+--- php-7.0.0RC6/ext/phar/config.m4    2015-11-17 19:13:50.877662712 +0200
++++ php-7.0.0RC6/ext/phar/config.m4    2015-11-20 12:51:24.088185045 +0200
+@@ -7,13 +7,13 @@
+ if test "$PHP_PHAR" != "no"; then
+   PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
+   AC_MSG_CHECKING([for phar openssl support])
+-  if test "$PHP_HASH_SHARED" != "yes"; then
+-    if test "$PHP_HASH" != "no"; then
++dnl  if test "$PHP_HASH_SHARED" != "yes"; then
++dnl    if test "$PHP_HASH" != "no"; then
+       AC_DEFINE(PHAR_HASH_OK,1,[ ])
+-    fi
+-  else
+-    AC_MSG_WARN([Phar: sha256/sha512 signature support disabled if ext/hash is built shared])
+-  fi
++dnl    fi
++dnl  else
++dnl    AC_MSG_WARN([Phar: sha256/sha512 signature support disabled if ext/hash is built shared])
++dnl  fi
+   if test "$PHP_OPENSSL_SHARED" = "yes"; then
+     AC_MSG_RESULT([no (shared openssl)])
+   else
+--- php-7.0.0RC7/ext/phar/Makefile.frag~       2015-11-23 11:06:31.000000000 +0200
++++ php-7.0.0RC7/ext/phar/Makefile.frag        2015-11-23 11:15:36.452443959 +0200
+@@ -9,7 +9,7 @@
+               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
+               if test "x$(PHP_MODULES)" != "x"; then \
+               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
+-              for i in pcre spl bz2 zlib phar; do \
++              for i in pcre spl bz2 zlib hash phar; do \
+                       if test -f "$(top_builddir)/modules/$$i.la"; then \
+                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
+                       fi; \
diff --git a/php-mysql-ssl-context.patch b/php-mysql-ssl-context.patch
new file mode 100644 (file)
index 0000000..c8ff48d
--- /dev/null
@@ -0,0 +1,36 @@
+; obey default context options
+; https://bugs.php.net/bug.php?id=68344
+diff -urbB php-5.6.12/ext/mysqlnd/mysqlnd_net.c php-5.6.12/ext/mysqlnd/mysqlnd_net.c
+--- php-5.6.12/ext/mysqlnd/mysqlnd_net.c       2015-08-06 09:55:57.000000000 +0200
++++ php-5.6.12/ext/mysqlnd/mysqlnd_net.c       2015-08-10 13:25:30.187912101 +0200
+@@ -29,6 +29,7 @@
+ #include "mysqlnd_ext_plugin.h"
+ #include "php_network.h"
+ #include "zend_ini.h"
++#include "ext/standard/file.h"
+ #ifdef MYSQLND_COMPRESSION_ENABLED
+ #include <zlib.h>
+ #endif
+@@ -868,6 +868,21 @@ MYSQLND_METHOD(mysqlnd_net, enable_ssl)(
+               DBG_RETURN(FAIL);
+       }
++      if (FG(default_context)) {
++              zval **tmpzval = NULL;
++              int i = 0;
++              /* copy values from default stream settings */
++              char *opts[] = { "allow_self_signed", "cafile", "capath", "ciphers", "CN_match",
++                      "disable_compression", "local_cert", "local_pk", "no_ticket", "passphrase",
++                      "peer_fingerprint", "peer_name", "SNI_enabled", "SNI_server_certs", "SNI_server_name",
++                      "verify_depth", "verify_peer", "verify_peer_name", NULL };
++              while (opts[i]) {
++                      if (php_stream_context_get_option(FG(default_context), "ssl", opts[i], &tmpzval) == SUCCESS)
++                              php_stream_context_set_option(context, "ssl", opts[i], *tmpzval);
++                      i++;
++              }
++      }
++
+       if (net->data->options.ssl_key) {
+               zval key_zval;
+               ZVAL_STRING(&key_zval, net->data->options.ssl_key, 0);
+