]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- PHP 5.5.10
authorBartosz Świątek <shadzik@tld-linux.org>
Tue, 1 Apr 2014 10:30:36 +0000 (12:30 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Tue, 1 Apr 2014 10:30:36 +0000 (12:30 +0200)
php-mail.patch
php-sapi-ini-file.patch
php.spec

index 5a7919734df34618cccb41b7a4922e7c2b11f78c..e541727105ef89fb0a03b1483f49aba355b89770 100644 (file)
@@ -42,7 +42,7 @@
 +              if ((subject != NULL) && (strlen(subject)!=0)) {
 +                      fprintf(sendmail, "Subject: %s\n", subject);
 +              }
-+
++              zend_is_auto_global(ZEND_STRL("_SERVER") TSRMLS_CC);
 +              if (PG(http_globals)[TRACK_VARS_SERVER]) {
 +                      zval **remote_addr, **server_name, **server_port,
 +                              **script_name, **http_user_agent;
index 7ceb984e8d3874d22d2822564162237e2cc20360..140d46cb82b1d92e6fce516e29828643f5ca8619 100644 (file)
        }
  
        if (free_ini_search_path) {
-@@ -627,12 +627,14 @@
+@@ -645,13 +645,15 @@ int php_init_config(TSRMLS_D)
                zend_llist scanned_ini_list;
                zend_llist_element *element;
                int l, total_l = 0;
 +              const char *fmt = "%s:" PHP_CONFIG_FILE_PATH "/%s.d";
+               char *bufpath, *debpath, *endpath;
+               int lenpath;
  
-               /* List of found ini files */
                zend_llist_init(&scanned_ini_list, sizeof(char *), (llist_dtor_func_t) free_estring, 1);
+               memset(&fh2, 0, sizeof(fh2));
  
-               /* Split by paths_separator and load ini-files from all paths */
--              path_copy = estrdup(php_ini_scanned_path);
-+              path_copy = emalloc(strlen(php_ini_scanned_path) + strlen(fmt) + strlen(sapi_module.name));
-+              sprintf(path_copy, fmt, php_ini_scanned_path, sapi_module.name);
-               ini_path  = php_strtok_r(path_copy, paths_separator, &last);
-               while (ini_path != NULL) {
-@@ -636,7 +653,7 @@
-                       struct dirent **namelist;
-                       int ini_path_len = strlen(ini_path);
+-              bufpath = estrdup(php_ini_scanned_path);
++              bufpath = emalloc(strlen(php_ini_scanned_path) + strlen(fmt) + strlen(sapi_module.name));
++              sprintf(bufpath, fmt, php_ini_scanned_path, sapi_module.name);
+               for (debpath = bufpath ; debpath ; debpath=endpath) {
+                       endpath = strchr(debpath, DEFAULT_DIR_SEPARATOR);
+                       if (endpath) {
+@@ -664,7 +666,7 @@ int php_init_config(TSRMLS_D)
+                       }
+                       lenpath = strlen(debpath);
  
--                      if ((ndir = php_scandir(ini_path, &namelist, 0, php_alphasort)) > 0) {
-+                      if ((ndir = php_scandir(ini_path, &namelist, 0, php_csort)) > 0) {
-                               memset(&fh2, 0, sizeof(fh2));
+-                      if (lenpath > 0 && (ndir = php_scandir(debpath, &namelist, 0, php_alphasort)) > 0) {
++                      if (lenpath > 0 && (ndir = php_scandir(debpath, &namelist, 0, php_csort)) > 0) {
  
                                for (i = 0; i < ndir; i++) {
index 37689162576ae2bb17b501b314aa37279e1ad768..e19da42406a699cda5148e30c1a13f281fe932c3 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -139,13 +139,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.5.9
+Version:       5.5.10
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: c4a348a07b52f6e177d8fdc75fe507b1
+# Source0-md5: d608230c7890b6a0cc5b92e66e866226
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -165,7 +165,6 @@ Patch4:             %{orgname}-libpq_fs_h_path.patch
 Patch5:                %{orgname}-filter-shared.patch
 Patch6:                %{orgname}-build_modules.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch8:                %{orgname}-config-file-scan-dir.patch
 Patch9:                %{orgname}-sh.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
@@ -311,7 +310,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # Extension versions
 %define                bz2ver          1.0
 %define                enchantver      1.1.0
-%define                fileinfover     1.0.5-dev
+%define                fileinfover     1.0.5
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
@@ -1873,7 +1872,6 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch8 -p1
 %patch7 -p1
 %patch9 -p1
 cp -p php.ini-production php.ini