]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- TLDized
authorMarcin Krol <hawk@tld-linux.org>
Mon, 15 Sep 2014 08:27:16 +0000 (08:27 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 15 Sep 2014 08:27:16 +0000 (08:27 +0000)
php.spec

index e314584c353894e808ef4308047874bfb6b63860..dbc89eb675571b5ddba559dce066e305b84730c7 100644 (file)
--- a/php.spec
+++ b/php.spec
 # standard
 #
 # Conditional build:
+%bcond_without default_php     # use this PHP as default PHP in distro
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci             # with Oracle oci8 extension module     (BR: proprietary libs)
-%bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
+%bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
 %bcond_with    system_gd       # with system gd (imageantialias function is missing then)
 %bcond_with    system_libzip   # with system libzip (reported broken currently)
-%bcond_with    default_php     # use this PHP as default PHP in distro
 %bcond_without curl            # without CURL extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without filter          # without filter extension module
@@ -135,7 +135,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     0.1
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,7 +165,7 @@ Source12:   %{orgname}-branch.sh
 Source13:      dep-tests.sh
 Source14:      skip-tests.sh
 Patch0:                %{orgname}-shared.patch
-Patch1:                %{orgname}-pldlogo.patch
+Patch1:                %{orgname}-tld.patch
 Patch2:                %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                %{orgname}-libpq_fs_h_path.patch
@@ -252,11 +252,7 @@ BuildRequires:     libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
 %{?with_webp:BuildRequires:    libvpx-devel}
 BuildRequires: tokyocabinet-devel
-%if "%{pld_release}" != "ac"
 BuildRequires: libtool >= 2:2.2
-%else
-BuildRequires: libtool >= 1.4.3
-%endif
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -447,9 +443,7 @@ Provides:   php(fcgi)
 Provides:      webserver(php) = %{version}
 Obsoletes:     php-cgi < 4:5.3.28-7
 Obsoletes:     php-fcgi < 4:5.3.0
-%if "%{pld_release}" != "ac"
 Conflicts:     logrotate < 3.8.0
-%endif
 
 %description cgi
 PHP as CGI or FastCGI program.
@@ -462,6 +456,7 @@ Summary:    PHP as CLI interpreter
 Summary(pl.UTF-8):     PHP jako interpreter działający z linii poleceń
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php-program
 Obsoletes:     php-cli < 4:5.3.28-7
 
 %description cli
@@ -485,20 +480,6 @@ applications to provide PHP scripting language support.
 Ten pakiet zawiera bibliotekę, którą można osadzać w aplikacjach w
 celu obsługi PHP jako języka skryptowego.
 
-%package program
-Summary:       /usr/bin/php symlink
-Summary(pl.UTF-8):     Dowiązanie symboliczne /usr/bin/php
-Group:         Development/Languages/PHP
-Requires:      %{name}-cli = %{epoch}:%{version}-%{release}
-Obsoletes:     /usr/bin/php
-Obsoletes:     php-program < 4:5.3.28-7
-
-%description program
-Package providing /usr/bin/php symlink to PHP CLI.
-
-%description program -l pl.UTF-8
-Pakiet dostarczający dowiązanie symboliczne /usr/bin/php do PHP CLI.
-
 %package fpm
 Summary:       PHP FastCGI Process Manager
 Summary(pl.UTF-8):     PHP FastCGI Process Manager - zarządca procesów FastCGI
@@ -597,11 +578,7 @@ Group:             Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      autoconf >= 2.13
 Requires:      automake
-%if "%{pld_release}" != "ac"
 Requires:      libtool >= 2:2.2
-%else
-Requires:      libtool
-%endif
 %{?with_pcre:Requires: pcre-devel >= 8.10}
 Requires:      shtool
 Provides:      php-devel = %{epoch}:%{version}-%{release}
@@ -611,6 +588,7 @@ Obsoletes:  php4-devel
 Obsoletes:     php52-devel
 Obsoletes:     php53-devel
 Obsoletes:     php54-devel
+Obsoletes:     php55-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2023,9 +2001,7 @@ cp -p php.ini-production php.ini
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-%if "%{pld_release}" != "ac"
 %patch34 -p1
-%endif
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
@@ -2629,9 +2605,6 @@ install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
-%if "%{pld_release}" == "ac"
-%{__sed} -i -e '/su/d' $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
-%endif
 
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
@@ -2690,16 +2663,11 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/{cgi-fcgi,cli,apache,apache2handler}.d
 mv $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/readline.ini,cli.d}
 
 # use system automake and {lib,sh}tool
-%if "%{pld_release}" != "ac"
        ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
        for i in libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4; do
                ln -snf %{_aclocaldir}/${i} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
        done
        ln -snf %{_datadir}/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/%{name}/build
-%else
-       ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/%{name}/build
-       ln -snf %{_datadir}/libtool/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/%{name}/build
-%endif
 ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/%{name}/build
 sed -i -e '/^phpdir/ s,/php/build,/%{name}/build,' $RPM_BUILD_ROOT%{_bindir}/phpize
 
@@ -2937,11 +2905,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cli.ini
 %attr(755,root,root) %{_bindir}/php%{ver_suffix}
 %{_mandir}/man1/php%{ver_suffix}.1*
-
-%files program
-%defattr(644,root,root,755)
+%if %{with default_php}
 %attr(755,root,root) %{_bindir}/php
+%attr(755,root,root) %{_bindir}/php.cli
 %{_mandir}/man1/php.1*
+%endif
 
 %if %{with fpm}
 %files fpm