]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- php 5.4.18
authorBartosz Świątek <shadzik@tld-linux.org>
Mon, 19 Aug 2013 10:45:16 +0000 (12:45 +0200)
committerBartosz Świątek <shadzik@tld-linux.org>
Mon, 19 Aug 2013 10:45:16 +0000 (12:45 +0200)
php-fileinfo.patch
php-sh.patch
php-sqlite3.patch
php.spec

index cc4dbe8b56b72abac875a49adfc4daf0a173c350..521ed4acf2859b78ab7862c57e852ca8e273d87c 100644 (file)
@@ -1,27 +1,3 @@
-diff -urNp php-5.4.17.orig/ext/fileinfo/libmagic/print.c php-5.4.17/ext/fileinfo/libmagic/print.c
---- php-5.4.17.orig/ext/fileinfo/libmagic/print.c      2013-07-03 06:10:53.000000000 +0000
-+++ php-5.4.17/ext/fileinfo/libmagic/print.c   2013-07-18 14:37:33.000000000 +0000
-@@ -28,7 +28,6 @@
- /*
-  * print.c - debugging printout routines
-  */
--
- #define _GNU_SOURCE
- #include "php.h"
-diff -urNp php-5.4.17.orig/ext/fileinfo/libmagic/softmagic.c php-5.4.17/ext/fileinfo/libmagic/softmagic.c
---- php-5.4.17.orig/ext/fileinfo/libmagic/softmagic.c  2013-07-03 06:10:53.000000000 +0000
-+++ php-5.4.17/ext/fileinfo/libmagic/softmagic.c       2013-07-18 14:37:33.000000000 +0000
-@@ -1630,7 +1630,7 @@ mget(struct magic_set *ms, const unsigne
-       /* Verify we have enough data to match magic type */
-       switch (m->type) {
-       case FILE_BYTE:
--              if (nbytes < (offset + 1)) /* should alway be true */
-+              if (nbytes < (offset + 1)) /* should always be true */
-                       return 0;
-               break;
-diff -urNp php-5.4.17.orig/ext/fileinfo/php_fileinfo.h php-5.4.17/ext/fileinfo/php_fileinfo.h
 --- php-5.4.17.orig/ext/fileinfo/php_fileinfo.h        2013-07-03 06:10:53.000000000 +0000
 +++ php-5.4.17/ext/fileinfo/php_fileinfo.h     2013-07-18 14:37:33.000000000 +0000
 @@ -24,7 +24,7 @@
@@ -33,15 +9,3 @@ diff -urNp php-5.4.17.orig/ext/fileinfo/php_fileinfo.h php-5.4.17/ext/fileinfo/p
  
  #ifdef PHP_WIN32
  #define PHP_FILEINFO_API __declspec(dllexport)
-diff -urNp php-5.4.17.orig/ext/fileinfo/tests/magic php-5.4.17/ext/fileinfo/tests/magic
---- php-5.4.17.orig/ext/fileinfo/tests/magic   2013-07-03 06:10:53.000000000 +0000
-+++ php-5.4.17/ext/fileinfo/tests/magic        2013-07-18 14:37:33.000000000 +0000
-@@ -3303,7 +3303,7 @@
- >>>0x44               string  =GLOB           \b.
- >>>>0x60      beshort x               \b%.4d
--# Scripts that run in the embeded Python interpreter
-+# Scripts that run in the embedded Python interpreter
- 0             string  #!BPY           Blender3D BPython script
- #------------------------------------------------------------------------------
index e2c67702bd791f0c17fccf36d1f770333ce0ebf0..848646ff57ec8e786f0bc3f4cdb74e4cf11571e0 100644 (file)
@@ -1,11 +1,11 @@
---- php-5.1.6/acinclude.m4.orig        2006-11-21 10:43:13.179505000 +0100
-+++ php-5.1.6/acinclude.m4     2006-11-21 10:55:32.479505000 +0100
+--- php-5.4.18/acinclude.m4.orig       2013-08-19 12:29:32.000000000 +0200
++++ php-5.4.18/acinclude.m4    2013-08-19 12:32:44.403972349 +0200
 @@ -68,8 +68,8 @@
      changequote({,})
-     ep_dir="`echo $1|$SED 's%/*[^/][^/]*/*$%%'`"
+     ep_dir=`echo $1|$SED 's%/*[^/][^/]*/*$%%'`
      changequote([,])
--    ep_realdir="`(cd \"$ep_dir\" && pwd)`"
--    $2="$ep_realdir/`basename \"$1\"`"
+-    ep_realdir=`(cd "$ep_dir" && pwd)`
+-    $2="$ep_realdir"/`basename "$1"`
 +    ep_realdir="$(cd "$ep_dir" && pwd)"
 +    $2="$ep_realdir/$(basename "$1")"
    fi
index 88752ed3e9fa62e9c8a2ab301fa7f9d3d64598f5..c933db7e1dd4e435dc77d5303cf9539f29fe5f55 100644 (file)
@@ -1,24 +1,6 @@
 diff -urNp php-5.4.17.orig/ext/sqlite3/libsqlite/sqlite3.c php-5.4.17/ext/sqlite3/libsqlite/sqlite3.c
 --- php-5.4.17.orig/ext/sqlite3/libsqlite/sqlite3.c    2013-07-03 06:10:53.000000000 +0000
 +++ php-5.4.17/ext/sqlite3/libsqlite/sqlite3.c 2013-07-18 14:37:33.000000000 +0000
-@@ -11864,7 +11864,7 @@ SQLITE_PRIVATE   int sqlite3MemdebugNoTy
- **
- *************************************************************************
- **
--** This file contains definitions of global variables and contants.
-+** This file contains definitions of global variables and constants.
- */
- /* An array to map all upper-case characters into their corresponding
-@@ -16130,7 +16130,7 @@ SQLITE_PRIVATE const sqlite3_mem_methods
- **   1.  All memory allocations sizes are rounded up to a power of 2.
- **
- **   2.  If two adjacent free blocks are the halves of a larger block,
--**       then the two blocks are coalesed into the single larger block.
-+**       then the two blocks are coalesced into the single larger block.
- **
- **   3.  New memory is allocated from the first available free block.
- **
 @@ -18139,7 +18139,7 @@ SQLITE_API sqlite3_int64 sqlite3_soft_he
    sqlite3_int64 priorLimit;
    sqlite3_int64 excess;
@@ -28,121 +10,6 @@ diff -urNp php-5.4.17.orig/ext/sqlite3/libsqlite/sqlite3.c php-5.4.17/ext/sqlite
  #endif
    sqlite3_mutex_enter(mem0.mutex);
    priorLimit = mem0.alarmThreshold;
-@@ -20926,7 +20926,7 @@ do_atof_calc:
-   /* store the result */
-   *pResult = result;
--  /* return true if number and no extra non-whitespace chracters after */
-+  /* return true if number and no extra non-whitespace characters after */
-   return z>=zEnd && nDigits>0 && eValid;
- #else
-   return !sqlite3Atoi64(z, pResult, length, enc);
-@@ -30074,7 +30074,7 @@ static int unixGetLastError(sqlite3_vfs
- ** setting the environment variable SQLITE_FORCE_PROXY_LOCKING to 1 will
- ** force proxy locking to be used for every database file opened, and 0
- ** will force automatic proxy locking to be disabled for all database
--** files (explicity calling the SQLITE_SET_LOCKPROXYFILE pragma or
-+** files (explicitly calling the SQLITE_SET_LOCKPROXYFILE pragma or
- ** sqlite_file_control API is not affected by SQLITE_FORCE_PROXY_LOCKING).
- */
-@@ -69899,7 +69899,7 @@ SQLITE_PRIVATE int sqlite3MemJournalSize
- /*
- ** Walk an expression tree.  Invoke the callback once for each node
--** of the expression, while decending.  (In other words, the callback
-+** of the expression, while descending.  (In other words, the callback
- ** is invoked before visiting children.)
- **
- ** The return value from the callback should be one of the WRC_*
-@@ -70936,7 +70936,7 @@ static int resolveOrderGroupBy(
- }
- /*
--** Resolve names in the SELECT statement p and all of its descendents.
-+** Resolve names in the SELECT statement p and all of its descendants.
- */
- static int resolveSelectStep(Walker *pWalker, Select *p){
-   NameContext *pOuterNC;  /* Context that contains this SELECT */
-@@ -71244,7 +71244,7 @@ SQLITE_PRIVATE void sqlite3ResolveSelect
- ** affinity of that column is returned. Otherwise, 0x00 is returned,
- ** indicating no affinity for the expression.
- **
--** i.e. the WHERE clause expresssions in the following statements all
-+** i.e. the WHERE clause expressions in the following statements all
- ** have an affinity:
- **
- ** CREATE TABLE t1(a);
-@@ -74260,13 +74260,13 @@ static int evalConstExpr(Walker *pWalker
- /*
- ** Preevaluate constant subexpressions within pExpr and store the
--** results in registers.  Modify pExpr so that the constant subexpresions
-+** results in registers.  Modify pExpr so that the constant subexpressions
- ** are TK_REGISTER opcodes that refer to the precomputed values.
- **
- ** This routine is a no-op if the jump to the cookie-check code has
- ** already occur.  Since the cookie-check jump is generated prior to
- ** any other serious processing, this check ensures that there is no
--** way to accidently bypass the constant initializations.
-+** way to accidentally bypass the constant initializations.
- **
- ** This routine is also a no-op if the SQLITE_FactorOutConst optimization
- ** is disabled via the sqlite3_test_control(SQLITE_TESTCTRL_OPTIMIZATIONS)
-@@ -75132,7 +75132,7 @@ static void renameParentFunc(
- ** ALTER TABLE command. The first argument is the text of a CREATE TRIGGER 
- ** statement. The second is a table name. The table name in the CREATE 
- ** TRIGGER statement is replaced with the third argument and the result 
--** returned. This is analagous to renameTableFunc() above, except for CREATE
-+** returned. This is analogous to renameTableFunc() above, except for CREATE
- ** TRIGGER, not CREATE INDEX and CREATE TABLE.
- */
- static void renameTriggerFunc(
-@@ -86752,7 +86752,7 @@ static int xferOptimization(
-   }
- #endif
- #ifndef SQLITE_OMIT_FOREIGN_KEY
--  /* Disallow the transfer optimization if the destination table constains
-+  /* Disallow the transfer optimization if the destination table constrains
-   ** any foreign key constraints.  This is more restrictive than necessary.
-   ** But the main beneficiary of the transfer optimization is the VACUUM 
-   ** command, and the VACUUM command disables foreign key constraints.  So
-@@ -93175,7 +93175,7 @@ static int flattenSubquery(
-   pSubSrc = pSub->pSrc;
-   assert( pSubSrc );
-   /* Prior to version 3.1.2, when LIMIT and OFFSET had to be simple constants,
--  ** not arbitrary expresssions, we allowed some combining of LIMIT and OFFSET
-+  ** not arbitrary expressions, we allowed some combining of LIMIT and OFFSET
-   ** because they could be computed at compile-time.  But when LIMIT and OFFSET
-   ** became arbitrary expressions, we were forced to add restrictions (13)
-   ** and (14). */
-@@ -94472,7 +94472,7 @@ SQLITE_PRIVATE int sqlite3Select(
-     */
-     if( pGroupBy ){
-       KeyInfo *pKeyInfo;  /* Keying information for the group by clause */
--      int j1;             /* A-vs-B comparision jump */
-+      int j1;             /* A-vs-B comparison jump */
-       int addrOutputRow;  /* Start of subroutine that outputs a result row */
-       int regOutputRow;   /* Return address register for output subroutine */
-       int addrSetAbort;   /* Set the abort flag and return */
-@@ -118508,7 +118508,7 @@ static int star_oh(const char *z){
- /*
- ** If the word ends with zFrom and xCond() is true for the stem
--** of the word that preceds the zFrom ending, then change the 
-+** of the word that precede the zFrom ending, then change the 
- ** ending to zTo.
- **
- ** The input word *pz and zFrom are both in reverse order.  zTo
-@@ -127688,7 +127688,7 @@ SQLITE_API int sqlite3_extension_init(
- **   * Implementations of the SQL scalar upper() and lower() functions
- **     for case mapping.
- **
--**   * Integration of ICU and SQLite collation seqences.
-+**   * Integration of ICU and SQLite collation sequences.
- **
- **   * An implementation of the LIKE operator that uses ICU to 
- **     provide case-independent matching.
 diff -urNp php-5.4.17.orig/ext/sqlite3/php_sqlite3.h php-5.4.17/ext/sqlite3/php_sqlite3.h
 --- php-5.4.17.orig/ext/sqlite3/php_sqlite3.h  2013-07-03 06:10:53.000000000 +0000
 +++ php-5.4.17/ext/sqlite3/php_sqlite3.h       2013-07-18 14:37:33.000000000 +0000
@@ -155,25 +22,3 @@ diff -urNp php-5.4.17.orig/ext/sqlite3/php_sqlite3.h php-5.4.17/ext/sqlite3/php_
  
  extern zend_module_entry sqlite3_module_entry;
  #define phpext_sqlite3_ptr &sqlite3_module_entry
-diff -urNp php-5.4.17.orig/ext/sqlite3/php_sqlite3_structs.h php-5.4.17/ext/sqlite3/php_sqlite3_structs.h
---- php-5.4.17.orig/ext/sqlite3/php_sqlite3_structs.h  2013-07-03 06:10:53.000000000 +0000
-+++ php-5.4.17/ext/sqlite3/php_sqlite3_structs.h       2013-07-18 14:37:33.000000000 +0000
-@@ -23,7 +23,7 @@
- #include <sqlite3.h>
--/* for backwards compatability reasons */
-+/* for backwards compatibility reasons */
- #ifndef SQLITE_OPEN_READONLY
- #define SQLITE_OPEN_READONLY 0x00000001
- #endif
-diff -urNp php-5.4.17.orig/ext/sqlite3/tests/bug53463.phpt php-5.4.17/ext/sqlite3/tests/bug53463.phpt
---- php-5.4.17.orig/ext/sqlite3/tests/bug53463.phpt    2013-07-03 06:10:53.000000000 +0000
-+++ php-5.4.17/ext/sqlite3/tests/bug53463.phpt 2013-07-18 14:37:33.000000000 +0000
-@@ -27,4 +27,4 @@ echo "Done\n";
- --EXPECT--
- string(8) "whatever"
- bool(false)
--Done
-+Done
-\ No newline at end of file
index 7c3392351cd7e51d55ebceeec1bdc7dbf5757370..c94458a61f28475546ac10312b7d831570a2de10 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -124,7 +124,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     2
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -135,13 +135,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.4.17
+Version:       5.4.18
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: 1e027e99e2a874310fd518e87e3947af
+# Source0-md5: b2e185b46b22a48a385cf21a0dc76e65
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini