]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 7.2.25
authorMarcin Krol <hawk@tld-linux.org>
Thu, 12 Dec 2019 22:57:52 +0000 (23:57 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 12 Dec 2019 22:57:52 +0000 (23:57 +0100)
pcre-shared.patch
php.spec

index 8bb03e442f1ca8fa7b4b946a4ac5661c7038a67f..c8b340aefebca88d214658e765614099b128a3b6 100644 (file)
@@ -1,6 +1,7 @@
---- php-7.2.0RC4/ext/pcre/config0.m4~  2017-10-15 16:17:20.000000000 +0300
-+++ php-7.2.0RC4/ext/pcre/config0.m4   2017-10-15 18:34:27.673725678 +0300
-@@ -11,7 +11,7 @@
+diff -urN php-7.2.25.orig/ext/pcre/config0.m4 php-7.2.25/ext/pcre/config0.m4
+--- php-7.2.25.orig/ext/pcre/config0.m4        2019-12-12 23:55:51.061000000 +0100
++++ php-7.2.25/ext/pcre/config0.m4     2019-12-12 23:56:02.320000000 +0100
+@@ -13,7 +13,7 @@
  
    if test "$PHP_PCRE_REGEX" != "yes" && test "$PHP_PCRE_REGEX" != "no"; then
      AC_MSG_CHECKING([for PCRE headers location])
@@ -9,7 +10,7 @@
        test -f $i/pcre.h && PCRE_INCDIR=$i
      done
  
-@@ -21,7 +21,7 @@
+@@ -23,7 +23,7 @@
      AC_MSG_RESULT([$PCRE_INCDIR])
  
      AC_MSG_CHECKING([for PCRE library location])
@@ -17,7 +18,7 @@
 +    for j in $PHP_PCRE_REGEX $PHP_PCRE_REGEX/$PHP_LIBDIR /usr/$PHP_LIBDIR; do
        test -f $j/libpcre.a || test -f $j/libpcre.$SHLIB_SUFFIX_NAME && PCRE_LIBDIR=$j
      done
-     
 @@ -52,12 +52,13 @@
      ],[
        -L$PCRE_LIBDIR
@@ -34,7 +35,7 @@
    else
      AC_MSG_CHECKING([for PCRE library to use])
      AC_MSG_RESULT([bundled])
-@@ -61,7 +62,7 @@
+@@ -70,7 +71,7 @@
                                 pcrelib/pcre_version.c pcrelib/pcre_xclass.c \
                                 pcrelib/pcre_jit_compile.c"
      PHP_PCRE_CFLAGS="-DHAVE_CONFIG_H -I@ext_srcdir@/pcrelib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1"
      PHP_ADD_BUILD_DIR($ext_builddir/pcrelib)
      PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h pcrelib/])
      AC_DEFINE(HAVE_BUNDLED_PCRE, 1, [ ])
---- php-7.2.0beta1/ext/pcre/php_pcre.h 2017-07-22 12:35:11.071146616 +0300
-+++ php-7.2.0beta1/ext/pcre/php_pcre.h 2017-07-22 12:41:01.858859537 +0300
+diff -urN php-7.2.25.orig/ext/pcre/php_pcre.c php-7.2.25/ext/pcre/php_pcre.c
+--- php-7.2.25.orig/ext/pcre/php_pcre.c        2019-12-12 23:55:51.061000000 +0100
++++ php-7.2.25/ext/pcre/php_pcre.c     2019-12-12 23:56:02.320000000 +0100
+@@ -21,6 +21,9 @@
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_globals.h"
++#if COMPILE_DL_PCRE
++#define COMPILE_DL_PCRE_NOREDIRECT
++#endif
+ #include "php_pcre.h"
+ #include "ext/standard/info.h"
+ #include "ext/standard/basic_functions.h"
+@@ -222,6 +225,14 @@
+       REGISTER_LONG_CONSTANT("PREG_JIT_STACKLIMIT_ERROR", PHP_PCRE_JIT_STACKLIMIT_ERROR, CONST_CS | CONST_PERSISTENT);
+       REGISTER_STRING_CONSTANT("PCRE_VERSION", (char *)pcre_version(), CONST_CS | CONST_PERSISTENT);
++#if COMPILE_DL_PCRE
++      pcre_get_compiled_regex_p = pcre_get_compiled_regex;
++      pcre_get_compiled_regex_cache_p = pcre_get_compiled_regex_cache;
++      php_pcre_replace_impl_p = php_pcre_replace_impl;
++      php_pcre_match_impl_p = php_pcre_match_impl;
++      php_pcre_split_impl_p = php_pcre_split_impl;
++#endif
++
+       return SUCCESS;
+ }
+ /* }}} */
+diff -urN php-7.2.25.orig/ext/pcre/php_pcre.h php-7.2.25/ext/pcre/php_pcre.h
+--- php-7.2.25.orig/ext/pcre/php_pcre.h        2019-12-12 23:55:51.061000000 +0100
++++ php-7.2.25/ext/pcre/php_pcre.h     2019-12-12 23:56:56.743000000 +0100
 @@ -33,7 +33,29 @@
  #include <locale.h>
  #endif
  PHPAPI pcre* pcre_get_compiled_regex(zend_string *regex, pcre_extra **extra, int *options);
  PHPAPI pcre* pcre_get_compiled_regex_ex(zend_string *regex, pcre_extra **extra, int *preg_options, int *coptions);
  
-@@ -56,14 +78,18 @@
+@@ -56,15 +78,19 @@
        int refcount;
  } pcre_cache_entry;
  
 +PCRE_EXTERN
  PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache(zend_string *regex);
+ PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache_ex(zend_string *regex, int locale_aware);
  
 +PCRE_EXTERN
  PHPAPI void  php_pcre_match_impl(  pcre_cache_entry *pce, char *subject, int subject_len, zval *return_value,
  PHPAPI void  php_pcre_split_impl(  pcre_cache_entry *pce, zend_string *subject_str, zval *return_value,
        zend_long limit_val, zend_long flags);
  
---- php-5.3.1.pcre/ext/pcre/php_pcre.c 2009-11-30 21:38:01.759684456 +0000
-+++ php-7.2.0beta1/ext/pcre/php_pcre.c 2017-07-22 12:42:57.878062137 +0300
-@@ -21,6 +21,9 @@
- #include "php.h"
- #include "php_ini.h"
- #include "php_globals.h"
-+#if COMPILE_DL_PCRE
-+#define COMPILE_DL_PCRE_NOREDIRECT
-+#endif
- #include "php_pcre.h"
- #include "ext/standard/info.h"
- #include "ext/standard/basic_functions.h"
-@@ -208,6 +211,14 @@
-       REGISTER_LONG_CONSTANT("PREG_JIT_STACKLIMIT_ERROR", PHP_PCRE_JIT_STACKLIMIT_ERROR, CONST_CS | CONST_PERSISTENT);
-       REGISTER_STRING_CONSTANT("PCRE_VERSION", (char *)pcre_version(), CONST_CS | CONST_PERSISTENT);
-+#if COMPILE_DL_PCRE
-+      pcre_get_compiled_regex_p = pcre_get_compiled_regex;
-+      pcre_get_compiled_regex_cache_p = pcre_get_compiled_regex_cache;
-+      php_pcre_replace_impl_p = php_pcre_replace_impl;
-+      php_pcre_match_impl_p = php_pcre_match_impl;
-+      php_pcre_split_impl_p = php_pcre_split_impl;
-+#endif
-+
-       return SUCCESS;
- }
- /* }}} */
---- php-7.2.0RC5/ext/standard/basic_functions.c        2017-10-28 21:08:47.383549141 +0300
-+++ php-7.2.0RC5/ext/standard/basic_functions.c        2017-10-28 21:10:20.625051932 +0300
+diff -urN php-7.2.25.orig/ext/phar/Makefile.frag php-7.2.25/ext/phar/Makefile.frag
+--- php-7.2.25.orig/ext/phar/Makefile.frag     2019-12-12 23:55:51.636000000 +0100
++++ php-7.2.25/ext/phar/Makefile.frag  2019-12-12 23:56:02.320000000 +0100
+@@ -14,7 +14,7 @@
+               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
+               if test "x$(PHP_MODULES)" != "x"; then \
+               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
+-              for i in spl bz2 zlib phar; do \
++              for i in pcre spl bz2 zlib phar; do \
+                       if test -f "$(top_builddir)/modules/$$i.la"; then \
+                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
+                       fi; \
+diff -urN php-7.2.25.orig/ext/standard/basic_functions.c php-7.2.25/ext/standard/basic_functions.c
+--- php-7.2.25.orig/ext/standard/basic_functions.c     2019-12-12 23:55:51.046000000 +0100
++++ php-7.2.25/ext/standard/basic_functions.c  2019-12-12 23:56:02.321000000 +0100
 @@ -113,6 +113,15 @@
  PHPAPI php_basic_globals basic_globals;
  #endif
  #include "php_fopen_wrappers.h"
  #include "streamsfuncs.h"
  
---- php-5.3.2/sapi/cli/tests/018.phpt~ 2008-03-17 16:05:39.000000000 +0200
-+++ php-5.3.2/sapi/cli/tests/018.phpt  2010-03-16 20:41:11.341251246 +0200
-@@ -20,8 +20,6 @@
- --EXPECTF--     
- [PHP Modules]
- %a
--pcre
--%a
- [Zend Modules]
- %aDone
---- php-7.0.0beta3/main/php_ini.c~     2015-08-26 18:50:15.000000000 +0300
-+++ php-7.0.0beta3/main/php_ini.c      2015-08-26 22:33:59.126957396 +0300
-@@ -765,8 +765,8 @@
+diff -urN php-7.2.25.orig/main/php_ini.c php-7.2.25/main/php_ini.c
+--- php-7.2.25.orig/main/php_ini.c     2019-12-12 23:55:50.942000000 +0100
++++ php-7.2.25/main/php_ini.c  2019-12-12 23:56:02.322000000 +0100
+@@ -809,8 +809,8 @@
   */
  void php_ini_register_extensions(void)
  {
  
        zend_llist_destroy(&extension_lists.engine);
        zend_llist_destroy(&extension_lists.functions);
---- php-5.3.1/ext/phar/Makefile.frag~  2009-07-23 15:48:04.000000000 +0000
-+++ php-5.3.1/ext/phar/Makefile.frag   2009-11-30 16:10:29.687175948 +0000
-@@ -10,7 +10,7 @@
-               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
-               if test "x$(PHP_MODULES)" != "x"; then \
-               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
--              for i in spl bz2 zlib phar; do \
-+              for i in pcre spl bz2 zlib phar; do \
-                       if test -f "$(top_builddir)/modules/$$i.la"; then \
-                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-                       fi; \
+diff -urN php-7.2.25.orig/sapi/cli/tests/018.phpt php-7.2.25/sapi/cli/tests/018.phpt
+--- php-7.2.25.orig/sapi/cli/tests/018.phpt    2019-12-12 23:55:50.890000000 +0100
++++ php-7.2.25/sapi/cli/tests/018.phpt 2019-12-12 23:56:02.405000000 +0100
+@@ -20,8 +20,6 @@
+ --EXPECTF--
+ [PHP Modules]
+ %a
+-pcre
+-%a
+ [Zend Modules]
+ %aDone
index 5f22f56ebe7bd6d1c1c5438e2596d2ced1a26c65..46a951f87cd5224b2fd11b247b81b99c99b3c570 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -146,7 +146,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.2.24
+Version:       7.2.25
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -155,7 +155,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: fc1ef05e9157bd33b3bb93d8822b57b8
+# Source0-md5: 50648a305a247164023f1fbe8e4d58d8
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini