]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 5.6.3, partial PLD merge (mysqlnd stuff)
authorMarcin Krol <hawk@tld-linux.org>
Sat, 22 Nov 2014 13:49:30 +0000 (13:49 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 22 Nov 2014 13:49:30 +0000 (13:49 +0000)
fpm-conf-split.patch
mysqlnd-ssl.patch [new file with mode: 0644]
php-fpm-config.patch
php.spec

index be1b1bc2594589f8d3bca81c76bfd739ec4b051b..5398f8be147a3b6fcc22baef1d02a5bb94122b26 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.5.7/sapi/fpm/php-fpm.conf.in~        2013-12-16 17:57:03.000000000 +0200
-+++ php-5.5.7/sapi/fpm/php-fpm.conf.in 2013-12-16 17:58:37.618025260 +0200
+--- php-5.6.3/sapi/fpm/php-fpm.conf.in~        2014-11-17 20:03:42.000000000 +0200
++++ php-5.6.3/sapi/fpm/php-fpm.conf.in 2014-11-17 20:04:50.287981731 +0200
 @@ -6,14 +6,6 @@
  ; prefix (@prefix@). This prefix can be dynamically changed by using the
  ; '-p' argument from the command line.
 -; Relative path can also be used. They will be prefixed by:
 -;  - the global prefix if it's been set (-p argument)
 -;  - @prefix@ otherwise
--;include=/etc/php/fpm.d/*.conf
+-;include=etc/fpm.d/*.conf
 -
  ;;;;;;;;;;;;;;;;;;
  ; Global Options ;
  ;;;;;;;;;;;;;;;;;;
-@@ -116,404 +116,10 @@
+@@ -115,407 +115,3 @@
+ ; ports and different management options.  The name of the pool will be
  ; used in logs and stats. There is no limitation on the number of pools which
  ; FPM can handle. Your system will tell you anyway :)
+-
 -; Start a new pool named 'www'.
 -; the variable $pool can we used in any directive and will be replaced by the
 -; pool name ('www' here)
 -; Valid syntaxes are:
 -;   'ip.add.re.ss:port'    - to listen on a TCP socket to a specific address on
 -;                            a specific port;
+-;   '[ip:6:addr:ess]:port' - to listen on a TCP socket to a specific IPv6 address on
+-;                            a specific port;
 -;   'port'                 - to listen on a TCP socket to all addresses on a
 -;                            specific port;
 -;   '/path/to/unix/socket' - to listen on a unix socket.
 -; Note: This value is mandatory.
--listen = /var/run/php/@processname@.sock
+-listen = 127.0.0.1:9000
 -
 -; Set listen(2) backlog.
 -; Default Value: 65535 (-1 on FreeBSD and OpenBSD)
@@ -72,7 +75,7 @@
 -; must be separated by a comma. If this value is left blank, connections will be
 -; accepted from any ip address.
 -; Default Value: any
--listen.allowed_clients = 127.0.0.1
+-;listen.allowed_clients = 127.0.0.1
 -
 -; Specify the nice(2) priority to apply to the pool processes (only if set)
 -; The value can vary from -19 (highest priority) to 20 (lower priority)
 -; the current environment.
 -; Default Value: clean env
 -;env[HOSTNAME] = $HOSTNAME
--env[PATH] = $PATH
+-;env[PATH] = /usr/local/bin:/usr/bin:/bin
 -;env[TMP] = /tmp
 -;env[TMPDIR] = /tmp
 -;env[TEMP] = /tmp
 -;php_admin_value[error_log] = /var/log/fpm-php.www.log
 -;php_admin_flag[log_errors] = on
 -;php_admin_value[memory_limit] = 32M
-+; Include one or more files. If glob(3) exists, it is used to include a bunch of
-+; files from a glob(3) pattern. This directive can be used everywhere in the
-+; file.
-+; Relative path can also be used. They will be prefixed by:
-+;  - the global prefix if it's been set (-p argument)
-+;  - @prefix@ otherwise
-+include=/etc/php/fpm.d/*.conf
 --- /dev/null  2007-02-13 18:29:53.000000000 +0200
-+++ php-5.6.0beta1/sapi/fpm/php-fpm.conf-d.in  2014-04-21 21:58:46.191751631 +0300
++++ php-5.6.3/sapi/fpm/php-fpm.conf-d.in       2014-11-17 20:05:20.559494174 +0200
 @@ -0,0 +1,403 @@
-+; vim:ft=dosini
-+;
 +; Start a new pool named 'www'.
 +; the variable $pool can we used in any directive and will be replaced by the
 +; pool name ('www' here)
 +; Valid syntaxes are:
 +;   'ip.add.re.ss:port'    - to listen on a TCP socket to a specific address on
 +;                            a specific port;
++;   '[ip:6:addr:ess]:port' - to listen on a TCP socket to a specific IPv6 address on
++;                            a specific port;
 +;   'port'                 - to listen on a TCP socket to all addresses on a
 +;                            specific port;
 +;   '/path/to/unix/socket' - to listen on a unix socket.
 +; Note: This value is mandatory.
-+listen = /var/run/php/@processname@.sock
++listen = 127.0.0.1:9000
 +
 +; Set listen(2) backlog.
 +; Default Value: 65535 (-1 on FreeBSD and OpenBSD)
 +; must be separated by a comma. If this value is left blank, connections will be
 +; accepted from any ip address.
 +; Default Value: any
-+listen.allowed_clients = 127.0.0.1
++;listen.allowed_clients = 127.0.0.1
 +
 +; Specify the nice(2) priority to apply to the pool processes (only if set)
 +; The value can vary from -19 (highest priority) to 20 (lower priority)
 +; the current environment.
 +; Default Value: clean env
 +;env[HOSTNAME] = $HOSTNAME
-+env[PATH] = $PATH
++;env[PATH] = /usr/local/bin:/usr/bin:/bin
 +;env[TMP] = /tmp
 +;env[TMPDIR] = /tmp
 +;env[TEMP] = /tmp
    PHP_ADD_MAKEFILE_FRAGMENT([$abs_srcdir/sapi/fpm/Makefile.frag])
  
    SAPI_FPM_PATH=sapi/fpm/php-fpm
---- php-5.5.7/sapi/fpm/Makefile.frag~  2013-12-16 17:57:03.000000000 +0200
-+++ php-5.5.7/sapi/fpm/Makefile.frag   2013-12-16 18:01:19.511829907 +0200
+--- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-15 15:59:32.000000000 +0300
++++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:12:57.402883790 +0200
 @@ -11,8 +11,9 @@
        @$(INSTALL) -m 0755 $(SAPI_FPM_PATH) $(INSTALL_ROOT)$(sbindir)/$(program_prefix)php-fpm$(program_suffix)$(EXEEXT)
  
        @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
 -      $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
 +      $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d || :
-       @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
-+      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf || :
+       @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
++      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf.default || :
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
        @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8
diff --git a/mysqlnd-ssl.patch b/mysqlnd-ssl.patch
new file mode 100644 (file)
index 0000000..3157280
--- /dev/null
@@ -0,0 +1,24 @@
+link mysqlnd.so with openssl if enabled
+
+--- php-5.6.1/ext/mysqlnd/config9.m4~  2014-10-01 12:17:38.000000000 +0300
++++ php-5.6.1/ext/mysqlnd/config9.m4   2014-10-07 20:19:44.653070295 +0300
+@@ -34,10 +34,17 @@
+   test -z "$PHP_OPENSSL" && PHP_OPENSSL=no
+   if test "$PHP_OPENSSL" != "no" || test "$PHP_OPENSSL_DIR" != "no"; then
+-    AC_CHECK_LIB(ssl, DSA_get_default_method, AC_DEFINE(HAVE_DSA_DEFAULT_METHOD, 1, [OpenSSL 0.9.7 or later]))
+-    AC_CHECK_LIB(crypto, X509_free, AC_DEFINE(HAVE_DSA_DEFAULT_METHOD, 1, [OpenSSL 0.9.7 or later]))
++    AC_CHECK_LIB(ssl, DSA_get_default_method, [
++      AC_DEFINE(HAVE_DSA_DEFAULT_METHOD, 1, [OpenSSL 0.9.7 or later])
++      PHP_ADD_EXTENSION_DEP(mysqlnd, ssl)
++    ])
++    AC_CHECK_LIB(crypto, X509_free, [
++      AC_DEFINE(HAVE_DSA_DEFAULT_METHOD, 1, [OpenSSL 0.9.7 or later])
++      PHP_ADD_EXTENSION_DEP(mysqlnd, crypto)
++    ])
+     PHP_SETUP_OPENSSL(MYSQLND_SHARED_LIBADD, [AC_DEFINE(MYSQLND_HAVE_SSL,1,[Enable mysqlnd code that uses OpenSSL directly])])
++
+   fi
+   mysqlnd_sources="$mysqlnd_base_sources $mysqlnd_ps_sources"
index 353c0120b281c020a29c627695532285e2c33369..cb2b91d853abf8d54a949a632d60fe3b88f1cc00 100644 (file)
@@ -1,15 +1,6 @@
---- php-5.4.7/sapi/fpm/php-fpm.conf.in 2012-10-05 22:16:44.895998479 +0300
-+++ php-5.3.17/sapi/fpm/php-fpm.conf.in        2012-10-12 12:35:47.601602945 +0300
-@@ -12,7 +12,7 @@
- ; Relative path can also be used. They will be prefixed by:
- ;  - the global prefix if it's been set (-p arguement)
- ;  - @prefix@ otherwise
--;include=etc/fpm.d/*.conf
-+;include=/etc/php/fpm.d/*.conf
- ;;;;;;;;;;;;;;;;;;
- ; Global Options ;
-@@ -22,14 +22,14 @@
+--- php-5.6.2/sapi/fpm/php-fpm.conf.in 2014-10-27 08:20:34.963718145 +0200
++++ php-5.6.2.old/sapi/fpm/php-fpm.conf.in     2014-10-27 08:07:47.762117299 +0200
+@@ -14,14 +14,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
-@@ -93,7 +93,7 @@
+@@ -115,3 +115,11 @@
+ ; ports and different management options.  The name of the pool will be
+ ; used in logs and stats. There is no limitation on the number of pools which
+ ; FPM can handle. Your system will tell you anyway :)
++
++; Include one or more files. If glob(3) exists, it is used to include a bunch of
++; files from a glob(3) pattern. This directive can be used everywhere in the
++; file.
++; Relative path can also be used. They will be prefixed by:
++;  - the global prefix if it's been set (-p argument)
++;  - @prefix@ otherwise
++include=/etc/php/fpm.d/*.conf
+--- php-5.6.2.old/sapi/fpm/php-fpm.conf-d.in   2014-10-27 08:07:47.762117299 +0200
++++ php-5.6.2/sapi/fpm/php-fpm.conf-d.in       2014-10-27 08:23:41.232196777 +0200
+@@ -32,7 +32,7 @@
  ;                            specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
- ; Set listen(2) backlog. A value of '-1' means unlimited.
- ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
-@@ -105,7 +105,7 @@
+ ; Set listen(2) backlog.
+ ; Default Value: 65535 (-1 on FreeBSD and OpenBSD)
+@@ -41,9 +41,9 @@
+ ; BSD-derived systems allow connections regardless of permissions. 
+ ; Default Values: user and group are set as the running user
+ ;                 mode is set to 0660
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+  
+ ; List of ipv4 addresses of FastCGI clients which are allowed to connect.
+ ; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
+@@ -53,7 +53,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Set permissions for unix socket, if one is used. In Linux, read/write
- ; permissions must be set in order to allow connections from a web server. Many
-@@ -277,7 +277,7 @@
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
+@@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php-5.4.18/sapi/fpm/Makefile.frag~ 2013-08-14 08:47:24.000000000 +0300
-+++ php-5.4.18/sapi/fpm/Makefile.frag  2013-08-29 10:20:38.161424172 +0300
-@@ -12,7 +12,7 @@
+--- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-27 08:18:59.000000000 +0200
++++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:19:37.524436179 +0200
+@@ -12,8 +12,8 @@
  
        @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
-       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
+       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d || :
 -      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
+-      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf.default || :
 +      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
++      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf || :
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
        @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8
index 244f8d59cfa53a8bebae053d45cf68bfa74fcfa0..0fd20030f96fb4ccaf7631f5b430d9548e6e6535 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -8,7 +8,6 @@
 # - update imap myrights patch (needs api porting)
 # --with-libmbfl=DIR      MBSTRING: Use external libmbfl.  DIR is the libmbfl base install directory BUNDLED
 # --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
-# NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
 # TODO:
@@ -60,8 +59,7 @@
 %bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
-# don't turn it on by default; see TODO item for mysqlnd in this spec
-%bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
+%bcond_without mysqlnd         # without mysqlnd support in mysql related extensions
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
 %bcond_without odbc            # without ODBC extension module
 %bcond_without opcache         # without Enable Zend OPcache extension support
@@ -146,13 +144,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.2
+Version:       5.6.3
 Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: c976f54d429a0e5214659b0098e44e37
+# Source0-md5: 7635f344145a4edd7dff6ecec795aaea
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -218,6 +216,7 @@ Patch65:    system-libzip.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
 Patch69:       fpm-conf-split.patch
+Patch70:       mysqlnd-ssl.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -546,7 +545,7 @@ Provides:   php(ereg)
 Provides:      php(libxml)
 Provides:      php(reflection)
 Provides:      php(standard)
-%{!?with_mysqlnd:Obsoletes:    php-mysqlnd}
+%{!?with_mysqlnd:Obsoletes:    %{name}-mysqlnd}
 %{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-common < 4:5.3.28-7
 Obsoletes:     php-pecl-domxml
@@ -2007,6 +2006,7 @@ cp -p php.ini-production php.ini
 %patch38 -p1
 %patch39 -p1
 %if %{with fpm}
+%patch69 -p1
 %patch41 -p1
 %patch42 -p1
 %endif
@@ -2030,7 +2030,7 @@ cp -p php.ini-production php.ini
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p1
 %patch67 -p1
-%patch69 -p1
+%patch70 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2408,7 +2408,9 @@ sapis=$(%{__sed} -rne 's/^PHP_INSTALLED_SAPIS = (.+)/\1/p' Makefile.* | tr ' ' '
 cp -af php_config.h.cli main/php_config.h
 cp -af Makefile.cli Makefile
 %{__make} libphp_common.la
-%{__make} build-modules
+# hack: MYSQLND_SHARED_LIBADD not initialized
+%{__make} build-modules \
+       MYSQLND_SHARED_LIBADD="-lssl -lcrypto"
 
 %if %{with apache1}
 %{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1